Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160516 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160516

Packages changed:
abiword
calligra
cheese (3.20.1 -> 3.20.2)
evolution (3.20.1 -> 3.20.2)
evolution-data-server (3.20.1 -> 3.20.2)
evolution-ews (3.20.1 -> 3.20.2)
ghex (3.18.0 -> 3.18.1)
glib2 (2.48.0 -> 2.48.1)
gnome-desktop (3.20.1 -> 3.20.2)
gnome-user-docs (3.20.1 -> 3.20.2)
goffice (0.10.28 -> 0.10.29)
harfbuzz (1.2.6 -> 1.2.7)
hunspell
kdevelop4
kernel-source (4.5.3 -> 4.5.4)
libsndfile
libvirt-python (1.3.3 -> 1.3.4)
libzypp (15.22.0 -> 16.0.0)
man-pages (4.05 -> 4.06)
myspell-dictionaries (20160203 -> 20160511)
ocaml
polari (3.20.1 -> 3.20.2)
python-atspi (2.20.1 -> 2.20.2)
python3-atspi (2.20.1 -> 2.20.2)
python3-setuptools (20.7.0 -> 21.0.0)
unixODBC
vinagre (3.20.1 -> 3.20.2)
vino (3.20.1 -> 3.20.2)
zypper (1.13.0 -> 1.13.1)

=== Details ===

==== abiword ====
Subpackages: libabiword-3_0

- Re-add abiword-librevenge.patch that was wrongly dropped when
upgrading to Abiword 3.0.1.
- Add libtool BuildRequires and an injected copy of abiword's
autogen.sh, as above patch touches the build system.
- Add abiword-libwps-0.4.patch: Port to libwps 0.4.
- Change pkgconfig(libwps-0.3) BuildRequires to
pkgconfig(libwps-0.4) in order to enable Microsoft Works Document
support again.
- Drop explicit libabiword-3_0 and link-grammar Requires: they are
auto-detected.

==== calligra ====
Subpackages: calligra-extras-dolphin calligra-extras-okular calligra-stage
calligra-words-common

- Use share-mime-info macros (boo#979301)

==== cheese ====
Version update (3.20.1 -> 3.20.2)
Subpackages: libcheese-common libcheese-gtk25 libcheese8

- Update to version 3.20.2:
+ Explicitly mark the GSettings schema for intltool. As
recommended in the GSettings documentation.
+ Add gettext-domain the GSettings schema.
+ Fix fallback application icon name (bgo#765874).
+ Updated translations.

==== evolution ====
Version update (3.20.1 -> 3.20.2)
Subpackages: evolution-plugin-bogofilter evolution-plugin-pst-import
evolution-plugin-spamassassin

- Update to version 3.20.2:
+ Optimize some of the DOM functions related to selection.
+ EMsgComposer: Move the DOM manipulation to EHTMLEditorView.
+ EHTMLEditorActions: 'Select All' action is always disabled.
+ EHTMLEditorView:
- Deleting a content in a PRE element could wrap the content in
SPAN element.
- Moving a Preformatted block one level up in the quoted
content will change it to Normal.
- Restore the selection end mark correctly when processing HTML
to plain text.
- Redoing a citation split removes an extra text.
- Simplify and improve how the undo/redo of delete operation in
quoted content is performed.
+ Recognize special folders for a global mail view also based on
flags.
+ Rather hide, than disable, items in Taskpad/Memopad context
menus.
+ Correct placement of emoticon and color chooser in composer
under Wayland.
+ Bugs fixed: bgo#765090, bgo#765102, bgo#765202, bgo#765446,
bgo#765665, bgo#765636, bgo#435219, bgo#765950, bgo#766017.
+ Updated translations.

==== evolution-data-server ====
Version update (3.20.1 -> 3.20.2)
Subpackages: evolution-data-server-devel libcamel-1_2-57 libebackend-1_2-10
libebook-1_2-16 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-28 libedataserver-1_2-21 libedataserverui-1_2-1
typelib-1_0-EBook-1_2 typelib-1_0-EBookContacts-1_2 typelib-1_0-EDataServer-1_2

- Update to version 3.20.2:
+ [IMAPx]:
- Release idle_lock before disconnecting the cancellable.
- Crash under imapx_server_info_changed_cb().
- [CalDAV] Backend not initialized when asked to authenticate.
+ Possible use-after-free on factory subprocess close.
+ Bugs fixed: bgo#728496, bgo#235681.
+ Updated translations.

==== evolution-ews ====
Version update (3.20.1 -> 3.20.2)
Subpackages: evolution-ews-lang libeews-1_2-0 libewsutils0

- Update to version 3.20.2:
+ Ask for password after NTLM/SSO authentication failure.
+ Bugs fixed: bgo#764976, bgo#765209, bgo#765398.
- Drop evolution-ews-ntlm-auth-test-failure.patch: Fixed upstream.

==== ghex ====
Version update (3.18.0 -> 3.18.1)
Subpackages: ghex-lang libgtkhex-3-0

- Update to version 3.18.1:
+ Update the AppData file to spec version 0.7+.
+ Updated translations.

==== glib2 ====
Version update (2.48.0 -> 2.48.1)
Subpackages: glib2-devel glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Update to version 2.48.1:
+ Bugs fixed: bgo#731988, bgo#747107, bgo#747478, bgo#748474,
bgo#748530, bgo#748806, bgo#749606, bgo#758174, bgo#758738,
bgo#762994, bgo#763379, bgo#763821, bgo#764092, bgo#764574,
bgo#764575, bgo#764685, bgo#764754, bgo#765959, bgo#765990.
+ Updated translations.

==== gnome-desktop ====
Version update (3.20.1 -> 3.20.2)
Subpackages: gnome-version libgnome-desktop-3-12 libgnome-desktop-3-devel
libgnome-desktop-3_0-common typelib-1_0-GnomeDesktop-3_0

- Update to version 3.20.2:
+ No changes.

==== gnome-user-docs ====
Version update (3.20.1 -> 3.20.2)

- Update to version 3.20.2:
+ Updated translations.

==== goffice ====
Version update (0.10.28 -> 0.10.29)
Subpackages: goffice-lang libgoffice-0_10-10

- Update to version 0.10.29:
+ Do not load invalid data labels in XYcolor plots (bgo#765155).
+ Fix an infinite loop condition in 3D plots (bgo#765480).
+ Implement line width and fill pattern support in themes
(bgo#765970).
+ Improve go_complex_sqrt.
+ Improve go_complex_div.

==== harfbuzz ====
Version update (1.2.6 -> 1.2.7)
Subpackages: harfbuzz-devel libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- Update to version 1.2.7:
+ Blacklist another version of Times New Roman (Bold) Italic from
Windows 7.
+ Fix Mongolian Free Variation Selectors shaping with certain
fonts.
+ Fix Tibetan shorthand contractions shaping.
+ Improved list of language tag mappings.
+ Unbreak build on Windows CE.
+ Make 'glyf' table loading lazy in hb-ot-font.

==== hunspell ====
Subpackages: hunspell-devel libhunspell-1_4-0

- Update baselibs.conf bnc#977784
- Add conflicts to hunspell 1.4.0

==== kdevelop4 ====
Subpackages: kdevelop4-devel kdevelop4-lang kdevelop4-plugin-cppsupport

- Use share-mime-info macros (boo#979301)

==== kernel-source ====
Version update (4.5.3 -> 4.5.4)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.5.4 (bsc#969870).
- Delete
patches.arch/ACPI-processor-Request-native-thermal-interrupt-hand.
- commit db90c25
- ALSA: timer: Fix leak in events via snd_timer_user_tinterrupt
(CVE-2016-4569,bsc#979213).
- ALSA: timer: Fix leak in events via snd_timer_user_ccallback
(CVE-2016-4569,bsc#979213).
- ALSA: timer: Fix leak in SNDRV_TIMER_IOCTL_PARAMS
(CVE-2016-4569,bsc#979213).
- commit 875e079
- Bluetooth: vhci: Fix race at creating hci device
(bsc#971799,bsc#966849).
- Bluetooth: vhci: purge unhandled skbs (bsc#971799,bsc#966849).
- Bluetooth: vhci: fix open_timeout vs. hdev race
(bsc#971799,bsc#966849).
- commit ea94c66
- net: fix infoleak in rtnetlink (CVE-2016-4486 bsc#978822).
- commit 61212a2
- bpf: fix refcnt overflow (CVE-2016-4558 bsc#979019).
- commit 6f2153b
- bpf: fix double-fdput in replace_map_fd_with_map_ptr()
(CVE-2016-4557 bsc#979018).
- commit c96cd1e

==== libsndfile ====
Subpackages: libsndfile-devel libsndfile1 libsndfile1-32bit

- Fix spec file to enable builds on non opensuse OS

==== libvirt-python ====
Version update (1.3.3 -> 1.3.4)

- Update to 1.3.4
- Add all new APIs and constants in libvirt 1.3.4

==== libzypp ====
Version update (15.22.0 -> 16.0.0)

- Prepare cmake to maintain the .pot and .po files in git. Add
initial .po file set derived from tarballs. Translations are now
maintained via Weblate.
- Provide 'libzypp(plugin:services) = 1' after fixing bsc#933760
- Bump major version for Factory, 15.x is continued on SuSE-SLE-12-SP1-Branch
- version 16.0.0 (0)
- Update sle-zypp-po.tar.bz2
- Update sle-zypp-po.tar.bz2

==== man-pages ====
Version update (4.05 -> 4.06)

- update to 4.06:
* New and rewritten pages
cgroups.7
cgroup_namespaces.7
* Newly documented interfaces in existing pages
clone.2
Document CLONE_NEWCGROUP
readv.2
Document preadv2() and pwritev2()
setns.2
Document CLONE_NEWCGROUP
unshare.2
Document CLONE_NEWCGROUP

==== myspell-dictionaries ====
Version update (20160203 -> 20160511)
Subpackages: myspell-cs_CZ myspell-da_DK myspell-de myspell-de_DE myspell-el_GR
myspell-en myspell-en_GB myspell-en_US myspell-es myspell-es_ES myspell-fr_FR
myspell-hu_HU myspell-it_IT myspell-lightproof-en myspell-lightproof-hu_HU
myspell-lightproof-pt_BR myspell-lightproof-ru_RU myspell-pl_PL myspell-pt_BR
myspell-ru_RU

- Version update to git state 20160511:
* Notably croatian and czech rules updates

==== ocaml ====
Subpackages: ocaml-compiler-libs ocaml-runtime

- add ocaml-4.02.3-bufferoverflow_infoleak.patch to prevent buffer
overflow and information leak [bsc#977990], [CVE-2015-8869]
- use spec-cleaner to clean the specfile

==== polari ====
Version update (3.20.1 -> 3.20.2)
Subpackages: typelib-1_0-Polari-1_0

- Update to version 3.20.2:
+ Support pasting text/image content from files (bgo#766066).
+ Enable text/image uploads via drag and drop (bgo#766068).
+ Updated translations.

==== python-atspi ====
Version update (2.20.1 -> 2.20.2)

- Update to version 2.20.2:
+ Update STATE_LAST_DEFINED so that STATE_READ_ONLY is recognized
(bgo#766121).

==== python3-atspi ====
Version update (2.20.1 -> 2.20.2)

- Update to version 2.20.2:
+ Update STATE_LAST_DEFINED so that STATE_READ_ONLY is recognized
(bgo#766121).

==== python3-setuptools ====
Version update (20.7.0 -> 21.0.0)

- update to version 21.0.0:
* Removed ez_setup.py from Setuptools sdist. The bootstrap script
will be maintained in its own branch and should be generally be
retrieved from its canonical location at
https://bootstrap.pypa.io/ez_setup.py.
- specfile:
* updated source url to files.pythonhosted.org
- update to version 20.10.1:
(no changelog available)
- changes from version 20.10.0:
* #553: egg_info section is now generated in a deterministic order,
matching the order generated by earlier versions of
Python. Except on Python 2.6, order is preserved when existing
settings are present.
* #556: Update to Packaging 16.7, restoring support for deprecated
python_implmentation marker.
* #555: Upload command now prompts for a password when uploading to
PyPI (or other repository) if no password is present in .pypirc
or in the keyring.
- update to version 20.9.0:
* #548: Update certify version to 2016.2.28
* #545: Safely handle deletion of non-zip eggs in rotate command.
- changes from version 20.8.1:
* Issue #544: Fix issue with extra environment marker processing in
WorkingSet due to refactor in v20.7.0.
- changes from version 20.8.0:
* Issue #543: Re-release so that latest release doesn't cause déjà
vu with distribute and setuptools 0.7 in older environments.

==== unixODBC ====
Subpackages: unixODBC-32bit

- Requested by fate#319390
- Add comment in spec file so people know why the .so files are
not in the devel package

==== vinagre ====
Version update (3.20.1 -> 3.20.2)
Subpackages: vinagre-lang

- Update to version 3.20.2:
+ Updated translations.

==== vino ====
Version update (3.20.1 -> 3.20.2)

- Update to version 3.20.2:
+ Updated translations.

==== zypper ====
Version update (1.13.0 -> 1.13.1)
Subpackages: zypper-aptitude zypper-log

- Prepare cmake to maintain the .pot and .po files in git. Add
initial .po file set derived from tarballs. Translations are now
maintained via Weblate.
- Fix install/remove commands to be case sensitive (bsc#940477)
- Fix testing for '-- download*' options (bsc#956480)
- Unify code acquiring the zypp lock (bnc#969107)
- Rephrase note if 'lsof' is not installed (bsc#974438)
- search: fix empty search result message (bsc#972999)
- versioncmp: don't check for zypp lock (bsc#970575)
- BuildRequires: libzypp-devel >= 15.22.1
- version 1.13.1
- Update sle-zypper-po.tar.bz2 (bsc#972768)
- Update zypper-po.tar.bz2

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages