Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
Re: [opensuse-factory] New Tumbleweed snapshot 20160514 released!
  • From: Chan Ju Ping <email@xxxxxxxxx>
  • Date: Tue, 17 May 2016 15:02:56 -0500
  • Message-id: <2113262.HbFTCvLFhs@ganymede.jupiter>
On Tuesday, May 17, 2016 1:49:05 PM CDT Rainer Klier wrote:
hi,

Am 2016-05-16 um 13:43 schrieb Ludwig Nussel:
pam (1.2.1 -> 1.3.0)
pam-modules
pam_ldap

after upgrading pam to 1.3.0 from tumbleweed repo and plasma workspace 5
from KDE frameworks5 repo from 5.6.3 to 5.6.4 i can't use
kscreenlocker/kcheckpass any more.

i have an upgraded openSUSE x86_64 system since 12.3 and therefor i have
to preserve my pam config files

common-session-pc
common-password-pc
common-auth-pc
common-account-pc

which use pam_unix2.so instead of pam_unix.so whenever i update pam
packages.
i learned this from tumbleweed update 2015-09-24.

there was a thread about this in this list named "tumbleweed update
2015-09-24 unlock screensaver failed".

after updating pam today i could not even login any more.

i solved this by restoring my old pam config files.



but kscreenlocker/kcheckpass do not work any more even after this restore.

they always report "unlock failed".
when starting journalctl i see:
Authentication failure for rainer (invoked by uid 1000)

could it be, that kscreenlocker/kcheckpass internally rely on
pam_unix.so which does not work on my machine?


i downgraded all required plasma5 packages to 5.6.3 and now it works again.

so it must have something to do with 5.6.4 versions of plasma5....

Whenever I see authentication problems on TW these days, I first check to see
if my btrfs / partition has run out of space.

See if that is the case with

$sudo btrfs filesystem usage /
< Previous Next >