Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160503 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160503

Packages changed:
Mesa (11.2.0 -> 11.2.1)
aria2 (1.21.0 -> 1.22.0)
gnome-tweak-tool (3.20.0 -> 3.20.1)
gst-rtsp-server (1.6.2 -> 1.8.1)
gstreamer-0_10-plugins-bad
gstreamer-editing-services (1.6.2 -> 1.8.1)
installation-images-openSUSE (14.237 -> 14.239)
libdrm (2.4.67 -> 2.4.68)
luit (20141204 -> 20150706)
meld (3.15.3 -> 3.16.0)
patterns-openSUSE
perl-Bootloader (0.911 -> 0.912)
python3-gst (1.6.2 -> 1.8.1)
python3-pycurl
scons (2.4.1 -> 2.5.0)
snapper (0.3.1 -> 0.3.2)
valgrind
virtualbox (5.0.17 -> 5.0.18)
xf86-video-qxl
xorg-x11-server (7.6_1.18.2 -> 7.6_1.18.3)

=== Details ===

==== Mesa ====
Version update (11.2.0 -> 11.2.1)
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
Mesa-libva libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1
libgbm1-32bit libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- u_dri3-Check-for-dummyContext-to-see-if-the-glx_contex.patch
* dri3: Check for dummyContext to see if the glx_context is valid
According to the comments in src/glx/glxcurrent.c
__glXGetCurrentContext() always returns a valid pointer. If no
context is made current, it will contain dummyContext. Thus a
test for NULL will always fail.
- update to 11.2.1
* It fixes crashes in VAAPI, some build problems in Nine has been addressed,
adds a drirc workaround for Warsow and resolves issues in the nouveau,
radeonsi and i965 drivers.
* fdo#93962 ES2-CTS.gtf.GL2FixedTests.scissor.scissor - segfault/asserts

==== aria2 ====
Version update (1.21.0 -> 1.22.0)
Subpackages: aria2-lang libaria2-0

- Update to version 1.22.0:
* Add description about possible fragmentation with
- -file-allocation=trunc.
* Make single-entry metalink download with multi-file torrent
work.
* Add all contributor's names in AUTHORS.
* Ignore floating number in torrent file.
* Added support for a dynamic management of the number of
concurrent downloads as a function of the overall bandwidth
observed. This change adds --optimize-concurrent-downloads
option.
* Add --stream-piece-selector=random.

==== gnome-tweak-tool ====
Version update (3.20.0 -> 3.20.1)

- Update to version 3.20.1:
+ Support versioned Gtk3 themes.
+ Support multiple selection XKB options.
+ Updated translations.
- Require python-gobject-Gdk: pygobject was further split in order
to be able to install it without X-dependencies. As g-t-t is
a GUI applicartion, the dependency on the X-stack is no issue
(boo#976069).

==== gst-rtsp-server ====
Version update (1.6.2 -> 1.8.1)

- Update to version 1.8.1:
+ No changes, version bump only.
- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
+ Bugs fixed: bgo#740509.

==== gstreamer-0_10-plugins-bad ====
Subpackages: gstreamer-0_10-plugins-bad-lang libgstbasecamerabinsrc-0_10-23
libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstphotography-0_10-23
libgstsignalprocessor-0_10-23 libgstvdp-0_10-23

- Only BuildRequire openal-soft-devel and package its resulting
plugin for openSUSE via conditional. Fix build for SLE 12.

==== gstreamer-editing-services ====
Version update (1.6.2 -> 1.8.1)
Subpackages: libges-1_0-0 typelib-1_0-GES-1_0

- Update to version 1.8.1:
+ titlesource: Add support for absolute positionning.
- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
- Replace gobject-introspection-devel for
pkgconfig(gobject-introspection-1.0) BuildRequires.
- Add explicit pkgconfig(glib-2.0) BuildRequires and version it.
- Add pkgconfig(gst-validate-1.0) BuildRequires: New dependency.

==== installation-images-openSUSE ====
Version update (14.237 -> 14.239)

- allow user to switch efi grub2 console to text mode
- 14.239
- More detailed listing of ifaces provided in ssh installation.bsc#956473
- 14.238

==== libdrm ====
Version update (2.4.67 -> 2.4.68)
Subpackages: libdrm-devel libdrm2 libdrm2-32bit libdrm_amdgpu1
libdrm_amdgpu1-32bit libdrm_intel1 libdrm_intel1-32bit libdrm_nouveau2
libdrm_nouveau2-32bit libdrm_radeon1 libdrm_radeon1-32bit libkms1

- update to 2.4.68
* bugfixes
- removed no longer needed patch
u_Fix-compilation-on-systems-that-don-t-provide-O_CLOE.patch
(https://lists.freedesktop.org/archives/dri-devel/2016-April/105283.html)

==== luit ====
Version update (20141204 -> 20150706)

- Update to version 20150706
* add configure option --with-man2html
* updated configure macros, mostly formatting changes from xterm, etc.
* update config.guess, config.sub

==== meld ====
Version update (3.15.3 -> 3.16.0)
Subpackages: meld-lang

- Update to version 3.16.0:
+ Updated translations.

==== patterns-openSUSE ====
Subpackages: patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt
patterns-openSUSE-base patterns-openSUSE-books patterns-openSUSE-console
patterns-openSUSE-devel_C_C++ patterns-openSUSE-devel_basis
patterns-openSUSE-devel_gnome patterns-openSUSE-devel_ide
patterns-openSUSE-devel_java patterns-openSUSE-devel_kde
patterns-openSUSE-devel_kde_frameworks patterns-openSUSE-devel_kernel
patterns-openSUSE-devel_perl patterns-openSUSE-devel_python
patterns-openSUSE-devel_qt4 patterns-openSUSE-devel_qt5
patterns-openSUSE-devel_rpm_build patterns-openSUSE-devel_ruby
patterns-openSUSE-devel_web patterns-openSUSE-dhcp_dns_server
patterns-openSUSE-directory_server patterns-openSUSE-enhanced_base
patterns-openSUSE-enhanced_base_opt patterns-openSUSE-file_server
patterns-openSUSE-fonts patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns
-openSUSE-gnome_games patterns-openSUSE-gnome_ide
patterns-openSUSE-gnome_imaging patterns-openSUSE-gnome_imaging_opt
patterns-openSUSE-gnome_internet patterns-openSUSE-gnome_laptop
patterns-openSUSE-gnome_multimedia patterns-openSUSE-gnome_multimedia_opt
patterns-openSUSE-gnome_office patterns-openSUSE-gnome_office_opt
patterns-openSUSE-gnome_utilities patterns-openSUSE-gnome_yast
patterns-openSUSE-imaging patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_laptop
patterns-openSUSE-lxde_office
patterns-openSUSE-mail_server patterns-openSUSE-minimal_base
patterns-openSUSE-minimal_base-conflicts patterns-openSUSE-misc_server
patterns-openSUSE-multimedia patterns-openSUSE-multimedia_opt
patterns-openSUSE-network_admin patterns-openSUSE-non_oss
patterns-openSUSE-non_oss_opt patterns-openSUSE-office
patterns-openSUSE-office_opt patterns-openSUSE-print_server
patterns-openSUSE-remote_desktop patterns-openSUSE-rest_dvd
patterns-openSUSE-sw_management patterns-openSUSE-sw_management_gnome
patterns-openSUSE-sw_management_kde patterns-openSUSE-tabletpc
patterns-openSUSE-technical_writing patterns-openSUSE-x11
patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- enable dmidecode/numactl/efibootmgr for aarch64

==== perl-Bootloader ====
Version update (0.911 -> 0.912)

- we don't need grub_installdevice on s390x (bsc#976466)
- 0.912

==== python3-gst ====
Version update (1.6.2 -> 1.8.1)

- Update to version 1.8.1:
+ No changes, version bump only.
- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
- Replace gstreamer-plugins-base-devel for
pkgconfig(gstreamer-plugins-base-1.0) BuildRequires and version
it.
- Add explicit pkgconfig(gstreamer-1.0) BuildRequires.

==== python3-pycurl ====

- Only BuildRequire python3-nose, python3-bottle and python3-simplejson
on openSUSE since SLE doesn't have python3-bottle or python3-simplejson
and they're only needed by the test suite.

==== scons ====
Version update (2.4.1 -> 2.5.0)

- SCons 2.5.0:
* Enhance implicit language scanning functionality
* Cache directory sharding to improve NFS performance

==== snapper ====
Version update (0.3.1 -> 0.3.2)
Subpackages: libsnapper3 snapper-zypp-plugin

- reverted some changes done accidentally to default-config (see
fate#312751)
- version 0.3.2

==== valgrind ====

- The previous did not help, remove -strong first.
- also remove -fstack-protector-strong from the CFLAGS

==== virtualbox ====
Version update (5.0.17 -> 5.0.18)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11 virtualbox-host-kmp-default virtualbox-qt

- drm-vboxvideo-Initialize-data-needed-to-map-fbdev-memory.patch:
* Add missing initialization of scanout buffer base and size for
proper fbdev support.
- drm-vboxvideo-Add-delayed-update-to-support-fbdev.patch:
* Add support for delayed_io in fbdev-layer.
(boo#977200).
- This submission fixes the bug in VB 5.0.18 that prevents proper operation
for guest VMs configured to use a LsiLogic adapter for disks. See ticket:
https://www.virtualbox.org/ticket/15317 for a description of the problem,
and changeset: https://www.virtualbox.org/changeset/60565/vbox for the fix,
which is implemented in file "changeset_60565.diff".
This update contains a fix for CVE-2016-0678. Bug report b.o.o #97366
discusses this vulnerability.
- Version bump to 5.0.18 (released 2016-04-18 by Oracle)
This is a maintenance release. The following items were fixed and/or added:
GUI: position off-screen windows to be fully visible again on relaunch in
consistence with default-behavior (bug #15226)
GUI: fixed the View menu / Full-screen Mode behavior on Mac OS X El Capitan
GUI: fixed a test which allowed to encrypt a hard disk with an empty
password
GUI: fixed a crash under certain conditions during VM shutdown
GUI: fixed the size of the VM list scrollbar in the VM selector when
entering a group
PC speaker passthrough: fixes (Linux hosts only; bug #627)
Drag and drop: several fixes
SATA: fixed hotplug flag handling when EFI is used
Storage: fixed handling of encrypted disk images with SCSI controllers (bug
#14812)
Storage: fixed possible crash with Solaris 7 if the BusLogic SCSI
controller is used
USB: properly purge non-ASCII characters from USB strings (bugs #8801,
#15222)
NAT Network: fixed 100% CPU load in VBoxNetNAT on Mac OS X under certain
circumstances (bug #15223)
ACPI: fixed ACPI tables to make the display color management settings
available again for older Windows versions (4.3.22 regression)
Guest Control: fixed VBoxManage copyfrom command (bug #14336)
Snapshots: fixed several problems when removing older snapshots (bug #15206)
VBoxManage: fixed --verbose output of the guestcontrol command
Windows hosts: hardening fixes required for recent Windows 10 insider
builds (bugs #15245, #15296)
Windows hosts: fixed support of jumbo frames in with bridged networking
(5.0.16 regression; bug #15209)
Windows hosts: don't prevent receiving multicast traffic if host-only
adapters are installed (bug #8698)
Linux hosts: added support for the new naming scheme of NVME disks when
creating raw disks
Solaris hosts / guests: properly sign the kernel modules (bug #12608)
Linux hosts / guests: Linux 4.5 fixes (bug #15251)
Linux hosts / guests: Linux 4.6 fixes (bug #15298)
Linux Additions: added a kernel graphics driver to support graphics when
X.Org does not have root rights (bug #14732)
Linux/Solaris Additions: fixed several issues causing Linux/Solatis guests
using software rendering when 3D acceleration is available
Windows Additions: fixed a hang with PowerPoint 2010 and the WDDM drivers
if Aero is disabled
- Drop VirtualBox-5.0.17-r106108-r106140.patch, fixed upstream.
- Fix build error caused by removal of macro page_cache_release() from kernel.
File "vbox-replace-page-cache-release.diff" is used to modify code to use
put_page() instead.

==== xf86-video-qxl ====

- U_qxl-use-pci-io.patch
* Fix build on AArch64 by backporting upstream patch to use
pci_io_write8 instead of outb

==== xorg-x11-server ====
Version update (7.6_1.18.2 -> 7.6_1.18.3)
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk

- removed u_exa-only-draw-valid-trapezoids.patch; no longer needed
since pixman 0.32.0
- removed no longer needed patch
u_ad-hoc-fix-for-mmap-s-truncated-offset-parameter-on-.patch, see
https://lists.x.org/archives/xorg-devel/2016-April/049493.html for
upstream discussion; obsoleted by upstream patch

https://cgit.freedesktop.org/xorg/xserver/commit/?id=4962c8c08842d9d3ca66d254b1ce4cacc4fb3756,
which is already in xorg-server 1.18.3
- Add permission verification for SUID wrapper
- Disable SUID wrapper per default until reviewed
- n_Install-Avoid-failure-on-wrapper-installation.patch:
rename to:
N_Install-Avoid-failure-on-wrapper-installation.patch
- u_xorg-wrapper-Drop-supplemental-group-IDs.patch:
Drop supplementary group privileges.
- u_xorg-wrapper-build-Build-position-independent-code.patch:
Build position independent.
- n_Install-Avoid-failure-on-wrapper-installation.patch:
Fix up build for wrapper.
- Place SUID wrapper into a separate package:
xorg-x11-server-wrapper
- Set configure option --enable-suid-wrapper for TW:
This way, the SUID wrapper is built which allows to run the Xserver
as root even though the the DM instance runs as user. This allows to
support drivers which require direct HW access.
- Update to version 1.18.3:
A few fixes relative to 1.18.2, including one fairly important
performance fix to the Present extension.
- Remove U_present-Only-requeue-for-next-MSC-after-flip-failure.patch
The patch is included in this release.
- Add patch U_present-Only-requeue-for-next-MSC-after-flip-failure.patch
Fix a hang while using the present extension
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=94515
https://bugs.freedesktop.org/show_bug.cgi?id=94596
- Add automake, autoconf, libtool, c_compiler, pkgconfig(xorg-macros),
pkgconfig(libudev), pkgconfig(libevdev), pkgconfig(mtdev) to Requires:
of the SDK. This simplifies the build of Xserver modules.

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages