Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160430 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160430

Packages changed:
ImageMagick (6.9.3.0 -> 6.9.3.8)
abcde (2.7.1 -> 2.7.2)
acpid (2.0.26 -> 2.0.27)
apparmor (2.10 -> 2.10.1)
argyllcms (1.6.3 -> 1.8.3)
audacity
autoyast2 (3.1.119 -> 3.1.125)
bind
calligra
ccache (3.2.4 -> 3.2.5)
cpupower (3.19 -> 4.6)
doxygen
evolution-ews
gdb (7.10.1 -> 7.11)
gettext-runtime (0.19.6 -> 0.19.7)
git
gnome-control-center
gnu-free-fonts
gobject-introspection
grep (2.22 -> 2.25)
gstreamer (1.6.3 -> 1.8.0)
gstreamer-plugins-bad (1.6.3 -> 1.8.0)
gstreamer-plugins-base (1.6.3 -> 1.8.0)
gstreamer-plugins-good (1.6.3 -> 1.8.0)
gstreamer-plugins-ugly (1.6.3 -> 1.8.0)
hexchat
hwinfo (21.23 -> 21.24)
ibus (1.5.11 -> 1.5.13)
intlfonts
jack
kernel-source (4.5.0 -> 4.5.2)
kf5-filesystem (20160409 -> 20160420)
kismet (2013_03_R1b -> 2016_01_R1)
kiwi (7.03.65 -> 7.03.67)
libapr-util1
libgexiv2
libgit2 (0.24.0 -> 0.24.1)
libgltf (0.0.1 -> 0.0.2)
libmicrohttpd (0.9.48 -> 0.9.49)
libqb (0.17.2+git20151001.1a7ea3b -> 1.0.0+git20160407.6f2b3e8)
libreoffice (5.1.2.2 -> 5.1.3.1)
librevenge
librsvg
libsolv (0.6.19 -> 0.6.20)
libsoup (2.54.0.1 -> 2.54.1)
libstorage (2.25.37 -> 2.26.2)
libvirt
libvirt-python (1.3.2 -> 1.3.3)
libzypp (15.21.5 -> 15.22.0)
mailman (2.1.21 -> 2.1.22)
mailx
meld (3.15.2 -> 3.15.3)
nfs-utils
nghttp2 (1.9.1 -> 1.10.0)
obs-service-set_version
ocfs2-tools
open-iscsi
p7zip (15.14 -> 15.14.1)
perl-DBD-XBase (1.05 -> 1.06)
perl-JSON-XS (3.01 -> 3.02)
phonon (4.8.1 -> 4.9.0)
phonon-backend-gstreamer (4.8.2 -> 4.9.0)
polkit-default-privs
pragha
pulseaudio
python-gobject
python-kde4
python3-gobject
rsyslog (8.17.0 -> 8.18.0)
sessreg
sqlite3 (3.12.1 -> 3.12.2)
sssd (1.13.3 -> 1.13.4)
subversion (1.9.3 -> 1.9.4)
suse-module-tools (12.3 -> 12.4)
tcpdump
timezone (2016c -> 2016d)
timezone-java (2016c -> 2016d)
tomcat (8.0.32 -> 8.0.33)
udisks2
upower
vm-install (0.8.50 -> 0.8.51)
webkit2gtk3 (2.12.0 -> 2.12.1)
whois (5.2.11 -> 5.2.12)
wicked (0.6.31 -> 0.6.32)
wine (1.9.7 -> 1.9.8)
wireshark (2.0.2 -> 2.0.3)
xdg-app (0.5.1 -> 0.5.2)
xine-lib
yast2 (3.1.185 -> 3.1.186)
yast2-add-on (3.1.12 -> 3.1.14)
yast2-auth-client (3.3.6 -> 3.3.7)
yast2-bootloader (3.1.176 -> 3.1.178)
yast2-installation (3.1.181 -> 3.1.182)
yast2-network (3.1.144 -> 3.1.148)
yast2-ntp-client (3.1.21 -> 3.1.22)
yast2-packager (3.1.94 -> 3.1.97)
yast2-storage (3.1.86 -> 3.1.90)

=== Details ===

==== ImageMagick ====
Version update (6.9.3.0 -> 6.9.3.8)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-6_Q16-6
libMagickCore-6_Q16-2 libMagickWand-6_Q16-2 perl-PerlMagick

- Update to 6.9.3-8:
* Respect gravity when rendering text (e.g. convert -gravity center
my.txt).
* Return empty string for %d property and no directory.
* Return filename for the %i property.
* Fixed lost pixels in frequency space.
* etc. see ChangeLog

==== abcde ====
Version update (2.7.1 -> 2.7.2)

- Update to version 2.7.2
* When using musicbrainz, don't assume that there will be release
events attached to a particular CD release. Bug fix for the addition
of year information support in 2.7.1.
* Support for output to the Matroska container (mka). Encoder
is FFmpeg (or avconv). Typical conf file syntax would be:
MKAENCODERSYNTAX=ffmpeg
FFMPEG=ffmpeg
FFMPEGENCOPTS="-c:a ac3 -b:a 448k"
OUTPUTTYPE="mka"
* Add id3tag mp3 tagger as this is the tagger available to
OpenBSD users.
* Allow for cddb response 500. This closes Issue 26:
http://abcde.einval.com/bugzilla/show_bug.cgi?id=26
* Fix for 'expansion of $REDIR' bug on MacOSX. This closes Issue 22:
http://abcde.einval.com/bugzilla/show_bug.cgi?id=22
* Makefile adjusted to allow the sample abcde.conf file to be
installed by default to /etc rather than $(prefix)/etc.
https://bugs.archlinux.org/task/46671
* Allow getalbumart to correctly place cover image when single
track is selected. This closes Issue 25:
http://abcde.einval.com/bugzilla/show_bug.cgi?id=25
- Update abcde-quote.patch
- Set BuildArch as noarch; the package doesn't contain any binary

==== acpid ====
Version update (2.0.26 -> 2.0.27)

- Update to version 2.0.27
* Fix out of tree build (sock.c ud_socket.c)
- kacpimon: fix out of tree build (kacpimon/Makefile.am)
- input_layer: Allow repeated reporting of VOLUME keys (input_layer.c)
- Remove some extra tags

==== apparmor ====
Version update (2.10 -> 2.10.1)
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-profiles apparmor-utils libapparmor-devel libapparmor1
libapparmor1-32bit pam_apparmor pam_apparmor-32bit perl-apparmor
python3-apparmor

- update to AppArmor 2.10.1 (2.10 branch r3326):
- fix incorrect output of child profile names (apparmor_parser -N) which
caused 'rcapparmor reload' to remove child profiles and hats (lp#1551950)
- fix a crash in aa-logprof / logparser.py for change_hat log events
(lp#1523297) and log events that look like file events, but aren't
(lp#1540562, lp#1525119, lp#1466812)
- write unix rules when saving a profile (lp#1522938, boo#954104#c3)
- several fixes for variable handling in aa-logprof
- map c (create) log events to w instead of a
- add python to the "no Px rule" list in logprof.conf
- let aa-logprof check for duplicate profiles
- let aa-status work without the apparmor.fail python module (boo#971917,
lp#1480492)
- add permissions in several profiles (including boo#948584, boo#948753,
boo#954959, boo#954958, boo#971790, boo#964971, boo#921098, boo#923201 and
boo#921098#c15).
- and many more fixes, see the full changelog at
http://wiki.apparmor.net/index.php/ReleaseNotes_2_10_1
- drop upstream(ed) patches:
- fix-initscript-aa_log_end_msg.diff
- syslog-ng-profile-boo948584.diff
- upstream-profile-updates-r3205-3241.diff
- refresh patches:
- apparmor-abstractions-no-multiline.diff
- apparmor-samba-include-permissions-for-shares.diff
- drop libapparmor autogen.sh call (broke the build) and remove libtool BR

==== argyllcms ====
Version update (1.6.3 -> 1.8.3)

- BuildRequire systemd-rpm-macros which defines _udevrulesdir for us
- Update to version 1.8.3
* Added SpyderCheckr24 scaning .cht and .cie files.
* Fixed USB problem with i1pro (Rev B & D ?), where communications
would occasionally break down on fast systems.
* Added another fixed display intergration time to i1pro non-adaptive
emission mode to cope with higher brightness displays.
* Added workaround for i1d3 Rev. B status code 0x83 on very low
light measurement
* Fixed minor bug in i1d3.c that truncated serial number string.
* Fixed bug in Klein K10 driver - adaptive measurement wasn't properly
using all the extra measurements.
* Improved Klein K10 driver to be more robust when lights off command
returns bogus error codes, or causes a cascade of bogus measurement
errors.
* Added workaround for OS X 10.9+ "App Nap" problem.
* Added maximum sensor frequency check for Spyder & i1d3 drivers,
so that erronious readings due to excessive brightness can't be missed.
* Changed chartread so that it doesn't warn of a possible wrong strip
being read, nor allows bi-directional strip reading, if "printtarg -r"
was used. A warning will be issued if "printtarg -r" was used, and
"chartread -B" wasn't used.
* Fixed collink for eeColor Full range RGB to use output curve
("second" 1D curves) to compensate for cLUT being wired for 1.0
output from 1.0 input.
* Added "lp" gamut mapping intent :- Luminance Preserving Perceptual,
for Photographers concerned with maintaining tonal variations.
* Fixed bugs in image specific gamut mapping that were degrading
the accuracy of the result.
* Re-wrote gamut smoothing code, and re-tuned it to behave similarly
to the V1.8.2 release.
* Changed default viewing condition glare to 5%, to smooth out shadow tone
curve.
* Reduced the level of Helmholtz-Kohlrausch effect in CIECAM02
implementation in the light of visual experiments.
- Changes from version 1.8.2
* Fixed endless loop bug in alternate calibration selectors code.
- Changes from version 1.8.1
* Fixed bug in "spec2cie -n" wrong field indexes were being used.
* Fixed colorimeter calibration selectors to add in alternate
selectors if the letters are free.
- Changes from version 1.8.0
* Added support for the Image Engineering EX1 spectroradiometer.
* Added support for the SwatchMate Cube reflective colorimeter,
with improved accuracy.
* Added Added Television Lighting Consistency Index (EBU TLCI-2012 Qa)
to spotread and specplot output.
* Added R9 value to CRI value in spotread and specplot output.
* Added workaround for JETI specbos having been calibrated by
a 3rd party, and its calibrated range being out of sync with
its claimed range.
* Added support for "EMISINPUT" type .ti3 file.
* Build using OpenSSL rather than axTLS if it is built on Linux.
* Fixed stack space problem in OS X UI programs by expanding main
thread proxy to have 8MB instead of the default 512K.
* Updated built in libtiff to V4.0.4beta.
* Changed CGATS format to not emit unknown keyword declaration ("KEYWORD")
by default.
* Added inst_calc_cond_mask to inst.h to allow for flags in calibration
conditions. A consequence of this is that calc needs to be masked with
this when comparing against a specific condition, and the
inst_calc_optional_flag
should be cleared if it is set, before callint inst->calibrate() if the
user wants to proceed with a particular calibration.
* Fixed bug with dispcal -e N
* Fixed bug in xicclu -fg and -kp
* Added dispcal -x x option to allow reading a chart and manually entering
the XYZ values.
* Fix spyder4 & 5 bug where some display types were set as refresh
when they shouldn't be.
* Fix collink "Warning :- RGB black hack trigger more than once!"
when -b is used with input video encoding (-e).
* Changed colprof so that the default ICC description is the base
filename rather than the whole file path.
* Fix technology type and display type selector "uniqueification"
bug that shows up in "ccxxmake -??".
* Add OEM field to ccmx and ccss files to mark files that have
been installed from OEM disk, so that custom ccmx & ccss files
can be given suggested selector letter priority (+ ref/CRT.ccss).
* Tweak CGATS write format to avoid scientific notation until the
numbers are bigger and smaller (i.e until e6 and e-6 are needed).
- Changes from version 1.7.0
* Improved gamut mapping to reduce unnecessary changes to less
saturated colors such as skin tones.
* Add support for DataColor Spyder 5.
* Add support for ColorHug2 colorimeter.
* Add support for Klein K10-A colorimeter.
* Added Google ChromeCast as a test patch generator for Video displays.
* Added ls2ti3 tool to convert LightSpace .bcs files to .ti3.
* Added IRIDAS .cube 3DLut format support to collink.
* Add X3D and X3DOM support as an alternative to VRML, and make X3DOM
the default.
* Add better cross compatibility with non-Argyll ICC profiles using
ArgyllCMS 'arts' tag to mark 'wtpt' Absolute Colorimetric chromaticity
transform, as well as implement proper absolute colorimetric intent
for Display profiles use the 'chad' tag. Note that the standard
ICC profiles provided by ArgyllCMS in the ref directory (such as sRGB etc.)
now include an 'arts' tag.
* Ignore any patches that have zero values for creating Display profiles,
unless they are for device zero.
* Fix various instrument communications problems for JETI specbos,
DTP20, DTP92 & DTP94.
* Fix gestaltSystemVersion warning on OS X 10.10.
* Fix very major bug in illumread. It wasn't actually working at all
since V1.4.0.
* Added collink -I[gG][:p.p]:x.x options that allows an output offset
gamma curve be targetted instead of BT1886.
* Added dispcal and collink -b black point hack. This forces the input
zero to map to the output zero for well behaved displays, reducing
dependence on the instrument accuracy for a very dark black point.
* Added preset list of display techologies to select from in ccxxmake.
* Added a -P prune option to profcheck, that creates a .ti3 file pruned
of any patches that have a delta E fit error greater than a threshold.
This may be of use in eliminating bad reading values from a measurement set.
* Added histogram plot option -h to both profcheck and verify.
* Added a dispread & fakeread -Z option to set the number of bits to
quantize the test values to.
* Fixed bug in targen - the -V dark emphasis wasn't being applied to OFPS
generated points.
* Make sure that if an instrument display reading is interrupted by a
forced calibration, that the user is asked to place it back on the
display before resuming the measurements.
- Remove obsolete patches
* argyllcms-udev-builtin.patch
* argyllcms-udev-hwdb.patch
- Some specfile cleanups and improvements
- Update argyllcms-udev151.patch

==== audacity ====
Subpackages: audacity-lang

- Add audacity-2.1.1-fix-tempdir.patch from upstream: fix usage of
custom temp directories (boo#976964).

==== autoyast2 ====
Version update (3.1.119 -> 3.1.125)
Subpackages: autoyast2-installation

- Upgrade: Removed obsolete bootloader stuff.
(bnc#976312)
- 3.1.125
- Removed obsolete bootloader stuff.
(related to FATE#317701)
- 3.1.124
- Updated schema - added optional URL for the installer
self update repository ("general" -> "self_update_url" node)
(FATE#319716)
- 3.1.123
- Remove unused import of dropped BootCommon package.
(related to FATE#317701)
- 3.1.122
- Removed calls of dropped LanUdevAuto module (yast2-network)
(bnc#955217, bnc#956605)
- 3.1.121
- Moved call "uptime" to yast2 package. Cleanup for bnc#956730.
- 3.1.120

==== bind ====
Subpackages: bind-chrootenv bind-doc bind-utils idnkit libbind9-140 libdns162
libidnkit1 libirs141 libisc160 libisccc140 libisccfg140 liblwres141

- remove BuildRequire libcap. That is only a legacy library, not
actually used for building. libcap-devel pulls in the right one.

==== calligra ====
Subpackages: calligra-extras-dolphin calligra-extras-okular calligra-stage
calligra-words-common

- Disable Vc-devel-static build requirement for now, it breaks the
build on Factory/Tumbleweed currently
- Build against libwps-0.4 on 13.2 as well to fix the build, it has
been released as official update

==== ccache ====
Version update (3.2.4 -> 3.2.5)

- Update to 3.2.5
* Only pass clang-specific -stdlib= to the preprocessor.
* Improved handling of stale NFS handles.
* Made it harder to misinterpret documentation of boolean
environment settings' semantics.
* Corrected "Performance" section in the manual regarding __DATE_,
__TIME__ and __FILE__ macros.
* Don?t (try to) update manifest file in ?read-only? and
?read-only direct? modes.
* Fixed a bug in caching of stat system calls in ?file_stat_matches
sloppiness mode?.
* Fixed bug in hashing of clang plugins, leading to unnecessary
cache misses.
* Fixed --print-config to show ?pch_defines sloppiness?.

==== cpupower ====
Version update (3.19 -> 4.6)
Subpackages: libcpupower0

- Add cpuidle functions to public libcpupower
* Add library_cleanup.patch

==== doxygen ====

- same work around ppc64 as already done for ppc64le [boo#921577]

==== evolution-ews ====
Subpackages: evolution-ews-lang libeews-1_2-0 libewsutils0

- Add evolution-ews-ntlm-auth-test-failure.patch: Fix NTLM auth
failure with latest samba. Fixes boo#976110, bgo#765106.

==== gdb ====
Version update (7.10.1 -> 7.11)

- update gdb-orphanripper.c from last fedora changes of 2013
http://pkgs.fedoraproject.org/cgit/rpms/gdb.git/log/gdb-orphanripper.c
may be solution to transient build hung on Rings:1 ppc64le
tracked by bug boo#974419
- Add gdb-7.10-swo18929.patch to fix crash printing values. [bnc#971556]
[swo#18929]
- Rebase to gdb version 7.11 as of version in Fedora 24:
* Per-inferior thread numbers.
* Breakpoint "explicit locations" (via CLI and GDB/MI).
* New convenience variables ($_gthread, $_inferior).
* Record btrace now supports non-stop mode.
* Various improvements on AArch64 GNU/Linux:
- Multi-architecture debugging support.
- displaced stepping.
- tracepoint support added in GDBserver.
* In Ada, the overloads selection menu provides the parameter
types and return types for the matching overloaded subprograms.
* Various remote protocol improvements, including several
new packets which can be used to support features such as
follow-exec-mode, exec catchpoints, syscall catchpoints, etc.
* Some minor improvements in the Python API for extending GDB.
- Added local patch gdb-fix-buf-overflow.diff.
- Added new patches from Fedora:
gdb-fedora-libncursesw.patch
gdb-fortran-stride-intel-1of6.patch
gdb-fortran-stride-intel-2of6.patch
gdb-fortran-stride-intel-3of6.patch
gdb-fortran-stride-intel-4of6.patch
gdb-fortran-stride-intel-5of6.patch
gdb-fortran-stride-intel-6of6-nokfail.patch
gdb-fortran-stride-intel-6of6.patch
gdb-opcodes-clflushopt-test.patch
gdb-testsuite-readline63-sigint.patch
- Removed obsolete patches:
gdb-6.3-bz231832-obstack-2gb.patch
gdb-probes-based-interface-robust-1of2.patch
gdb-probes-based-interface-robust-2of2.patch
gdb-rhbz1260558-ppc64le-skip_trampoline_code.patch
gdb-rhbz1270564-invalid-dwarf-regno.patch
gdb-rhel5-compat.patch
- Really disable problematic testcases.
- Disable guile support for SLE10.

==== gettext-runtime ====
Version update (0.19.6 -> 0.19.7)
Subpackages: gettext-tools

- drop gettext-runtime-grep-2.24.patch, no longer required for 2.25
- GNU gettext 0.19.7:
* can now load custom string extraction rules in XML
Internationalization Tag Set (ITS) standard
* the existing XML-based language scanners (Glade, GSettings, and
AppData) rewritten using ITS
* Add msgfmt --xml option to merge translations back to the
original XML document.

==== git ====
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- add desktop entry for the git gui

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-user-faces

- Adjust BuildRequired versions according to configure:
+ gsettings-desktop-schemas >= 3.19.3.
+ gnome-settings-daemon >= 3.19.1.

==== gnu-free-fonts ====

- Add reproducible.patch to fix build-compare

==== gobject-introspection ====
Subpackages: girepository-1_0 gobject-introspection-devel libgirepository-1_0-1

- gi-find-deps.sh: scan GI overrides glue layers to add their
respective dependencies.

==== grep ====
Version update (2.22 -> 2.25)

- grep 2.25:
* In the C or POSIX locale, grep now treats all bytes as valid
characters even if the C runtime library says otherwise.
( Fixes yast2-users and other build failures - boo#966780 )
* grep -oz now uses null bytes, not newlines, to terminate output
lines.
* grep now outputs details more consistently when reporting a
write error.
- Update to 2.24
* grep -z would match strings it should not. To trigger the bug,
you'd have to use a regular expression including an anchor
(^ or $) and a feature like a range or a backreference, causing
grep to forego its DFA matcher and resort to using re_search.
With a multibyte locale, that matcher could mistakenly match a
string containing a newline. For example, this command:
printf 'a\nb\0' | LC_ALL=en_US.utf-8 grep -z '^[a-b]*b'
would mistakenly match and print all four input bytes. After
the fix, there is no match, as expected.
[bug introduced in grep-2.7]
* grep -Pz now diagnoses attempts to use patterns containing ^
and $, instead of mishandling these patterns. This problem
seems to be inherent to the PCRE API; removing this limitation
is on PCRE's maint/README wish list. Patterns can continue to
match literal ^ and $ by escaping them with \ (now needed even
inside [...]). [bug introduced in grep-2.5]
- Update to 2.23
* Binary files are now less likely to generate diagnostics and
more likely to yield text matches. grep now reports "Binary
file FOO matches" and suppresses further output instead of
outputting a line containing an encoding error; hence grep can
now report matching text before a later binary match.
Formerly, grep reported FOO to be binary when it found an
encoding error in FOO before generating output for FOO, which
meant it never reported both matching text and matching binary
data; this was less useful for searching text containing
encoding errors in non-matching lines. [bug introduced in
grep-2.21]
* grep -c no longer stops counting when finding binary data.
[bug introduced in grep-2.21]
* grep no longer outputs encoding errors in unibyte locales. For
example, if the byte '\x81' is not a valid character in a
unibyte locale, grep treats the byte as binary data. [bug
introduced in grep-2.21]
* grep -oP is no longer susceptible to an infinite loop when
processing invalid UTF8 just before a match. [bug introduced in
grep-2.22]
* --exclude and related options are now matched against trailing
parts of command-line arguments, not against the entire
arguments. This partly reverts the --exclude-related change
in 2.22. [bug introduced in grep-2.22]
* --line-buffer is no longer ineffective when combined with -l.
[bug introduced in grep-2.5]
* -xw is now equivalent to -x more consistently, with -P and
with backrefs. [bug only partially fixed in grep-2.19]
- Update info handling scriplets
* move from postun to preun
* add dependeny for preun
- Refresh partially upstreamed patch
* testsuite.patch

==== gstreamer ====
Version update (1.6.3 -> 1.8.0)
Subpackages: gstreamer-devel gstreamer-utils libgstreamer-1_0-0
libgstreamer-1_0-0-32bit typelib-1_0-Gst-1_0

- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
+ Bugs fixed: bgo#763491, bgo#763895, bgo#764034, bgo#763770.
- Rebase gstreamer-rpm-prov.patch, base on fedora patch.

==== gstreamer-plugins-bad ====
Version update (1.6.3 -> 1.8.0)
Subpackages: libgstadaptivedemux-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
libgstwayland-1_0-0

- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
+ Bugs fixed: bgo#763756, bgo#763793, bgo#763877, bgo#763974,
bgo#764066, bgo#763262.
- Add pkgconfig(xcb) and pkgconfig(wayland-scanner) BuildRequires:
New dependencies.
- Add 2 new subpackages and handle them in post/un
+ libsgtbadaudio and libgstplayer.

==== gstreamer-plugins-base ====
Version update (1.6.3 -> 1.8.0)
Subpackages: gstreamer-plugins-base-devel libgstallocators-1_0-0
libgstapp-1_0-0 libgstaudio-1_0-0 libgstaudio-1_0-0-32bit libgstfft-1_0-0
libgstpbutils-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0
libgstsdp-1_0-0 libgsttag-1_0-0 libgsttag-1_0-0-32bit libgstvideo-1_0-0
libgstvideo-1_0-0-32bit typelib-1_0-GstAllocators-1_0 typelib-1_0-GstApp-1_0
typelib-1_0-GstAudio-1_0 typelib-1_0-GstFft-1_0 typelib-1_0-GstPbutils-1_0
typelib-1_0-GstRtp-1_0 typelib-1_0-GstRtsp-1_0 typelib-1_0-GstSdp-1_0
typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
+ Bugs fixed: bgo#763316.
- Add pkgconfig(opus) BuildRequires: New optional dependency.
- Add explicit pkgconfig(gio-unix-2.0) BuildRequires: Already
pulled in, but add it so we can version it.

==== gstreamer-plugins-good ====
Version update (1.6.3 -> 1.8.0)
Subpackages: gstreamer-plugins-good-extra

- Changed required version of libvpx to >= 1.3.0, package can be
successfully built against it and version >= 1.4.0 isn't
available for openSUSE 13.2 and Leap 42.1 on PMBS.
- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
- Add explicit pkgconfig(libsoup-2.4) BuildRequires and version it.
- Pass --enable-v4l2-probe to configure. This is a runtime check.

==== gstreamer-plugins-ugly ====
Version update (1.6.3 -> 1.8.0)

- Added installed (but unpackaged) file libgstmpg123.so on PMBS to
subpackage gstreamer-plugins-ugly-orig-addon.
- Update to version 1.8.0:
+ Hardware-accelerated zero-copy video decoding on Android
+ New video capture source for Android using the
android.hardware.Camera API.
+ Windows Media reverse playback support (ASF/WMV/WMA).
+ New tracing system provides support for more sophisticated
debugging tools.
+ New high-level GstPlayer playback convenience API.
+ Initial support for the new Vulkan API, see Matthew Waters'
blog post for more details.
+ Improved Opus audio codec support: Support for more than two
channels; MPEG-TS demuxer/muxer can now handle Opus;
sample-accurate encoding/decoding/transmuxing with Ogg,
Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container;
new codec utility functions for Opus header and caps handling
in pbutils library. The Opus encoder/decoder elements were
also moved to gst-plugins-base (from -bad), and the opus RTP
depayloader/payloader to -good.
+ GStreamer VAAPI module now released and maintained as part of
the GStreamer project.
+ Asset proxy support in the GStreamer Editing Services.
- Add pkgconfig(libmpg123) BuildRequires.

==== hexchat ====
Subpackages: hexchat-lang

- Remove non existent configure --enable-minimal-flags and --enable-ntlm

==== hwinfo ====
Version update (21.23 -> 21.24)
Subpackages: hwinfo-devel

- adjust dmi parser to read memory size according to latest smbios spec
(bsc#974737)
- adjust dmi parser to read memory size according to latest smbios spec
(bsc#974737)
- 21.24

==== ibus ====
Version update (1.5.11 -> 1.5.13)
Subpackages: ibus-branding-openSUSE-KDE ibus-gtk ibus-gtk-32bit ibus-gtk3
libibus-1_0-5 libibus-1_0-5-32bit python-ibus typelib-1_0-IBus-1_0

- Upstream update to 1.5.13
* Add SetCursorLocationRelative D-Bus method
- Upstream update to 1.5.12
* Fix ibus-daemon does not update user cache
* Fix lookup window on a secondary monitor cannot get its correct
size
* Fix default position of property panel under multi monitor
environments
* Change language code from ISO 939-2 to ISO 639-1
* Fix minor bugs
- Drop show-input-mode-icon.patch
* this feature has been reimplemented in another approach
- Own all oxygen icon subdirs, starting with KF 5.21.0, oxygen is
no longer installed to the same location

==== intlfonts ====
Subpackages: intlfonts-euro-bitmap-fonts

- spec file change to avoid transient build failure
about the 'for b' loop generating the *pcf.gz files.

==== jack ====
Subpackages: libjack-devel libjack0

- Fix the build failure with gcc6:
gcc6-fixes.diff

==== kernel-source ====
Version update (4.5.0 -> 4.5.2)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Update patches.kernel.org/patch-4.5.1-2 (fate#318900 bsc#963490
bnc#972330).
One more bnc.
- commit 0454a6e
- Linux 4.5.2 (fate#318900 bsc#963490).
- Delete patches.suse/fs_add_file_dentry.patch.
- Delete patches.suse/nfs-use-file-dentry.patch.
- commit 8a6791e
- netfilter: x_tables: fix unconditional helper (CVE-2016-3134
bsc#971126).
- netfilter: x_tables: make sure e->next_offset covers remaining
blob size (CVE-2016-3134 bsc#971126).
- netfilter: x_tables: validate e->target_offset early
(CVE-2016-3134 bsc#971126).
- netfilter: x_tables: check for size overflow (CVE-2016-3135
bsc#970904).
- commit 99697f1
- series.conf: move netfilter section right after core networking
- commit 9105886
- Update patches.kernel.org/patch-4.5.1 (CVE-2016-2184
CVE-2016-2185 CVE-2016-2186 CVE-2016-3140 CVE-2016-3689
bnc#967903 bnc#970892 bnc#970958 bnc#971124 bnc#971628
boo#969098 boo#970968 boo#971737 boo#971853 bsc#969383
bsc#969870 bsc#971125 bnc#970955 CVE-2016-3136).
One more reference.
- commit da73f3b
- Update config files: arm64: Enable Xilinx ZynqMP
- commit fd7ad3d
- rpm/kernel-binary.spec.in: No -kgraft subpackage for openSUSE (fate#320268)
- commit 269d6bf
- Linux 4.5.1 (CVE-2016-2184 CVE-2016-2185 CVE-2016-2186
CVE-2016-3140 CVE-2016-3689 bnc#967903 bnc#970892 bnc#970958
bnc#971124 bnc#971628 boo#969098 boo#970968 boo#971737
boo#971853 bsc#969383 bsc#969870 bsc#971125).
- Delete
patches.arch/intel_idle-prevent-SKL-H-boot-failure-when-C8-C9-C10.
- Delete

patches.drivers/0001-Input-ims-pcu-sanity-check-against-missing-interface.patch.
- Delete

patches.drivers/0001-Input-powermate-fix-oops-with-malicious-USB-descript.patch.
- Delete

patches.drivers/0001-USB-digi_acceleport-do-sanity-checking-for-the-numbe.patch.
- Delete
patches.drivers/0001-USB-usb_driver_claim_interface-add-sanity-checking.patch.
- Delete
patches.drivers/ALSA-hda-Don-t-handle-ELD-notify-from-invalid-port.
- Delete
patches.drivers/ALSA-hda-Fix-forgotten-HDMI-monitor_present-update.
- Delete
patches.drivers/ALSA-hda-Fix-spurious-kernel-WARNING-on-Baytrail-HDM.
- Delete
patches.drivers/ALSA-hda-Fix-unexpected-resume-through-regmap-code-p.
- Delete
patches.drivers/ALSA-hda-Limit-i915-HDMI-binding-only-for-HSW-and-la.
- Delete
patches.drivers/ALSA-hda-Really-restrict-i915-notifier-to-HSW.
- Delete
patches.drivers/ALSA-usb-audio-Add-sanity-checks-for-endpoint-access.
- Delete
patches.drivers/ALSA-usb-audio-Fix-NULL-dereference-in-create_fixed.
- Delete
patches.drivers/drm-radeon-rework-fbdev-handling-on-chips-with-no-co.
- Delete
patches.fixes/net-irda-Fix-use-after-free-in-irtty_open.patch.
- commit cf9b28d
- config: armv7hl: Enable R8169
Enable RTL8169 PCI NIC, found on Jetson TK1 board.
- commit b98c3d3
- USB: digi_acceleport: do sanity checking for the number of ports
(bnc#970892, CVE-2016-3140).
- commit c3d2a95
- KVM: arm/arm64: Handle forward time correction gracefully (bnc#974266).
- commit 76b2c0d
- Input: powermate - fix oops with malicious USB descriptors
(bnc#970958, CVE-2016-2186).
- commit 9c51535
- USB: usb_driver_claim_interface: add sanity checking
(bnc#971124, CVE-2016-2185).
- commit babf987
- Input: ims-pcu - sanity check against missing interfaces
(bnc#971628, CVE-2016-3689).
- commit f5cb5e8
- rpm/find-requires: Generate dependencies for KMPs defined in supported.conf
(fate#319339)
- commit 007a83c
- rpm/kernel-source.rpmlintrc: Disable rpmlint check for KMP subpackages
The check is there to ensure that KMPs are built using the
%kernel_module_package macro, but we are deliberately not doing this for
KMPs built from the kernel specfile (fate#319339).
- commit 7c48b60
- Update config files.
Set SERIAL_8250_SHARE_IRQ (bnc#973748).
- commit 606f94a
- ACPI / processor: Request native thermal interrupt handling
via _OSC (bsc#969870).
- commit f6eec7e
- rpm/kernel-binary.spec.in: Only build the -kgraft package for modular kernels
(fate#320268)
- commit 9bab96f
- rpm/kernel-binary.spec.in: Only build KMPs if CONFIG_SPLIT_PACKAGE=y
(fate#319339)
- commit def905b
- rpm/kernel-binary.spec.in: Tag KMPs so that weak-modules2 ignores them
Also require a suse-module-tools version that can handle this (fate#319339).
- commit 58d21f9
- rpm/kernel-binary.spec.in: Add rpm scriptlets for KMPs (fate#319339)
Use the --{add,remove}-kernel-modules options of weak-modules2 instead
of --{add,remove}-kmp, because we do not want any symlinks to be created
for these KMPs.
- commit 95f8b94
- rpm/split-modules: Split modules into KMPs defined in supported.conf
(fate#319339)
- commit 39da39b
- rpm/mkspec: Generate KMP subpackage sections from a template (fate#319339)
The KMPs are defined in the supported.conf file using a +<name>-kmp
guard.
- commit 09cb6b1
- rpm/kernel-obs-build.spec.in:add e1000 and ibmveth
Those modules are required in order to have --vm-telnet option
working
- commit 1e87b6d
- rpm/kernel-binary.spec.in: Simplify parsing of supported.conf (fate#319339)
- commit 006b146
- rpm/kernel-binary.spec.in: Introduce a kernel-default-kgraft metapackage
(fate#320268)
- commit 0439a47

==== kf5-filesystem ====
Version update (20160409 -> 20160420)

- Define %_kf5_appstreamdir

==== kismet ====
Version update (2013_03_R1b -> 2016_01_R1)

- Kismet 2016-01-R1:
* force validation of fcs by default for all sources
* support for recent autotools
* fixes for crashes when alert backlog was set to zero
* fixes for failures in some VIF situations
* fixes to resizing windows
* fixes to GPS averaging
* fixes to Radiotap changes in recent kernels
* add WPS state parsing
* handle BSSTimestamp parsing
- upstream sources no longer signed, use source URLs

==== kiwi ====
Version update (7.03.65 -> 7.03.67)
Subpackages: kiwi-desc-isoboot kiwi-desc-netboot kiwi-desc-oemboot
kiwi-desc-vmxboot kiwi-doc kiwi-media-requires kiwi-pxeboot kiwi-templates
kiwi-tools

- v7.03.67 released
- Add part_msdos module for self build EFI image
On ARM we have a few hooks in kiwi that allow us to adapt the
resulting image to target boards. On some systems, we need to
install the firmware to hardware specified sector offsets on
the image target (sd card).
Unfortunately some systems demand firmware at sector 1 which is
where the GPT would usually reside. So we need to use an MBR partition
layout.
We can convert the GPT into an MBR using gdisk in our ARM scripts,
but at that point grub2 would have to be able to interpret the MBR
as well. So we need the "msdos_part" module included (bnc#975898)
- Follow up fix for not writing grub.cfg to EFI dir
With the move to grub2-install and also shim-install
the static copy of the grub configuration into the
EFI boot directory became obsolete (bnc#968270)
- v7.03.66 released
- Fixed kiwi-pxeboot package setup
The package was marked noarch but has architecture dependant
requirements. Therefore it can't be marked noarch (bnc#974651)
- Fixed oem and vmx buildservice boot requires
The packages kiwi-desc-oemboot-requires and kiwi-desc-vmxboot-requires
did not explicitly require grub2 or the architecture specific efi module
packages for the arm architectures. The requirement was added by the
contents of the arm boot image descriptions. However those packages
will not be part of the boot image descriptions in the near future
and thus the buildservice needs them to be referenced explicitly
in the spec file
- Translated using Weblate (Greek)
Currently translated at 89.2% (25 of 28 strings)

==== libapr-util1 ====
Subpackages: libapr-util1-devel

- require just posgresql-devel everywhere, it seems to work now

==== libgexiv2 ====

- Add gobject-introspection BuildRequires: needed in order to scan
the python bindings for gi dependencies.
- Build Python bindings:
+ Add python-devel, python3-devel, python-gobject and
python3-gobject BuildRequires.
+ Split new packages python-gexiv2 and python3-gexiv2.

==== libgit2 ====
Version update (0.24.0 -> 0.24.1)

- libgit2 0.24.1:
+ various compatible backported bug fixes

==== libgltf ====
Version update (0.0.1 -> 0.0.2)

- Update to libgltf-0.0.2 (LO 4.3.3+)
libgltf-0.0.1.tar.bz2 -> libgltf-0.0.2.tar.bz2

==== libmicrohttpd ====
Version update (0.9.48 -> 0.9.49)

- Update to 0.9.49
* See provided Changelog for details
- Fix typo in previous changelog entry
- Refresh patches
- Use pkgconfig style dependencies

==== libqb ====
Version update (0.17.2+git20151001.1a7ea3b -> 1.0.0+git20160407.6f2b3e8)

- further avoid magic in qblog.h by using named constants
- defs: add wrappers over preprocessor operators
- Upstream version cs: 6f2b3e85d0315288ee76869b99369e2b1f2f1b71
- Update to version 1.0.0
- build: update library soname to 0.18.0
- build: enable syslog tests when configuring in spec
- log: allow changing the identifier for syslog (+tests)
- ipc: return -errno when getsockopt/setsockopt fail
- ipc: set socket buffer size used by ipcs service
- ipc: set socket receive buffer
- includes: format __attribute__ func. annotations in qblog.h
- spec cleanup: get rid of redundant %clean section
- ipc: set gid on unix sockets
- lib: store server peer credentials in qb_ipcc_connection
- lib: create mmap files in socket directory
- includes: Fix format string
- ipc: Prevent fd and memory leaks in handle_new_connection() (bsc#947341)
* Drop bug-947341_libqb-ipc-fd-memory-leaks.patch which has been merged
upstream
- Upstream version cs: 6fc24f855bfc8dadb4c84bf823b225680670b1c3 (v1.0)

==== libreoffice ====
Version update (5.1.2.2 -> 5.1.3.1)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions
libreoffice-draw libreoffice-filters-optional libreoffice-gnome
libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions libreofficekit

- Version update to 5.1.3.1:
* Various small bugfixes all around 5.1 series
- fix bnc#856729 - LO-L3: Double borders in Calc
* bnc856729.patch
- update constraints file for aarch64

==== librevenge ====
Subpackages: librevenge-0_0-0 librevenge-devel librevenge-generators-0_0-0
librevenge-stream-0_0-0

- Do not BuildRequire gdb: there is no need to be ordered behind
gdb in the build tree. Configure does check for the presence of
the gdb binary, but the detected value is not used in the entire
source tree.

==== librsvg ====
Subpackages: gdk-pixbuf-loader-rsvg librsvg-2-2 librsvg-devel
typelib-1_0-Rsvg-2_0

- Add librsvg-Fix-rsvg-convert.patch: Actually scale the image if
required, regression fix from upstream git (bgo#760262).

==== libsolv ====
Version update (0.6.19 -> 0.6.20)
Subpackages: libsolv-devel libsolv-tools perl-solv python-solv

- Better support of complex deps in pool_match_dep and
selection_make_matchdeps
- make SOLVER_REASON_CLEANDEPS_ERASE introspection reason work again
- make dep2str use rpm-like output if disttype is rpm
- implement filtering of Requires(pre,post) for installed packages
- simplify handling of pseudo package updates [bnc#967006]
- improve speed of rpmmd metadata parsing
- bump version to 0.6.20

==== libsoup ====
Version update (2.54.0.1 -> 2.54.1)
Subpackages: libsoup-2_4-1 libsoup-devel typelib-1_0-Soup-2_4

- Update to version 2.54.1:
+ Fixed an ABI break in 2.54.0 caused by adding a member to
SoupAuthClass; 2.54.1 is ABI-compatible with 2.53.92 and
earlier, but NOT with the anomalous 2.54.0. If you built
packages against 2.54.0, you will need to rebuild them against
2.54.1.
+ Fixed NTLM authentication when ntlm_auth from the latest
version of Samba is present (bgo#765106).
+ Updates to MSVC build, including for GSS-API support.
+ Updated translations.
- Drop libsoup-auth-ntlm-fix.patch: Fixed upstream.
- Add libsoup-auth-ntlm-fix.patch: Fix NTLM auth failure with
latest samba (bgo#765106, boo#976110).

==== libstorage ====
Version update (2.25.37 -> 2.26.2)

- call udevadm settle after call of parted (bsc#975162)
- 2.26.2
- provide information about DASD format and type
(related to bnc#958893)
- 2.26.1

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen

- qemu: perf: Fix crash/memory corruption on failed VM start
03e8d5fb-qemu-perf-memory-corruption.patch
bsc#977131
- Fix setting implicit video devices as primary
6d8b6d28-mark-implicit-video-primary.patch
bsc#977150

==== libvirt-python ====
Version update (1.3.2 -> 1.3.3)

- Update to 1.3.3
- Add all new APIs and constants in libvirt 1.3.3

==== libzypp ====
Version update (15.21.5 -> 15.22.0)

- Fix credential file parser losing entries with known URL but
different user name (bsc#933760)
- RepoManager: allow extraction of multiple baseurls for service
repos (bsc#964932)
- addRepository: fix to use the correct history file for logging
- specfile: add /etc/zypp/credentials.d to the file list
- version 15.22.0 (19)
- RepoindexFileReader: fix service metadata TTL default value (bsc#967828)
- version 15.21.7 (19)
- DiskUsageCounter: Limit estimated waste per file (bsc#974275)
- version 15.21.6 (19)

==== mailman ====
Version update (2.1.21 -> 2.1.22)

- update to 2.1.22
* bug fixes, i18n updates; for details see NEWS

==== mailx ====

- Correct parenthese expansion to fulfill natural order (bnc#974561)

==== meld ====
Version update (3.15.2 -> 3.15.3)
Subpackages: meld-lang

- Update to version 3.15.3:
+ Handle unicode dates in non-UTF8 locales in folder comparison.
+ Try to auto-detect when to use our dark theme highlighting.
+ After undo/redo actions in file comparisons, place the cursor
at the natural edit position and scroll it back onscreen.
- Require python-gobject-Gdk: pygobject was further split in order
to be able to install it without X-dependencies. As meld is a
GUI application, the dependency on the X-stack is no issue.

==== nfs-utils ====
Subpackages: nfs-client nfs-doc nfs-kernel-server

- 0001-close-the-syslog-fd-in-daemon_init.patch
Without this, tracing doesn't work
- 0001-mount.nfs-trust-the-exit-status-of-start_statd.patch
(bsc#945937)
- 0001-mount-run-START_STATD-fully-as-root.patch
(bsc#969152)

==== nghttp2 ====
Version update (1.9.1 -> 1.10.0)

- Update to 1.10.0
* Pass unknown SETTINGS values to nghttp2_on_frame_recv_callback
* Add ALTSVC frame support
* Run error callback when peer does not send initial SETTINGS
frame
* Update http-parser
* Update sphinx_rtd_theme
* nghttp: add an --expect-continue option
* nghttpx: Fix downstream connect callback called early
* nghttpx: Truncate too long -b option signature
* nghttpx: Fix bug that server push from mruby script did not
work
* nghttpx: Try next HTTP/1 backend address when connection
cannot be made
* nghttpx: Retry next HTTP/2 backend address when connection
cannot be made
* nghttpx: Enable link header field based push for non-final
response
* nghttpx: Detect online/offline state of backend servers
* nghttpx: Better load balancing between backend HTTP/2 servers
* nghttpx: Fix crash with backend failure
- Update to 1.9.2
* nghttpx: Fix crash with backend failure
* nghttpx: Better distribute load to backend h2 servers
* nghttpx: Fix error messages on deprecated mode
* nghttpx: Fix bug that logger wrote string which was not
NULL-terminated
* nghttpx: Fix bug that proxy with HTTP/1.1 CONNECT did not work

==== obs-service-set_version ====

- Update to version 0.5.3:
* VersionDetector._autodetect: prioritize the directory name over the file
name

==== ocfs2-tools ====

- Add 0009-o2cb-fix-systemd-o2cb.service-failure.patch to fix bsc#963959

==== open-iscsi ====
Subpackages: iscsiuio

- Ported 3 changes from SLE 12 that are not upstream, but
are needed here, as there are in SLE:
* Fixed systemd start of iscsi.service (bsc#897565)
* iscsiuio: ARP table too small when switches involve
* Discovery via non-tcp transport needs IPC set.

==== p7zip ====
Version update (15.14 -> 15.14.1)

- Update to version 15.14.1
- Patch #32 Compiling in OS X fails with p7zip_15.14.
- Fixed spec file to build with copied makefile.linux_amd64_asm
for arch x86-64 and added required yasm as BuildRequires.

==== perl-DBD-XBase ====
Version update (1.05 -> 1.06)

- updated to 1.06
see /usr/share/doc/packages/perl-DBD-XBase/Changes
1.06 Sun Mar 6 20:48:11 CET 2016
Add support for W column type (byte array by Visual FoxPro).
Fixed overload arg warning.
Restore the table_info functionality.
Fix for type B little endian issue, reported by Andres Thomas.

==== perl-JSON-XS ====
Version update (3.01 -> 3.02)

- updated to 3.02
see /usr/share/doc/packages/perl-JSON-XS/Changes
TODO: how to cope with tagged values and standard json decoders
TODO: investigate magic (Eric Brine)

==== phonon ====
Version update (4.8.1 -> 4.9.0)
Subpackages: libphonon4 phonon-devel

- Remove now unused automoc4 BuildRequires
- Update to 4.9.0:
* Changes
* Builsystem helpers are now installed to CMAKE_INSTALL_DATAROOTDIR
* CMake 2.8.9 is required to use GNUInstallDirs and for the Qt5
code branches
* automoc4 support was removed. Building always use the cmake
built-in solution now.
* Qt5 and Qt4 builds use different CMake configurations now
Qt4 is as it always has been
* Qt5 moved away from crudely ported Qt4 configurations to using
extra-cmake-modules' KDE compiler and cmake flags.
* Installation paths and so forth are still jointly configured as
to retain backwards compatibility (i.e. Qt5 build does not
follow ECM's KDEInstallationPaths)
* Bug Fixes
* VolumeSlider has seen async behavior improvements making the
slider not hop around when changing the volume rapidly and
the backend is lagging a bit behind.
* The volume change now occurs upon slider release rather
than instantly.
* Fixed a duble encoding issue with local paths that contain
percent encoded characters being double-encoded [kde#356218]
* New API
* New AudioOutputInterface49 for backends to implement. This
interface implements long-existing frontend interfaces for
muting, giving the backend easier access and control.
* setMuted(bool) mutes an AudioOuput (without the 4.9
interface this is done via setVolume(0.0) on the backend)
* mutedChanged(bool) signal emitted by the backend to
asyncronuously notify of the mute application
* The interface is only used if PulseSupport is not
intercepting calls
* New methods to differntiate states of PulseSupport
* request(bool) is used by backends to request PulseAudio
usage but no interception, this essentially enables device
listing but lets everything else fall through to the backend
(the existing isActive() method will not return true after
request(true), which makes it different from enable(true))
* isRequested() is a getter for request()'s state
* isUsable() is part of the previouys isActive() behavior,
it is true iff pulseaudio can be used
(daemon running, connected etc)
* isUsed() is a combination of isRequested() and isUsable()
(i.e. active but not intercepting)
* The existing isActive() communicates the same state as
before (active and intercepting) but now also takes
requested into consideration
* Enabling always implies requsting automatically, so
request(false) and enable(true) will ultimately still
restul in isRequested==true
- Update to 4.8.3:
* Set target interface include install dir
* Do not assume we have a backend when setting an output device,
kde#341296
- Update to 4.8.2:
* Revised the logic used by PulseSupport to come up with an icon
name for PulseAudio. If the application has
QApplication::windowIcon set with an QIcon constructed through
QIcon::fromTheme(string) the actual icon name will be used.
Otherwise the lower-case version of
QCoreApplication::applicationName is used.
* Fixed building with the compiler clang by reverting
a previously introduced workaround.
- Drop phonon obsoletes/provides, it was last used in openSUSE 11.4
- Move DBus interface file into devel package, it's unused at runtime

==== phonon-backend-gstreamer ====
Version update (4.8.2 -> 4.9.0)

- Remove now unused automoc4 BuildRequires
- Update to 4.9.0
* No changelog provided
- Drop upstreamed Fix-finding-recent-versions-of-GStreamer.patch

==== polkit-default-privs ====

- added brltty (bsc#967436)
- add importd privs as default tracked (bsc#964935)
- polkit-default-privs: relaxing firewalld polkit rule for desktop (bsc#971580)

==== pragha ====
Subpackages: pragha-lang

- BuildRequires: pkgconfig(grilo-0.2) for oS <= 13.2. The program
isn't ready for grilo-0.3 yet.
- Add pragha-gtk_switch_set_state.patch: fix build for openSUSE
13.1.

==== pulseaudio ====
Subpackages: libpulse-devel libpulse-mainloop-glib0 libpulse0 libpulse0-32bit
pulseaudio-bash-completion pulseaudio-esound-compat pulseaudio-module-bluetooth
pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc
pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils

- Use /etc/pulse/client.conf.d/50-system.conf as a system setup by
setup-pulseaudio script instead of modifying the global config.
- Move libpulsedsp.so into pulseaudio-utils subpackage and add it
to baselibs.conf so that 32bit compat lib is built (boo#968568);
also recommends is added in libpulse0-32bit for easy installation
- Fix padsp script to support bi-arch libs (boo#968568) with
padsp-biarch.patch
- Call bootstrap.sh for rebuilding properly with patches
- Drop the obsoleted disable-srbchannel.patch, which has been fixed
in upstream already

==== python-gobject ====
Subpackages: python-gobject-Gdk python-gobject-cairo python-gobject-devel

- Do not package GIMarshallingTests: it's only used by the test
suite and is useless on an installed system (the corresponding
typelibs and libraries are also not installed).

==== python-kde4 ====
Subpackages: python-kde4-devel python-kde4-doc python-kde4-khtml
python-kde4-knewstuff python-kde4-phonon python-kde4-plasma

- Add fix-build.diff to fix the build in Factory (boo#975915)

==== python3-gobject ====
Subpackages: python3-gobject-Gdk python3-gobject-cairo

- Do not package GIMarshallingTests: it's only used by the test
suite and is useless on an installed system (the corresponding
typelibs and libraries are also not installed).

==== rsyslog ====
Version update (8.17.0 -> 8.18.0)

- rsyslog 8.18.0:
* templates: add option to convert timestamps to UTC
* omjournal: fix segfault (regression in 8.17.0)
* imptcp: added AF_UNIX support
* new template options
* compressSpace
* date-utc
* redis: support for authentication
* omkafka: makes kafka-producer on-HUP restart optional
* imfile: new "FreshStartTail" input parameter
* omjournal: fix libfastjson API issues
* ommongodb: fix json API issues
* dynamic stats subsystem: a couple of smaller changes
* foreach loop: now also iterates over objects (not just arrays)
* enhancement: queue subsystem is more robst in regard to some corruptions
* enhancement: Allow rsyslog to bind UDP ports even w/out specific
interface being up at the moment.
* new External plugin for sending metrics to SPM Monitoring SaaS
* bugfix imfile: fix memory corruption bug when appending @cee
* bugfix: memory misallocation if position.from and position.to is used
a negative amount of memory is tried to be allocated if position.from
is smaller than the buffer size (at least with json variables). This
usually leads to a segfault.
* bugfix: fix potential memleak in TCP allowed sender definition
* bugfix: $PrivDropToGroupID actually did a name lookup
* bugfix: small memory leak in imfile
* bugfix: double free in jsonmesg template
* bugfix: incorrect formatting of stats when CEE/Json format is used
* bugfix omfwd: new-style keepalive action parameters did not work
due to being inconsistently spelled inside the code. Note that legacy
parameters $keepalive... always worked
* bugfix: memory leaks in logctl utility
* bugfix omrelp: fix segfault if no port action parameter was given
* bugfix imtcp: Messages not terminated by a NL were discarded

==== sessreg ====

- replaced formerly to be upstreamed patch
u_Pass-P-to-the-preprocessor-when-generating-filenames.patch
by upstream patch
U_Pass-P-to-the-preprocessor-when-generating-filenames.patch

==== sqlite3 ====
Version update (3.12.1 -> 3.12.2)
Subpackages: libsqlite3-0 libsqlite3-0-32bit sqlite3-devel sqlite3-doc

- SQLite 3.12.2:
* Fix compatibility with some legacy versions of sqlite database
* Minor bugfixes

==== sssd ====
Version update (1.13.3 -> 1.13.4)
Subpackages: libnfsidmap-sss libsss_idmap0 libsss_nss_idmap0 sssd-32bit
sssd-krb5-common sssd-ldap

- Enable PAC responder.
PAC is an extension element returned by domain controller, to speed
up resolution of authorisation data such as group memberships.
- Update to new upstream release 1.13.4
* The IPA sudo provider was reimplemented. The new version reads the
data from IPA's LDAP tree (as opposed to the compat tree populated by
the slapi-nis plugin that was used previously). The benefit is that
deployments which don't require the compat tree for other purposes,
such as support for non-SSSD clients can disable those autogenerated
LDAP trees to conserve resources that slapi-nis otherwise requires. There
should be no visible changes to the end user.
* SSSD now has the ability to renew the machine credentials (keytabs)
when the ad provider is used. Please note that a recent version of
the adcli (0.8 or newer) package is required for this feature to work.
* The automatic ID mapping feature was improved so that the administrator
is no longer required to manually set the range size in case a RID in
the AD domain is larger than the default range size
* A potential infinite loop in the NFS ID mapping plugin that was
resulting in an excessive memory usage was fixed
* Clients that are pinned to a particular AD site using the ad_site
option no longer communicate with DCs outside that site during service
discovery.
* The IPA identity provider is now able to resolve external
(typically coming from a trusted AD forest) group members during
get-group-information requests. Please note that resolving external
group memberships for AD users during the initgroup requests used to
work even prior to this update. This feature is mostly useful for cases
where an IPA client is using the compat tree to resolve AD trust users.
* The IPA ID views feature now works correctly even for deployments
without a trust relationship. Previously, the subdomains IPA provider
failed to read the views data if no master domain record was created
on the IPA server during trust establishment.
* A race condition in the client libraries between the SSSD closing
the socket as idle and the client application using the socket was
fixed. This bug manifested with a Broken Pipe error message on the
client.
* SSSD is now able to resolve users with the same usernames in different
OUs of an AD domain
* The smartcard authentication now works properly with gnome-screensaver

==== subversion ====
Version update (1.9.3 -> 1.9.4)
Subpackages: libsvn_auth_gnome_keyring-1-0 libsvn_auth_kwallet-1-0
subversion-bash-completion subversion-devel subversion-perl subversion-python
subversion-server subversion-tools

- Apache Subversion 1.9.4, fixing two server-side vulnerabilities:
* CVE-2016-2167: svnserve/sasl may authenticate users using the
wrong realm (boo#976849)
* CVE-2016-2168: Remotely triggerable DoS vulnerability in
mod_authz_svn during COPY/MOVE authorization check (boo#976850)
- Client-side bugfixes:
* diff: support '--summarize --ignore-properties'
* checkout: fix performance regression on NFS
* gpg-agent: properly handle passwords with percent characters
* svn-graph.pl: fix assertion about a non-canonical path
* hot-backup.py: better input validation
* commit: abort on Ctrl-C in plaintext password prompt
* diff: produce proper forward binary diffs with --git
* ra_serf: fix deleting directories with many files
- Server-side bugfixes:
* improve documentation for AuthzSVNGroupsFile and groups-db
* fsfs: reduce peak memory usage when listing large directories
* fsfs: fix a rare source of incomplete dump files and reports
- Client-side and server-side bugfixes:
* update INSTALL documentation file
* fix potential memory access bugs
* fix potential out of bounds read in svn_repos_get_logs5()
- Bindings bugfixes:
* ignore absent nodes in javahl version of svn status -u
- API changes:
* properly interpret parameters in svn_wc_get_diff_editor6()

==== suse-module-tools ====
Version update (12.3 -> 12.4)

- Skip KMPs built from the kernel spec file directly (fate#319339)
- Bump version number to 12.4

==== tcpdump ====

- fix filelist to fix build on s390/s390x

==== timezone ====
Version update (2016c -> 2016d)

- timezone update 2016d
* Venezuela (America/Caracas) switches from -0430 to -04 on
2016-05-01 at 02:30 [boo#975875]
* Asia/Magadan switches from +10 to +11 on 2016-04-24 at 02:00.
* New zone Asia/Tomsk, split off from Asia/Novosibirsk. It covers
Tomsk Oblast, Russia, which switches from +06 to +07 on
2016-05-29 at 02:00
* Changes for past time zones (corrections and new Europe/Kirov)
* Corrections to historical time in Kazakhstan from 1991
through 2005.

==== timezone-java ====
Version update (2016c -> 2016d)

- timezone update 2016d
* Venezuela (America/Caracas) switches from -0430 to -04 on
2016-05-01 at 02:30 [boo#975875]
* Asia/Magadan switches from +10 to +11 on 2016-04-24 at 02:00.
* New zone Asia/Tomsk, split off from Asia/Novosibirsk. It covers
Tomsk Oblast, Russia, which switches from +06 to +07 on
2016-05-29 at 02:00
* Changes for past time zones (corrections and new Europe/Kirov)
* Corrections to historical time in Kazakhstan from 1991
through 2005.

==== tomcat ====
Version update (8.0.32 -> 8.0.33)
Subpackages: tomcat-admin-webapps tomcat-el-3_0-api tomcat-jsp-2_3-api
tomcat-lib tomcat-servlet-3_1-api tomcat-webapps

- Version update to 8.0.33:
* Another bugfix release for 8.0 series, full details:
http://tomcat.apache.org/tomcat-8.0-doc/changelog.html#Tomcat_8.0.33_(markt)
- Rebase tomcat-8.0-tomcat-users-webapp.patch
- Rebase tomcat-7.0.53-JDTCompiler-java.patch
to tomcat-8.0.33-JDTCompiler-java.patch

==== udisks2 ====
Subpackages: libudisks2-0

- Add udisks2-Reread-partition-table-before-wiping.patch: Reread
partition table before wiping when creating new partitions
(fdo#85477).

==== upower ====
Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0

- Add upower-fix-get-critical-crash.patch: daemon: fix
get_critical_action(), without this upower daemon will crash when
trying to take action (boo#975653, fdo#94262).

==== vm-install ====
Version update (0.8.50 -> 0.8.51)

- bsc#976500 - vm-install: failure due to incorrectly parsing the
output of sfdisk
- Version 0.8.51

==== webkit2gtk3 ====
Version update (2.12.0 -> 2.12.1)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.12.1:
+ Fix spotify player.
+ Improve themed control elements rendering to better match GTK+
widgets.
+ Make remote web inspector work again.
+ Fix several crashes and rendering issues.
+ Fix several memory leaks.
+ Fix the build in Linux / PowerPC.
+ Fix detection of S390X and PPC64 architectures.
+ Fix the build in glibc-based BSD systems.
+ Updated translations.
- Add -DUSE_SYSTEM_MALLOC=ON to configure for ppc ppc64 ppc64le
and s390x, needed now for build to complete.

==== whois ====
Version update (5.2.11 -> 5.2.12)

- whois 5.2.12:
* Added the .xn--e1a4c (??, European Union) and .xn--mix891f (??,
Macao) TLD servers.
* Updated the .jobs, .kn and .pro TLD servers.
* Updated the .gi, .lc, .sc and .vc TLD servers, because the precedent
data caused the program to return an error status.
* Updated the list of new gTLDs.
* Fixed the code which queries whois.iana.org for TLDs to
recognize IDN TLDs too.

==== wicked ====
Version update (0.6.31 -> 0.6.32)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.32
- tunnel: add device binding support (fate#317977)
- gre: fix flags use, added missed keyed gre options
- doc: added an initial FAQ to the documentation
- util: fix null string and string array in compare
- ipv6: cleaned up IPv6 RA PI and RDNSS processing
- ipv6: receive IPv6 RA DNSSL options forwarded by kernel
- dhcp6: refresh ipv6 link on each prefix event to fix workaround
for missed NEWLINK event on changes caused by RA (boo#972471).
- macvlan: fix enum values for BRIDGE and PASSTHRU modes (boo#974231)

==== wine ====
Version update (1.9.7 -> 1.9.8)
Subpackages: wine-32bit

- Updated to 1.9.8 development snapshot
- More work towards the WineD3D command stream.
- Bug fix update of the Mono engine.
- More WebServices reader support.
- Still more Shader Model 5 support.
- Support for gradients in metafiles.
- Improved table formatting in WinHelp.
- Various bug fixes.
- updated winetricks

==== wireshark ====
Version update (2.0.2 -> 2.0.3)
Subpackages: wireshark-ui-gtk

- Wireshark 2.0.3 (boo#976944)
This release fixes a number issues in protocol dissectors that
could have allowed a remote attacker to crash Wireshark or cause
excessive CPU usage through specially crafted packages inserted
into the network or a capture file.
* The NCP dissector could crash (wnpa-sec-2016-19)
* TShark could crash due to a packet reassembly bug (wnpa-sec-2016-20)
* The IEEE 802.11 dissector could crash (wnpa-sec-2016-21)
* The PKTC dissector could crash (wnpa-sec-2016-22)
* The PKTC dissector could crash (wnpa-sec-2016-23)
* The IAX2 dissector could go into an infinite loop (wnpa-sec-2016-24)
* Wireshark and TShark could exhaust the stack (wnpa-sec-2016-25)
* The GSM CBCH dissector could crash (wnpa-sec-2016-26)
* MS-WSP dissector crash (wnpa-sec-2016-27)
* Further bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-2.0.3.html

==== xdg-app ====
Version update (0.5.1 -> 0.5.2)

- Update to version 0.5.2:
+ The way locale extensions work has changed. Now we build a
single extension for all locales, but we allow you to specify a
subset of it during installation and update time using the
- -subpath commandline flag. The main reason for this is that
the many extensions didn't scale, both in technical terms
(large ostree summary file size), but also in terms of the UI
listing hundreds of uninteresting things.
+ We no longer use sizes in the commit objects to get installed
and download size, instead we store some extra metadata in the
summary file. This allows us to get much faster access to
these, as with recent ostree versions we can cache the summary
file.
+ New command xdg-app build-sign that lets you sign a commit at
any time.
+ New argument xdg-app build --force-clean that removes
pre-existing build dirs.
+ xdg-app run now uses the "current" version as the default if
you specify no branch or arch. It used to default to the
"master" branch. This will default to the last installed
version, but can be changed with xdg-app make-current.
+ Added config-opts to the build-options in xdg-app-builder. This
allows you to extend the configure flags in an arch dependent
way.
+ Documentation updates.

==== xine-lib ====
Subpackages: libxine-devel libxine2 libxine2-pulse

- Drop libsmbclient BuildRequires: requiring a library to build is
in any case wrong. It's the responsibility of a -devel package to
pull in the real libraries.

==== yast2 ====
Version update (3.1.185 -> 3.1.186)
Subpackages: yast2-devel-doc

- Added restarting state to Installation to for example recover
data or skip dialogs until the one wich restarted yast.
(related to bsc#974409)
- 3.1.186

==== yast2-add-on ====
Version update (3.1.12 -> 3.1.14)

- AutoYaST: Do not reset add-on signature handling by the general
signature handling. (bnc#976859)
- 3.1.14
- Added missing "priority" tag in the AutoYaST schema (bsc#976457)
- 3.1.13

==== yast2-auth-client ====
Version update (3.3.6 -> 3.3.7)

- Introduce many new features:
* Simplify SSSD management interface.
* Enroll to AD directly from SSSD management interface.
* Edit settings for NSS/PAM LDAP.
* Edit settings for Kerberos.
Implements: fate#319137 fate#320407
Partly implements: fate#316205 fate#320364

==== yast2-bootloader ====
Version update (3.1.176 -> 3.1.178)

- Adapted new version of bootloader to the AutoYaST configuration
module.
(related to FATE#317701)
- 3.1.78
- Added requirement in proposal. (bnc#977004)
- 3.1.177

==== yast2-installation ====
Version update (3.1.181 -> 3.1.182)

- Disk Activation step will be skipped in case of installer update
success (bsc#974409)
- License agreement will be remembered in case of going back after
a installer update.
- 3.1.182

==== yast2-network ====
Version update (3.1.144 -> 3.1.148)

- bnc#966694
- TigerVNC Viewer Error: No matching security types. Do not touch
VNC arguments when enabling or disabling it. Thanks to
msrb@xxxxxxxx for the patch.
- 3.1.148
- bnc#974910
- fixed internal error when no "interfaces" group is found in an
AY profile
- 3.1.147
- bnc#955217, bnc#956605
- fixed internal error caused by the previous patch
- 3.1.146
- bnc#955217, bnc#956605
- unified udev rule handling by always doing it in the 1st stage
of installation.
- 3.1.145

==== yast2-ntp-client ====
Version update (3.1.21 -> 3.1.22)

- Calls to sntp adjusted to the syntax of ntp 4.2.8
(bnc#937837, bnc#916617, FATE#320392)
- 3.1.22

==== yast2-packager ====
Version update (3.1.94 -> 3.1.97)

- Move the default pattern selection to a different place to not
conflict with the pattern selection in the system upgrade mode
(FATE#320199)
- 3.1.97
- Added public methods to modify and know info about files read,
in this case to avoid display the welcome dialog again after
restart yast (bsc#974409)
- 3.1.96
- Select the default product patterns defined by the
'defaultpattern()' provides in the initial installation
(FATE#320199)
- 3.1.95

==== yast2-storage ====
Version update (3.1.86 -> 3.1.90)

- raise min /boot size for BTRFS/aarch64 (bsc#974280)
- 3.1.90
- Don't allow to create or change partition table on LDL
formatted DASDs (bsc#958893)
- 3.1.89
- updated requirement to libstorage (related to bnc#958893)
- 3.1.88
- set parameters for space aware cleanup algorithm in snapper (for
fate#312751)
- 3.1.87

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages