Mailinglist Archive: opensuse-factory (352 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160326 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160326

Packages changed:
NetworkManager
WindowMaker (0.95.6 -> 0.95.7)
akonadi-calendar (15.12.2 -> 15.12.3)
akonadi-search (15.12.2 -> 15.12.3)
akonadi-server (15.12.2 -> 15.12.3)
ark (15.12.2 -> 15.12.3)
baloo5
baloo5-widgets (15.12.2 -> 15.12.3)
dialog (1.2 -> 1.3)
dolphin (15.12.2 -> 15.12.3)
dragonplayer (15.12.2 -> 15.12.3)
ethtool (4.2 -> 4.5)
gpgmepp5 (15.12.2 -> 15.12.3)
grub2
gthumb (3.4.1 -> 3.4.2)
gwenview5 (15.12.2 -> 15.12.3)
gzip
hexchat (2.10.2 -> 2.12.0)
hugin (2015.0.0 -> 2016.0.0)
jack
java-1_8_0-openjdk-plugin
kaccounts-integration (15.12.2 -> 15.12.3)
kalarmcal (15.12.2 -> 15.12.3)
kamera (15.12.2 -> 15.12.3)
kate (15.12.2 -> 15.12.3)
kcalc (15.12.2 -> 15.12.3)
kcalcore (15.12.2 -> 15.12.3)
kcalutils (15.12.2 -> 15.12.3)
kcharselect (15.12.2 -> 15.12.3)
kcolorchooser (15.12.2 -> 15.12.3)
kcontacts (15.12.2 -> 15.12.3)
kdebase4 (15.12.2 -> 15.12.3)
kdebase4-runtime (15.12.2 -> 15.12.3)
kdelibs4 (4.14.17 -> 4.14.18)
kdenetwork4-filesharing (15.12.2 -> 15.12.3)
kdepim (15.12.2 -> 15.12.3)
kdepim-runtime (15.12.2 -> 15.12.3)
kdepimlibs (15.12.2 -> 15.12.3)
kdnssd (15.12.2 -> 15.12.3)
kget (15.12.2 -> 15.12.3)
kgpg (15.12.2 -> 15.12.3)
kholidays (15.12.2 -> 15.12.3)
kiconthemes
kidentitymanagement (15.12.2 -> 15.12.3)
kimap (15.12.2 -> 15.12.3)
kio
kio-extras5 (15.12.2 -> 15.12.3)
kio_audiocd (15.12.2 -> 15.12.3)
kiwi-config-openSUSE
kldap (15.12.2 -> 15.12.3)
kmag (15.12.2 -> 15.12.3)
kmailtransport (15.12.2 -> 15.12.3)
kmbox (15.12.2 -> 15.12.3)
kmime (15.12.2 -> 15.12.3)
kmousetool (15.12.2 -> 15.12.3)
kompare (15.12.2 -> 15.12.3)
konsole (15.12.2 -> 15.12.3)
kontactinterface (15.12.2 -> 15.12.3)
kopete (15.12.2 -> 15.12.3)
kpimtextedit (15.12.2 -> 15.12.3)
kqtquickcharts (15.12.2 -> 15.12.3)
krdc (15.12.2 -> 15.12.3)
krfb (15.12.2 -> 15.12.3)
kruler (15.12.2 -> 15.12.3)
ktnef (15.12.2 -> 15.12.3)
ktp-accounts-kcm (15.12.2 -> 15.12.3)
ktp-approver (15.12.2 -> 15.12.3)
ktp-auth-handler (15.12.2 -> 15.12.3)
ktp-common-internals (15.12.2 -> 15.12.3)
ktp-contact-list (15.12.2 -> 15.12.3)
ktp-contact-runner (15.12.2 -> 15.12.3)
ktp-desktop-applets (15.12.2 -> 15.12.3)
ktp-filetransfer-handler (15.12.2 -> 15.12.3)
ktp-kded-module (15.12.2 -> 15.12.3)
ktp-send-file (15.12.2 -> 15.12.3)
ktp-text-ui (15.12.2 -> 15.12.3)
kwalletmanager5 (15.12.2 -> 15.12.3)
libinput (1.2.1 -> 1.2.2)
libkcddb4 (15.12.2 -> 15.12.3)
libkcompactdisc4 (15.12.2 -> 15.12.3)
libkdcraw (15.12.2 -> 15.12.3)
libkexiv2 (15.12.2 -> 15.12.3)
libkface (15.12.2 -> 15.12.3)
libkgeomap (15.12.2 -> 15.12.3)
libkipi (15.12.2 -> 15.12.3)
libkomparediff2 (15.12.2 -> 15.12.3)
libksane (15.12.2 -> 15.12.3)
libmbim (1.12.2 -> 1.12.4)
libotr (4.1.0 -> 4.1.1)
libreoffice
libtool
libvirt
libxml2 (2.9.2 -> 2.9.3)
libzypp (15.21.4 -> 15.21.5)
lirc
man-pages (4.04 -> 4.05)
marble (15.12.2 -> 15.12.3)
mlterm (3.6.1 -> 3.7.0)
mobipocket (15.12.2 -> 15.12.3)
nmap (7.10 -> 7.11)
okular (15.12.2 -> 15.12.3)
opencv
opencv-qt5
pcsc-lite (1.8.15 -> 1.8.16)
perl-DateTime (1.25 -> 1.26)
perl-Log-Log4perl (1.36 -> 1.47)
perl-Package-DeprecationManager (0.15 -> 0.16)
poppler (0.41.0 -> 0.42.0)
poppler-qt (0.41.0 -> 0.42.0)
poppler-qt5 (0.41.0 -> 0.42.0)
powertop
python3-requests
python3-setuptools (20.2.2 -> 20.3.1)
python3-urllib3
signon-kwallet-extension (15.12.2 -> 15.12.3)
spectacle (15.12.2 -> 15.12.3)
sudo (1.8.15 -> 1.8.16)
sweeper (15.12.2 -> 15.12.3)
syndication (15.12.2 -> 15.12.3)
timezone (2016a -> 2016c)
timezone-java (2016a -> 2016c)
viewvc (1.1.23 -> 1.1.24)
vim (7.4.1558 -> 7.4.1635)
virt-manager
wdiff
webkitgtk (2.4.9 -> 2.4.10)
webkitgtk3 (2.4.9 -> 2.4.10)
xmlgraphics-fop (1.1 -> 2.1)
xterm (322 -> 324)
xz
yast2 (3.1.179 -> 3.1.180)
yast2-installation (3.1.175 -> 3.1.176)
yast2-packager (3.1.90 -> 3.1.91)
yast2-storage (3.1.82 -> 3.1.84)
zypper (1.12.35 -> 1.13.0)

=== Details ===

==== NetworkManager ====
Subpackages: NetworkManager-devel libnm-glib-vpn1 libnm-glib4 libnm-util2
libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Split out a NetworkManager-branding-upstream subpackage that
installs the default upstream version of the
/etc/NetworkManager/NetworkManager.conf file.
- Add Requires: NetworkManager-branding to main package.

==== WindowMaker ====
Version update (0.95.6 -> 0.95.7)

- Fix build breakace related to giflib < 5.1.
- Update to WindowMaker-0.95.7
- Small modification of wm-giflib.patch.
- Spec file fixes.
- Removed: WindowMaker-0.96.6.tar.gz
- Added: WindowMaker-0.96.7.tar.gz

==== akonadi-calendar ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== akonadi-search ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5AkonadiSearch

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== akonadi-server ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5AkonadiPrivate5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ark ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libkerfuffle15

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== baloo5 ====
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Added Do-not-block-indexing-of-text-plain-files-without-txt-extension.patch
from upstream: fixes indexing of text/plain files without .txt
extension (kde#358098)

==== baloo5-widgets ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== dialog ====
Version update (1.2 -> 1.3)

- Update to 1.3-20160209
* modify editbox widget to add a trailing newline if the text
has none to ensure the last line is not ignored (report by
Florent Rougon).
* change mouse initialization to look for button-presses rather
than button-clicks, for better response.
* modify dump_curses_key() to show mouse-coding in readable form.
* correct mapping of mouse-clicks on the day-grid in calendar
widget when "--week-start" is used to set the start of the week
(report by Stefan Vogtner).
* integrated changes from Stefan Vogtner:
* use Gregorian algorithm for leap year
* use mktime if available; calendar was written just as it became
standard.
- Changes for version 1.3
* correct --infobox documentation, which said it shows an OK
button.
* fix a couple of place in test-scripts which referred to
$SIG_TRAP rather than $SIG_QUIT
* reorganize dialog.3, to use subsections for generating navigation
pane, using man2html
* add "--week-start" option for calendar widget (prompted by
discussion with Stefan Vogtner).
* add a limit-check in editbox.c to ensure that mouse-clicks
outside the filled-in text area do not access past the end of
the array (report by Stefan Vogtner).
* update configure macros from ncurses changes.
* update config.guess, config.sub

==== dolphin ====
Version update (15.12.2 -> 15.12.3)
Subpackages: dolphin-part libdolphinvcs5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== dragonplayer ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ethtool ====
Version update (4.2 -> 4.5)

- Update to new upstream release 4.5
* Fix: Heap corruption when dumping registers from a file
(-d option)
* Fix: Stricter input validation for EEPROM setting (-E option)
* Feature: Add PHY statistics support (--phy-statistics option)
* Feature: Support setting default Rx flow indirection table
(-X option)
* Doc: Properly indent sub-options in man page
* address build issues (mostly compiler warnings)

==== gpgmepp5 ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5QGpgme5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Fix GRUB_DISABLE_LINUX_UUID to be ignore and also fallback kernel device
won't be used if fs uuid not detected (bsc#971867)
* added 0001-10_linux-Fix-grouping-of-tests-for-GRUB_DEVICE.patch
* added 0002-20_linux_xen-fix-test-for-GRUB_DEVICE.patch

==== gthumb ====
Version update (3.4.1 -> 3.4.2)
Subpackages: gthumb-lang

- Update to version 3.4.2:
+ User visible changes: Sort catalogs first by name then by date,
instead of doing the opposite.
+ Bugs fixed:
- Crash after pressing shift-arrow (bgo#760050).
- Stopping slideshow freezes entire program (bgo#759787).
- Crash if trying to delete image on sftp mounted (bgo#759727).
- Crash when deleting duplicate (bgo#759631).
- Crash after changing and renaming file (bgo#750142).
+ Updated translations.

==== gwenview5 ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== gzip ====

- Add reproducible.patch to fix build-compare

==== hexchat ====
Version update (2.10.2 -> 2.12.0)
Subpackages: hexchat-lang

- Version update to 2.12.0:
* add support for IRCv3.2
* add cap 3.2
* add sasl 3.2
* add chghost
* add cap-notify
* add support for twitch.tv/membership cap
* add support for SNI (Server Name Indication)
* add ability to do DnD reordering in some settings dialogs
* add option to disable middle-click closing tabs
* rewrite sysinfo plugin
* change formatting, unified across platforms
* fix handling unsupported CPU arch on unix
* rewrite identd plugin
* add ability to change port
* fix handling multiple connections
* fix threading issues
* rewrite checksum plugin
* fix support for very large files
* remove openssl dependency
* remove DH-{AES,BLOWFISH} mechanisms (insecure)
* remove ?IRC? encoding, replaced with UTF-8
* remove ?System Default? encoding, replaced with UTF-8
* remove configure option to disable ipv6
* remove msproxy and socks5 library support (unused)
* change tab-complete to favor other user nicks over own
* change url detection to support unicode
* change decoding to not attempt ISO-8859-1 fixing corruption
* change pluginpref to escape values
* change installer on Windows to not overwrite gtkrc file
* fix numerous crashes (but not #600)
* fix crash on printing very long lines
* fix crash on failing to open log file
* fix crash when using unsorted userlist
* fix crash when timestamp format set to nothing
* fix crash when tab-completeing long strings
* fix crash with long values in pluginpref API
* fix various other unsafe string handling throughout
* fix poor performance with nick indent enabled
* fix fishlim plugin handling networks with server-time
* fix logging hostname of users in new queries
* fix Key Press event sending non-UTF-8 text to plugins
* fix VERSION response on windows 10
* fix get_info(?win_ptr?) from python
* fix running portable-mode from another directory
* fix duplicate timestamps on selection
* fix ?cfgdir argument
* fix mode-button text being cut off
* fix scrollback timestamps with server-time
* fix url handler accepting quoted paths with spaces
* fix using correct encoding when jumping networks
* improve DCC handling large files
* improve python detection in configure
* improve scrollback file handling (corruption, line endings)
* improve build options on unix to be more secure
* update translations
* update network list
- Use python3 not python2
* Add patch hexchat-python3.patch
- As we build only on sle12+ and no non-suse distro the conditionals
from previous commit do not make much sense

==== hugin ====
Version update (2015.0.0 -> 2016.0.0)

- Updated to version 2016.0.0
* Added user defined output. The user can define own output sequences to
implement new use cases, e.g. zero noise output.
* Added --clip-exposure switch to nona to automatically mask over and under
exposed areas in input images.
* Color management
* * GUI tools (Hugin, calibrate_lens_gui) take ICC profiles in files and
monitor color profile into account to display images.
* * celeste and cpfind converts internal image to sRGB before working.
* Some buttons got a context menu for easier access to some function
* * Show all in fast preview window to allow better interaction with stacked
projects
* * Celeste in cp tab: the button can now create cp or clean cp
* Updated internal levmar library to version 2.6
* The identify tool in the fast preview window shows now also the image
numbers on top of the images. (This can be suppressed by pressing the alt
button).
* Fixes internal image format for GPU remapping. This should fix the
"unsupported framebufferformat" error.
* Use own code for OpenGL intialization. Now freeglut is not needed anymore.
(This should prevent the appearing of window when running "nona -g".
Linux/Window only)
* Control point and mask editor retain viewpoint when changing zoom factor.
* PTBatcherGUI: Minimize to tray is now user configurable.
* Fixes a bug in photometric optimizer and merge projects with line control
points.
- Hugin is built in "build" subdirectory (in-source builds are not allowed now).

==== jack ====
Subpackages: libjack-devel libjack0

- Use pkgconfig buildrequires and cleanup spec.
- BuildIgnore libiec61883 to allow Leap42 and earlier build again.
- Add reproducible.patch to fix build-compare

==== java-1_8_0-openjdk-plugin ====

- Fix build-compare by not including rebuild-counter

==== kaccounts-integration ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kalarmcal ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kamera ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kate ====
Version update (15.12.2 -> 15.12.3)
Subpackages: kate-plugins kwrite

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcalc ====
Version update (15.12.2 -> 15.12.3)

- Added kcalc-fix_set_size.patch: fixes window not appearing with
Qt 5.6 because it's being set to zero size (kde#360105)
- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcalcore ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcalutils ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5CalendarUtils5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcharselect ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcolorchooser ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kcontacts ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdebase4 ====
Version update (15.12.2 -> 15.12.3)
Subpackages: kdebase4-libkonq kdebase4-nsplugin kdepasswd kdialog
keditbookmarks konqueror konqueror-plugins libkonq-devel libkonq5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdebase4-runtime ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdelibs4 ====
Version update (4.14.17 -> 4.14.18)
Subpackages: kdelibs4-core kdelibs4-doc libkde4 libkde4-devel libkdecore4
libkdecore4-devel libksuseinstall1

- Update to 4.14.18
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdenetwork4-filesharing ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdepim ====
Version update (15.12.2 -> 15.12.3)
Subpackages: akonadi_resources akregator5 kaddressbook5 kalarm5 kleopatra5
kmail5 knotes5 kontact5 korganizer5 libkdepim

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdepim-runtime ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdepimlibs ====
Version update (15.12.2 -> 15.12.3)
Subpackages: akonadi-contact akonadi5 kio-pimlibs libKF5AkonadiContact5
libKF5AkonadiMime5 libKF5AkonadiNotes5

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kdnssd ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kget ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kgpg ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kholidays ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kiconthemes ====
Subpackages: kiconthemes-devel libKF5IconThemes5

- Drop breeze.diff: it caused an incorrect fallback to breeze
instead of hicolor when a different icon theme is configured, and
has been reverted (and even rejected in a second try) upstream
(kde#356064, kde#360664)

==== kidentitymanagement ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kimap ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kio ====
Subpackages: kio-core kio-devel

- Added 0001-Fix-crash-in-rename-dialog.patch (kde#360488)

==== kio-extras5 ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kio_audiocd ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kiwi-config-openSUSE ====

- Add ppc64le to excludearch

==== kldap ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kmag ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kmailtransport ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kmbox ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kmime ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kmousetool ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kompare ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== konsole ====
Version update (15.12.2 -> 15.12.3)
Subpackages: konsole-part

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kontactinterface ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kopete ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kpimtextedit ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kqtquickcharts ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== krdc ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== krfb ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kruler ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktnef ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-accounts-kcm ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libktpaccountskcminternal9

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-approver ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-auth-handler ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-common-internals ====
Version update (15.12.2 -> 15.12.3)
Subpackages: ktp-icons

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-contact-list ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-contact-runner ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-desktop-applets ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-filetransfer-handler ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-kded-module ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-send-file ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== ktp-text-ui ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== kwalletmanager5 ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libinput ====
Version update (1.2.1 -> 1.2.2)
Subpackages: libinput-devel libinput-udev libinput10

- Update to version 1.2.2:
* The two main changes are better cursor handling on the Lenovo
T450/T460-generation touchpads and the rejection of mislabelled
tablet devices.

==== libkcddb4 ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libkcddb4-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkcompactdisc4 ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libkcompactdisc4-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkdcraw ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkexiv2 ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkface ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5KFace10_0_0 libkface-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855
- Add fix-opencv.diff back for Leap and oS 13.2 support

==== libkgeomap ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5KGeoMap10_0_0 libkgeomap-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkipi ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5Kipi30_0_0 libkipi-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libkomparediff2 ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libksane ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libKF5Sane5 libksane-devel

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== libmbim ====
Version update (1.12.2 -> 1.12.4)

- Update to version 1.12.4:
+ Updated '--connect' arguments to allow specifying "key=value"
pairs. The old legacy "[(APN), (PAP|CHAP|MSCHAPV2), (Username),
(Password)]" format is kept as valid for backwards
compatibility, although it should be assumed deprecated.
+ mbimcli:
- Longer timeouts for connect/register operations.
- Report IP configuration when connected.
- Allow specifying session ids.
+ libmbim-glib: probing retry interval increased to 5s.
+ Some other minor fixes.

==== libotr ====
Version update (4.1.0 -> 4.1.1)
Subpackages: libotr-devel libotr5

- libotr 4.1.1:
* Fix an integer overflow bug that can cause a heap buffer
overflow (and from there remote code execution) on 64-bit
platforms - CVE-2016-2851 (boo#969785)
* Fix possible free() of an uninitialized pointer
* Be stricter about parsing v3 fragments
* Add a testsuite ("make check" to run it)
* Fix a memory leak when reading a malformed instance tag file
* Protocol documentation clarifications
- add libotr-4.1.1-fix-base64-tests.patch to fix test suite failure
- skip failing tests on ppc architectures

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions
libreoffice-draw libreoffice-filters-optional libreoffice-gnome
libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions

- Remove services patch, no longer needed everything tweaked upstream:
* libreoffice-disable-services-check.patch

==== libtool ====
Subpackages: libltdl7 libltdl7-32bit

- Fix install_info_{install,delete} usage: install-info does not
allow file globbing.

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen

- spec: restart daemons in %posttrans after connection drivers
have been processed
bsc#854343, bsc#968483

==== libxml2 ====
Version update (2.9.2 -> 2.9.3)
Subpackages: libxml2-2 libxml2-2-32bit libxml2-devel libxml2-tools

- Update to new upstream release 2.9.3 (bsc#954429):
* Fixes for CVE-2015-8035, CVE-2015-7942, CVE-2015-7941,
CVE-2015-1819, CVE-2015-7497, CVE-2015-7498, CVE-2015-5312,
CVE-2015-7499, CVE-2015-7500 and CVE-2015-8242
* And other bugfixes
- Removed upstream fixed patches:
* libxml2-dont_initialize_catalog.patch
* 0001-Fix-missing-entities-after-CVE-2014-3660-fix.patch
* 0002-Adding-example-from-bugs-738805-to-regression-tests.patch

==== libzypp ====
Version update (15.21.4 -> 15.21.5)

- Use PluginExecutor for commit- and system-hooks (bnc#971637)
- BuildRequires: libsolv-devel >= 0.6.19 (bnc#971018)
- version 15.21.5 (19)
- Update zypp-po.tar.bz2
- Update zypp-po.tar.bz2

==== lirc ====
Subpackages: libirrecord0 liblirc0 liblirc_client0 liblirc_driver0 lirc-devel

- remove lirc.4 as this is part of man-pages from 4.05 on

==== man-pages ====
Version update (4.04 -> 4.05)

- update to 4.05:
* new and rewritten pages
+ copy_file_range.2
+ personality.2
+ fmemopen.3
+ ntp_gettime.3
+ open_memstream.3
+ posix_spawn.3
+ readdir.3
+ readdir_r.3
+ lirc.4
* newly documented interfaces in existing pages
+ adjtimex.2
Document ntp_adjtime(3)
+ epoll_ctl.2
Document EPOLLEXCLUSIVE
+ madvise.2
Document MADV_FREE
+ +proc.5
Document CmaTotal and CmaFree fields of /proc/meminfo
Document additional /proc/meminfo fields
Document DirectMap4k, DirectMap4M, DirectMap2M, DirectMap1G
Document MemAvailable /proc/meminfo field
Document inotify /proc/PID/fdinfo entries
Document fanotify /proc/PID/fdinfo entries
Add some kernel version numbers for /proc/PID/fdinfo entries
/proc/PID/fdinfo displays the setting of the close-on-exec flag
socket.7
Document some BPF-related socket options
- removed upstreamed patches
* man-pages-adjtimex.2.patch
* man-pages-open-btrfs.patch

==== marble ====
Version update (15.12.2 -> 15.12.3)
Subpackages: libastro-qt5-1 libmarblewidget-qt5-23 marble-data marble-devel
marble-doc marble-kde

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== mlterm ====
Version update (3.6.1 -> 3.7.0)

- Update to version 3.7.0
* Support OSC 1337. (See http://www.iterm2.com/images.html)
* Add 'mlfc' tool which automatically generates ~/.mlterm/aafont and
~/.mlterm/font-fb.
* Change the format of ~/.mlterm/*font is changed as follows.
[Charset] = [Font name];[Size],[Font name];[Size],[Font name];...
- > [Charset] = [Font name]
* Drop XT_CBLINK (CSI?12h/CSI?12l) support.
* Simplify font configuration of OSC 5379. ('mlcc font USASCII <Font name>'
is available.)
* "CSI 38;2;r;g;b m" and "CSI 48;2;r;g;b m" shows high colors instead of
approximate vt 256 colors. "vt_color_mode" / --vtcolor(=256/high/true)
option
changes the behavior.
- Add mlterm-noreturn.patch to fix signature of non-returning function.

==== mobipocket ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== nmap ====
Version update (7.10 -> 7.11)

- Nmap 7.11:
* Add support for diffie-hellman-group-exchange-* SSH key
exchange methods to ssh2.lua, allowing ssh-hostkey to run on
servers that only support custom Diffie-Hellman groups.
* Add support in sslcert.lua for Microsoft SQL Server's TDS
protocol, so you can now grab certs with ssl-cert or check
ciphers with ssl-enum-ciphers.
* Fix crashes in Zenmap

==== okular ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== opencv ====
Subpackages: libopencv3_1 opencv-devel

- Test for python versions greater than or equal to the current
version.
- Add python 3 support

==== opencv-qt5 ====

- Test for python versions greater than or equal to the current
version.
- Add python 3 support

==== pcsc-lite ====
Version update (1.8.15 -> 1.8.16)
Subpackages: libpcsclite1

- Updated to version 1.8.16
* SCardCancel() was not correctly handled
When a SCardGetStatusChange() was cancelled then a next PC/SC
call after the SCardGetStatusChange() may fail with a strange
error code if the event waited in SCardGetStatusChange() occurs.
* Doxygen: fix different documentation issues
* SCARD_SCOPE_GLOBAL is now defined in a public header (even if
never used)
* Enable Trace and Profile features using compiler flags and
without modifying the source code
* Some other minor improvements and bug corrections

==== perl-DateTime ====
Version update (1.25 -> 1.26)

- updated to 1.26
see /usr/share/doc/packages/perl-DateTime/Changes
1.26 2016-03-21
- Switched from Module::Build to ExtUtils::MakeMaker. Implementation by Karen
Etheridge. GitHub #13.

==== perl-Log-Log4perl ====
Version update (1.36 -> 1.47)

- updated to 1.47
see /usr/share/doc/packages/perl-Log-Log4perl/Changes
1.47 (2016/03/17)
* (ms) [rt.cpan.org #102647] Slaven Rezic fixed a test
case for file permissions
* (ms) Fixed synopsis code in Log::Log4perl::Appender::DBI,
reported by Chris Collins.
* (ms) Added suggestion by Dylan Doxey to test for both MSWin32 and
cygwin to detect windows-like systems for which tests need
to be skipped.
* (ms) [rt.cpan.org #110915] Fixed "Redundant argument in sprintf"
warning caused by DateFormat.pm with %d{Z} placeholders,
reported by Alexander Hartmaier.
* (ms) [rt.cpan.org #110512] Felix Ostmann fixed a broken error
message raised when a boolean filter can't be found.
* (ms) All hash traversals in Config.pm now done via "sort keys"
to make sure we can reliably reproduce potential problems.
- updated to 1.46
see /usr/share/doc/packages/perl-Log-Log4perl/Changes

==== perl-Package-DeprecationManager ====
Version update (0.15 -> 0.16)

- updated to 0.16
see /usr/share/doc/packages/perl-Package-DeprecationManager/Changes
0.16 2016-03-21
- The subs installed into the caller are now named with Sub::Name. This makes
these subs appear to be part of the caller, as opposed to an import, which
is what we want, since each installed sub is constructed uniquely for a
given package.

==== poppler ====
Version update (0.41.0 -> 0.42.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 poppler-tools

- Update to version 0.42.0:
+ core:
- Add the support for version 5 + revision 6 documents
(fdo#85368).
- Add initial support for Signature handling.
- Initialize gamut mapping multipliers in ::copy() functions
(fdo#90697).
- Implement jpx streams support with depth < 8.
- Handle SMaskInData = 0 for JPX encoded images (fdo#93468).
- Fix rendering of some broken PDF files (fdo#92508).
- PSOutputDev:
. Support for LZW encoding.
. Add support for Flate compression in Level 3 output.
- SplashOuputDev:
. Implement function shading (fdo#94441).
. Improve rendering of some non embedded fonts (fdo#94054).
. Fall back to Gfx implementation of tiling pattern if
repetition rate is small (fdo#90596).
. Implementation of Matte entries in softmasks of
softmasked images (fdo#22473).
. Assure line width > 0 in case of text stroke (fdo#94038).
- TextOuputDev: Cache result of inner loop in visitDepthFirst
(fdo#77087).
- Avoid attempting a tiling pattern fill with a singular
transform matrix.
+ utils:
- pdfinfo: Add option to show document structure
- pdfsig: New command that gives information about signature
+ qt4: Fix bug in links to remote documents getting the page
number wrong sometimes.
+ qt5: Fix bug in links to remote documents getting the page
number wrong sometimes.
- Add pkgconfig(nss) BuildRequires: Build nss support.
- Bump soname following upstream changes.

==== poppler-qt ====
Version update (0.41.0 -> 0.42.0)

- Update to version 0.42.0:
+ core:
- Add the support for version 5 + revision 6 documents
(fdo#85368).
- Add initial support for Signature handling.
- Initialize gamut mapping multipliers in ::copy() functions
(fdo#90697).
- Implement jpx streams support with depth < 8.
- Handle SMaskInData = 0 for JPX encoded images (fdo#93468).
- Fix rendering of some broken PDF files (fdo#92508).
- PSOutputDev:
. Support for LZW encoding.
. Add support for Flate compression in Level 3 output.
- SplashOuputDev:
. Implement function shading (fdo#94441).
. Improve rendering of some non embedded fonts (fdo#94054).
. Fall back to Gfx implementation of tiling pattern if
repetition rate is small (fdo#90596).
. Implementation of Matte entries in softmasks of
softmasked images (fdo#22473).
. Assure line width > 0 in case of text stroke (fdo#94038).
- TextOuputDev: Cache result of inner loop in visitDepthFirst
(fdo#77087).
- Avoid attempting a tiling pattern fill with a singular
transform matrix.
+ utils:
- pdfinfo: Add option to show document structure
- pdfsig: New command that gives information about signature
+ qt4: Fix bug in links to remote documents getting the page
number wrong sometimes.
+ qt5: Fix bug in links to remote documents getting the page
number wrong sometimes.
- Add pkgconfig(nss) BuildRequires: Build nss support.
- Bump soname following upstream changes.

==== poppler-qt5 ====
Version update (0.41.0 -> 0.42.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.42.0:
+ core:
- Add the support for version 5 + revision 6 documents
(fdo#85368).
- Add initial support for Signature handling.
- Initialize gamut mapping multipliers in ::copy() functions
(fdo#90697).
- Implement jpx streams support with depth < 8.
- Handle SMaskInData = 0 for JPX encoded images (fdo#93468).
- Fix rendering of some broken PDF files (fdo#92508).
- PSOutputDev:
. Support for LZW encoding.
. Add support for Flate compression in Level 3 output.
- SplashOuputDev:
. Implement function shading (fdo#94441).
. Improve rendering of some non embedded fonts (fdo#94054).
. Fall back to Gfx implementation of tiling pattern if
repetition rate is small (fdo#90596).
. Implementation of Matte entries in softmasks of
softmasked images (fdo#22473).
. Assure line width > 0 in case of text stroke (fdo#94038).
- TextOuputDev: Cache result of inner loop in visitDepthFirst
(fdo#77087).
- Avoid attempting a tiling pattern fill with a singular
transform matrix.
+ utils:
- pdfinfo: Add option to show document structure
- pdfsig: New command that gives information about signature
+ qt4: Fix bug in links to remote documents getting the page
number wrong sometimes.
+ qt5: Fix bug in links to remote documents getting the page
number wrong sometimes.
- Add pkgconfig(nss) BuildRequires: Build nss support.
- Bump soname following upstream changes.

==== powertop ====
Subpackages: powertop-lang

- Change license to GPL-2.0
- Require xterm-bin on openSUSE and xterm on other systems.
xterm was splitted on openSUSE to have fewer dependencies.
- Fixing powertop-no-date.patch: Missed a whitespace between
program name and version.

==== python3-requests ====

- modify no-default-cacert.patch again, to perform passthrough
of empty parameters if cert path is not specified
- modify requests-do-not-use-bundle.patch to use built-in facilities
to exclude the bundles, and to keep requests.packages
- modify patches to change setup.py to facilitate their functions
- reenable tests, add python3-pytest as requirement
- recommend ca-certificates-mozilla, require ca-certificates
everywhere (also apply no-default-cacert everywhere)
- make sure requirements in egg-info are set right, and that
the package depends on good-enough version of urllib3
(see PACKAGING_NOTES for details)

==== python3-setuptools ====
Version update (20.2.2 -> 20.3.1)

- update to version 20.3.1:
* Issue #519: Remove import hook when reloading the "pkg_resources"
module.
* Pull Request #184: Update documentation in "pkg_resources" around
new "Requirement" implementation.
- update to version 20.3:
* Pull Request #179: "pkg_resources.Requirement" objects are now a
subclass of "packaging.requirements.Requirement", allowing any
environment markers and url (if any) to be affiliated with the
requirement
* Pull Request #179: Restore use of RequirementParseError exception
unintentionally dropped in 20.2.

==== python3-urllib3 ====

- synchronize spec file and patches with python2 version:
* enable most tests
* urllib3-ssl-default-context.patch: use ssl's default context
for native ssl the same way it is used for pyopenssl
* urllib3-test-ssl-drop-sslv3.patch: do not use SSLv3 protocol
* drop unneeded 0001-Don-t-pin-dependency-to-exact-version.patch
- not adding optional dependencies of the pyopenssl module, because
ndg-httpsclient doesn't exist yet, so the pyopenssl module is unusable

==== signon-kwallet-extension ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== spectacle ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== sudo ====
Version update (1.8.15 -> 1.8.16)

- Add gpg signature
- Use valid category for tests
- update to 1.8.16:
* Fixed a compilation error on Solaris 10 with Stun Studio 12.
Bug #727.
* When preserving variables from the invoking user's environment, if
there are duplicates sudo now only keeps the first instance.
* Fixed a bug that could cause warning mail to be sent in list
mode (sudo -l) for users without sudo privileges when the
LDAP and sssd backends are used.
* Fixed a bug that prevented the "mail_no_user" option from working
properly with the LDAP backend.
* In the LDAP and sssd backends, white space is now ignored between
an operator (!, +, +=, -=) when parsing a sudoOption.
* It is now possible to disable Path settings in sudo.conf
by omitting the path name.
* The sudoedit_checkdir Defaults option is now enabled by default
and has been extended. When editing files with sudoedit, each
directory in the path to be edited is now checked. If a directory
is writable by the invoking user, symbolic links will not be
followed. If the parent directory of the file to be edited is
writable, sudoedit will refuse to edit it.
Bug #707.
* The netgroup_tuple Defaults option has been added to enable matching
of the entire netgroup tuple, not just the host or user portion.
Bug #717.
* When matching commands based on the SHA2 digest, sudo will now
use fexecve(2) to execute the command if it is available. This
fixes a time of check versus time of use race condition when the
directory holding the command is writable by the invoking user.
* On AIX systems, sudo now caches the auth registry string along
with password and group information. This fixes a potential
problem when a user or group of the same name exists in multiple
auth registries. For example, local and LDAP.
* Fixed a crash in the SSSD backend when the invoking user is not
found. Bug #732.
* Added the --enable-asan configure flag to enable address sanitizer
support. A few minor memory leaks have been plugged to quiet
the ASAN leak detector.
* The value of _PATH_SUDO_CONF may once again be overridden via
the Makefile. Bug #735.
* The sudoers2ldif script now handles multiple roles with same name.
* Fixed a compilation error on systems that have the posix_spawn()
and posix_spawnp() functions but an unusable spawn.h header.
Bug #730.
* Fixed support for negating character classes in sudo's version
of the fnmatch() function.
* Fixed a bug in the LDAP and SSSD backends that could allow an
unauthorized user to list another user's privileges. Bug #738.
* The PAM conversation function now works around an ambiguity in the
PAM spec with respect to multiple messages. Bug #726.

==== sweeper ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== syndication ====
Version update (15.12.2 -> 15.12.3)

- Update to KDE Applications 15.12.3
* KDE Applications 15.12.3
* https://www.kde.org/announcements/announce-applications-15.12.3.php
* boo#970855

==== timezone ====
Version update (2016a -> 2016c)

- timezone update 2016c [boo#972433]
* Azerbaijan no longer observes DST (Asia/Baku)
* Chile reverts from permanent to seasonal DST.
* Correct past timestamps for Europe/Kaliningrad, Europe/Vilnius,
Europe/Volgograd 1989-1991
- timezone update 2016b [boo#971377]
* New zones Europe/Astrakhan and Europe/Ulyanovsk for Astrakhan
and Ulyanovsk Oblasts, Russia, both of which will switch from
+03 to +04 on 2016-03-27 at 02:00 local time.
* New zone Asia/Barnaul for Altai Krai and Altai Republic, Russia,
which will switch from +06 to +07 on the same date and local time.
* Asia/Sakhalin moves from +10 to +11 on 2016-03-27 at 02:00.
* As a trial of a new system that needs less information to be made
up, the new zones use numeric time zone abbreviations like "+04"
instead of invented abbreviations like "ASTT".
* Haiti will not observe DST in 2016.
* Palestine's spring-forward transition on 2016-03-26 is at 01:00,
not 00:00.
* tzselect's diagnostics and checking, and checktab.awk's checking,
have been improved.
* tzselect now tests Julian-date TZ settings more accurately.
(Thanks to J William Piggott.)
- tzcode-revert-01-8c9cb9580.patch, tzcode-revert-02-301f794f3.patch,
tzcode-revert-03-39fd078a6.patch: Revert some porting fixes specific
to MS-Windows that rewrites parts of zic touched by our patches.

==== timezone-java ====
Version update (2016a -> 2016c)

- timezone update 2016c [boo#972433]
* Azerbaijan no longer observes DST (Asia/Baku)
* Chile reverts from permanent to seasonal DST.
* Correct past timestamps for Europe/Kaliningrad, Europe/Vilnius,
Europe/Volgograd 1989-1991
- timezone update 2016b [boo#971377]
* New zones Europe/Astrakhan and Europe/Ulyanovsk for Astrakhan
and Ulyanovsk Oblasts, Russia, both of which will switch from
+03 to +04 on 2016-03-27 at 02:00 local time.
* New zone Asia/Barnaul for Altai Krai and Altai Republic, Russia,
which will switch from +06 to +07 on the same date and local time.
* Asia/Sakhalin moves from +10 to +11 on 2016-03-27 at 02:00.
* As a trial of a new system that needs less information to be made
up, the new zones use numeric time zone abbreviations like "+04"
instead of invented abbreviations like "ASTT".
* Haiti will not observe DST in 2016.
* Palestine's spring-forward transition on 2016-03-26 is at 01:00,
not 00:00.
* tzselect's diagnostics and checking, and checktab.awk's checking,
have been improved.
* tzselect now tests Julian-date TZ settings more accurately.
(Thanks to J William Piggott.)
- tzcode-revert-01-8c9cb9580.patch, tzcode-revert-02-301f794f3.patch,
tzcode-revert-03-39fd078a6.patch: Revert some porting fixes specific
to MS-Windows that rewrites parts of zic touched by our patches.

==== viewvc ====
Version update (1.1.23 -> 1.1.24)

- viewvc 1.1.24:
* fix minor bug in human_readable boolean calculation
* allow hr_funout option to apply to unidiff diffs, too
* fix infinite loop in rcsparse
* fix iso8601 timezone offset handling
* add support for renamed roots
* fix minor buglet in viewvc-install error message

==== vim ====
Version update (7.4.1558 -> 7.4.1635)
Subpackages: gvim vim-data

- Updated to revision 1635, fixes the following problems
* Quickfix code using memory after being freed.
* Using channel timeout instead of request timeout.
* Timers don't work on Unix.
* Not checking for failed open().
* Memory leak when out of memory.
* When starting the GUI fails a swap file is left behind.
* Timer with an ":echo" command messes up display.
* Although emoji characters are ambiguous width, best is to treat
them as full width.
* Catching exception that won't be thrown.
* Having type() handle a Funcref that is or isn't a partial differently
causes problems for existing scripts.
* Comparing a function that exists on two dicts is not backwards compatible.
* string() doesn't handle a partial.
* Contents file is only for Amiga distro.
* Compiler warnings for non-virtual destructor.
* The versplit feature makes the code uneccessary complicated.
* Can't build with small features.
* Still can't build with small features.
* Still quickfix test in old style.
* Build fails with tiny features.
* Malformed channel request causes a hang.
* When a JSON message is split it isn't decoded.
* Starting job with output to buffer changes options in the current buffer.
* When 'fileformats' is set in the vimrc it applies to new buffers
but not the initial buffer.
* Emoji characters are not considered as a kind of word character.
* Channel test doesn't work with Python 2.6.
* Channel demo doesn't work with Python 2.6.
* All Channels share the message ID, it keeps getting bigger.
* Can't get info about a channel.
* Trying to close file descriptor that isn't open.
* Missing changes to structs.
* Channel out_cb and err_cb are not tested.
* 64-bit Compiler warning.
* Handling emoji characters as full width has problems with backwards
compatibility.
* Unicode table for double width is outdated.
* Compiler doesn't understand switch on all enum values.
* List of test targets is outdated.
* If the help tags file was removed "make install" fails.
* Vertical movement after CTRL-A ends up in the wrong column.
* Channel test is a bit flaky.
- Updated to revision 1591, fixes the following problems
* Crash when using function reference.
* Using ":call dict.func()" where the function is a partial
does not work.
* Get E923 when using function(dict.func, [], dict).
* Warning for unitinialized variable.
* Partial is not recognized everywhere.
* Nesting partials doesn't work.
* Compiler warnings with 64 bit compiler.
* Old style test for quickfix.
* Combining dict and args with partial doesn't always work.
* Warning for shadowed variable.
* The quickfix title is truncated.
- Updated to revision 1579, fixes the following problems
* Passing cookie to a callback is clumsy.
* Dict options with a dash are more difficult to use.
* Missing update to proto file.
* ":helptags ALL" crashes.
* An empty list in function() causes an error.
* Crash when assert_equal() runs into a NULL string.
* Crash in assert_fails().
* Using CTRL-] in help on option in parentheses doesn't work.
* Using old style tests for quickfix.
* There is no way to avoid the message when editing a file.
* No test for ":help".
* Setting 'compatible' in test influences following tests.
* Tests get stuck at the more prompt.
* ":undo 0" does not work.
* Write error of viminfo file is not handled properly.
* Cannot pass "dict.Myfunc" around as a partial.
* There is no way to invoke a function later or periodically.

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Replace virtinst-replace-unar-with-other-archivers.patch with the
upstream version
21fd079e-replace-unar-with-other-archivers.patch
- bsc#971825 - virt-manager needs to use grub.xen installing a PV
Tumbleweed VM
virtinst-pvgrub2-bootloader.patch
- fate#320353 - Add the ability for virt-convirt to decompress
compressed files in an OVA
f11eb00b-virt-convert-decompress-gz-files-before-converting.patch
- bsc#951726 - Error - 'wrong number of arguments (3 for 1) ...'
when attempting to create DomU through the yast
virt-manager.spec

==== wdiff ====
Subpackages: wdiff-lang

- Enable experimental tools (same as in Fedora)
* mdiff
* wdiff2
* unify
- Enable internal testsuite
- Small spec file improvements and cleanups

==== webkitgtk ====
Version update (2.4.9 -> 2.4.10)
Subpackages: libjavascriptcoregtk-1_0-0 libwebkitgtk-1_0-0 libwebkitgtk-devel
libwebkitgtk2-lang typelib-1_0-JavaScriptCore-1_0 typelib-1_0-WebKit-1_0

- Update to version 2.4.10:
+ Fix rendering of form controls and scrollbars with GTK+ >= 3.19
+ Fix crashes on PPC64.
+ Fix the build on powerpc 32 bits.
+ Add ARM64 build support.
+ Security fixes: CVE-2015-1120, CVE-2015-1076, CVE-2015-1071,
CVE-2015-1081, CVE-2015-1122, CVE-2015-1155, CVE-2014-1748,
CVE-2015-3752, CVE-2015-5809, CVE-2015-5928, CVE-2015-3749,
CVE-2015-3659, CVE-2015-3748, CVE-2015-3743, CVE-2015-3731,
CVE-2015-3745, CVE-2015-5822, CVE-2015-3658, CVE-2015-3741,
CVE-2015-3727, CVE-2015-5801, CVE-2015-5788, CVE-2015-3747,
CVE-2015-5794, CVE-2015-1127, CVE-2015-1153, CVE-2015-1083.
+ Updated translations.
- Rebase webkitgtk-aarch64.patch, webkitgtk-commit-size.patch.
- Drop webkitgtk-js-endian-fixes.patch and
webkitgtk-protocall-endian-fix.patch: fixed upstream.

==== webkitgtk3 ====
Version update (2.4.9 -> 2.4.10)
Subpackages: libjavascriptcoregtk-3_0-0 libwebkitgtk-3_0-0

- Update to version 2.4.10:
+ Fix rendering of form controls and scrollbars with GTK+ >= 3.19
+ Fix crashes on PPC64.
+ Fix the build on powerpc 32 bits.
+ Add ARM64 build support.
+ Security fixes: CVE-2015-1120, CVE-2015-1076, CVE-2015-1071,
CVE-2015-1081, CVE-2015-1122, CVE-2015-1155, CVE-2014-1748,
CVE-2015-3752, CVE-2015-5809, CVE-2015-5928, CVE-2015-3749,
CVE-2015-3659, CVE-2015-3748, CVE-2015-3743, CVE-2015-3731,
CVE-2015-3745, CVE-2015-5822, CVE-2015-3658, CVE-2015-3741,
CVE-2015-3727, CVE-2015-5801, CVE-2015-5788, CVE-2015-3747,
CVE-2015-5794, CVE-2015-1127, CVE-2015-1153, CVE-2015-1083.
+ Updated translations.
- Rebase webkitgtk-aarch64.patch, webkitgtk-commit-size.patch.
- Drop webkitgtk-js-endian-fixes.patch and
webkitgtk-protocall-endian-fix.patch: fixed upstream.

==== xmlgraphics-fop ====
Version update (1.1 -> 2.1)

- Fix manpage for xmlgraphics-fop-fontmetrics
- Update to fop 2.1
- https://xmlgraphics.apache.org/fop/changes.html#version_2.1
- Remove upstreamed fop-commons-2.0.patch
and xmlgraphics-fop-xconf.patch
- Add hyphenation-more-stack.patch to fix build with offo 2.2

==== xterm ====
Version update (322 -> 324)
Subpackages: xterm-bin

- Patch #324 - 2016/03/10
* updated configure macro CF_LD_RPATH_OPT from ncurses changes.
* provide alternate fix for Juha Nurmela's report by turning on
POSIX signals if _POSIX_C_SOURCE is at least one. This is
done to improve the behavior if a direct child process
receives a STOP signal.
* revert change to CF_POSIX_C_SOURCE from patch #323
(reports by Ashish Shukla, Christian Weisgerber).
- Patch #323 - 2016/03/07
* updated appdata and desktop files to add keywords (report by
Richard Hughes).
* modify configure macro CF_POSIX_C_SOURCE to accommodate some
systems, e.g., FreeBSD, which have separated their
implementation specific preprocessor symbols from the POSIX
ones, requiring both to be defined (report by Juha Nurmela).
* change the directory to the current working dir of the child
process in exec-formatted and exec-selectable actions (patch
by Alexander Pohoyda).
* correct typo in xterm.man (patch by Larry Hynes).
* correct typo in ctlseqs.ms (report by Shriramana Sharma).
* add feature to support XHTML and SVG screen dumps (patch by
Jens Schweikhardt).
* correct response to DECRQSS when terminal id is less than 400
(patch by Iwamoto Kouichi).

==== xz ====
Subpackages: liblzma5 liblzma5-32bit xz-devel

- Install xznew with correct permissions (boo#970842)

==== yast2 ====
Version update (3.1.179 -> 3.1.180)
Subpackages: yast2-devel-doc

- Added proc_modules.scr from yast-installation to avoid that
yast-sound depends on yast-installation (bsc#972310)
- 3.1.180

==== yast2-installation ====
Version update (3.1.175 -> 3.1.176)

- Moved proc_modules.scr to yast2.rpm to avoid that yast-sound
depends on yast-installation (bsc#972310)
- 3.1.176

==== yast2-packager ====
Version update (3.1.90 -> 3.1.91)

- Fixed list of skipped packages in the installation summary
dialog (boo#971759)
- 3.1.91

==== yast2-storage ====
Version update (3.1.82 -> 3.1.84)

- Add PowerNV support. (boo#970582)
PowerNV doesn't require any special boot partition.
Firmware just kexecs kernel of the root device
- Require libstorage 2.25.36
- 3.1.84

==== zypper ====
Version update (1.12.35 -> 1.13.0)
Subpackages: zypper-aptitude zypper-log

- Update zypper-po.tar.bz2
- Bump minor version; 1.12 is continued on SuSE-SLE-12-SP1-Branch
- version 1.13.0
- man: Rephrase unclear explanation of --non-interactive (bsc#969186)
- man: add missing --non-interactive-include-reboot-patches option
- version 1.12.36
- Update zypper-po.tar.bz2
- Update zypper-po.tar.bz2

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages