Mailinglist Archive: opensuse-factory (554 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160126 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160126

Packages changed:
Mesa (11.1.0 -> 11.1.1)
MozillaThunderbird
SuSEfirewall2 (3.6.315 -> 3.6.318)
amavisd-new
ark (15.12.0 -> 15.12.1)
autoyast2 (3.1.111 -> 3.1.113)
baloo5-widgets (15.12.0 -> 15.12.1)
cantarell-fonts (0.0.20 -> 0.0.20.1)
claws-mail (3.13.1 -> 3.13.2)
digikam
dolphin (15.12.0 -> 15.12.1)
dragonplayer (15.12.0 -> 15.12.1)
evolution (3.18.3 -> 3.18.4)
evolution-data-server (3.18.3 -> 3.18.4)
evolution-ews (3.18.3 -> 3.18.4)
ffmpeg (2.8.2 -> 2.8.5)
file
gedit (3.18.2 -> 3.18.3)
giflib (5.1.1 -> 5.1.2)
gnome-bluetooth (3.18.1 -> 3.18.2)
gnome-dictionary (3.18.0 -> 3.18.1)
gnome-keyring
gnutls (3.4.4 -> 3.4.8)
gpgmepp5 (15.12.0 -> 15.12.1)
icewm (1.3.11 -> 1.3.12)
insserv-compat
jasper
kaccounts-integration (15.12.0 -> 15.12.1)
kamera (15.12.0 -> 15.12.1)
kate (15.12.0 -> 15.12.1)
kcalc (15.12.0 -> 15.12.1)
kcharselect (15.12.0 -> 15.12.1)
kcolorchooser (15.12.0 -> 15.12.1)
kde-l10n (15.12.0 -> 15.12.1)
kdebase4 (15.12.0 -> 15.12.1)
kdebase4-runtime (15.12.0 -> 15.12.1)
kdebase4-workspace
kdelibs4 (4.14.15 -> 4.14.16)
kdenetwork4-filesharing (15.12.0 -> 15.12.1)
kdnssd (15.12.0 -> 15.12.1)
kernel-firmware (20151207git -> 20160112git)
kernel-source
kget (15.12.0 -> 15.12.1)
kgpg (15.12.0 -> 15.12.1)
kio
kio-extras5 (15.12.0 -> 15.12.1)
kio_audiocd (15.12.0 -> 15.12.1)
klettres (15.12.0 -> 15.12.1)
kmag (15.12.0 -> 15.12.1)
kmahjongg (15.12.0 -> 15.12.1)
kmines (15.12.0 -> 15.12.1)
kmousetool (15.12.0 -> 15.12.1)
kmplot (15.12.0 -> 15.12.1)
kolourpaint (15.12.0 -> 15.12.1)
kompare (15.12.0 -> 15.12.1)
konsole (15.12.0 -> 15.12.1)
kopete (15.12.0 -> 15.12.1)
kpat (15.12.0 -> 15.12.1)
kqtquickcharts (15.12.0 -> 15.12.1)
krdc (15.12.0 -> 15.12.1)
kreversi (15.12.0 -> 15.12.1)
krfb (15.12.0 -> 15.12.1)
kruler (15.12.0 -> 15.12.1)
ksudoku (15.12.0 -> 15.12.1)
ktp-common-internals (15.12.0 -> 15.12.1)
libetonyek (0.1.3 -> 0.1.6)
libkcddb4 (15.12.0 -> 15.12.1)
libkcompactdisc4 (15.12.0 -> 15.12.1)
libkdcraw (15.08.3 -> 15.12.1)
libkdegames (15.12.0 -> 15.12.1)
libkexiv2 (15.08.3 -> 15.12.1)
libkface (15.12.0 -> 15.12.1)
libkgeomap (15.08.3 -> 15.12.1)
libkipi (15.08.3 -> 15.12.1)
libkolabxml (1.1.1 -> 1.1.2)
libkomparediff2 (15.12.0 -> 15.12.1)
libksane (15.08.3 -> 15.12.1)
libpng16 (1.6.20 -> 1.6.21)
libreoffice (5.0.4.2 -> 5.1.0.2)
libsecret (0.18.3 -> 0.18.4)
libstorage (2.25.33 -> 2.25.35)
marble (15.08.3 -> 15.12.1)
mobipocket (15.12.0 -> 15.12.1)
ntp
okular (15.12.0 -> 15.12.1)
opus (1.1.1 -> 1.1.2)
patterns-openSUSE
perl-Image-ExifTool (10.00 -> 10.10)
perl-XML-XPath (1.21 -> 1.24)
pinfo
poppler (0.39.0 -> 0.40.0)
poppler-qt (0.39.0 -> 0.40.0)
poppler-qt5 (0.39.0 -> 0.40.0)
python-Unidecode (0.04.18 -> 0.04.19)
python-ldap (2.4.22 -> 2.4.25)
python-pycparser (2.12 -> 2.14)
python-six
python3-pip (8.0.0 -> 8.0.2)
python3-setuptools (19.2 -> 19.4)
shadow
signon-kwallet-extension (15.12.0 -> 15.12.1)
skanlite (1.1 -> 1.1git)
snapper (0.2.9 -> 0.2.10)
spectacle (15.12.0 -> 15.12.1)
sqlite3 (3.10.0 -> 3.10.2)
sweeper (15.12.0 -> 15.12.1)
udhcp
xorg-x11-server
yast2-live-installer (3.1.4 -> 3.1.5)

=== Details ===

==== Mesa ====
Version update (11.1.0 -> 11.1.1)
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
Mesa-libva libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1
libgbm1-32bit libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- u_dri2-Check-for-dummyContext-to-see-if-the-glx_context-is-valid.patch
Check for dummyContext to see if the glx_context is valid (boo#962609).
- n_VDPAU-XVMC-libs-Replace-hardlinks-with-copies.patch
* Since these are packaged separately in (open)SUSE anyway, one
can use copies as well. This makes debug packages possible
again. (bnc #962609)
- update to 11.1.1
* Bugfix release and adding KB Lake PCI id's
+ fdo#91806 - configure does not test whether assembler supports sse4.1
+ fdo#92229 - [APITRACE] SOMA have serious graphical errors
+ fdo#92233 - Unigine Heaven 4.0 silhuette run
+ fdo#93004 - Guild Wars 2 crash on nouveau DX11 cards
+ fdo#93215 - [Regression bisected] Ogles1conform Automatic mipmap
generation test is fail
+ fdo#93257 - [SKL, bisected] ASTC dEQP tests segfault
+ fixes for r600,nv*,glx,glsl,radeonsi and i965

==== MozillaThunderbird ====
Subpackages: MozillaThunderbird-translations-common

- Add build conditionals for valgrind and -Os
- Convert existing conditions for kde to bcond

==== SuSEfirewall2 ====
Version update (3.6.315 -> 3.6.318)

- Merge pull request #5 from hwoarang/firewalld-conflict
- SuSEfirewall2{,_init}.service: Conflict with firewalld service
- basic.service -> basic.target (bsc#961258)

==== amavisd-new ====
Subpackages: amavisd-new-docs

- Add amavisd-new-2.10.1-myhostname.patch:
$myhostname is set using POSIX::uname, but expects a FQDN. This
patch changes this behaviour to use Net::Domain::hostfqdn instead

==== ark ====
Version update (15.12.0 -> 15.12.1)
Subpackages: libkerfuffle15

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Drop upstream patch
* Fix-ark-cannout-open-rar-file-with-space-in-archive-file-path.patch
* Fallback-to-read-only-mode-if-there-are-no-read-write-executables.patch

==== autoyast2 ====
Version update (3.1.111 -> 3.1.113)
Subpackages: autoyast2-installation

- LVM: taking care about "auto" option --> switching to "max".
(bnc#962034)
- 3.1.113
- Fixed rules.xml : OR operator is interpreted as AND.
(bnc#961941)
- 3.1.112
- Fix wrong warning message about the 'init' section
not being processed (bsc#962526)

==== baloo5-widgets ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== cantarell-fonts ====
Version update (0.0.20 -> 0.0.20.1)

- Update to version 0.0.20.1:
+ Fix composited glyph issues.
+ Fix parallel build issue.

==== claws-mail ====
Version update (3.13.1 -> 3.13.2)
Subpackages: claws-mail-lang

- Update to version 3.13.2 (CVE-2015-8708):
+ Bugs fixed: claws#2358, claws#3557, claws#3584.
+ Updated translations.

==== digikam ====
Subpackages: digikam-lang kipi-plugins kipi-plugins-acquireimage
kipi-plugins-geolocation kipi-plugins-lang

- Add the file digikam-libs.tar.bz2 based on the Digikam 4.13.0
source file. These are the libs that have moved to KF5 upstream,
but digikam is still KDE4 based.
This should enable to build digikam until the KF5 based version
is released
- re-enable support for MediaWiki export in kipi-plugins

==== dolphin ====
Version update (15.12.0 -> 15.12.1)
Subpackages: dolphin-part libdolphinvcs5

- Added Do-not-delete-sub-menus-of-the-control-menu-explicitly.patch:
fixes a possible crash when closing the "Control" menu (boo#952460,
kde#354558)
- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== dragonplayer ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== evolution ====
Version update (3.18.3 -> 3.18.4)
Subpackages: evolution-plugin-bogofilter evolution-plugin-spamassassin

- Update to version 3.18.4:
+ EHTMLEditorView:
- Allow to append a query to the link.
- Cannot append text to links if non-breaking space is
presented.
- Extra new line added after pressing the Backspace in a list
item with one character.
- History can be overwritten when redoing the Return key press
in an empty list item.
- Redoing the Return key press in the list can fail.
- Pressing the Return key in the bulleted list does not end
it.
- Cannot remove an empty bulleted list item with Backspace key.
- Only change a smiley to plain text when the node is smiley.
+ Address crashes related to second instance execution.
+ Bugs fixed: bgo#759584, bgo#759564, bgo#760365.
+ Updated translations.

==== evolution-data-server ====
Version update (3.18.3 -> 3.18.4)
Subpackages: evolution-data-server-devel libcamel-1_2-54 libebackend-1_2-10
libebook-1_2-16 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-28 libedataserver-1_2-21 libedataserverui-1_2-1
typelib-1_0-EBook-1_2 typelib-1_0-EBookContacts-1_2 typelib-1_0-EDataServer-1_2

- Update to version 3.18.4:
+ [IMAPx] Enhance IDLE run management on folders.
+ Updated translations.

==== evolution-ews ====
Version update (3.18.3 -> 3.18.4)
Subpackages: evolution-ews-lang libeews-1_2-0 libewsutils0

- Update to version 3.18.4:
+ Updated translations.

==== ffmpeg ====
Version update (2.8.2 -> 2.8.5)
Subpackages: libavcodec56 libavformat56 libavutil54 libswresample1 libswscale3

- Update to version 2.8.5
* Fixes CVE-2016-1897 and CVE-2016-1898 [boo#961937]
- Update to version 2.8.4
* Many bugfixes, see the included Changelog for all the changes.
* resolving CVE-2015-8661 [boo#960385], CVE-2015-8662 [boo#960384],
CVE-2015-8663 [boo#960383]
- Drop ffmpeg-remove_some_unused_ctrl_id_mappings.patch, fixed
upstream.
- Obsolete ffmpeg-tools from packman
- Add some provides to make it easier for firefox to recommend
this package for installation
- Added patch ffmpeg-remove_some_unused_ctrl_id_mappings.patch to
successfully build against libvpx >= 1.5 (at least on PMBS).
- Add buildconditionals for libass,libva,vdpau to fix build in SLE_11
- Rename bcond dca to dcadec
- Add more buildconditionals to get closer to removal of BUILD_ORIG
- Remove unused imlib2
- Sync with packman changes
* All packman specific changes are protected with BUILD_ORIG
- Added the following patches
* ffmpeg-2.4.5-arm6l.patch
* ffmpeg-libcdio_cdda-pkgconfig.patch
- Update to new upstream maintenance release 2.8.3
* avformat/matroskadec: Check subtitle stream before dereferencing
* avcodec/jpeg2000dec: Fix potential integer overflow with tile
dimensions
* avcodec/jpeg2000dec: Check for duplicate SIZ marker
* avcodec/jpeg2000: Change coord to 32bit to support larger than
32k width or height
* avcodec/jpeg2000dec: Check SIZ dimensions to be within the
supported range
* avcodec/jpeg2000: Check comp coords to be within the supported
size
* dds: validate compressed source buffer size
* dds: validate source buffer size before copying
* softfloat: assert when the argument of av_sqrt_sf is negative
- Fixes CVE-2015-8363 [bnc#957114], CVE-2015-8364 [bnc#957115],
CVE-2015-8365 [bnc#957116]

==== file ====
Subpackages: file-devel file-magic libmagic1 libmagic1-32bit

- add file-5.25-avoid-double-evaluation-in-python-bindings.dif (bsc#949905)

==== gedit ====
Version update (3.18.2 -> 3.18.3)
Subpackages: python3-gedit

- Update to version 3.18.3:
+ Several crash fixes.
+ A few other more minor bug fixes.
+ Add kudos to appdata.
+ Updated translations.

==== giflib ====
Version update (5.1.1 -> 5.1.2)
Subpackages: giflib-devel libgif7

- Update to version 5.1.2 (fixes CVE-2015-7555, bsc#960319)
* Code Fixes
+ Code hardening using reallocarray() from OpenBSD.
+ Sanity check in giffilter catches files with malformed
extension records. Fixes SourceForge bug #63: malformed gif
causes segfault in giffilter.
+ Inexpensive sanity check in DGifSlurp() catches malformed files
with no image descriptor. Fixes SourceForge bug #64: malformed
gif causes crash in giftool.
+ Fix SourceForge bug #66: GifDrawBoxedText8x8() modifying
constant input parameter.
+ Bail out of GIF read on invalid pixel width. Addresses Savannah
bug #67: invalid shift in dgif_lib.c
+ Fix SourceForge bug #69: #69 Malformed: Gif file with no
extension block after a GRAPHICS_EXT_FUNC_CODE extension causes
segfault (in giftext).
+ Fix SourceForge bug #71: Buffer overwrite when giffixing a
malformed gif.
+ Fix SourceForge bug #73: Null pointer deference in gifclrmap
(only reachable with malformed GIF).
+ Fix SourceForge bug #74: Double free in gifsponge under 5.1,1,
for any valid gif image.
+ Fix SourceForge bug #75: GAGetArgs overflows due to uncounted
use of va_arg.
+ Sanity check in giffix catches some malformed files. Addresses
SourceForge bug #77: dgif_lib.c: extension processing error
- Modified patches:
* giflib-automake-1_13.patch
* giflib-visibility.patch
+ rediff to changed context

==== gnome-bluetooth ====
Version update (3.18.1 -> 3.18.2)
Subpackages: libgnome-bluetooth13 typelib-1_0-GnomeBluetooth-1_0

- Update to version 3.18.2:
+ Added API to export adapter status.
+ Updated translations.

==== gnome-dictionary ====
Version update (3.18.0 -> 3.18.1)
Subpackages: libgdict-data

- Update to version 3.18.1:
+ Library:
- Create new GdictDatabaseChooserButton widget.
- Symbolic icons.
+ Application:
- Fix spelling in "Creating XDG config directory" message.
- Use GTK's automagic menu loading.
- Symbolic icons.
- Replace action area with header bar.
- Replace deprecated GtkTable with GtkGrid.
+ Updated translations.
- Rename libgdict-1_0-9 subpackage to libgdict-1_0-10, following
upstreams soname bump.

==== gnome-keyring ====
Subpackages: gnome-keyring-32bit gnome-keyring-pam gnome-keyring-pam-32bit
libgck-modules-gnome-keyring

- boo#962480: Add mdm as valid display manager to unlock gkr.

==== gnutls ====
Version update (3.4.4 -> 3.4.8)
Subpackages: libgnutls-devel libgnutls-openssl27 libgnutls30 libgnutls30-32bit

- Update to 3.4.8
All changes since 3.4.4:
* libgnutls: Corrected memory leak in gnutls_pubkey_import_privkey()
when used with PKCS #11 keys.
* libgnutls: For DSA and ECDSA keys in PKCS #11 objects, import
their public keys from either a public key object or a certificate.
That is, because private keys do not contain all the required
parameters for a direct import.
* libgnutls: Fixed issue when writing ECDSA private keys in PKCS #11
tokens.
* libgnutls: Fixed out-of-bounds read in
gnutls_x509_ext_export_key_usage()
* libgnutls: The CHACHA20-POLY1305 ciphersuites were updated to
conform to draft-ietf-tls-chacha20-poly1305-02.
* libgnutls: Several fixes in PKCS #7 signing which improve
compatibility with the MacOSX tools.
* libgnutls: The max-record extension not negotiated on DTLS. This
resolves issue with the max-record being negotiated but ignored.
* certtool: Added the --p7-include-cert and --p7-show-data options.
* libgnutls: Properly require TLS 1.2 in all CBC-SHA256 and CBC-SHA384
ciphersuites. This solves an interoperability issue with openssl.
* libgnutls: Corrected the setting of salt size in
gnutls_pkcs12_mac_info().
* libgnutls: On a rehandshake allow switching from anonymous to ECDHE
and DHE ciphersuites.
* libgnutls: Corrected regression from 3.3.x which prevented
ARCFOUR128 from using arbitrary key sizes.
* libgnutls: Added GNUTLS_SKIP_GLOBAL_INIT macro to allow programs
skipping the implicit global initialization.
* gnutls.pc: Don't include libtool specific options to link flags.
* tools: Better support for FTP AUTH TLS negotiation
* libgnutls: Added new simple verification functions. That avoids the
need to install a callback to perform certificate verification. See
doc/examples/ex-client-x509.c for usage.
* libgnutls: Introduced the security parameter 'future' which is at
the 256-bit level of security, and 'ultra' was aligned to its
documented size at 192-bits.
* libgnutls: When writing a certificate into a PKCS #11 token, ensure
that CKA_SERIAL_NUMBER and CKA_ISSUER are written.
* libgnutls: Allow the presence of legacy ciphers and key exchanges in
priority strings and consider them a no-op.
* libgnutls: Handle the extended master secret as a mandatory
extension. That fixes incompatibility issues with Chromium (#45).
* libgnutls: Added the ability to copy a public key into a PKCS #11
token.
* tools: Added support for LDAP and XMPP negotiation for STARTTLS.
* p11tool: Allow writing a public key into a PKCS #11 token.
* certtool: Key generation security level was switched to HIGH. That
is, by default the tool generates 3072 bit keys for RSA and DSA.
* libgnutls: When re-importing CRLs to a trust list ensure that there
no duplicate entries.
* certtool: Removed any arbitrary limits imposed on input file sizes
and maximum number of certificates imported.
* certtool: Allow specifying fixed dates on CRL generation.
* gnutls-cli-debug: Added check for inappropriate fallback support
(RFC7507).

==== gpgmepp5 ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== icewm ====
Version update (1.3.11 -> 1.3.12)
Subpackages: icewm-config-upstream icewm-default icewm-lite

- Version bump to 1.3.12:
* various bugfixes collected from all upstream vendors
* added new translations
- Removed upstreamed patches:
* icewm-toolbar-icons-generic.patch
* icewm-fix-local-search.patch

==== insserv-compat ====

- ntp was renamed to ntpd at some point (bsc#960820)

==== jasper ====
Subpackages: libjasper-devel libjasper1 libjasper1-32bit

- Add jasper-CVE-2016-1867.patch
* CVE-2016-1867: Out-of-bounds Read in the JasPer's
jpc_pi_nextcprl() function (bsc#961886)

==== kaccounts-integration ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kamera ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kate ====
Version update (15.12.0 -> 15.12.1)
Subpackages: kate-plugins kwrite

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kcalc ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kcharselect ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kcolorchooser ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kde-l10n ====
Version update (15.12.0 -> 15.12.1)
Subpackages: kde-l10n-cs kde-l10n-da kde-l10n-da-data kde-l10n-da-doc
kde-l10n-de kde-l10n-de-data kde-l10n-de-doc kde-l10n-el kde-l10n-en_GB
kde-l10n-en_GB-data kde-l10n-en_GB-doc kde-l10n-es kde-l10n-es-data
kde-l10n-es-doc kde-l10n-fr kde-l10n-fr-data kde-l10n-hu kde-l10n-it
kde-l10n-it-data kde-l10n-it-doc kde-l10n-ja kde-l10n-pl kde-l10n-pl-data
kde-l10n-pt kde-l10n-pt_BR kde-l10n-pt_BR-data kde-l10n-ru kde-l10n-ru-data
kde-l10n-zh_CN kde-l10n-zh_TW

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kdebase4 ====
Version update (15.12.0 -> 15.12.1)
Subpackages: kdebase4-libkonq kdebase4-nsplugin kdepasswd kdialog
keditbookmarks konqueror konqueror-plugins libkonq-devel libkonq5

- Drop the dolphin4 package and include the necessary dolphin files
into the konqueror package. Drop the unnecessary files
- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kdebase4-runtime ====
Version update (15.12.0 -> 15.12.1)

- Drop the branding-upstream sub package. This has always been
empty and was just there as counterpart of the openSUSE branding
package. Now with the latter gone, the upstream one can also be
dropped.
- Drop the requirement for a branding package. This is no longer
needed and no branding package actually exists.
- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kdebase4-workspace ====
Subpackages: kdebase4-workspace-libs python-kdebase4

- Drop the upstream branding package for workspace. This is no
longer required. Move the files from the upstream branding
package to the workspace package.

==== kdelibs4 ====
Version update (4.14.15 -> 4.14.16)
Subpackages: kdelibs4-core kdelibs4-doc libkde4 libkde4-devel libkdecore4
libkdecore4-devel libksuseinstall1

- Update to 4.14.16
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Drop upstream patch bko355275.patch
- Drop support for Nepomuk which is no longer used

==== kdenetwork4-filesharing ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kdnssd ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kernel-firmware ====
Version update (20151207git -> 20160112git)
Subpackages: ucode-amd

- Update to version 20160112git (commit 40e9ae8)
* Update firmware patch for Intel Bluetooth 7265 (D1)
* rtlwifi: v35 firmware for rtl8723bu
* qed: Add firmware 8.7.3.0.
* Clarified licensing terms for the current ath9k_htc firmware
* brcm: add firmware for BCM4350 rev 5
* fix permissions on brcm/brcmfmac4371-pcie.bin
* add a symlink from qat_mmp.bin to its new file name
* add fw for new qat devices
* WHENCE: Add version information for hfi1
* Update Skylake audio firmware
* moxa: Refer to LICENCE.moxa for mxuport driver
* moxa: Add firmware for Moxa 11x0 USB Serial devices
* iwlwifi: replace 7265D-10.ucode by 7265-10.ucode
* Update Intel OPA hfi1 firmware
* update Marvell USB8797-B0 firmware image
* update Marvell 8897-B0 firmware images to 7.p53
* update Marvell 8897-B0 firmware images to 7.p18
* add Marvell SD/USB8801 B0 firmware images
- Fix the Supplements dependency of ucode-amd.

==== kernel-source ====
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- scsi: ignore errors from scsi_dh_add_device() (boo#962813).
- commit 1b0ab71
- ALSA: hda - Flush the pending probe work at remove (boo#960710).
- commit 1a7f7c2
- rpm/old-flavors: Obsolete kernel-xen <= 4.4, to match 4.3.anything
- commit cd04346
- mm: readahead: Increase default readahead window (VM Performance, bnc#548529).
- Delete
patches.fixes/cpufreq_ondemand_performance_optimise_default_settings.patch.
patches.fixes/mm-Fix-assertion-mapping-nrpages-0-in-end_writeback.patch.
- commit 42f90c8
- HID: multitouch: fix input mode switching on some Elan panels
(boo#954532).
- commit 71b733e
- Enable CONFIG_PINCTRL_CHERRYVIEW and _BROXTON (boo#954532)
Needed for recent tablets/laptops.
CONFIG_PINCTRL_BAYTRAIL is still disabled as it can't be built as a
module.
- commit d33a340
- patches.fixes/keys-fix-leak.patch: (bnc#962075, CVE-2016-0728).
- commit e2007ee
- hwrng: core - sleep interruptible in read (bnc#962597).
- commit d407b31
- Delete
patches.fixes/0001-NFSv4-do-not-accept-an-incompatible-delegation.patch.
This was fixed in 4.3 by
Commit: 24311f884189 ("NFSv4: Recovery of recalled read delegations is
broken")
- commit c67a4b2
- drm/i915: shut up gen8+ SDE irq dmesg noise (boo#961887).
- commit ef6f4af
- Delete obsolete patches
- Delete

patches.arch/arm64-gpex-0001-device-core-Introduce-per-device-MSI-domain-pointer.patch.
- Delete

patches.arch/arm64-gpex-0002-PCI-MSI-add-hooks-to-populate-the-msi_domain-field.patch.
- Delete

patches.arch/arm64-gpex-0003-PCI-MSI-of-add-support-for-OF-provided-msi_domain.patch.
- Delete

patches.arch/arm64-gpex-0004-PCI-MSI-Let-pci_msi_get_domain-use-struct-device-s-m.patch.
- Delete

patches.arch/arm64-gpex-0005-irqchip-GICv2m-Get-rid-of-struct-msi_controller.patch.
- Delete

patches.arch/arm64-gpex-0006-irqchip-gicv3-its-Get-rid-of-struct-msi_controller.patch.
- Delete

patches.arch/arm64-gpex-0007-PCI-MSI-Drop-domain-field-from-msi_controller.patch.
- Delete

patches.arch/arm64-gpex-0008-PCI-MSI-of-Allow-msi_domain-lookup-using-the-PHB-nod.patch.
- commit 370a5bb
- Delete patches.fixes/nouveau-fix-race-with-fence-signaling.
This patch was obsoleted by protecting ->channel with RCU.
- commit a704b3b
- Delete patches.fixes/dm-release-map_lock-before-set_disk_ro.
The drivers/md/dm.c:__bind has changes significantly and this patch
is no longer relevant.
- commit 75554c0
- rpm/kernel-binary.spec.in: Fix build if no UEFI certs are installed
- commit ef1b7d3
- rpm/kernel-binary.spec.in: Install libopenssl-devel for newer sign-file
- commit fbdf0b8

==== kget ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Drop the BuildRequires on kdebase4-workspace. In a Plasma5
environment it would be impossible to shutdown the system through
KDE4.

==== kgpg ====
Version update (15.12.0 -> 15.12.1)

- Fix ServiceMenus symlinks for KF5/Plasma5, they were pointing to
nowhere (boo#959490)
- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kio ====
Subpackages: kio-core kio-devel

- Added fix-kcookiejar-autoload.patch to fix the swapped values
for the autoload.

==== kio-extras5 ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kio_audiocd ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== klettres ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kmag ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kmahjongg ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kmines ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kmousetool ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kmplot ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kolourpaint ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kompare ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== konsole ====
Version update (15.12.0 -> 15.12.1)
Subpackages: konsole-part

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kopete ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kpat ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kqtquickcharts ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== krdc ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kreversi ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== krfb ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== kruler ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== ksudoku ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== ktp-common-internals ====
Version update (15.12.0 -> 15.12.1)
Subpackages: ktp-icons

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libetonyek ====
Version update (0.1.3 -> 0.1.6)

- Version bump to 0.1.6:
* All formats:
+ Improved handling of text language, e.g., written language
props now include country and script.
* Keynote 6:
+ Parse links.
+ Parse text language.
+ Parse lists (bullets).
+ Resize tables properly.
+ Fix handling of texts containing non-ASCII characters (i.e.,
the majority of non-English languages).
* Miscellaneous:
+ Fix build with boost 1.54/1.55.
+ Make help output of conversion tools more help2man-friendly.
+ Fix build with recent clang, which does not like 'register'
keyword.
+ Various small fixes and improvements.
* Changes to 0.1.5
+ Parse slide background.
+ Parse shape style: fill, line stroke, opacity, shadow.
+ Parse table style: default cell borders, background etc.
+ Various fixes and improvements.
* Changes to 0.1.4
* Parse formulas.
* Parse cell type and number format.
* Require mdds 1.0 by default (but 0.12.1 is still supported).
* Add support for Keynote 6. Imported features include: shapes,
images, text + text formatting, presentation notes, tables
(only simple tables are supported.)
- Generate manpages for the conversion tools

==== libkcddb4 ====
Version update (15.12.0 -> 15.12.1)
Subpackages: libkcddb4-devel

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libkcompactdisc4 ====
Version update (15.12.0 -> 15.12.1)
Subpackages: libkcompactdisc4-devel

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libkdcraw ====
Version update (15.08.3 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Add fix-libraw-dependency.diff and decrease the requirement of libraw
for SLE12 from 0.16 to 0.15.4
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887

==== libkdegames ====
Version update (15.12.0 -> 15.12.1)
Subpackages: kdegames-carddecks-default libkdegames-devel libkf5kdegames6

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libkexiv2 ====
Version update (15.08.3 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Update patch: fix-reduce-required-exiv2-to-0.23.diff for 15.12.0
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887

==== libkface ====
Version update (15.12.0 -> 15.12.1)
Subpackages: libKF5KFace10_0_0 libkface-devel

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libkgeomap ====
Version update (15.08.3 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887

==== libkipi ====
Version update (15.08.3 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887

==== libkolabxml ====
Version update (1.1.1 -> 1.1.2)

- New upstream release 1.1.2
- Build fixes for the tests (Qt5 related)

==== libkomparediff2 ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== libksane ====
Version update (15.08.3 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887

==== libpng16 ====
Version update (1.6.20 -> 1.6.21)
Subpackages: libpng16-16 libpng16-16-32bit libpng16-compat-devel libpng16-devel

- Update to new upstream release 1.6.21
* Widened the 'limit' check on the internally calculated error limits in
the 'DIGITIZE' case (the code used prior to 1.7 for rgb_to_gray error
checks) and changed the check to only operate in non-release builds
(base build type not RC or RELEASE.)
* Fixed undefined behavior in pngvalid.c, undefined because
(png_byte) << shift is undefined if it changes the signed bit
(because png_byte is promoted to int). The libpng exported functions
png_get_uint_32 and png_get_uint_16 handle this.

==== libreoffice ====
Version update (5.0.4.2 -> 5.1.0.2)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions
libreoffice-draw libreoffice-filters-optional libreoffice-gnome
libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions

- Update to 5.1.0.2:
* More small fixes here and there for the RC2 release
- Remove upstreamed patches:
* libreoffice-graphite.patch
* libreoffice-uno-py26.patch
* libreoffice-kde4-filelist.patch
* libreoffice-old-gtkapi.patch
- Reenable collada, debian and fedora both build with it so do the
same
- Set ulimit to unlimited prior build to allow better debugging of
build crashes
- Add patch attempting to fix build on old gtk2 versions:
* libreoffice-old-gtkapi.patch
- Add patch to fix filelist generating after kde3 removal:
* libreoffice-kde4-filelist.patch
- Add patch to fix graphite2 bundled build on SLE11:
* libreoffice-graphite.patch
- Add patch to fix build of pyuno with python2.6:
* libreoffice-uno-py26.patch

==== libsecret ====
Version update (0.18.3 -> 0.18.4)
Subpackages: libsecret-1-0 libsecret-devel typelib-1_0-Secret-1

- Update to version 0.18.4:
+ Multithreading fixes (bgo#756766).
+ Fix memory leaks (bgo#756766).
+ Updated translations.

==== libstorage ====
Version update (2.25.33 -> 2.25.35)
Subpackages: libstorage-ruby libstorage6

- Added fixed lt.po again that had broken build
- 2.25.35
- repeat the btrfs file system detection when a race condition in
the "btrfs" command is detected (bsc#948247)
- Added --zero=y --yes to 'lvcreate' call to prevent interactive
prompt (bsc#948539)
- Temporarily removed lt.po that breaks build
- 2.25.34
- detect corrupt backup GPT in parted output (see bsc#946673)

==== marble ====
Version update (15.08.3 -> 15.12.1)
Subpackages: libastro-qt5-1 marble-data marble-devel marble-doc marble-kde

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265
- Update to KDE Applications 15.12.0
* KDE Applications 15.12.0
* https://www.kde.org/announcements/announce-applications-15.12.0.php
* boo#958887
- Drop upstreamed patches:
* fix-libastro-version-tagging.diff

==== mobipocket ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== ntp ====
Subpackages: ntp-doc

- Explicitely run /usr/sbin/sntp to synchronize in start-ntpd. When
run as cron job, /usr/sbin/ is not in the path, which caused the
synchronization to fail. (boo#962318)

==== okular ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== opus ====
Version update (1.1.1 -> 1.1.2)

- Update to version 1.1.2, fixes the following bugs:
+ Resetting the encoder or decoder state with OPUS_RESET_STATE
would disable some run-time selected architecture-specific
optimizations.
+ In hybrid mode discontinuous transmission (DTX) operation,
the comfort noise above 8 kHz was incorrectly estimated
and could oscillate in time.

==== patterns-openSUSE ====
Subpackages: patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt
patterns-openSUSE-base patterns-openSUSE-books patterns-openSUSE-console
patterns-openSUSE-devel_C_C++ patterns-openSUSE-devel_basis
patterns-openSUSE-devel_gnome patterns-openSUSE-devel_ide
patterns-openSUSE-devel_java patterns-openSUSE-devel_kde
patterns-openSUSE-devel_kde_frameworks patterns-openSUSE-devel_kernel
patterns-openSUSE-devel_perl patterns-openSUSE-devel_python
patterns-openSUSE-devel_qt4 patterns-openSUSE-devel_qt5
patterns-openSUSE-devel_rpm_build patterns-openSUSE-devel_ruby
patterns-openSUSE-devel_web patterns-openSUSE-dhcp_dns_server
patterns-openSUSE-directory_server patterns-openSUSE-enhanced_base
patterns-openSUSE-enhanced_base_opt patterns-openSUSE-file_server
patterns-openSUSE-fonts patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns
-openSUSE-gnome_games patterns-openSUSE-gnome_ide
patterns-openSUSE-gnome_imaging patterns-openSUSE-gnome_imaging_opt
patterns-openSUSE-gnome_internet patterns-openSUSE-gnome_laptop
patterns-openSUSE-gnome_multimedia patterns-openSUSE-gnome_multimedia_opt
patterns-openSUSE-gnome_office patterns-openSUSE-gnome_office_opt
patterns-openSUSE-gnome_utilities patterns-openSUSE-gnome_yast
patterns-openSUSE-imaging patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_laptop
patterns-openSUSE-lxde_office
patterns-openSUSE-mail_server patterns-openSUSE-minimal_base
patterns-openSUSE-minimal_base-conflicts patterns-openSUSE-misc_server
patterns-openSUSE-multimedia patterns-openSUSE-multimedia_opt
patterns-openSUSE-network_admin patterns-openSUSE-non_oss
patterns-openSUSE-non_oss_opt patterns-openSUSE-office
patterns-openSUSE-office_opt patterns-openSUSE-print_server
patterns-openSUSE-remote_desktop patterns-openSUSE-rest_dvd
patterns-openSUSE-sw_management patterns-openSUSE-sw_management_gnome
patterns-openSUSE-sw_management_kde patterns-openSUSE-tabletpc
patterns-openSUSE-technical_writing patterns-openSUSE-x11
patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- Replace cdrecord in console pattern again with wodim: as long as
kiwi hard requires wodim, we can't require cdrecord from the
pattern.
- Drop deja-dup from GNOME patterns: it was added back in the days
when we increased the live CD from 650MB to 1000MB in order to
help fill up the space - but now we are struggling to keep below
the 1000MB limit.
- Drop tango-icon-theme from the GNOME base pattern: it's been a
while that GNOME relied on anything but adwaita and hicolor.

==== perl-Image-ExifTool ====
Version update (10.00 -> 10.10)
Subpackages: exiftool perl-File-RandomAccess

- Update to 10.10 (changes since 10.00):
* Add a new Olympus CameraType.
* Add a new Canon LensType.
* Add a few new QuickTime GenreID values.
* Decode a new Pentax tag.
* Leica programmers should all be ashamed of the complete shambles
of metadata they have created.
* Minor change to the name of a Sigma lens for Canon.
* Improve recognition of Pentax lens adapter.
* Rename a few Sony tags and improved decoding of others.
* Rename a few Pentax tags.
* Fix problem importing structured information from -X option
output.
* Fix round-off errors in value and typo in name of
CanonVRD:GammaWhitePoint.
* Fix test failures if Encode, POSIX or Time::Local modules are
missing.
* Add ability to read PNG chunks after the normal PNG end of file
(IEND).
* Add ability to delete a PNG trailer (with -trailer:all=).
* Add some new Nikon LensID's.
* Add a few new Canon LensType's.
* Add a new Pentax LensType.
* Decode some new PanasonicRaw tags.
* Decode a new Pentax tag.
* Enhance -m option to allow IPTC values which are too short to
be written.
* Add support for JPEG 2000 extended-length boxes.
* Add a few new Canon LensType and CanonModelID values.
* Add a new Nikon LensID.
* Add ExifTool version number as a comment in -listx output.
* Add support for Leica SL (Typ 601) maker notes.
* Add a new Sony LensType.
* Decode more Sony tags for some new models.
* Decode a new Pentax tag.
* Patch for invalid makernote entry written by
Sony ILCE-7M2 v1.21.
* Patch problem reading EXE resources with a missing null
terminator.
* Add a few new Microsoft XMP tags.
* Enhance -r option to allow processing of directory names
beginning with ".".
* Avoid writing XMP-microsoft:LensModel unless specified
explicitly.
* Limit precision of area size in picasa_faces config file.
* Move Nikon NCDT GPS tags into the GPS group so they work with
the Composite GPS tags.
* Fix problem reading Ricoh RMETA information from some cameras.
* Add new Canon and Sony LensType values.
* Add some new Nikon LensID's.
* Add a new PentaxModelID.
* Add preliminary support for Motorola maker notes.
* Change format of XMP-photoshop:DocumentAncestors to write a
simple Bag of strings rather than structures (since this is
what the Adobe software writes, contrary to their own XMP
specification).
* Fix problem where HASH references may be exposed when copying a
list of structures to a non-list-type tag.
* Add a couple of new XMP-digiKam tags.
* Add a new CanonModelID.
* Add a new ACDSee XMP tag.
* Decode a new Canon tag.
* Improve a few lens names.
* Patch to remove trailing null when reading improperly written
QuickTime strings.
* Fix bug where SystemTags weren't available for use with the -p
and -if options.
* Fix problem with warnings on some systems about unimplemented
functions for FileGroupID and FileUserID when -p or -if were
used.
* Add ability to write empty XMP structures.
* Add write support for PhaseOne MakerNotes tags in IIQ files.
* Add a new Nikon LensID.
* Decode a new Olympus tag and improved decoding of DriveMode.
* Minor improvements to HtmlDump of PhaseOne IIQ and PDF files.
* Patch to allow overwriting of empty XMP written by some
PhaseOne cameras.
* Fix bug in HtmlDump feature that could cause a
"substr outside of string" error.
* Add ability to extract OS X system metadata ("MDItem" tags).
* Add a value conversion for GoogleTrackDuration.
* Enchance the -i option to allow full path names to be specified.
* Fix a potential runtime error when writing corrupted JPEG images.
* Add a new Olympus LensType.
* Add a couple of new Olympus FlashModel values.
* Add a new Nikon LensID.
* Add a new Pentax LensType.
* Decode a number of new Sony tags.
* Decode H264:DateTimeOriginal DST flag, and add " DST" to time
string if set.
* Decode a few more CanonCustom settings.
* Fix problem creating user-defined XMP structure elements with
names containing characters which are illegal in tag names.
* Improve mechanism for generating tags which must be
specifically requested when copying or used in -if or -p
expressions.
* Patch Composite:FileNumber to handle case where
Canon:FileNumber is 10000.
* Patch reading FujiFilm RawImageWidth/Height for new X-Pro2 RAF
images.
* Fix problem reading PDF objects which begin with a comment line.
* Fix problem which could result in ExifTool corrupting a PDF file
when writing.
* API Changes:
+ add Filter option;
+ change GetNewValues method name to GetNewValue (GetNewValues
still works for backward compatibility);
+ change QuickTimeUTC API option to also enforce proper time
zero;
+ add MDItemTags option;
+ add RequestTags option;
+ no longer generate MDItem tags when RequestAll option is set.

==== perl-XML-XPath ====
Version update (1.21 -> 1.24)

- updated to 1.24
see /usr/share/doc/packages/perl-XML-XPath/Changes
1.24 2016-01-19 MANWAR
- Fixed issue RT# 111278 (XML::XPath::PerlSAX doesn't compile).
- updated to 1.23
see /usr/share/doc/packages/perl-XML-XPath/Changes
1.23 2016-01-18 MANWAR
- Fixed issues RT# 6363 (using < in a query returns results as if <= had been
used).
1.22 2016-01-13 MANWAR
- Fixed issues RT# 30818 and RT# 80277.

==== pinfo ====

- Add pinfo-curses-detection.patch: Fix detection of ncurses by
correctly using autoconf.

==== poppler ====
Version update (0.39.0 -> 0.40.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 libpoppler58
poppler-tools

- Update to version 0.40.0:
+ core:
- CairoOutputDev: Use shape mask with soft mask (fdo#91931).
- TextOutputDev:
. Handle right-to-left text in search
. Fix finding Arabic Presentation Forms ligatures.
- Fix crash in invalid file (fdo#93476).
- Regression test improvements.
+ utils:
- pdftocairo:
. Fix writing to stdout out with image output.
. Document that -singlefile appends file type (fdo#86254).
. Ensure surface flushed before accessing image data.
. Check for invalid use of options (fdo#92195).
- pdfunite: Fix typo in manual.
+ build system: Improve cmake build system.

==== poppler-qt ====
Version update (0.39.0 -> 0.40.0)

- Update to version 0.40.0:
+ core:
- CairoOutputDev: Use shape mask with soft mask (fdo#91931).
- TextOutputDev:
. Handle right-to-left text in search
. Fix finding Arabic Presentation Forms ligatures.
- Fix crash in invalid file (fdo#93476).
- Regression test improvements.
+ utils:
- pdftocairo:
. Fix writing to stdout out with image output.
. Document that -singlefile appends file type (fdo#86254).
. Ensure surface flushed before accessing image data.
. Check for invalid use of options (fdo#92195).
- pdfunite: Fix typo in manual.
+ build system: Improve cmake build system.

==== poppler-qt5 ====
Version update (0.39.0 -> 0.40.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.40.0:
+ core:
- CairoOutputDev: Use shape mask with soft mask (fdo#91931).
- TextOutputDev:
. Handle right-to-left text in search
. Fix finding Arabic Presentation Forms ligatures.
- Fix crash in invalid file (fdo#93476).
- Regression test improvements.
+ utils:
- pdftocairo:
. Fix writing to stdout out with image output.
. Document that -singlefile appends file type (fdo#86254).
. Ensure surface flushed before accessing image data.
. Check for invalid use of options (fdo#92195).
- pdfunite: Fix typo in manual.
+ build system: Improve cmake build system.

==== python-Unidecode ====
Version update (0.04.18 -> 0.04.19)

- update to Unidecode 0.04.19:
* Add unidecode_expect_ascii() and unidecode_expect_nonascii()
functions for performance critical applications.

==== python-ldap ====
Version update (2.4.22 -> 2.4.25)

- Update to upstream release 2.4.25

==== python-pycparser ====
Version update (2.12 -> 2.14)

- Add python-pycparser-rpmlintrc to sources
- Tag added patch better
- Update to version 2.14
* Added CParser parameter to specify output directory for generated parsing
tables (#84).
* Removed lcc's cpp and its license from the distribution. Using lcc's cpp
is no longer recommended, now that Clang has binary builds available for
Windows.
2.13:
* Added support for offsetof() the way gcc implements it (special builtin
that takes a type as an argument).
* Added faked va_* macros (these are expected to come from stdarg.h)
* Added a bunch more fake headers and typedefs to support parsing C projects
like Git and SQLite without modifications to pycparser.
* Added support for empty initializer lists (#79).
- Package fake_libc_include
* switch to github release as pypi tarball don't contains all files
- Add 0002-Add-missing-typedef-sa_family_t-from-sys-socket.h.patch
* upstream patch enhancing the fake_libc_include

==== python-six ====

- Run tests in -doc package to avoid dependency loops
* python-setuptools -> python-six -> python-py -> python-setuptools
* python-setuptools -> python-six -> python-pytest -> python-setuptools
- Actually run the tests. They weren't previously being run.

==== python3-pip ====
Version update (8.0.0 -> 8.0.2)

- specfile:
* update copyright year
- update to version 8.0.2:
* Stop attempting to trust the system CA trust store because it's
extremely common for them to be broken, often in incompatible
ways. See #3416.
- changes from version 8.0.1 (2016-01-21):
* Detect CAPaths in addition to CAFiles on platforms that provide
them.
* Installing argparse or wsgiref will no longer warn or error - pip
will allow the installation even though it may be useless (since
the installed thing will be shadowed by the standard library).
* Upgrading a distutils installed item that is installed outside of
a virtual environment, while inside of a virtual environment will
no longer warn or error.
* Fix a bug where pre-releases were showing up in pip list
- -outdated without the --pre flag.
* Switch the SOABI emulation from using RuntimeWarnings to debug
logging.
* Rollback the removal of the ability to uninstall distutils
installed items until a future date.

==== python3-setuptools ====
Version update (19.2 -> 19.4)

- update to version 19.4:
* Issue #341: Correct error in path handling of package data files
in "build_py" command when package is empty.
* Distribute #323, Issue #141, Issue #207, and Pull Request #167:
Another implementation of "pkg_resources.WorkingSet" and
"pkg_resources.Distribution" that supports replacing an extant
package with a new one, allowing for setup_requires dependencies
to supersede installed packages for the session.
- specfile:
* update copyright year
* added dependency on six
- update to version 19.3:
* Issue #229: Implement new technique for readily incorporating
dependencies conditionally from vendored copies or primary
locations. Adds a new dependency on six.

==== shadow ====

- Moved call from %verifyscript into %post:
* Caused call to %service_add_post shadow.service shadow.timer
during rpm -qV shadow

==== signon-kwallet-extension ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== skanlite ====
Version update (1.1 -> 1.1git)
Subpackages: skanlite-doc

- Update to the latest git snapshot from upstream. This contains
the rework done to make it work with KDE Frameworks. Unfortunately
this means that the lang package is gone for the moment, but at
least the program is still there as that the required libraries
are only available in a KF5 based version

==== snapper ====
Version update (0.2.9 -> 0.2.10)
Subpackages: libsnapper3 snapper-zypp-plugin

- improved error message (see bsc#956606)
- Allow rollback only for the root file system (bsc#954445)
- version 0.2.10
- added conditional compilation of installation-helper
(gh#openSUSE/snapper#202)

==== spectacle ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== sqlite3 ====
Version update (3.10.0 -> 3.10.2)
Subpackages: libsqlite3-0 libsqlite3-0-32bit sqlite3-devel sqlite3-doc

- SQlite 3.10.2:
* Fix case-folding bug introduced in 3.10.0 in the LIKE operator
* Fix a use-after-free that can occur when SQLite is compiled
with -DSQLITE_HAS_CODEC.
* Fix the build so that it works with -DSQLITE_OMIT_WAL.
- SQLite 3.10.1:
* Fix a 16-month-old bug in the query planner that could generate
incorrect results when a scalar subquery attempts to use the
block sorting optimization.
* Add SQLITE_FCNTL_JOURNAL_POINTER file control

==== sweeper ====
Version update (15.12.0 -> 15.12.1)

- Update to KDE Applications 15.12.1
* KDE Applications 15.12.1
* https://www.kde.org/announcements/announce-applications-15.12.1.php
* boo#961265

==== udhcp ====

- Cleanup a bit with spec-cleaner
- Obey rpmoptflags
- Build debug packages bnc#890844
* udhcp-do-not-strip.patch

==== xorg-x11-server ====
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk

- u_Panning-Set-panning-state-in-xf86RandR12ScreenSetSize.patch
Fix panning when configured in xorg.conf* (boo#771521).
- Handle source-file-list in build not prep
- N_xorg-x11-server-rpmmacros.patch:
Delete: Process xorg-x11-server.macros in install

==== yast2-live-installer ====
Version update (3.1.4 -> 3.1.5)

- dropped unused inst client
- 3.1.5

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages