Mailinglist Archive: opensuse-factory (396 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20151209 released!
Changed packages:

==== Mesa ====
Version update (11.0.5 -> 11.0.6)
Subpackages: Mesa-32bit Mesa-devel Mesa-dri-devel Mesa-libEGL-devel
Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit
Mesa-libGLESv1_CM-devel Mesa-libGLESv1_CM1 Mesa-libGLESv2-2
Mesa-libGLESv2-devel Mesa-libglapi-devel Mesa-libglapi0 Mesa-libglapi0-32bit
libOSMesa-devel libOSMesa9 libOSMesa9-32bit libgbm-devel libgbm1 libgbm1-32bit
libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libwayland-egl-devel libwayland-egl1 libxatracker2

- Update to version 11.0.6:
+ This release brings driver fixes for i965, r600, radeonsi,
nouveau, vc4, and llvmpipe including a serious regression for
r100/r200 era hardware.
+ Additional patches cover glsl, nir, mesa/meta and VC-1
decoding.

==== MozillaThunderbird ====
Version update (38.3.0 -> 38.4.0)
Subpackages: MozillaThunderbird-translations-common

- update to Thunderbird 38.4.0 (bnc#952810)
* MFSA 2015-116/CVE-2015-4513/CVE-2015-4514
Miscellaneous memory safety hazards
* MFSA 2015-122/CVE-2015-7188 (bmo#1199430)
Trailing whitespace in IP address hostnames can bypass same-origin policy
* MFSA 2015-123/CVE-2015-7189 (bmo#1205900)
Buffer overflow during image interactions in canvas
* MFSA 2015-127/CVE-2015-7193 (bmo#1210302)
CORS preflight is bypassed when non-standard Content-Type headers
are received
* MFSA 2015-128/CVE-2015-7194 (bmo#1211262)
Memory corruption in libjar through zip files
* MFSA 2015-130/CVE-2015-7196 (bmo#1140616)
JavaScript garbage collection crash with Java applet
* MFSA 2015-131/CVE-2015-7198/CVE-2015-7199/CVE-2015-7200
(bmo#1188010, bmo#1204061, bmo#1204155)
Vulnerabilities found through code inspection
* MFSA 2015-132/CVE-2015-7197 (bmo#1204269)
Mixed content WebSocket policy bypass through workers
* MFSA 2015-133/CVE-2015-7181/CVE-2015-7182/CVE-2015-7183
(bmo#1202868, bmo#1205157)
NSS and NSPR memory corruption issues
(fixed in mozilla-nspr and mozilla-nss packages)
- requires NSPR 4.10.10 and NSS 3.19.2.1
- added explicit appdata provides (bnc#952325)

==== alsa-plugins ====
Subpackages: alsa-plugins-32bit alsa-plugins-pulse alsa-plugins-pulse-32bit

- Add supplements to 32bit packages to be fetched automatically
(bsc#956402)

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- systemd: Set TasksMax=infinity for current systemd releases.
The default limit of 512 is too small and prevents the creation of
new server processes. Apache has its own runtime/harcoded limits.
- fix crash when for -X
+ httpd-2.4.17-debug-crash.patch
- add a note: FollowSymLinks or SymLinksIfOwnerMatch is neccessary
for RewriteRule in given dir [bnc#955701]

==== appstream-glib ====
Version update (0.5.2 -> 0.5.4)
Subpackages: libappstream-builder8 libappstream-glib8

- Update to version 0.5.4:
+ New Features: Add as_utils_version_from_uint16().
+ Bugfixes: Generate GUID values according to RFC4122.
- Add pkgconfig(uuid) BuildRequires: New dependency.

==== aria2 ====
Version update (1.19.2 -> 1.19.3)
Subpackages: aria2-lang

- Update to 1.19.3
* Fix bug that pause/unpause seeding torrent prevents new
downloads from starting
* Add --bt-enable-hook-after-hash-check option
* Add --socket-recv-buffer-size option
* Set the maximum socket receive buffer in bytes. Specifing 0
will disable this option. This value will be set to socket file
descriptor using SO_RCVBUF socket option with setsockopt() call.
* Disable --deferred-input when --save-session is used together
* base32: decode lowercased characters as well
* Send the last error message as part of tellStatus RPC response
* Don't enable mmap if file allocation is disabled
* Evict timed out pooled socket periodically
* Don't write control file if content is not changed from
previous one
* Remove content-length and content-range if transfer-encoding
is given
* Retry after 404 status if --max-file-not-found > 0
- Build shared library

==== atril ====
Version update (1.12.0 -> 1.12.1)
Subpackages: atril-backends atril-lang libatrildocument3 libatrilview3

- Update to 1.12.1:
* [dvi] Fix crash due to regression.
* Update translations.

==== boost-devel ====
Subpackages: boost-license1_59_0 libboost_atomic1_59_0 libboost_chrono1_59_0
libboost_container1_59_0 libboost_context1_59_0 libboost_coroutine1_59_0
libboost_date_time1_59_0 libboost_filesystem1_59_0 libboost_graph1_59_0
libboost_graph_parallel1_59_0 libboost_iostreams1_59_0 libboost_locale1_59_0
libboost_log1_59_0 libboost_math1_59_0 libboost_mpi1_59_0
libboost_program_options1_59_0 libboost_python1_59_0 libboost_random1_59_0
libboost_regex1_59_0 libboost_serialization1_59_0 libboost_signals1_59_0
libboost_system1_59_0 libboost_test1_59_0 libboost_thread1_59_0
libboost_timer1_59_0 libboost_wave1_59_0

- coroutine2 depends on context, disable it if context is not built

==== gtk2-metatheme-breeze ====
Version update (0.1~git20150827 -> 5.4.95)
Subpackages: gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.4.95.
- Change upstream project to https://projects.kde.org/breeze-gtk.
- Add cmake, extra-cmake-modules, gcc-c++, kf5-filesystem and
pkgconfig(Qt5Core) to build dependences.
- Add kconf_update to metatheme-breeze-common and make it
architecture-dependent.

==== bridge-utils ====

- Cleanup with spec-cleaner
- Remove the /sbin/ link, it should not be needed.
Lets see what breaks, people should migrate to bridge anwyay

==== calligra ====
Version update (2.9.8 -> 2.9.9)
Subpackages: calligra-doc calligra-extras-dolphin calligra-extras-okular
calligra-stage calligra-words-common

- Update to 2.9.9
* Bugfix release, for more details please see
https://www.calligra.org/news/calligra-2-9-9-released/

==== libchromaprint0 ====

- Use pkgconfig for ffmpeg BuildRequires

==== clamav ====
Version update (0.98.7 -> 0.99)

- Update to version 0.99
* Processing of YARA rules(some limitations- see signatures.pdf).
* Support in ClamAV logical signatures for many of the features
added for YARA, such as Perl Compatible Regular Expressions,
alternate strings, and YARA string attributes. See signatures.pdf
for full details.
* New and improved on-access scanning for Linux. See the recent blog
post and clamdoc.pdf for details on the new on-access capabilities.
* A new ClamAV API callback function that is invoked when a virus
is found. This is intended primarily for applications running in
all-match mode. Any applications using all-match mode must use
the new callback function to record and report detected viruses.
* Configurable default password list to attempt zip file decryption.
* TIFF file support.
* Upgrade Windows pthread library to 2.9.1.
* A new signature target type for designating signatures to run
against files with unknown file types.
* Improved fidelity of the "data loss prevention" heuristic
algorithm. Code supplied by Bill Parker.
* Support for LZMA decompression within Adobe Flash files.
* Support for MSO attachments within Microsoft Office 2003 XML files.
* A new sigtool option(--ascii-normalize) allowing signature authors
to more easily generate normalized versions of ascii files.
* Windows installation directories changed from \Program Files\Sourcefire\
ClamAV to \Program Files\ClamAV or \Program Files\ClamAV-x64.
- Refactor a little the specfile; remove some obsolete conditional
macros, as clamav doesn't build for SLE11 anyway
- Remove clamav-sles9.patch; sles9 is not supported for a while

==== curl ====
Version update (7.45.0 -> 7.46.0)
Subpackages: libcurl-devel libcurl4

- Update to 7.46.0
* Added CURLOPT_STREAM_DEPENDS
* Added CURLOPT_STREAM_DEPENDS_E
* Added CURLOPT_STREAM_WEIGHT
* Added CURLFORM_CONTENTLEN
* oauth2: Added support for OAUTHBEARER SASL mechanism to IMAP,
POP3 and SNMP
* Many bugfixes, see http://curl.haxx.se/changes.html#7_46_0 for the
complete list.

==== libsocks0 ====

- Add dante-miniupnp14.patch to fix compilation with miniupnpc
API level 14.

==== dbus-1-devel ====
Version update (1.8.20 -> 1.10.6)
Subpackages: libdbus-1-3 libdbus-1-3-32bit

- Update to 1.10.6
* Fixes:
- On Unix when running tests as root, don't assert that root
and the dbus-daemon user can still call
UpdateActivationEnvironment; assert that those privileged
users can call BecomeMonitor instead (fdo#93036, Simon
McVittie)
- On Windows, fix a memory leak in the autolaunch transport
(fdo#92899, Simon McVittie)
- On Windows Autotools builds, don't run tests that rely on
dbus-run-session and other Unix-specifics (fdo#92899, Simon
McVittie)
- Update to 1.10.4
* Changes between 1.10.2 and 1.10.4
- Enhancements:
+ GetConnectionCredentials, GetConnectionUnixUser and
GetConnectionUnixProcessID with argument
"org.freedesktop.DBus" will now return details of the
dbus-daemon itself. This is required to be able to call
SetEnvironment on systemd. (fdo#92857, Jan Alexander
Steffens)
- Fixes:
+ Make UpdateActivationEnvironment always fail with
AccessDenied on the system bus. Previously, it was
possible to configure it so root could call it, but the
environment variables were not actually used, because the
launch helper would discard them. (fdo#92857, Jan Alexander
Steffens)
+ On Unix with --systemd-activation on a user bus, make
UpdateActivationEnvironment pass on its arguments to
systemd's SetEnvironment method, solving inconsistency
between the environments used for traditional activation
and systemd user-service activation. (fdo#92857, Jan
Alexander Steffens)
+ On Windows, don't crash if <syslog/> or --syslog is used
(fdo#92538, Ralf Habacker)
+ On Windows, fix a memory leak when setting a DBusError from
a Windows error (fdo#92721, Ralf Habacker)
+ On Windows, don't go into infinite recursion if we abort the
process with backtraces enabled (fdo#92721, Ralf Habacker)
+ Fix various failing tests, variously on Windows and
cross-platform:
. don't test system.conf features (users, groups) that only
make sense on the system bus, which is not supported on
Windows
. don't call _dbus_warn() when we skip a test, since it is
fatal
. fix computation of expected <standard_session_servicedirs/>
. when running TAP tests, translate newlines to Unix format,
fixing cross-compiled tests under Wine on Linux
. don't stress-test refcounting under Wine, where it's
really slow
. stop assuming that a message looped-back to the test will
be received immediately
. skip some system bus tests on Windows since they make no
sense there (fdo#92538, fdo#92721; Ralf Habacker, Simon
McVittie)
* Changes between 1.10.0 and 1.10.2
- Fixes:
+ Correct error handling for activation: if there are multiple
attempts to activate the same service and it fails
immediately, the first attempt would get the correct reply,
but the rest would time out. We now send the same error
reply to each attempt. (fdo#92200, Simon McVittie)
+ If BecomeMonitor is called with a syntactically invalid
match rule, don't crash with an assertion failure, fixing a
regression in 1.9.10. This was not exploitable as a denial
of service, because the check for a privileged user is done
first. (fdo#92298, Simon McVittie)
+ On Linux with --enable-user-session, add the bus address to
the environment of systemd services for better backwards
compatibility (fdo#92612, Jan Alexander Steffens)
+ On Windows, fix the logic for replacing the installation
prefix in service files' Exec lines (fdo#83539; Milan Crha,
Simon McVittie)
+ On Windows, if installed in the conventional layout with
${prefix}/etc and ${prefix}/share, use relative paths
between bus configuration files to allow the tree to be
relocated (fdo#92028, Simon McVittie)
+ Make more of the regression tests pass in Windows builds
(fdo#92538, Simon McVittie)
* Summary of major changes since 1.8.0:
- The basic setup for the well-known system and session buses is
now done in read-only files in ${datadir} (normally /usr/share).
- AppArmor integration has been merged, with features similar to
the pre-existing SELinux integration. It is mostly compatible
with the patches previously shipped by Ubuntu, with one
significant change: Ubuntu's GetConnectionAppArmorSecurityContext
method has been superseded by GetConnectionCredentials and was
not included.
- The --enable-user-session configure option can be enabled
by OS integrators intending to use systemd to provide a
session bus per user (in effect, treating all concurrent
graphical and non-graphical login sessions as one large session).
- The new listenable address mode "unix:runtime=yes" listens on
$XDG_RUNTIME_DIR/bus, the same AF_UNIX socket used by the
systemd user session. libdbus and "dbus-launch --autolaunch"
will connect to this address by default. GLib >= 2.45.3 and
sd-bus >= 209 have a matching default.
- All executables are now dynamically linked to libdbus-1.
Previously, some executables, most notably dbus-daemon, were
statically linked to a specially-compiled variant of libdbus.
This results in various private functions in the _dbus
namespace being exposed by the shared library. These are not
API, and must not be used outside the dbus source tree.
- On platforms with ELF symbol versioning, all public symbols
are versioned LIBDBUS_1_3.
* New bus APIs:
- org.freedesktop.DBus.GetConnectionCredentials returns
LinuxSecurityLabel where supported
- org.freedesktop.DBus.Monitoring interface (privileged)
. BecomeMonitor method supersedes match rules with eavesdrop=true,
which are now deprecated
- org.freedesktop.DBus.Stats interface (semi-privileged)
. now enabled by default
. new GetAllMatchRules method
- org.freedesktop.DBus.Verbose interface (not normally compiled)
. toggles the effect of DBUS_VERBOSE
* New executables:
- dbus-test-tool
- dbus-update-activation-environment
* New optional dependencies:
- The systemd: pseudo-transport requires libsystemd or libsd-daemon
- Complete documentation requires Ducktype and yelp-tools
- Full test coverage requires GLib 2.36 and PyGI
- AppArmor integration requires libapparmor and optionally libaudit
* Dependencies removed:
- dbus-glib

==== dbus-1 ====
Version update (1.8.20 -> 1.10.6)
Subpackages: dbus-1-x11

- Update to 1.10.6
* Fixes:
- On Unix when running tests as root, don't assert that root
and the dbus-daemon user can still call
UpdateActivationEnvironment; assert that those privileged
users can call BecomeMonitor instead (fdo#93036, Simon
McVittie)
- On Windows, fix a memory leak in the autolaunch transport
(fdo#92899, Simon McVittie)
- On Windows Autotools builds, don't run tests that rely on
dbus-run-session and other Unix-specifics (fdo#92899, Simon
McVittie)
- Update to 1.10.4
* Changes between 1.10.2 and 1.10.4
- Enhancements:
+ GetConnectionCredentials, GetConnectionUnixUser and
GetConnectionUnixProcessID with argument
"org.freedesktop.DBus" will now return details of the
dbus-daemon itself. This is required to be able to call
SetEnvironment on systemd. (fdo#92857, Jan Alexander
Steffens)
- Fixes:
+ Make UpdateActivationEnvironment always fail with
AccessDenied on the system bus. Previously, it was
possible to configure it so root could call it, but the
environment variables were not actually used, because the
launch helper would discard them. (fdo#92857, Jan Alexander
Steffens)
+ On Unix with --systemd-activation on a user bus, make
UpdateActivationEnvironment pass on its arguments to
systemd's SetEnvironment method, solving inconsistency
between the environments used for traditional activation
and systemd user-service activation. (fdo#92857, Jan
Alexander Steffens)
+ On Windows, don't crash if <syslog/> or --syslog is used
(fdo#92538, Ralf Habacker)
+ On Windows, fix a memory leak when setting a DBusError from
a Windows error (fdo#92721, Ralf Habacker)
+ On Windows, don't go into infinite recursion if we abort the
process with backtraces enabled (fdo#92721, Ralf Habacker)
+ Fix various failing tests, variously on Windows and
cross-platform:
. don't test system.conf features (users, groups) that only
make sense on the system bus, which is not supported on
Windows
. don't call _dbus_warn() when we skip a test, since it is
fatal
. fix computation of expected <standard_session_servicedirs/>
. when running TAP tests, translate newlines to Unix format,
fixing cross-compiled tests under Wine on Linux
. don't stress-test refcounting under Wine, where it's
really slow
. stop assuming that a message looped-back to the test will
be received immediately
. skip some system bus tests on Windows since they make no
sense there (fdo#92538, fdo#92721; Ralf Habacker, Simon
McVittie)
* Changes between 1.10.0 and 1.10.2
- Fixes:
+ Correct error handling for activation: if there are multiple
attempts to activate the same service and it fails
immediately, the first attempt would get the correct reply,
but the rest would time out. We now send the same error
reply to each attempt. (fdo#92200, Simon McVittie)
+ If BecomeMonitor is called with a syntactically invalid
match rule, don't crash with an assertion failure, fixing a
regression in 1.9.10. This was not exploitable as a denial
of service, because the check for a privileged user is done
first. (fdo#92298, Simon McVittie)
+ On Linux with --enable-user-session, add the bus address to
the environment of systemd services for better backwards
compatibility (fdo#92612, Jan Alexander Steffens)
+ On Windows, fix the logic for replacing the installation
prefix in service files' Exec lines (fdo#83539; Milan Crha,
Simon McVittie)
+ On Windows, if installed in the conventional layout with
${prefix}/etc and ${prefix}/share, use relative paths
between bus configuration files to allow the tree to be
relocated (fdo#92028, Simon McVittie)
+ Make more of the regression tests pass in Windows builds
(fdo#92538, Simon McVittie)
* Summary of major changes since 1.8.0:
- The basic setup for the well-known system and session buses is
now done in read-only files in ${datadir} (normally /usr/share).
- AppArmor integration has been merged, with features similar to
the pre-existing SELinux integration. It is mostly compatible
with the patches previously shipped by Ubuntu, with one
significant change: Ubuntu's GetConnectionAppArmorSecurityContext
method has been superseded by GetConnectionCredentials and was
not included.
- The --enable-user-session configure option can be enabled
by OS integrators intending to use systemd to provide a
session bus per user (in effect, treating all concurrent
graphical and non-graphical login sessions as one large session).
- The new listenable address mode "unix:runtime=yes" listens on
$XDG_RUNTIME_DIR/bus, the same AF_UNIX socket used by the
systemd user session. libdbus and "dbus-launch --autolaunch"
will connect to this address by default. GLib >= 2.45.3 and
sd-bus >= 209 have a matching default.
- All executables are now dynamically linked to libdbus-1.
Previously, some executables, most notably dbus-daemon, were
statically linked to a specially-compiled variant of libdbus.
This results in various private functions in the _dbus
namespace being exposed by the shared library. These are not
API, and must not be used outside the dbus source tree.
- On platforms with ELF symbol versioning, all public symbols
are versioned LIBDBUS_1_3.
* New bus APIs:
- org.freedesktop.DBus.GetConnectionCredentials returns
LinuxSecurityLabel where supported
- org.freedesktop.DBus.Monitoring interface (privileged)
. BecomeMonitor method supersedes match rules with eavesdrop=true,
which are now deprecated
- org.freedesktop.DBus.Stats interface (semi-privileged)
. now enabled by default
. new GetAllMatchRules method
- org.freedesktop.DBus.Verbose interface (not normally compiled)
. toggles the effect of DBUS_VERBOSE
* New executables:
- dbus-test-tool
- dbus-update-activation-environment
* New optional dependencies:
- The systemd: pseudo-transport requires libsystemd or libsd-daemon
- Complete documentation requires Ducktype and yelp-tools
- Full test coverage requires GLib 2.36 and PyGI
- AppArmor integration requires libapparmor and optionally libaudit
* Dependencies removed:
- dbus-glib

==== libexempi-devel ====
Subpackages: libexempi3

- Add gpg signature
- Cleanup spec file with spec-cleaner

==== filesystem ====

- own /usr/share/licenses to support %license tags in rpm, see
http://rpm.org/wiki/Releases/4.11.0

==== libfluidsynth1 ====

- Add baselibs.conf as a source file
- Added jackmulti.diff to fix inverse logic of audio.jack.multi option
- Added reverb_mixer.diff to workaround reverb issue,
see: http://sourceforge.net/p/fluidsynth/tickets/137/

==== libfolks-data ====
Version update (0.11.1 -> 0.11.2)
Subpackages: libfolks-eds25 libfolks-telepathy25 libfolks-tracker25 libfolks25

- Update to version 0.11.2:
+ Various EDS unit test fixes, improvements and simplifications.
+ Improve Telepathy error handling on connection failure of a CM
to avoid timeouts.
+ Bugs fixed: bgo#751044.
+ Updated translations.

==== freeipmi ====
Version update (1.4.10 -> 1.5.1)

- Update to 1.5.1
o Update Intel Node Manager support for 3.0 specification.
- Update API and fiid templates in libfreeipmi.
- Support new OEM SEL events
- Update ipmi-oem commands.
- Support new get/set-turbo-synchronization-ratio
- Support new 'policypowerdomain' option in
get-node-manager-capabilities and set-node-manager-policy.
- Update output of get-node-manager-policy and
get-node-manager-capabilities for changes.
- get/set-node-manager-alert-thresholds converted to
get/set-node-manager-policy-alert-thresholds. Legacy
commands still supported.
o Update libfreeipmi for IPMI 2.0 Errata 7.
- Support/handle FRU Multirecord NVM Express type.
o Support Get Device SDR Info, Get Device SDR, and Reserve
Device SDR Repository commands in libfreeipmi.
o Support ipmi-sel OEM interpretation of Linux kernel panics.
o Re-organize OEM header files into per-vendor files.
o In ipmi-oem, fix error in "DNS Register BMC" output in
"get-dns-config" output in Inventec, Quanta, and Wistron vendor
sections.
o Support systemd through --with-systemdsystemunitdir configure
option.
o Minor corner case bug fixes.
- Update to 1.4.11
o Fix logic error with a few OEM SEL events for Intel E5 2600 V3
motherboard.
o Fix various logic errors in ipmi-oem Intel Node Manager extensions.
o Documentation updates.

==== gfxboot ====
Version update (4.5.11 -> 4.5.12)
Subpackages: gfxboot-devel

- fix booting from submenu (bsc#957893)
- 4.5.12

==== gimp ====
Version update (2.8.14 -> 2.8.16)
Subpackages: gimp-help-browser gimp-plugin-aa gimp-plugins-python libgimp-2_0-0
libgimpui-2_0-0

- Explcitly declare the libgimp version in Requires, so upgrades
bring in the updated libraries as well. Makes the upgrade from
2.8.x > 2.8.16 seamless and avoids an error on start.
- update to version 2.8.16
- fix a couple of rpmlint warnings
+Core:
- Seek much less when writing XCF
- Don't seek past the end of the file when writing XCF
- Windows: call SetDLLDirectory() for less DLL hell
- Fix velocity parameter on .GIH brushes
- Fix brokenness while transforming certain sets of linked layers
+GUI:
- Always show image tabs in single window mode
- Fix switching of dock tabs by DND hovering
- Don't make the scroll area for tags too small
- Fixed a crash in the save dialog
- Fix issue where ruler updates made things very slow on Windows
+Plug-ins:
- Fix several issues in the BMP plug-in
- Make Gfig work with the new brush size behavior again
- Fix font export in the PDF plug-in
- Support layer groups in OpenRaster files
- Fix loading of PSD files with layer groups
+ General:
- OSX build system fixes
- Bug fixes
- Translation updates

==== glib2-devel ====
Version update (2.46.1 -> 2.46.2)
Subpackages: glib2-tools libgio-2_0-0 libgio-2_0-0-32bit libglib-2_0-0
libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit libgobject-2_0-0
libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Update to version 2.46.2:
+ Varioius small fixes, with a focus on win32.
+ The docs should now be complete when doing non-srcdir builds.
+ Bugs fixed: bgo#687223, bgo#754983, bgo#754994, bgo#755609,
bgo#756179, bgo#756382, bgo#757628.

==== gnome-disk-utility ====
Version update (3.18.2 -> 3.18.3.1)

- Update to version 3.18.3.1:
+ Fix the --restore-disk-image option.

==== gpg2 ====
Version update (2.1.9 -> 2.1.10)

- GnuPG 2.1.10 adds TOFU (Trust-On-First-USe) and anonymous key
retrival via Tor.
* gpg: New trust models "tofu" and "tofu+pgp".
* gpg: New command --tofu-policy. New options --tofu-default-policy
and --tofu-db-format.
* gpg: New option --weak-digest to specify hash algorithms which
should be considered weak.
* gpg: Allow the use of multiple --default-key options; take the last
available key.
* gpg: New option --encrypt-to-default-key.
* gpg: New option --unwrap to only strip the encryption layer.
* gpg: New option --only-sign-text-ids to exclude photo IDs from key
signing.
* gpg: Check for ambigious or non-matching key specification in the
config file or given to --encrypt-to.
* gpg: Show the used card reader with --card-status.
* gpg: Print export statistics and an EXPORTED status line.
* gpg: Allow selecting subkeys by keyid in --edit-key.
* gpg: Allow updating the expiration time of multiple subkeys at
once.
* dirmngr: New option --use-tor. For full support this requires
libassuan version 2.4.2 and a patched version of libadns
(e.g. adns-1.4-g10-7 as used by the standard Windows installer).
* dirmngr: New option --nameserver to specify the nameserver used in
Tor mode.
* dirmngr: Keyservers may again be specified by IP address.
* dirmngr: Fixed problems in resolving keyserver pools.
* dirmngr: Fixed handling of premature termination of TLS streams so
that large numbers of keys can be refreshed via hkps.
* gpg: Fixed a regression in --locate-key [since 2.1.9].
* gpg: Fixed another bug for keyrings with legacy keys.
* gpgsm: Allow combinations of usage flags in --gen-key.
* Make tilde expansion work with most options.
* Many other cleanups and bug fixes.

==== grep ====

- testsuite.patch: also disable long-pattern-perf test

==== gstreamer-plugins-bad ====
Subpackages: libgstadaptivedemux-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
libgstwayland-1_0-0

- Add pkgconfig(libssh2) BuildRequires: Build ssh support.
- Add libcurl.so to BUILD_ORIG file list for openSUSE 13.1 only,
as packman builds against Update where a new enough version is
provided.

==== gstreamer-plugins-ugly ====

- Add conditional for patch1, touching configure.ac with this patch
breaks BUILD_ORIG building.

==== install-initrd-openSUSE ====
Version update (14.208 -> 14.210)

- added all i2c drivers (bsc#954101)
- 14.210
- adjust text menu message
- add 'boot installed system' boot option
- rework boot menus to hide advanced stuff in a submenu
- add 'boot from hard disk' entry to efi boot menu
- 14.209

==== iptables ====
Version update (1.4.21 -> 1.6.0~)
Subpackages: libiptc0 xtables-plugins

- Update to new snapshot v1.4.21-367-g9763347 [1.6.0~]
* -m ah/esp/rt: restore matching "any SPI id" by default
(they unexpectedly defaulted to --spi 0 rather than --spi ALL)
* -m cgroup: new module
* -m dst: make ! --dst-len work
* -m ipcomp: new module
* -m socket: add --restore-skmark option
* -j CT: add support for new zone options
* -j REJECT: add missing ICMPv6 codes
* -j TEE: make it possible to delete rules with -D ... -j
* -j SNAT/DNAT: add randomize-full support

==== kdevelop4 ====
Version update (4.7.1 -> 4.7.2)
Subpackages: kdevelop4-devel kdevelop4-lang kdevelop4-plugin-cppsupport

- Update to 4.7.2
* No upstream changelog provided
* Bugfix release
- Drop Do-not-use-function-returning-reference-to-temporary.patch,
included upstream

==== kdevelop4-plugins-php ====
Version update (1.7.1 -> 1.7.2)

- Update to 1.7.2
* No upstream changelog available
* Bugfix release
- Bump libkdevplatform-devel BuildRequires to 1.7.2

==== kdevplatform ====
Version update (1.7.1 -> 1.7.2)
Subpackages: kdevplatform-lang libkdevplatform-devel libkdevplatform8

- Update to 1.7.2
* No upstream changelog provided
* Bugfix release
- Drop make-subversion-plugin-compile-with-subversion-1.9.patch,
included upstream

==== kio ====
Subpackages: kio-core kio-devel

- Added register-dbus-name-for-kioexec.patch: prevent klauncher
from freezing and displaying an error message when opening
documents (boo#924764, kde#353037)

==== kiwi ====
Version update (7.03.34 -> 7.03.37)
Subpackages: kiwi-desc-isoboot kiwi-desc-netboot kiwi-desc-oemboot
kiwi-desc-vmxboot kiwi-doc kiwi-media-requires kiwi-pxeboot kiwi-templates
kiwi-tools

- v7.03.37 released
- Update suse-leap-42.1-JeOS
Use ext4 as write filesystem in overlayfs, btrfs is broken
for this use case (bnc#950999)
- Allow ext4 to be set in hybridpersistent_filesystem
- v7.03.36 released
- fix appdata generation on product builds with multiple media
- v7.03.35 released
- Retrieve vm tools version from vmtoolsd
- Deleted __checkMountDependencies runtime check
I'm afraid but this check causes more false positives than the
correct detection of an inconsistency in the mount table. Checking
if the string 'kiwi' appears in the process list is not enough,
especially in contained environment where the host kernel shares
mount information with a VM or container guest this check is
always wrong. We need a better solution here. Fixes Issue#501
- Added Leap 42.1 support for kiwi --describe
Allow to analyse Leap Systems, fixes Issue #516
- Bundle all built OEM images
it is valid to build multiple OEM targets, e.g. with
<type ... installiso='true' installpxe='true' image='oem'> and
KIWI correctly builds an install.iso and an install.tar.xz in
this case. However, when using OBS only the install.iso is
exported. This is, because "kiwi --bundle-build" will only export
one image and return.
Change this to export all: .iso, .raw and .tar.xz
- Translated using Weblate (Dutch)
Currently translated at 82.1% (23 of 28 strings)
- Translated using Weblate (Russian)
Currently translated at 100.0% (28 of 28 strings)
[kiwi] add searching in the parent directory for the current path for device
drivers, kernel modules packages like openSUSE xen-kmp-default put the drivers
there
- Translated using Weblate (Spanish)
Currently translated at 100.0% (28 of 28 strings)
- Added vmdk descriptor update
VMWare applications are made aware that an image has vm-tools installed
via tags appended to the VMDK's metadata. Typically, the tools write
the metadata during their first run, but in our case the first run of
the tools is the first boot of the appliance, so the host application
is not aware of tools until after a VM has been rebooted, missing a
critical opportunity to configure an instance before or during the
first boot. In order to allow VMWare applications (include vCloud)
to be aware that vm-tools are installed, we need to add the appropriate
metadata to the image during its creation

==== kross ====
Subpackages: kross-devel

- Move kf5kross from -devel to main package. At least one other
package ("parley") requires it. A normal application package
should not require a -devel package.

==== libass5 ====
Version update (0.12.3 -> 0.13.0)

- Update to 0.13.0
* Add native font selection backends for OSX (CoreText) and
Windows (DirectWrite). You can now run libass without
fontconfig on these platforms. This fixes problems with
fontconfig behaving badly on these platforms (it could take
minutes to scan all system fonts). Even on Linux, this speeds
up loading of embedded fonts (such as provided by
ass_add_font()). The DirectWrite backend only works on Windows
Vista and later. On XP, fontconfig is still needed. libass can
be compiled with both DirectWrite and fontconfig, and then it
will fallback to fontconfig automatically if DirectWrite is not
available at runtime.
* Add ass_get_available_font_providers() API function.
* Change the 4th parameter of ass_set_fonts(). This now selects
the font provider. This is somewhat backwards compatible with
the old behavior, but if you ever passed values other than 0
or 1, your application might break with this libass release.
* The ass_fonts_update() function now does nothing. It's kept
for backward compatibility only.
* Much faster gaussian blur. This can bring a large speedup with
big blurred signs and such.
* Drop ENCA support
* Bug fixes
+ Fix compilation of the freetype rasterizer (disabled by
default)
+ Fix rendering with some cases of consecutive line breaks
(\N\N).
+ Fix some memory allocation failure checks
+ Avoid system locale dependent behavior by reinventing some
standard C functions
+ Fix rendering errors with strikes (GH #193)
+ MSVC compilation fixes
- Enable harfbuzz and yasm build requires

==== libassuan-devel ====
Version update (2.4.0 -> 2.4.2)
Subpackages: libassuan0

- libassuan 2.4.2:
* The nPth version of the connect system hook does now wrap the
call with npth_unprotec/npth_protect to avoid blocking during a
connect.
* Add feature to assuan_sock_connect_byname to test for SOCKS5
availability.
- libassuan 2.4.1:
* In Tor mode fallback to port 9150 if 9050 is not listening.

==== libbluray1 ====
Version update (0.9.1 -> 0.9.2)

- Update to version 0.9.2:
+ Add primary audio stream to bd_select_stream().
+ Improve error resilience.
+ Fix Java 8 compability issues.
+ Fix Android build.
+ Fix SecurityException in AWTAutoShutdown.
+ Fix BD-J check when install path in Windows contains
non-ASCII chars.
+ Fix jvm.dll loading in Windows ($JAVA_HOME/bin should be in
dll load path).
+ Fix class translating in recent Java 8 versions.
- Fixed patches libbluray-autotools.patch and libbluray-jvm_dir.patch.

==== libgit2-23 ====
Version update (0.23.3 -> 0.23.4)

- libgit2 0.23.4:
* various bug fixes and improvements
- drop upstreamed libgit2-fix-.pc-file.patch

==== libkexiv2-11 ====
Subpackages: libkexiv2-devel

- Require exiv2 version 0.25 as upstream strongly recommendeds it
since 0.24 has "bad bugs". Make an exception in SLE12, where
we only require 0.23, as that's the only available version.
- Added patch: fix-reduce-required-exiv2-to-0.23.diff that reduces
the required exiv2 version in cmake.

==== libmetalink3 ====
Version update (0.1.2 -> 0.1.3)

- Update to version 0.1.3
* This release fixes the bug that signature element in metalink v4
was not parsed correctly.
- Update libmetalink-autotools.patch
- Use download Url as source
- Perform a spec-cleaner
- Build with libxml2 and cunit support

==== libpng12-0 ====
Version update (1.2.54 -> 1.2.55)
Subpackages: libpng12-0-32bit libpng12-devel

- updated to 1.2.55:
Avoid potential pointer overflow in png_handle_iTXt(), png_handle_zTXt(),
png_handle_sPLT(), and png_handle_pCAL() (Bug report by John Regehr).
Fixed incorrect implementation of png_set_PLTE() that uses png_ptr
not info_ptr, that left png_set_PLTE() open to the CVE-2015-8126
vulnerability.

==== libpng16-16 ====
Version update (1.6.19 -> 1.6.20)
Subpackages: libpng16-16-32bit libpng16-compat-devel libpng16-devel

- update to 1.6.20:
Avoid potential pointer overflow/underflow in png_handle_sPLT() and
png_handle_pCAL() (Bug report by John Regehr).
Fixed incorrect implementation of png_set_PLTE() that uses png_ptr
not info_ptr, that left png_set_PLTE() open to the CVE-2015-8126
vulnerability.
Backported tests from libpng-1.7.0beta69.
Fixed an error in handling of bad zlib CMINFO field in pngfix, found by
American Fuzzy Lop, reported by Brian Carpenter. inflate() doesn't
immediately fault a bad CMINFO field; instead a 'too far back' error
happens later (at least some times). pngfix failed to limit CMINFO to
the allowed values but then assumed that window_bits was in range,
triggering an assert. The bug is mostly harmless; the PNG file cannot
be fixed.
In libpng 1.6 zlib initialization was changed to use the window size
in the zlib stream, not a fixed value. This causes some invalid images,
where CINFO is too large, to display 'correctly' if the rest of the
data is valid. This provides a workaround for zlib versions where the
error arises (ones that support the API change to use the window size
in the stream).

==== libpsl0 ====

- fix SLE 11 build:
* adding 0001-Remove-include-of-bits-stat.h.patch
* skip IDN feature
- update descriptions and categories

==== libraw-devel ====
Version update (0.17.0 -> 0.17.1)
Subpackages: libraw15

- updated to 1.17.1:
* fixed two errors found by fuzzer (CVE-2015-8367)
* phase_one_correct always returns value; handle P1 return codes
in postprocessing
- removed upstreamedretval.diff

==== gdk-pixbuf-loader-rsvg ====
Version update (2.40.11 -> 2.40.12)
Subpackages: librsvg-2-2 librsvg-devel typelib-1_0-Rsvg-2_0

- Update to version 2.40.12:
+ Refactoring of the test harness to use Glib's gtest
infrastructure, instead of using home-grown machinery. Tests
can simply be put as SVG files in the tests/subdirectories; it
is not necessary to list them explicitly in some text file.
+ Gzipped SVGs now work if read from streams.
+ References to objects/filters/URIs/etc. are now handled lazily.
Also, there is a general-purpose cycle detector so malformed
SVGs don't cause infinite loops.
+ Removed parsing of Adobe blend modes; they were not
implemented, anyway.
+ Bugs fixed: bgo#700911, bgo#630732, bgo#677068.

==== libthai-data ====
Version update (0.1.23 -> 0.1.24)
Subpackages: libthai0 libthai0-32bit

- Update to version 0.1.24:
+ Fix infinite loop caused by optimization in previous version.
(deb#805703).
+ Updated word break dictionary.

==== libuv1 ====

- Make building more verbose

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen

- Run udevadm settle after removing NICs in lxc driver.
bsc#829033. lxc-wait-after-eth-del.patch

==== libyui-qt-pkg7 ====
Version update (2.45.5 -> 2.45.6)

- Respect /etc/zypp/zypp.conf settings for options "Allow vendor
change" and "Cleanup when deleting packages" (bsc#954117)
- 2.45.6

==== libmysqlclient-devel ====
Version update (10.0.21 -> 10.0.22)
Subpackages: libmysqlclient18 libmysqlclient18-32bit libmysqlclient_r18
libmysqld18 mariadb mariadb-client mariadb-errormessages

- update to 10.0.22
* Release notes:
https://kb.askmonty.org/en/mariadb-10022-release-notes/
* Changelog:
https://kb.askmonty.org/en/mariadb-10022-changelog/
* fixed CVEs:
CVE-2015-4802, CVE-2015-4807, CVE-2015-4815, CVE-2015-4826
CVE-2015-4830, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861
CVE-2015-4870, CVE-2015-4913, CVE-2015-4792
* remove the following patches (applied upstream)
* mysql-community-server-5.6.12-srv_buf_size.patch
* mariadb-10.0.16-header_files_const_warnings.patch
- add mariadb-10.0.21-mysql-test_main_bootstrap.patch that fix
main.bootstrap test (change default charset to utf8 in test
result) [bnc#937787]
- add mariadb-10.0.22-fix_build_denabled_profiling_off.patch to
fix compilation with '-DENABLED_PROFILING=OFF'

==== libmozjs-17_0 ====

- Disable pagesize check unconditionally to cover also ppc64

==== libmutter0 ====
Version update (3.18.1 -> 3.18.2)
Subpackages: mutter mutter-data typelib-1_0-Meta-3_0

- Update to version 3.18.2:
+ Misc. crash fixes (bgo#756675, bgo#756660, bgo#757148,
bgo#756796).
+ Fix modifiers-only input source switching on Ubuntu.
+ Exit cleanly on initialization errors (bgo#757311).
+ Updated translations.

==== nano ====
Version update (2.4.3 -> 2.5.0)
Subpackages: nano-lang

- Update to 2.5.0
* color synax highlighting improvements
* several bugfixes
* since this release there will no longer be separate stable and
unstable branches

==== nbd ====
Version update (3.11 -> 3.12.1)
Subpackages: nbd-doc

- Update to version 3.12.1
* ensures the source to the "nbdtab" man page is correctly shipped
with the rest of the source.
- Changes from version 3.12
* inetd mode should work again, now using the default export name
in the newstyle protocol
* when specifying an export on the server command line or not specifying
a name on a client command line, the newstyle protocol is used with
the default export name (but a warning will be produced stating
that oldstyle is no longer supported)
* All traces of oldstyle (except a few error messages) have been
removed
* We now listen on IPv4 and IPv6 by default, regardless of what
the system's configuration is like, by explicitly listening both
on 0.0.0.0 and ::.
* Some bugs in the handling of the TRIM command have been removed
* nbd *client now uses readit() in the negotiation, rather than
plain non *retrying read().
* It is now possible to listen on multiple addresses; the
"listenaddr" parameter has been changed into a comma *separated
list of addresses to listen on
* nbd *client now supports an nbdtab file, which allows connecting
a device by just using the device name
* nbd *server now uses a GThreadPool to implement asynchronous handling
of requests
* Punching holes on files is now supported on cygwin, too.
- Remove no-return-nonvoid.patch; fixed on upstream release

==== nfs-client ====
Subpackages: nfs-doc nfs-kernel-server

- nfs-utils-uninit-mem.patch: fix use of uninitialized memory (bsc#956743)

==== openldap2 ====

- Introduce patch 0010-Revert-Revert-ITS-8240-remove-obsolete-assert.patch
to fix CVE-2015-6908. (bsc#945582)
- Introduce patch 0011-Enforce-minimum-DH-size-of-1024.patch
to address weak DH size vulnerability (bsc#937766)
- Introduce patch 0009-Fix-ldap-host-lookup-ipv6.patch
to fix an issue with unresponsive LDAP host lookups in IPv6 environment.
(bsc#955210)

==== libldap-2_4-2 ====
Subpackages: libldap-2_4-2-32bit openldap2-client openldap2-devel

- Introduce patch 0010-Revert-Revert-ITS-8240-remove-obsolete-assert.patch
to fix CVE-2015-6908. (bsc#945582)
- Introduce patch 0011-Enforce-minimum-DH-size-of-1024.patch
to address weak DH size vulnerability (bsc#937766)
- Introduce patch 0009-Fix-ldap-host-lookup-ipv6.patch
to fix an issue with unresponsive LDAP host lookups in IPv6 environment.
(bsc#955210)

==== openmpi-libs ====
Version update (1.8.3 -> 1.8.8)

- Really do remove openmpi-external_libltdl.patch.
- updated to 1.8.8
- remove unneeded patch4 openmpi-external_libltdl.patch
- update files list
- list of changes since 1.8.3
1.8.8
-----
- Fix a segfault in MPI_FINALIZE with the PSM MTL.
- Fix mpi_f08 sentinels (e.g., MPI_STATUS_IGNORE) handling.
- Set some additional MXM default values for OSHMEM.
- Fix an invalid memory access in MPI_MRECV and MPI_IMRECV.
- Include two fixes that were mistakenly left out of the official
v1.8.7 tarball:
- Fixed MPI_WIN_POST and MPI_WIN_START for zero-size messages
- Protect the OOB TCP ports from segfaulting when accessed by
port scanners
1.8.7
----
* * NOTE: v1.8.7 technically breaks ABI with prior versions
* * in the 1.8 series because it repairs two incorrect API
* * signatures. However, users will only need to recompile
* * if they were using those functions - which they couldn't
* * have been, because the signatures were wrong :-)
- Plugged a memory leak that impacted blocking sends
- Fixed incorrect declaration for MPI_T_pvar_get_index and added
missing return code MPI_T_INVALID_NAME.
- Fixed an uninitialized variable in PMI2 support
- Added new vendor part id for Mellanox ConnectX4-LX
- Fixed NBC_Copy for legitimate zero-size messages
- Fixed MPI_Win_post and MPI_Win_start for zero-size messages
- Protect the OOB ports from segfaulting when accessed by port
scanners
- Fixed several Fortran typos
- Fixed configure detection of XRC support
- Fixed support for highly heterogeneous systems to avoid
memory corruption when printing out the bindings
1.8.6
-----
- Fixed memory leak on Mac OS-X exposed by TCP keepalive
- Fixed keepalive support to ensure that daemon/node failure
results in complete job cleanup
- Update Java binding support
- Fixed MPI_THREAD_MULTIPLE bug in vader shared memory BTL
- Fixed issue during shutdown when CUDA initialization wasn't
complete
- Fixed orted environment when no prefix given
- Fixed trivial typo in MPI_Neighbor_allgather manpage
- Fixed tree-spawn support for sh and ksh shells
- Several data type fixes
- Fixed IPv6 support bug
- Cleaned up an unlikely build issue
- Fixed PMI2 process map parsing for cyclic mappings
- Fixed memalign threshold in openib BTL
- Fixed debugger access to message queues for blocking send/recv
1.8.5
-----
- Fixed configure problems in some cases when using an external
hwloc installation. Thanks to Erick Schnetter for reporting the
error and helping track down the source of the problem.
- Fixed linker error on OS X when using the clang compiler.
Thanks to Erick Schnetter for reporting the error and helping
track down the source of the problem.
- Fixed MPI_THREAD_MULTIPLE deadlock error in the vader BTL.
Thanks to Thomas Klimpel for reporting the issue.
- Fixed several Valgrind warnings. Thanks for Lisandro Dalcin for
contributing a patch fixing some one-sided code paths.
- Fixed version compatibility test in OOB that broke ABI within the
1.8 series. NOTE: this will not resolve the problem between
pre-1.8.5 versions, but will fix it going forward.
- Fix some issues related to running on Intel Xeon Phi
coprocessors.
- Opportunistically switch away from using GNU Libtool's libltdl
library when possible (by default).
- Fix some VampirTrace errors. Thanks to Paul Hargrove for
reporting the issues.
- Correct default binding patterns when --use-hwthread-cpus was
specified and nprocs <= 2.
- Fix warnings about -finline-functions when compiling with clang.
- Updated the embedded hwloc with several bug fixes, including the
"duplicate Lhwloc1 symbol" that multiple users reported on some
platforms.
- Do not error when mpirun is invoked with with default bindings
(i.e., no binding was specified), and one or more nodes do not
support bindings. Thanks to Annu Desari for pointing out the
problem.
- Let root invoke "mpirun --version" to check the version without
printing the "Don't run as root!" warnings. Thanks to Robert
McLay for the suggestion.
- Fixed several bugs in OpenSHMEM support.
- Extended vader shared memory support to 32-bit architectures.
- Fix handling of very large datatypes. Thanks to Bogdan Sataric
for the bug report.
- Fixed a bug in handling subarray MPI datatypes, and a bug when
using MPI_LB and MPI_UB. Thanks to Gus Correa for pointing out
the issue.
- Restore user-settable bandwidth and latency PML MCA variables.
- Multiple bug fixes for cleanup during MPI_FINALIZE in unusual
situations.
- Added support for TCP keepalive signals to ensure timely
termination when sockets between daemons cannot be created
(e.g., due to a firewall).
- Added MCA parameter to allow full use of a SLURM allocation when
started from a tool (supports LLNL debugger).
- Fixed several bugs in the configure logic for PMI and hwloc.
- Fixed incorrect interface index in TCP communications setup.
Thanks to Mark Kettenis for spotting the problem and providing
a patch.
- Fixed MPI_IREDUCE_SCATTER with single-process communicators when
MPI_IN_PLACE was not used.
- Added XRC support for OFED v3.12 and higher.
- Various updates and bug fixes to the Mellanox hcoll collective
support.
- Fix problems with Fortran compilers that did not support
REAL*16/COMPLEX*32 types. Thanks to Orion Poplawski for
identifying the issue.
- Fixed problem with rpath/runpath support in pkg-config files.
Thanks to Christoph Junghans for notifying us of the issue.
- Man page fixes:
- Removed erroneous "color" discussion from MPI_COMM_SPLIT_TYPE.
Thanks to Erick Schnetter for spotting the outdated text.
- Fixed prototypes for MPI_IBARRIER. Thanks to Maximilian for
finding the issue.
- Updated docs about buffer usage in non-blocking communications.
Thanks to Alexander Pozdneev for citing the outdated text.
- Added documentation about the 'ompi_unique' MPI_Info key with
MPI_PUBLISH_NAME.
- Fixed typo in MPI_INTERCOMM_MERGE. Thanks to Harald Servat for
noticing and sending a patch.
- Updated configure paths in HACKING.
Thanks to Maximilien Levesque for the fix.
- Fixed Fortran typo in MPI_WIN_LOCK_ALL. Thanks to Thomas Jahns
for pointing out the issue.
- Fixed a number of MPI one-sided bugs.
- Fixed MPI_COMM_SPAWN when invoked from a singleton job.
- Fixed a number of minor issues with CUDA support, including
registering of shared memory and supporting reduction support for
GPU buffers.
- Improved support for building OMPI on Cray platforms.
- Fixed performance regression introduced by the inadvertent
default enabling of MPI_THREAD_MULTIPLE support.
1.8.4
-----
- Fix MPI_SIZEOF; now available in mpif.h for modern Fortran
compilers (see README for more details). Also fixed various
compiler/linker errors.
- Fixed inadvertant Fortran ABI break between v1.8.1 and v1.8.2 in
the mpi interface module when compiled with gfortran >= v4.9.
- Fix various MPI_THREAD_MULTIPLE issues in the TCP BTL.
- mpirun no longer requires the --hetero-nodes switch; it will
automatically detect when running in heterogeneous scenarios.
- Update LSF support, to include revamped affinity functionality.
- Update embedded hwloc to v1.9.1.
- Fixed max registerable memory computation in the openib BTL.
- Updated error message when debuggers are unable to find various
symbols/types to be more clear. Thanks to Dave Love for raising
the issue.
- Added proper support for LSF and PBS/Torque libraries in static
builds.
- Rankfiles now support physical processor IDs.
- Fixed potential hang in MPI_ABORT.
- Fixed problems with the PSM MTL and "re-connect" scenarios,
such as MPI_INTERCOMM_CREATE.
- Fix MPI_IREDUCE_SCATTER with a single process.
- Fix (rare) race condition in stdout/stderr funneling to mpirun
where some trailing output could get lost when a process
terminated.
- Removed inadvertent change that set --enable-mpi-thread-multiple
"on" by default, thus impacting performance for non-threaded
apps.
- Significantly reduced startup time by optimizing internal hash
table implementation.
- Fixed OS X linking with the Fortran mpi module when used with
gfortran >= 4.9. Thanks to Github user yafshar for raising the
issue.
- Fixed memory leak on Cygwin platforms. Thanks for Marco Atzer
for reporting the issue.
- Fixed seg fault in neighborhood collectives when the degree of
the topology is higher than the communicator size. Thanks to
Lisandro Dalcin for reporting the issue.
- Fixed segfault in neighborhood collectives under certain use-cases.
- Fixed various issues regarding Solaris support. Thanks to Siegmar
Gross for patiently identifying all the issues.
- Fixed PMI configure tests for certain Slurm installation patterns.
- Fixed param registration issue in Java bindings. Thanks to
Takahiro Kawashima and Siegmar Gross for identifying the issue.
- Several man page fixes.
- Silence several warnings and close some memory leaks (more
remain, but it's better than it was).
- Re-enabled the use of CMA and knem in the shared memory BTL.
- Updated mpirun manpage to correctly explain new map/rank/binding
options. Fixed MPI_IALLGATHER problem with intercommunicators.
Thanks for Takahiro Kawashima for the patch.
- Numerous updates and performance improvements to OpenSHMEM.
- Turned off message coalescing in the openib BTL until a proper
fixfor that capability can be provided (tentatively expected
for 1.8.5)
- Fix a bug in iof output that dates back to the dinosaurs which
would output extra bytes if the system was very heavily loaded
- Fix a bug where specifying mca_component_show_load_errors=0
could cause ompi_info to segfault
- Updated valgrind suppression file

==== libopus0 ====
Version update (1.1 -> 1.1.1)

- Update to version 1.1.1:
+ x86 SSE, SSE2 and SSE4.1 intrinsics optimizations with run-time
CPU detection.
+ MIPS intrinsics optimizations.
+ ARM Neon optimizations.
+ Many architecture-independent optimizations and memory
footprint reductions that should improve performance on all
platforms, and several minor bug fixes.
- Pass --enable-intrinsics to configure.

==== patterns-openSUSE-apparmor ====
Subpackages: patterns-openSUSE-apparmor_opt patterns-openSUSE-base
patterns-openSUSE-books patterns-openSUSE-console patterns-openSUSE-devel_C_C++
patterns-openSUSE-devel_basis patterns-openSUSE-devel_gnome
patterns-openSUSE-devel_ide patterns-openSUSE-devel_java
patterns-openSUSE-devel_kde patterns-openSUSE-devel_kde_frameworks
patterns-openSUSE-devel_kernel patterns-openSUSE-devel_perl
patterns-openSUSE-devel_python patterns-openSUSE-devel_qt4
patterns-openSUSE-devel_qt5 patterns-openSUSE-devel_rpm_build
patterns-openSUSE-devel_ruby patterns-openSUSE-devel_web
patterns-openSUSE-dhcp_dns_server patterns-openSUSE-directory_server
patterns-openSUSE-enhanced_base patterns-openSUSE-enhanced_base_opt
patterns-openSUSE-file_server patterns-openSUSE-fonts
patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns-openSUSE-gnome_games patte
rns-openSUSE-gnome_ide patterns-openSUSE-gnome_imaging
patterns-openSUSE-gnome_imaging_opt patterns-openSUSE-gnome_internet
patterns-openSUSE-gnome_laptop patterns-openSUSE-gnome_multimedia
patterns-openSUSE-gnome_multimedia_opt patterns-openSUSE-gnome_office
patterns-openSUSE-gnome_office_opt patterns-openSUSE-gnome_utilities
patterns-openSUSE-gnome_yast patterns-openSUSE-imaging
patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_laptop
patterns-openSUSE-lxde_office patterns-openSUSE-mail_serv
er patterns-openSUSE-minimal_base patterns-openSUSE-minimal_base-conflicts
patterns-openSUSE-misc_server patterns-openSUSE-multimedia
patterns-openSUSE-multimedia_opt patterns-openSUSE-network_admin
patterns-openSUSE-non_oss patterns-openSUSE-non_oss_opt
patterns-openSUSE-office patterns-openSUSE-office_opt
patterns-openSUSE-print_server patterns-openSUSE-remote_desktop
patterns-openSUSE-rest_dvd patterns-openSUSE-sw_management
patterns-openSUSE-sw_management_gnome patterns-openSUSE-sw_management_kde
patterns-openSUSE-tabletpc patterns-openSUSE-technical_writing
patterns-openSUSE-x11 patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- Update GNOME patterns:
+ gnome_imaging_opt: Drop xsane, GNOME already includes
simple-scan serving the same purpose.
+ gnome_internet:
- Drop gftp, gwibber, smuxi, xchat-gnome.
- Replace pan by evolution-rss.
+ gnome_utilities: Drop conduit, kerneloops-applet, pdfmod,
synapse, tasque and the-board.

==== libpcre1 ====
Version update (8.37 -> 8.38)
Subpackages: libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0 pcre-devel
pcre-doc pcre-tools

- pcre 8.38:
* CVE-2015-3217: Call Stack Overflow Vulnerability in match()
bsc#933878
* Other fixes to assertions, crashes, buffer overflows and
performance issues found by fuzzer, affecting applications
accepting regular expression from untrusted sources

==== perl-Bootloader ====
Version update (0.844 -> 0.900)
Subpackages: perl-Bootloader-YAML

- make grub_installdevice parsing more robust
- continue after wrong entries in grub_install_device
- move bootloader scripts into separate subdirectories
- updated doc
- introduce separate per-bootloader scripts
- add documentation
- some minor corrections
- support --reinit option to force grub2 install
- adjust Makefile
- add new wrapper script to get rid of old perl-Bootloader code for grub2
- 0.900

==== perl-DBD-Pg ====
Version update (3.5.1 -> 3.5.3)

- update to version 3.5.3
changes with 3.5.3:
- Minor fix in the test file t/03dbmethod.t
changes with 3.5.2:
- Fix enum value ordering on Postgres servers 9.1 and greater
- Return bigint values as plain integer values when they fit
- Fix typo in sprintf for get_info() SQL_DATA_SOURCE_NAME
- Set the repository in META.yml to github

==== perl-Date-Manip ====
Version update (6.51 -> 6.52)

- updated to 6.52
see /usr/share/doc/packages/perl-Date-Manip/Changes

==== perl-ExtUtils-Depends ====
Version update (0.404 -> 0.405)

- updated to 0.405
see /usr/share/doc/packages/perl-ExtUtils-Depends/Changes
0.405
- Remove MYMETA.* from MANIFEST file; closes autogenerated RT ticket
[#108554]

==== perl-Gtk2 ====
Version update (1.2496 -> 1.2497)

- Update to 1.2497:
* Avoid a stack handling error in Gtk2::TreeModel::get on
Perl >= 5.23.
* Fix a test failure in t/GdkWindow.t; it occurs only on
GTK+ >= 2.24.26 and < 2.24.29.
- Remove perl-Gtk2-fix-test-failure.patch: fixed upstream.

==== perl-Tie-Simple ====
Version update (1.03 -> 1.04)

- updated to 1.04
see /usr/share/doc/packages/perl-Tie-Simple/Changes
1.04 2015-11-28 11:23:48-06:00 America/Chicago
* Re-established a public git repository.
* Cleaned up the repo and switched to Dist::Zilla for development support.
* [RT#108096] The EXTEND method is no longer available for tied arrays.
(HT: Slaven Rezic for the fix / Dave Mitchell for finding the problem /
ANDK for reporting it)
* Fixed a type in the DESTROY method in Tie::Simple::Handle

==== libpolkit0 ====
Subpackages: polkit polkit-devel typelib-1_0-Polkit-1_0

- polkit-revert-session-magic.patch: revert a session detection change
that could lead to sessions not being detected as active due to
a systemd bug. bsc#954139

==== python-M2Crypto ====
Version update (0.22.3 -> 0.22.5)

- fix SSLv2 link error for 13.2 and Leap 42.1
(M2Crypto-0.22.5-SSLv2_link_error.patch)
- update to 0.22.5, fix URL
- drop python-M2Crypto-SWIG-3.0.5.patch (functionality included upstream)
- SLE12 requires swig3 for a successful build, too

==== rpcbind ====

- Add 0002-revert-auth.patch: revert old patch no longer working
with libtirpc 1.0.1
(http://sourceforge.net/p/libtirpc/mailman/message/34585439/)
- Add 099-poll.patch: use libtirpc with poll() implementation

==== libdcerpc-binding0 ====
Version update (4.3.1 -> 4.3.2)
Subpackages: libdcerpc-binding0-32bit libdcerpc0 libdcerpc0-32bit libgensec0
libgensec0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libregistry0 libsamba-credentials0
libsamba-credentials0-32bit libsamba-hostconfig0 libsamba-hostconfig0-32bit
libsamba-passdb0 libsamba-passdb0-32bit libsamba-util0 libsamba-util0-32bit
libsamdb0 libsamdb0-32bit libsmbclient-devel libsmbclient-raw0
libsmbclient-raw0-32bit libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap0
libsmbldap0-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba samba-32bit samba-client samba-client-32bit samba-doc
samba-libs samba-libs-32bit samba-winbind samba-winbind-32bit

- Update to 4.3.2.
+ vfs_gpfs: Re-enable share modes; (bso#11243).
+ dcerpc.idl: Accept invalid dcerpc_bind_nak pdus; (bso#11327).
+ s3-smbd: Fix old DOS client doing wildcard delete - gives an attribute
type of zero; (bso#11452).
+ Add libreplace dependency to texpect, fixes a linking error on Solaris;
(bso#11511).
+ s4: Fix linking of 'smbtorture' on Solaris; (bso#11512).
+ s4:lib/messaging: Use correct path for names.tdb; (bso#11562).
+ Fix segfault of 'net ads (join|leave) -S INVALID' with nss_wins;
(bso#11563).
+ async_req: Fix non-blocking connect(); (bso#11564).
+ auth: gensec: Fix a memory leak; (bso#11565).
+ lib: util: Make non-critical message a warning; (bso#11566).
+ Fix winbindd crashes with samlogon for trusted domain user; (bso#11569).
+ smbd: Send SMB2 oplock breaks unencrypted; (bso#11570).
+ ctdb: Open the RO tracking db with perms 0600 instead of 0000; (bso#11577).
+ s3:smb2_server: Make the logic of SMB2_CANCEL DLIST_REMOVE() clearer;
(bso#11581).
+ s3-smbd: Fix use after issue in smbd_smb2_request_dispatch(); (bso#11581).
+ manpage: Correct small typo error; (bso#11584).
+ s3: smbd: If EAs are turned off on a share don't allow an SMB2 create
containing them; (bso#11589).
+ Backport some valgrind fixes from upstream master; (bso#11597).
+ auth: Consistent handling of well-known alias as primary gid; (bso#11608).
+ winbind: Fix crash on invalid idmap configs; (bso#11612).
+ s3: smbd: have_file_open_below() fails to enumerate open files below an
open directory handle; (bso#11615).
+ Changing log level of two entries to DBG_NOTICE; (bso#9912).

==== shim ====

- acquired updated signature from Microsoft
- Add shim-bsc950569-fix-cryptlib-va-functions.patch to fix the
definition of va functions to avoid the potential crash
(bsc#950569)
- Update shim-opensuse-cert-prompt.patch to avoid setting NULL to
MokListRT (bsc#950801)
- Drop shim-fix-mokmanager-sections.patch as we are using the
newer binutils now
- Refresh shim-change-debug-file-path.patch

==== perl-Mail-SpamAssassin ====
Subpackages: spamassassin

- change default spampd settings to properly support IPv6 and allow larger SPAM

==== squid ====
Version update (3.5.10 -> 4.0.3)

- Update to 4.0.3
* Bug 4372: missing template files
* Bug 4371: compile errors: no such file or directory:
DiskIO/*/*DiskIOModule.o
* Bug 4368: A simpler and more robust HTTP request line parser
* Fix compile erorr on clang undefined reference to
'__atomic_load_8'
* ext_kerberos_ldap_group_acl: Add missing workarounds for
Heimdal Kerberos
* ext_ldap_group_acl: Allow unlimited LDAP search filter
* ext_unix_group_acl: Support -r parameter to strip @REALM from
usernames
* ... and much code cleanup and polishing
* ... and all fixes from squid 3.5.11
- Changes for squid-4.0.2
* Regression Bug 4351: compile errors when authentication modules
disabled
* Regression fix: HTTP/1.1 Transfer-Encoding:chunked parsing
* Bug 4359: assertion failure 'Comm::IsConnOpen(conn)' within
ConnStateData::requestTimeout
* Bug 4356: segmentation fault using proxy_auth ACL
* Bug 4352: compile errors in OS X 10.11
* Bug 4021: ext_user_regex does exact match
* Bug 3574: avoid crashes, prohibit reconfiguration during
shutdown
* Support re-assigning delay pools based on HTTP reply details
* ... and all fixes from squid 3.5.11
- fixes for boo#956989
- updated pretrans scriptlet so it handles only rpm link vs folders issue
- pre scriptlet updated to not change configuration file without real need
for configuration updates
- update to 4.0.1
* Bug 4329: GCC 5.2 no known conversion for argument
* Bug 4292: negotiate_wrapper: Unreleased Resources
* Bug 4269: ignore-must-revalidate broken
* Bug 4190: assertion 'hash_remove_link' from Auth::User::cacheCleanup
* Bug 3920: Splay::remove() reference counting inconsistent
* Bug 3069: CONNECT method bytes sent logging
* Bug 2741 partial: libsecurity API for GnuTLS support
* Bug 1961 partial: redesign of URL handling
* Fix crash when parsing invalid squid.conf
* Fix eCAP: Return 'unknown body size' for bodies with unknown body sizes
* Remove unused OS detection: Sun, SysV, Ultrix, BSDi
* Remove cache_peer_domain directive
* RFC 6176 compliance: Remove SSLv2 support
* HTTP/1.1: Remove refresh_pattern ignore-auth and ignore-must-revalidate
* Remove GCC 2.x and 3.x detection and support
* C++11 compiler support is now mandatory
* Enable flexible transport protocol
* Enable long (--foo) command line parameters on squid binary
* Add per-rule refresh_pattern matching statistics
* Replace sslversion=N with tls-min-version=1.N
* Replace sslproxy_* directives with tls_outgoing_options
* Replace GNU atomics and related hacks with C++11 std::atomic
* Replace external_acl_type format %macros with logformat codes
* Support Ephemeral Elliptic Curve Diffie-Hellman (EECDH) key exchange
* Support Secure ICAP services
* Support rotate=N option on access_log
* Support bypass for non-HTTP intercepted traffic (on_unsupported_protocol)
* Support lifetime timeout for persistent connections (pconn_lifetime)
* Support timeout for URL-rewrite helper lookups (url_rewrite_timeout)
* Support logging fast things (nanosecond log resolution)
* Support ICAP/eCAP adaptation for 100-continue responses
* Support configurable helper queue size, with consistent defaults
and better overflow handling.
* Support named service PID file by default (pid_filename)
* url_lfs_rewrite: Add URL-rewriter based on local file existence
* negotiate_kerberos_auth: output group= kv-pair
* helper-mux: add man(8) page
* purge: convert README to man(1) page
* basic_msnt_multi_domain_auth: Superceeded by basic_smb_lm_auth
* basic_sspi_auth: fix MinGW compile errors
* negotiate_sspi_auth: fix various build errors
* Crypto-NG: libnettle Base64 algorithm support
* Parser-NG: HTTP Parser structural redesign
* libltdl: copyright updated to LGPL version 2.1
* ... and several performance optimizations
* ... and many documentation changes
* ... and much code cleanup and polishing
- fix dependency (C++11)
* gcc >= 4.7
- rebase squid-config.patch
- rebase and fix squid-brokenad.patch

==== susehelp ====
Subpackages: susehelp_cz susehelp_de susehelp_en susehelp_es susehelp_fr
susehelp_hu susehelp_it

- Add susehelp-use-apache2.patch: Update old "apache" references
to "apache2" which is the current name used (bnc#936061).

==== libtracker-common-1_0 ====
Version update (1.6.0 -> 1.6.1)
Subpackages: libtracker-control-1_0-0 libtracker-miner-1_0-0
libtracker-sparql-1_0-0 tracker tracker-devel tracker-miner-files
typelib-1_0-Tracker-1_0 typelib-1_0-TrackerControl-1_0
typelib-1_0-TrackerMiner-1_0

- Update to version 1.6.1:
+ tracker tool: Fixes to UID detection.
+ libtracker-miner:
- Fix cancellation of tasks during TrackerFileNotifier
destruction.
- Handle failure to get a TrackerSparqlConnection.
+ libtracker-common: Fix buffer overrun in libunistring-based
unaccenting.
+ libtracker-control: Documentation fixes.
+ tracker-extract: Photo orientation extraction fixes (TIFF,
XMP).
+ Many fixes to functional tests.
+ Updated translations.

==== nautilus-extension-tracker-tags ====
Version update (1.6.0 -> 1.6.1)
Subpackages: tracker-gui

- Update to version 1.6.1:
+ tracker tool: Fixes to UID detection.
+ libtracker-miner:
- Fix cancellation of tasks during TrackerFileNotifier
destruction.
- Handle failure to get a TrackerSparqlConnection.
+ libtracker-common: Fix buffer overrun in libunistring-based
unaccenting.
+ libtracker-control: Documentation fixes.
+ tracker-extract: Photo orientation extraction fixes (TIFF,
XMP).
+ Many fixes to functional tests.
+ Updated translations.

==== transmission-common ====
Subpackages: transmission-gtk

- Add transmission-miniupnp14.patch to fix compilation with
miniupnpc API level 14

==== gvim ====
Version update (7.4.898 -> 7.4.935)
Subpackages: vim vim-data

- Updated to revision 935, fixes the following problems
* Test 94 fails on some systems.
* test_utf8 has confusing dummy command.
* Crash when using longest completion match.
- Updated to revision 930, fixes the following problems
* When a BufLeave autocommand changes folding in a way it syncs undo,
undo can be corrupted.
* Python interface can produce error "vim.message' object has no attribute
'isatty'".
* Libraries for dynamically loading interfaces can only be defined at compile
time.
* Compiler complains about type punned pointer.
* t_Ce and t_Cs are documented but not supported. (Hirohito Higashi)
* Wrong indenting for C++ constructor.
* No utf-8 support for the hangul input feature.
* New compiler warning: logical-not-parentheses
* When removing from 'path' and then adding, a comma may go missing. (Malcolm
Rowe)
* When running out of memory while copying a dict memory may be freed twice.
(ZyX)
* Compiler warning for comparing signed and unsigned.
* A digit in an option name has problems.
* The dll options are not in the options window.
* The rubydll option is not in the options window.
* Missing proto file update. (Randall W. Morris)
* Leaking memory with ":helpt {dir-not-exists}".
* Prototypes not always generated.
* User may yank or put using the register being recorded in.
* Completing the longest match doesn't work properly with multi-byte
characters.
* Ruby crashes when there is a runtime error.
* A clientserver message interrupts handling keys of a mapping.
* "gv" after paste selects one character less if 'selection' is "exclusive".
* MS-Windows: Most users appear not to like the window border.
- Refresh vim-7.3-sh_is_bash.patch

==== libjavascriptcoregtk-4_0-18 ====
Subpackages: libwebkit2gtk-4_0-37 typelib-1_0-JavaScriptCore-4_0
typelib-1_0-WebKit2-4_0 webkit2gtk-4_0-injected-bundles

- Add binutils-gold BuildRequires: Use the gold linker for build
and remove --reduce-memory-overheads from RPMOPT flags since
gold-linker does not know it.

==== whois ====
Version update (5.2.10 -> 5.2.11)

- whois 5.2.11:
* Fixed the --select-types and --sources long options.
* Updated the list of new gTLDs.
* Removed the .an TLD.
* Removed the .xn--l1acc (.???, Mongolia) TLD server.
* Added the .xn--mgbtx2b (????, Iraq) and .xn--qxam (.??, Greece)
TLD servers.

==== wine ====
Version update (1.8~rc2 -> 1.8~rc3)
Subpackages: wine-32bit

- Updated to 1.8-rc3 codefreeze snapshot
- bugfixes only
- winetricks updated

==== xfsprogs ====
Version update (4.2.0 -> 4.3.0)

- Update to 4.3.0
* xfs_fsr: improved temp file attr fork handling
* libxfs: output verifier names in warnings
* xfs_repair: enable verifier corruption warnings on very verbose
output settings
* xfs_fsr: abstract mntinfo/mntent differences
* xfs_io: reflink and dedupe operation support
* libxcmd: factoring of runtime reporting
* man page fixes
* xfs_db: blockget/blocktrash support for v5 filesystems
* xfs_repair: many directory/attr cleanups and fixes
* Log zeroing rework for v5 filesystems to prevent log sequence
numbers from going backwards
- xfsprogs-ppc64.diff: Removed since we use asm/types.h for definitions now

==== yast2-dhcp-server ====
Version update (3.1.5 -> 3.1.7)

- Adapted to latest changes in UI::ServiceStatus API (fate#318771)
- 3.1.7
- Several UI improvements and fixes, including the usage of the
new generic widget to handle the service status (fate#318771).
- 3.1.6

==== yast2-dns-server ====
Version update (3.1.17 -> 3.1.19)

- Adapted to latest changes in UI::ServiceStatus API (fate#318771)
- 3.1.19
- Use new version of the UI component for services handling
(fate#318771)
- 3.1.18

==== yast2-installation ====
Version update (3.1.163 -> 3.1.164)

- Ensure second stage and YaST-Firstboot don't get killed by
getty when running over 2nd or 3rd serial console (bsc#935965)
- 3.1.164
- Do not crash in proposal client if zfcp proposal reports itself
as unavailable (bnc#956745)

==== yast2-ruby-bindings ====
Version update (3.1.41 -> 3.1.42)

- Reverted the last change because it broke updating the table in
Service Manager
(because the distinction between :cell and :Cell was lost)
(bnc#956380)
- 3.1.42

==== yast2-storage ====
Version update (3.1.72 -> 3.1.73)

- Revert previous patch for bsc#949683 (adding _netdev is not
needed any longer because the problem is fixed in systemd)
- 3.1.73

==== zsh ====
Version update (5.1.1 -> 5.2)

- Update to version 5.2
* The new module zsh/param/private can be loaded to allow the shell
to define parameters that are private to a function scope (i.e. are
not propagated to nested functions called within this function).
* The GLOB_STAR_SHORT option allows the pattern **/* to be shortened to
just ** if no / follows. so **.c searches recursively for a file whose
name has the suffix ".c".
* The effect of the WARN_CREATE_GLOBAL option has been significantly
extended, so expect it to cause additional warning messages about
parameters created globally within function scope.




Removed packages:
conduit
> conduit-lang
dbus-sharp
dbus-sharp-glib
libstdc++6-gcc48-locale
gftp
> gftp-common
> gftp-common-lang
gconf-sharp2
libgoocanvas3
> libgoocanvas3-lang
glade-sharp2
> glib-sharp2
> gtk-sharp2
libxtables10
libtirpc1
log4net
libminiupnpc10
mono-locale-extras
notify-sharp
pan
> pan-lang
pdfmod
> pdfmod-lang
python-flickrapi
python-gdata
python-goocanvas
smuxi
> smuxi-engine
> smuxi-engine-campfire
> smuxi-engine-campfire-lang
> smuxi-engine-irc
> smuxi-engine-irc-lang
> smuxi-engine-lang
> smuxi-engine-twitter
> smuxi-engine-twitter-lang
> smuxi-engine-xmpp
> smuxi-frontend
> smuxi-frontend-gnome
> smuxi-frontend-gnome-irc
> smuxi-frontend-gnome-irc-lang
> smuxi-frontend-gnome-lang
> smuxi-frontend-gnome-twitter
> smuxi-frontend-gnome-twitter-lang
> smuxi-frontend-gnome-xmpp
> smuxi-frontend-lang
> smuxi-server
> smuxi-server-lang
synapse
> synapse-lang
tasque
> tasque-lang
vobject
xchat-gnome
> xchat-gnome-lang


Added packages:
libadns1
libaria2-0
calligra-l10n-cs
> calligra-l10n-da
> calligra-l10n-de
> calligra-l10n-de-doc
> calligra-l10n-el
> calligra-l10n-en_GB
> calligra-l10n-es
> calligra-l10n-es-doc
> calligra-l10n-fr
> calligra-l10n-fr-doc
> calligra-l10n-hu
> calligra-l10n-it
> calligra-l10n-it-doc
> calligra-l10n-ja
> calligra-l10n-pl
> calligra-l10n-pt
> calligra-l10n-pt-doc
> calligra-l10n-pt_BR
> calligra-l10n-pt_BR-doc
> calligra-l10n-ru
> calligra-l10n-ru-doc
> calligra-l10n-zh_CN
> calligra-l10n-zh_TW
evolution-plugin-rss
> evolution-plugin-rss-lang
libstdc++6-locale
libxtables11
libtirpc3
libminiupnpc15
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >