Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: [opensuse-factory] TW : multiversions of kernel-default & zypper dup
26.10.2015 22:45, Andrei Borzenkov пишет:
26.10.2015 22:33, ellanios82 пишет:

Hello List ,

this evening , zypper dup -d produces :

" The following 2 NEW packages are going to be installed:
kernel-default-4.2.3-1.4

The following package is going to be REMOVED:
kernel-default-4.2.3-1.1


in /etc/zypp/zypp.conf the following line is un-commented :

multiversion = provides:multiversion(kernel)

.........................

calling " zypper dup ' , after the TW change from kernel-desktop to
kernel-default , zypper requires the removal
of the old kernel-default when installing new kernel-default

. . . How can one have zypper dup keep multiversions ?



Multiple rebuilds of the same version cannot be installed in parallel
anyway, they overwrite each other. So only the last installed package
will be physically present. So this is a bug fix. It resulted in RPM
conflict in the past.

But now I ask myself why "zypper up" does not install it ...

10:~ # zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following NEW package is going to be installed:
kernel-default-4.2.3-1.4

The following package is going to be REMOVED:
kernel-default-4.2.3-1.1

The following package is going to be downgraded:
gnu-unifont-bitmap-fonts

1 package to downgrade, 1 new, 1 to remove.
Overall download size: 47.5 MiB. Already cached: 0 B. After the operation, 485.7
KiB will be freed.
Continue? [y/n/? shows all options] (y): n
10:~ # zypper up
Loading repository data...
Reading installed packages...

The following package update will NOT be installed:
kernel-default

Nothing to do.
10:~ #

What is the difference? Also "zypper info kernel-default" says "out of date" which is correct; why "zypper up" ignores it?
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups