Mailinglist Archive: opensuse-factory (1324 mails)

< Previous Next >
Re: [opensuse-factory] Re: ncurses spec
  • From: Tomáš Čech <sleep_walker@xxxxxxxxxxxx>
  • Date: Tue, 6 Oct 2015 13:45:52 +0200
  • Message-id: <20151006114536.GA18486@venom>
On Tue, Oct 06, 2015 at 01:18:46PM +0200, Jan Engelhardt wrote:

On Tuesday 2015-10-06 13:04, Tomáš Čech wrote:
But we already have that in 13.2 (libncurses5, libncurses6).
So - issue marked solved.
(If you meant two seaprate SRPMs, then I also go for "no",
since both are easily buildable from the single tarball.)

1] not that easily
2] when you use ncurses-devel, it won't let you choose ABI version on RPM level

Oh yeah, ncurses5-devel / ncurses6-devel sounds like a good idea.
Then again, we already have pkgconfig(ncurses{,w}{5,6}) so there is not soo
much to be gained.

1] pkgconfig(ncurses{5,6}) is natural and generated automatically, so
it would correspond ncurses{5,6}-devel

2] I'd like to drop narrow versions of libraries anyway

So actually that wouldn't be a problem.

Tomas
< Previous Next >