Mailinglist Archive: opensuse-factory (988 mails)

< Previous Next >
Re: [opensuse-factory] New Tumbleweed snapshot 20150714 released!
Hi,

2015-07-16 12:07 GMT+02:00 Ludwig Nussel <ludwig.nussel@xxxxxxx>:
Changed packages:
[...]
==== kdelibs4support ====
Version update (5.11.0 -> 5.12.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.12.0
* Fix KMimeType::Ptr::isNull implementation.
* Reenable support for KDateTime streaming to kDebug/qDebug,
for more SC
* Load correct translation catalog for kdebugdialog
* Don't skip documenting deprecated methods, so that people can
read the porting hints
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.12.0.php
[...]
==== kunitconversion-devel ====
Version update (5.11.0 -> 5.12.0)
Subpackages: libKF5UnitConversion5

- Update to 5.12.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.12.0.php
[...]

I'm trying to zypper dup from TW 20150712 to the latest one and I get
the following problems:

---- 8< ----
3 Problems:
Problem: libKF5KHtml5-lang-5.12.0-1.1.noarch requires libKF5KHtml5 =
5.12.0, but this requirement cannot be provided
Problem: kdelibs4support-lang-5.11.0-1.2.noarch requires
kdelibs4support = 5.11.0, but this requirement cannot be provided
Problem: libKF5UnitConversion5-lang-5.11.0-1.1.noarch requires
libKF5UnitConversion5 = 5.11.0, but this requirement cannot be
provided

Problem: libKF5KHtml5-lang-5.12.0-1.1.noarch requires libKF5KHtml5 =
5.12.0, but this requirement cannot be provided
uninstallable providers: libKF5KHtml5-5.12.0-1.1.i586[repo-oss]
Solution 1: keep obsolete libKF5KHtml5-lang-5.11.0-1.1.noarch
Solution 2: install libKF5KHtml5-5.12.0-1.1.i586 despite the inferior
architecture
Solution 3: break libKF5KHtml5-lang-5.12.0-1.1.noarch by ignoring some
of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):
---- 8< ----

zypper info tells me about the packages (otherwise written, the
repository they belong to is 'repo-oss':
---- 8< ----
libKF5KHtml5-lang: Version: 5.12.0-1.1; Status: out-of-date (version
5.11.0-1.1 installed)
libKF5KHtml5: Version: 5.11.0-1.1; Status: up-to-date
kdelibs4support-lang: Version: 5.11.0-1.2; Status: up-to-date;
Repository: @System
kdelibs4support: Version: 5.12.0-1.2; Status: out-of-date (version
5.11.0-1.2 installed)
libKF5UnitConversion5-lang: Version: 5.11.0-1.1; Status: up-to-date;
Repository: @System
libKF5UnitConversion5: Version: 5.12.0-1.1; Status: out-of-date
(version 5.11.0-1.1 installed)
---- 8< ----

I have the following active repositories:
---- 8< ----
Repository 'kde-applications' is up to date.
Retrieving repository 'kde-extra' metadata
.......................................................................................................................[done]
Building repository 'kde-extra' cache
............................................................................................................................[done]
Repository 'packman' is up to date.
Repository 'repo-debug' is up to date.
Repository 'repo-non-oss' is up to date.
Repository 'repo-oss' is up to date.
Repository 'repo-update' is up to date.
---- 8< ----

Has anyone seeing this? Any suggestion on how to proceed?

Thank you in advance and good night,

Fra
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups