Mailinglist Archive: opensuse-factory (988 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20150630 released!
Changed packages:

==== NetworkManager-openvpn ====
Version update (1.0.0 -> 1.0.2)
Subpackages: NetworkManager-openvpn-gnome

- Update to version 1.0.2:
+ Default to disabling periodic renegotioation. This avoids
renegotiating unnecessarily if the server doesn't specify a
renegotiation timeout, improving usability for OTP users.
+ Build fixes.
+ Updated translations.

==== SuSEfirewall2 ====
Version update (3.6.312 -> 3.6.315)

- reduce amount of setprocinfo set values, adjusted to existence and
also current kernel defaults.
- missing IPv6 commands to enable broadcast (e.g.: avahi over ipv6)
(bsc#935716)

==== WindowMaker-applets ====

- Force gnu89 inline semantics

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- dropped 2.0 -> 2.2 modules transition during upgrade
* apache-20-22-upgrade renamed to apache-22-24-upgrade
- apache-*-upgrade script is called in %posttrans now [bnc#927223]

==== apparmor-abstractions ====
Subpackages: apparmor-docs apparmor-parser apparmor-profiles apparmor-utils
libapparmor-devel libapparmor1 libapparmor1-32bit pam_apparmor
pam_apparmor-32bit perl-apparmor python3-apparmor

- systemd-rpm-macros and %systemd_requires were at the wrong place,
move them to the parser package (boo#931792)

==== arpwatch ====

- Deal with added two whitespaces in more recent oui.txt versions.
+ arpwatch-2.1a15-massagevendor.patch

==== atftp ====

- Use ATFTPD_BIND_ADDRESSES in init script (boo#921219)
- Move autoreconf back to %buils as it causes issues with quilt

==== attica-qt5-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Attica5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== bluedevil5 ====
Subpackages: bluedevil5-lang

- Added bluez-qt-5.11.patch: port to bluez-qt 5.11 changes

==== bluez-qt-devel ====
Version update (5.3.1 -> 5.11.0)
Subpackages: bluez-qt-imports bluez-qt-udev

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== boost-jam ====
Version update (201104 -> 20120824)

- Remove xz compressed archive
- Clenaup spec file with spec-cleaner
- boost-jam-codecleanup.diff was dropped
- Update to 20120824 from the boost-1.51.0 release.

==== build ====
Version update (20150317 -> 20150615)
Subpackages: build-mkbaselibs build-mkdrpms

- fixing test suite call
- support build time source services
- docker VM support
- Simple image creation support
- vc: create changelog file only in case of a change
- get hostarch based on preinstalled kernel image
- architecture CanDo updates
- avoid endless loops during in binfmt misc registration
- debian debootstrap fixes
- added support of debbuild build engine
- optional support of network inside of KVM
- allow lintian to break the build

==== bundle-lang-common-cs ====
Subpackages: bundle-lang-common-da bundle-lang-common-de bundle-lang-common-el
bundle-lang-common-en bundle-lang-common-es bundle-lang-common-fi
bundle-lang-common-fr bundle-lang-common-hu bundle-lang-common-it
bundle-lang-common-ja bundle-lang-common-pl bundle-lang-common-pt
bundle-lang-common-ru bundle-lang-common-zh

- Some lang packages have localized manuals, so don't collect them
to avoid conflicts with native lang packages

==== bundle-lang-gnome-cs ====
Subpackages: bundle-lang-gnome-da bundle-lang-gnome-de bundle-lang-gnome-el
bundle-lang-gnome-en bundle-lang-gnome-es bundle-lang-gnome-fr
bundle-lang-gnome-hu bundle-lang-gnome-it bundle-lang-gnome-ja
bundle-lang-gnome-pl bundle-lang-gnome-pt bundle-lang-gnome-ru
bundle-lang-gnome-zh

- Some lang packages have localized manuals, so don't collect them
to avoid conflicts with native lang packages

==== bundle-lang-kde-cs ====
Subpackages: bundle-lang-kde-da bundle-lang-kde-de bundle-lang-kde-el
bundle-lang-kde-en bundle-lang-kde-es bundle-lang-kde-fr bundle-lang-kde-hu
bundle-lang-kde-it bundle-lang-kde-ja bundle-lang-kde-pl bundle-lang-kde-pt
bundle-lang-kde-ru bundle-lang-kde-zh

- Some lang packages have localized manuals, so don't collect them
to avoid conflicts with native lang packages

==== libcelt0-2 ====
Version update (0.11.1 -> 0.11.3)

- Update to 0.11.3
* no upstream changelog provided
- Cleanup spec file with spec-cleaner
- Update baselibs.conf

==== libchromaprint0 ====
Version update (1.1 -> 1.2)

- Update to version 1.2
* Fixed compilation with neither libswresample nor libavresample
(#11)
* Fixed compilation with static libav (#10)
* Functions chromaprint_encode_fingerprint and
chromaprint_decode_fingerprint are changed to accept const
pointer as input
* Added support for using the Kiss FFT library (should make
Android port easier)
* Removed obsolete dev tools from the package
* More compatible DEBUG() macro
- Cleanup spec file with spec-cleaner
- Add missing dependency on boost
- Use cmake macro

==== cim-schema ====
Version update (2.43.0 -> 2.44.0)

- Upgrade to version 2.44.0
http://dmtf.org/sites/default/files/cim/cim_schema_v2440/releasenotes.html
- use spec-cleaner

==== cups ====
Subpackages: cups-client cups-devel cups-libs cups-libs-32bit

- Fix the previous commit by using direct systemd call and ensuring we
work even on older distros
- Fix postin-without-tmpfile-creation and run %tmpfiles_create
macro on our cups.conf

==== daps ====
Version update (2.0~rc6 -> 2.0)

Stable release DAPS 2.0:
- supporting rng _and_ rnc schemas for validation with jing
- added a --debug switch and error reporting to daps_autobuild
- moved a --meta related warning so it does not get displayed
when running a *-name subcommand
- fixed a quoting issue in daps-migrate and daps_functions
- fixed an error in the DB4->DB5 migration stylesheet (formatting
was lost on <term> tags)
New release DAPS 2.0~rc7
- replaced daps-auto.pl with daps_autobuild
* uses an XML file as a config file (can be validated with
schema that is also provided)
* supports git _and_ svn repos
- DB5 fix for target productinfo
- locdrop target can now read information about translated files
from in-file tag provided by docmanager
- fixed two issues in the unpack-locdrop target
- fixed stylesheet issues when using saxon as a parser
- Added missing dependency on $(RESULT_DIR) for epub
- bash code cleanup
- Changed default DB5 schema fom docbook.rng to docbookxi.rng
(supports xi:includes)
- Documentation: now covers all 2.0 changes

==== ebtables ====

- add ebtables-v2.0.10-4-audit.patch needed for CC certification
[bnc#934680]

==== efibootmgr ====
Version update (0.11.0 -> 0.12)

- Update to 0.12
* This release is mostly a maintenance release that uses
libefivar's new library API for creating device paths and load
options.
* Also DHCPv4 network boot entries are now something you can
create without knowing an awful lot about ACPI.
- Refresh patches
efibootmgr-0.11.0-derhat.diff as efibootmgr-derhat.diff
efibootmgr-0.11.0-check-boot-order.diff as
efibootmgr-check-boot-order.diff
- Update project and download url

==== libefivar0 ====
Version update (0.15 -> 0.20)

- Add efivar-fix-vars_del_variable.patch to fix the deletion of
the variable with the old efivar kernel modules
- Add efivar-revert-linker-order.patch to adjust the linker order
which caused the compilation error in pesign
- Use default CFLAGS
- Update to 0.20
* Make sure tester is build with the right link order for
libraries.
* Adjust linker order for pkg-config
* Work around LocateDevicePath() not grokking PcieRoot() devices
properly.
* Rectify some missing changelog entries
- Changes for 0.19
* Lots of debugging in this release, as well as some of the
documentation that's planned. There's more of that to come.
- Changes for 0.18
* This release is mostly about adding the efidp and libefiboot
APIs available.Next release will feature documentation for
them, verification that various different device path types
work, etc. Right now efi device path generation is basically
limited to:
+ full file paths on sata devices
+ full file paths on sas devices
+ HD() paths for SATA and SAS devices
+ ipv4 dhcp device paths that don't specify their own
filenames
- Drop upstreamed patche
* efivar-correct-license-header.patch
- Drop as Makefiles have been restructured, CFLAGS no longer
defined in them
* efivar-suse-build.patch
- Use fdupes to reduce amount of duplicate files

==== epiphany ====
Version update (3.16.1 -> 3.16.2)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.16.2:
+ Fix regressions in the form filler (bgo#750842).
+ Other code fixes and minor improvements.
+ Updated translations.

==== libexiv2-devel ====
Version update (0.24 -> 0.25)

- readd parallel-build-dep.patch
- Update to version 0.25
* exivsimple has array index errors when stripping quotes form
trivial input strings
* Use SVN eol-style LF on all files
* Access violation on IptcData::operator[] when key is invalid
* PNG images with tiff tags throw exceptions
* Plasma kde crashes when specific jpeg is on the Desktop
* TIFF parser,Binary array elements should be decoded using the
Makernote's endianness, not that of the image
* Coverity scan : Issue CID 981992 , 981993
* Wrong key name in output of addmodel sample
* Printing tags does not honor multi-byte label widths correctly
* Wrong ApertureValue written
* pyexiv2 fails on cifs shares on an Ubuntu client
* TIFF parser,Parse TIFF PageNumber
* Add new sample applications exifdata and exivvalue
* Add option -K Key (--key Key) to specify one or more keys to
output
* "exiv2 -eX" followed by "exiv2 -iX" produces invalid XMP
metadata packet
* Sony NEX Lens Information
* Handle Pentax makernotes in samsung-rebranded cameras
* Olympus XZ-1 FocusDistance incorrect
* Support Panasonic Makernote
* detection of Pentax DA 35/2.4 lens
* Canon EOS M EF-M lenses
* Lens matching on Canon
* Tamron 18-270 is not detected anymore
* Wrong aperture for Tamron 70-300?
* Recognize Samsung NX 10mm Fisheye
* Pentax/Sigma 24-70mm F2.8 IF EX DG HSM data
* See also http://www.exiv2.org/changelog.html
- Dropped the following upstreamed patches:
* fix-overflow-in-info-tags-r3264.patch
* fix-video-timescale-handling.patch
* parallel-build-dep.patch
* fix-parallel-build.patch
- Switch to cmake build system: there are various code snips that
use variables that are only defined in the cmake build system
(e.g. src/utils.cpp uses EXV_HAVE_UNISTD_H to include unistd.h,
which is not done with configure. With gcc5 this results now in
a failure, as unistd.h is no longer implicit).
- Add exiv2-cmake-libsuffix.patch: Install the library to lib64 on
the respective archs.

==== extra-cmake-modules ====
Version update (5.10.0 -> 5.11.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.11.0
* New arguments for ecm_add_tests(). (kde#345797)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== frameworkintegration-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.11.0
* Use the correct initialDirectory for the KDirSelectDialog
* Make sure the scheme is specified when overriding the start
url value
* Only accept existing directories in FileMode::Directory mode
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== cpp ====
Version update (4.8 -> 5)
Subpackages: gcc gcc-c++ gcc-fortran gcc-gij gcc-info gcc-java gcc-objc
libgcj-devel libstdc++-devel

- Properly query gcc-%gcc_suffix for paths.
- Fix bogus requires to gcc5-c++-{32,64}bit.
- Adjust for GCC 5 package renames.
- Switch gcc to default 5.
- Add gcc-go{,-32bit,-64bit} packages.

==== libatomic1 ====
Version update (4.8.3+r218481 -> 5.1.1+r224716)
Subpackages: libgcc_s1 libgcc_s1-32bit libgfortran3 libgomp1 libitm1 libobjc4
libquadmath0 libstdc++6 libstdc++6-32bit libtsan0

- Update to gcc-5-branch head (r224716).
- Fix libffi include install. [bnc#935510]
- Package new mwaitxintrin.h file.
- Update to gcc-5-branch head (r224257).
- Fix build against SLE11 SP4.
* Where mpfr 2.4.0 is not available disable the few features
requiring it to allow building with mpfr 2.3.2,
gcc48-remove-mpfr-2.4.0-requirement.patch.
* Disable building the MPX library.
* Re-instantiate IA64 support.
* Add gcc5-no-return-gcc43-workaround.patch to avoid bogus warnings
from the GCC 4.3 host compiler.
- Update to gcc-5-branch head (r223279).
* Includes fix for [bnc#930496] and [bnc#930392].
- Enable 32bit code generation for ppc64le but do not build 32bit
target libraries. Fixes ppc64le kernel compile.
- Update to gcc-5-branch head (r222900).
- Add proper dependences to -32bit/-64bit compiler variants. Add
gcc5-c++-32/64bit and gcc5-obj-c++-32/64bit (for their dependencies
only).
- Rename libstdc++5-devel to libstdc++6-devel-gcc5 following shared
library suffixing (but applying always).
- Likewise for libgcj devel and jar packages and for libffi.
- Renames libgcj and libffi spec files.
- Update to gcc-5-branch head (r222451).
* Includes GCC 5.1.0 release and first chunk of bugfixes and powerpc
backports.
- Enable building libmpx for i586 and x86_64.
- Update to gcc-5-branch head (r222226).
* Includes GCC 5.1 RC2.
- Update to gcc-5-branch head (r222139).
- Update to gcc-5-branch head (r222032).
* Matches GCC 5.1 RC1.
- Update to SVN trunk head (r221942).
- Prepare for non-icecream cross-compilers
* Define sysroot to match cross-binutils config
* Prepare for requiring cross-newlib for some targets
* Use all-host target for libc bootstrap, too
* Install target files, but suppress stripping them (breaks them)
* Suppress -icecream-backend subpackage
* Allow building on any architecture
- Update to SVN trunk head (r221888).
- Enable cross compiler builds.
- libsanitizer-tsan-res-state.patch: remove obsolete patch.
- gcc5-libsanitize-aarch64-va42.patch: support aarch64 42-bit address
- space
- Update to SVN trunk head (r221624).
- Require own ada version for suse_version > 1330, not explicitely
gcc49-ada.
- Amend _constraints to request more physical memory for gcc5 and
gcc5-testresults as well as 4 processors for gcc5.
- Update to SVN trunk head (r221515).
- Update to SVN trunk head (r221482).
* Fixes miscompile of vim.
- Update to SVN trunk head (r221322).
* Contains fixes for PR65120 and should reduce the amount of
false -Wlogical-not-parentheses warnings.
- Switch to release checking builds.
- Update to SVN trunk head (r221139).
* Includes gcc5-pr65040.patch which is now removed.
- Add libsanitizer-tsan-res-state.patch to fix build with new glibc.
- Enable asan and ubsan for ppc64le.
- Add gcc5-pr65040.patch to remove -Wformat-signedness from -Wformat=2.
- Renumber patches.
- Update to SVN trunk head (r220959).
- Update to SVN trunk head (r220833).
- Update to SVN trunk head (r220758).
- Update to SVN trunk head (r220678).
- Update to SVN trunk head (r220617).
- Update to SVN trunk head (r220580).
- Pulls bugfixing from Fedora mass-rebuild.
- Update to SVN trunk head (r220205).
- Strip GO binaries again.
- Update to SVN trunk head (r220030).
- Package go and gofmt manpages.
- Update to SVN trunk head (r219990).
- Make sure to not strip GO binaries as that makes them fail to run.
- Bump libgcj SO version.
- Update to SVN trunk head (r219892).
- Do not remove fixed includes for non-icecream like built crosses.
- Use the C++98 libstdc++ ABI by default on openSUSE 13.2 and older.
- Update to SVN trunk head (r219634).
- Bump libgo SO version.
- Update to SVN trunk head (r219531).
- Update gcc-dir-version.patch with upstream libgcj.pc file name changes.
- Update to SVN trunk head (r218749).
- Drop gcc5-pr61558.patch.
- Update to SVN trunk head (r218668).
- Enable GRAPHITE everywhere.
- Add gcc5-pr61558.patch to help identifying that issue easier.
- Update to SVN trunk head (r218580).
- Update to SVN trunk head (r218267).
* Obsoletes gcc5-libsanitizer-fix.diff and gcc5-fix-gnatvsn.patch
- Add gcc5-libsanitizer-fix.diff to fix bug in libsanitizer that
prevents build on aarch64.
- Update to SVN trunk head (r217714).
* should fix non-%x86 build.
- New package, inherits from gcc49
* gcc-dir-version.patch, drop patchlevel from install directory names
* gcc-add-defaultsspec.diff, add the ability to provide a specs file
that is read by default
* Wunprototyped-calls.diff, new warning to warn about calls to functions
without seeing a real prototype earlier
* libjava-no-multilib.diff, do not build multilibs for libjava even on
multilib systems (we use baselibs for it)
* tls-no-direct.diff, avoid direct %fs references on x86 to not slow down
Xen
* gcc43-no-unwind-tables.diff, do not produce unwind tables for CRT files
* gcc41-java-slow_pthread_self.patch, force us to assume pthread_self
is fast
* gcc41-ppc32-retaddr.patch, fix expansion of __builtin_return_addr for ppc
* gcc44-textdomain.patch, make translation files version specific and
adjust textdomain to find them
* gcc44-rename-info-files.patch, fix cross-references in info files when
renaming them to be version specific
* gcc48-libstdc++-api-reference.patch, fix link in the installed libstdc++
html documentation
- Adds the following patches
* gcc5-fix-gnatvsn.patch, fix PR63931
- Drops IA64 support.

==== glibc-32bit ====
Subpackages: glibc-locale-32bit

- Add /usr/include/gnu/lib-names-.*.h to baselibs
- pthread-join-deadlock.patch: Don't require rtld lock to store static TLS
offset in the DTV (bsc#930015, BZ #18457)
- heap-top-corruption.patch: Do not corrupt the top of a threaded heap if
top chunk is MINSIZE (BZ #18502)
- threaded-trim-threshold.patch: Fix regression in threaded application
malloc performance (bsc#915955, BZ #17195)

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- Add /usr/include/gnu/lib-names-.*.h to baselibs
- pthread-join-deadlock.patch: Don't require rtld lock to store static TLS
offset in the DTV (bsc#930015, BZ #18457)
- heap-top-corruption.patch: Do not corrupt the top of a threaded heap if
top chunk is MINSIZE (BZ #18502)
- threaded-trim-threshold.patch: Fix regression in threaded application
malloc performance (bsc#915955, BZ #17195)

==== gnome-calculator ====
Version update (3.16.1 -> 3.16.2)
Subpackages: gnome-shell-search-provider-gnome-calculator

- Update to version 3.16.2:
+ Fix: Search provider crash introduced by 3.16.1.

==== gnome-software ====
Version update (3.16.3 -> 3.16.4)

- Update to version 3.16.4:
+ Fix a frequent crash in appstream plugin.
+ Fix a critical warning when opening the app folder dialog.
+ Fix a possible crash when changing the download-updates option
in gsettings.
+ Hide updates UI on managed systems.
+ Improve the error dialog for failed offline updates.
+ Workaround text coming up as selected in the updates dialog.
- Add pkgconfig(polkit-gobject-1) BuildRequires: New dependency.

==== gpg2 ====

- fix build with openSUSE 13.2 and earlier, call make to
compensate for incorrect documentation dependencies.

==== graphviz-gd ====
Subpackages: graphviz-gnome

- Enable ocaml and java plugins on aarch64

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-x86_64-efi
grub2-x86_64-xen

- If we have a post entry and the description field is empty, we should use the
"Pre" number and add that description to the post entry. (fate#317972)
- Show user defined comments in grub2 menu for snapshots (fate#318101)
* modified grub2-snapper-plugin.sh
- add 0001-grub-core-kern-efi-efi.c-Ensure-that-the-result-star.patch
make sure firmware path starts with '/' (boo#902982)

==== hdparm ====
Version update (9.45 -> 9.48)

- update to version 9.48
* 9.48 - fixed a number of output bugs due to the devslp patch
* 9.47 - added devslp patch (IDENTIFY word 76) from David Woodhouse.
- help and manpage fixes from Michal Minar.
* 9.46 - fix compilation with "musl libc".
- added "hex:aabbcc.." for binary security passwords.
- return EIO when read_big_block() fails
- use llabs() rather than abs() in identify.c
- use spec-cleaner

==== hwinfo ====
Version update (21.13 -> 21.16)
Subpackages: hwinfo-devel

- another Makefile fix
- 21.16
- fix Makefile typo
- 21.15
- adjusting Makefile
- use pkg-config for dbus
- allow to build outside git repository
- update compiler flags
- fix spelling errors
- 21.14

==== install-initrd-openSUSE ====
Version update (14.177 -> 14.179)

- fix module dependency ordering (bsc#934580)
- 14.179
- Switch off Linemode for PowerPC64 architectures
- 14.178

==== intel-gpu-tools ====
Version update (1.10 -> 1.11)

- use correct filelist macros
- Update to version 1.11
* Various new tests and tools
* Single combined test list (supported by piglit since commit 8a122bb)
* Optional dependency on libunwind to provide automatic stack traces on test
failures. (Thomas Wood)
* Add optional default debug and optimisation flags for tests to enable better
stack traces and debugging. (Thomas Wood)
* Test programs are now installed into libexec. This is useful when building a
complete software stack for a DUT from scratch. (Building and installing
tests can still be disabled by the --disable-tests configure flag.)
(Joonas Lahtinen)
* New tool to decode watermark registers (Ville Syrjälä)
* Timeout mechanism now reports test as failed
* Introduce intel_reg as the one Intel graphics register multitool to replace
intel_reg_read, intel_reg_write, intel_iosf_sb_read, intel_iosf_sb_write,
intel_vga_read, intel_vga_write, intel_reg_dumper, intel_reg_snapshot,
and quick_dump.py. (Jani Nikula)
* Add functions to manipulate i915.ko parameters and ensure features are
enabled
for testing. (Paulo Zanoni)
- supersedes u_Fix-pointer-cast-in-order-to-fix-build-on-32bit-arch.patch
- added new buildrequires to gtk-doc and libunwind
- added /usr/lib/intel-gpu-tools/* and /usr/share/intel-gpu-tools/* to filelist

==== iproute2 ====

- Update iproute2-dirs.diff to respect /usr/share/tc [bnc#934828]

==== ipsec-tools ====

- rework racoon.psk.patch
* comment example entry (its not a backdoor just an example)

==== irda ====

- Force gnu89 inline semantics

==== java-1_5_0-gcj-compat ====
Subpackages: java-1_5_0-gcj-compat-devel

- Use priority matching to ibm-java, always 5 bigger than it

==== java-1_8_0-openjdk ====
Subpackages: java-1_8_0-openjdk-headless

- Use priority matching to ibm-java, always 5 bigger than it
- Added patch:
* zero-dummy.patch
- Fix crash of ZERO VM built with gcc5

==== kactivities5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php
- Unconditionally obsolete kactivities4
- Drop kamd-rename.patch (kde#348212, kde#347817)

==== karchive-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Archive5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kauth-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Auth5

- Update to 5.11.0
* Make KAUTH_HELPER_INSTALL_ABSOLUTE_DIR available to all KAuth users
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php
- Drop 0001-Create-reproducible-builds.patch, merged upstream

==== kbookmarks-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Bookmarks5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kcmutils-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5KCMUtils5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kcodecs-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Codecs5

- Update to 5.11.0
* KEmailAddress: Add overload for extractEmailAddress and
firstEmailAddress which returns an error message.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kcompletion-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Completion5

- Update to 5.11.0
* Fix unwanted selection when editing the filename in the
file dialog (kde#344525)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kconf_update5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.11.0
* Prevent crash if QWindow::screen() is null
* Add KConfigGui::setSessionConfig() (kde#346768)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php
- Drop 0001-ensure-platform-window-resize-processing.patch and
0001-Add-KConfigGui-setSessionConfig.patch, merged upstream
- Delete 0001-ensure-platform-window-resize-processing.patch

==== kconfigwidgets-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5ConfigWidgets5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kcoreaddons ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.11.0
* New KPluginLoader::findPluginById() convenience API
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kcrash-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Crash5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdbusaddons-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdeclarative-components ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kdeclarative-devel libKF5Declarative5 libKF5QuickAddons5

- Update to 5.11.0
* Support creation of ConfigModule from KPluginMetdata
* Fix pressAndhold events
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kded ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kded-devel

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdelibs4support ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.11.0
* Use QTemporaryFile instead of hardcoding a temporary file.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdesignerplugin ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdesu-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Su5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdewebkit-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5WebKit5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdnssd-framework-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5DNSSD5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kdoctools ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kdoctools-devel kdoctools-lang

- Update to 5.11.0
* Update translations
* Update customization/ru
* Fix entities with wrong links
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kemoticons-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Emoticons5

- Update to 5.11.0
* Cache the theme in the integration plugin
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kernel-default ====
Subpackages: kernel-default-devel

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-desktop ====
Subpackages: kernel-desktop-devel

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-docs ====

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-pv-devel ====

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-devel ====
Subpackages: kernel-macros kernel-source

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-syms ====

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kernel-xen ====
Subpackages: kernel-xen-devel

- Btrfs: fix regression in raid level conversion.
- Btrfs: fix uninit variable in clone ioctl.
- Btrfs: fix range cloning when same inode used as source and
destination.
- btrfs: cleanup orphans while looking up default subvolume.
- btrfs: incorrect handling for fiemap_fill_next_extent return.
- Btrfs: send, don't leave without decrementing clone root's
send_progress.
- Btrfs: send, add missing check for dead clone root.
- commit 56152db
- Update config files: extend CONFIG_DPM_WATCHDOG_TIMEOUT to 60 (bnc#934397)
- commit b5e86cc
- mmc: sdhci: fix low memory corruption (bnc#934531).
- commit 0e899eb

==== kf5-filesystem ====
Version update (5.6.0 -> 20150610)

- Change versionining from KF5-version-based to date-based
- Drop and %_kf5_version %_plasma5_branding_version macros.
_kf5_version is unused since KF5 5.5.0, and for plasma we can
utilize individual packages version
- Add a warning that these macros are only guaranteed to be suitable
for projects/packages which use KDEInstallDirs from extra-cmake-modules,
and can, to some extent work with cmake's GNUInstallDirs.

==== kglobalaccel-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5

- Update to 5.11.0
* Move platform specific code into plugins
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kguiaddons-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5GuiAddons5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== khtml-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5KHtml5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== ki18n-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5I18n5

- Adjust patch fallbackLang.diff to search through some openSUSE
specific locale paths. Search only these specific locations to
prevent searching too many locations.
- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kiconthemes-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5IconThemes5

- Update to 5.11.0
* Optimize KIconEngine::availableSizes()
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kidletime-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5IdleTime5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kimageformats ====
Version update (5.10.0 -> 5.11.0)

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kinfocenter5 ====

- remove explicit conflict with KDE3, there in no such file at
this location in kdebase3

==== kinit ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kinit-devel

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kio ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kio-core kio-devel

- Update to 5.11.0
* Do not try to complete users and assert when prepend is non-empty.
(kde#346920)
* Use KPluginLoader::factory() when loading KIO::DndPopupMenuPlugin
* Fix deadlock when using network proxies (kde#346214)
* Fixed KIO::suggestName to preserve file extensions
* Kick off kbuildsycoca4 when updating sycoca5.
* KFileWidget: Don't accept files in directory only mode
* KIO::AccessManager: Make it possible to treat sequential
QIODevice asynchronously
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kitemmodels-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5ItemModels5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kitemviews-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5ItemViews5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kiwi ====
Version update (7.02.55 -> 7.02.56)
Subpackages: kiwi-desc-isoboot kiwi-desc-netboot kiwi-desc-oemboot
kiwi-desc-vmxboot kiwi-doc kiwi-media-requires kiwi-pxeboot kiwi-templates
kiwi-tools

- v7.02.56 released
- Fixed installation of Archive into root system
Archives marked as bootinclude were excluded from being installed
into the image too. This is an unexpected behaviour change and
is fixed now

==== kjobwidgets-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5JobWidgets5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kjs-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kjsembed-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5JsEmbed5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kmediaplayer-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5MediaPlayer5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== knewstuff-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5NewStuff5

- Update to 5.11.0
* Add new method fillMenuFromGroupingNames
* KMoreTools: add many new groupings
* KMoreToolsMenuFactory: handling for "git-clients-and-actions"
* createMenuFromGroupingNames: make url parameter optional
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== knotifications-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Notifications5

- Update to 5.11.0
* Fix crash in NotifyByExecute when no widget has been set
(kde#348510)
* Improve handling of notifications being closed (kde#342752)
* Replace QDesktopWidget usage with QScreen
* Ensure KNotification can be used from a non-GUI thread
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== knotifyconfig-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5NotifyConfig5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kpackage ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kpackage-devel

- Update to 5.11.0
* Guard the structure qpointer access (kde#347231)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kparts-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Parts5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kpeople5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kpeople5-devel

- Update to 5.11.0
* Use QTemporaryFile instead of hardcoding /tmp.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kplotting-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Plotting5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kpty-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Pty5

- Update to 5.11.0
* Use tcgetattr & tcsetattr if available
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kross ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kross-devel

- Update to 5.11.0
* Fix loading of Kross modules "forms" and "kdetranslation"
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== krunner-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5Runner5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kservice ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kservice-devel

- Update to 5.11.0
* When running as root preserve file ownership on existing
cache files (kde#342438)
* Guard against being unable to open stream (kde#342438)
* Fix check for invalid permissions writing file (kde#342438)
* Fix querying ksycoca for x-scheme-handler/* pseudo-mimetypes.
(kde#347353)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== ksh ====

- cpp.patch: fix use of cc -E without -P

==== ktexteditor ====
Version update (5.10.0 -> 5.11.0)
Subpackages: ktexteditor-devel

- Update to 5.11.0
* Allow like in KDE 4.x times 3rdparty apps/plugins to install
own highlighting XML files into katepart5/syntax
* Add KTextEditor::Document::searchText()
* Bring back use of KEncodingFileDialog (kde#343255)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== ktextwidgets-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5TextWidgets5

- Update to 5.11.0
* Add a method to clear decorator
* Allow to use custom sonnet decorator
* Implement "find previous" in KTextEdit.
* Re-add support for speech-to-text
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kunitconversion-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5UnitConversion5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kwallet-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: kwalletd5 libKF5Wallet5 libkwalletbackend5-5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kwidgetsaddons-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5WidgetsAddons5

- Update to 5.11.0
* KAssistantDialog: Re-add the Help button that was present in
KDELibs4 version
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kwindowsystem-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5WindowSystem5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== kxmlgui-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5XmlGui5

- Update to 5.11.0
* Add session management for KMainWindow (kde#346768)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php
- Drop 0001-Add-session-management-for-KMainWindow.patch, merged upstream

==== kxmlrpcclient5-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5XmlRpcClient5

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== laptop-mode-tools ====
Version update (1.62 -> 1.64)

- Clean up all various rpmlint warnings
- Update to version 1.64
+ Don't touch USB Controller power settings. The individual devices,
when plugged in, while on battery, inherit the power settings
from the USB controller
+ start-stop-programs: add support for systemd.
+ Replace hardcoded path to udevadm with "which udevadm".
+ Honor .conf files only.
+ Make '/usr/lib' path configurable. This is especially useful for
systems that use /usr/lib64, or /lib64 directly
+ Don't call killall with the -g argument.
+ Fix RPM Spec file build errors
- Changes from 1.63
+ Kick the power savings back in, as soon as the stick is unplugged
+ Release lock descriptors in start-stop-programs module.
+ Add option to disable alarm level check. This is helpful if
you have a broken battery reporting incorrect states
+ Check for external helper application's presence. And if not
available, handle it.
+ Added PCIe ASPM module.
+ Do not ship the board-specific/ folder in default installs
- Remove AUTHORS section
- Remove laptop-mode-1.49-initscript.diff and
laptop-mode-1.62-customize-installation-of-udev-systemd-files.patch;
fixed on upstream release
- Switch to systemd

==== lftp ====
Version update (4.6.2 -> 4.6.3a)

- update to 4.6.3a
* new mirror setting mirror:overwrite and options
- -overwrite/--no-overwrite.
* new mirror option --upload-older.
* new mirror option --recursion={always,never,missing,newer}.
* try to download zero sized files as they may be non-empty.
* torrent: new options --only-new, --only-incomplete.
* torrent: fixed endless loop in FD deallocation.
* fixed a memleak when parsing a directory listing with special
files.
* fixed one byte buffer overflow in cls.
* fixed cmd:fail-exit description in the man page.
* fixed large stack usage when parsing fish directory listings.
- refresh lftp-stdio.h.patch
- use spec-cleaner

==== libKF5ModemManagerQt-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5ModemManagerQt6

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== libKF5NetworkManagerQt-devel ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5NetworkManagerQt6

- Update to 5.11.0
* Drop WiMAX support for NM 1.2.0+
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== libappindicator3-1 ====
Version update (12.10.1+13.10.20130920 -> 12.10.1+bzr20141110)
Subpackages: typelib-1_0-AppIndicator3-0_1

- Update to 12.10.1+bzr20141110:
* scroll-event: change parameter to the right type.
- Rebase 0001_Fix_mono_dir.patch.
- Remove no-deprecated.patch: merged upstream.
- Remove dont-build-examples.patch: fixed upstream.
- Minor spec cleanup.

==== libdbusmenu-glib4 ====
Version update (12.10.3+14.04.20140217.1 -> 12.10.3+bzr20150410)
Subpackages: libdbusmenu-gtk3-4

- Update to 12.10.3+bzr20150410 (changes since 12.10.3+bzr20140610):
* Use the configure-generated libtool script instead of
/usr/bin/libtool, which might not match what we have.
* Use gi's typelibdir pkgconfig variable and install into this
directory, now that gi supports multiarch.
* Parser: don't override the label for stock items if a custom
one is provided.
- Minor spec cleanup.
- Update to version 12.10.3+14.10.20140610
+ No changelog available

==== libetonyek-0_1-1 ====
Version update (0.1.1 -> 0.1.2)

- Add patch to fix testsuite on i586:
* 0001-fix-test-on-i386.patch
- Version bump to 0.1.2:
* Initial support for pages and numbers
* Ditch libetonyek-0.1.1-constants.patch as we do not require
us to build for older boost

==== libffi4 ====
Version update (4.8.3+r218481 -> 5.1.1+r224716)
Subpackages: libffi4-32bit

- Update to gcc-5-branch head (r224716).
- Fix libffi include install. [bnc#935510]
- Package new mwaitxintrin.h file.
- Update to gcc-5-branch head (r224257).
- Fix build against SLE11 SP4.
* Where mpfr 2.4.0 is not available disable the few features
requiring it to allow building with mpfr 2.3.2,
gcc48-remove-mpfr-2.4.0-requirement.patch.
* Disable building the MPX library.
* Re-instantiate IA64 support.
* Add gcc5-no-return-gcc43-workaround.patch to avoid bogus warnings
from the GCC 4.3 host compiler.
- Update to gcc-5-branch head (r223279).
* Includes fix for [bnc#930496] and [bnc#930392].
- Enable 32bit code generation for ppc64le but do not build 32bit
target libraries. Fixes ppc64le kernel compile.
- Update to gcc-5-branch head (r222900).
- Add proper dependences to -32bit/-64bit compiler variants. Add
gcc5-c++-32/64bit and gcc5-obj-c++-32/64bit (for their dependencies
only).
- Rename libstdc++5-devel to libstdc++6-devel-gcc5 following shared
library suffixing (but applying always).
- Likewise for libgcj devel and jar packages and for libffi.
- Renames libgcj and libffi spec files.
- Update to gcc-5-branch head (r222451).
* Includes GCC 5.1.0 release and first chunk of bugfixes and powerpc
backports.
- Enable building libmpx for i586 and x86_64.
- Update to gcc-5-branch head (r222226).
* Includes GCC 5.1 RC2.
- Update to gcc-5-branch head (r222139).
- Update to gcc-5-branch head (r222032).
* Matches GCC 5.1 RC1.
- Update to SVN trunk head (r221942).
- Prepare for non-icecream cross-compilers
* Define sysroot to match cross-binutils config
* Prepare for requiring cross-newlib for some targets
* Use all-host target for libc bootstrap, too
* Install target files, but suppress stripping them (breaks them)
* Suppress -icecream-backend subpackage
* Allow building on any architecture
- Update to SVN trunk head (r221888).
- Enable cross compiler builds.
- libsanitizer-tsan-res-state.patch: remove obsolete patch.
- gcc5-libsanitize-aarch64-va42.patch: support aarch64 42-bit address
- space
- Update to SVN trunk head (r221624).
- Require own ada version for suse_version > 1330, not explicitely
gcc49-ada.
- Amend _constraints to request more physical memory for gcc5 and
gcc5-testresults as well as 4 processors for gcc5.
- Update to SVN trunk head (r221515).
- Update to SVN trunk head (r221482).
* Fixes miscompile of vim.
- Update to SVN trunk head (r221322).
* Contains fixes for PR65120 and should reduce the amount of
false -Wlogical-not-parentheses warnings.
- Switch to release checking builds.
- Update to SVN trunk head (r221139).
* Includes gcc5-pr65040.patch which is now removed.
- Add libsanitizer-tsan-res-state.patch to fix build with new glibc.
- Enable asan and ubsan for ppc64le.
- Add gcc5-pr65040.patch to remove -Wformat-signedness from -Wformat=2.
- Renumber patches.
- Update to SVN trunk head (r220959).
- Update to SVN trunk head (r220833).
- Update to SVN trunk head (r220758).
- Update to SVN trunk head (r220678).
- Update to SVN trunk head (r220617).
- Update to SVN trunk head (r220580).
- Pulls bugfixing from Fedora mass-rebuild.
- Update to SVN trunk head (r220205).
- Strip GO binaries again.
- Update to SVN trunk head (r220030).
- Package go and gofmt manpages.
- Update to SVN trunk head (r219990).
- Make sure to not strip GO binaries as that makes them fail to run.
- Bump libgcj SO version.
- Update to SVN trunk head (r219892).
- Do not remove fixed includes for non-icecream like built crosses.
- Use the C++98 libstdc++ ABI by default on openSUSE 13.2 and older.
- Update to SVN trunk head (r219634).
- Bump libgo SO version.
- Update to SVN trunk head (r219531).
- Update gcc-dir-version.patch with upstream libgcj.pc file name changes.
- Update to SVN trunk head (r218749).
- Drop gcc5-pr61558.patch.
- Update to SVN trunk head (r218668).
- Enable GRAPHITE everywhere.
- Add gcc5-pr61558.patch to help identifying that issue easier.
- Update to SVN trunk head (r218580).
- Update to SVN trunk head (r218267).
* Obsoletes gcc5-libsanitizer-fix.diff and gcc5-fix-gnatvsn.patch
- Add gcc5-libsanitizer-fix.diff to fix bug in libsanitizer that
prevents build on aarch64.
- Update to SVN trunk head (r217714).
* should fix non-%x86 build.
- New package, inherits from gcc49
* gcc-dir-version.patch, drop patchlevel from install directory names
* gcc-add-defaultsspec.diff, add the ability to provide a specs file
that is read by default
* Wunprototyped-calls.diff, new warning to warn about calls to functions
without seeing a real prototype earlier
* libjava-no-multilib.diff, do not build multilibs for libjava even on
multilib systems (we use baselibs for it)
* tls-no-direct.diff, avoid direct %fs references on x86 to not slow down
Xen
* gcc43-no-unwind-tables.diff, do not produce unwind tables for CRT files
* gcc41-java-slow_pthread_self.patch, force us to assume pthread_self
is fast
* gcc41-ppc32-retaddr.patch, fix expansion of __builtin_return_addr for ppc
* gcc44-textdomain.patch, make translation files version specific and
adjust textdomain to find them
* gcc44-rename-info-files.patch, fix cross-references in info files when
renaming them to be version specific
* gcc48-libstdc++-api-reference.patch, fix link in the installed libstdc++
html documentation
- Adds the following patches
* gcc5-fix-gnatvsn.patch, fix PR63931
- Drops IA64 support.

==== libfreehand-0_1-1 ====
Version update (0.1.0 -> 0.1.1)

- Upgrade to upstream version 0.1.1
* drastical improvement of all features
- fills
- strokes
- embedded images
- embedded text
* output of visible elements only in right place on the canvas
* coverage from Freehand 3.0 to Freehand 11
- Add build dependency on icu and lcms2
- Fix source url.

==== libgcj_bc1 ====
Version update (4.8.3+r218481 -> 5.1.1+r224716)

- Update to gcc-5-branch head (r224716).
- Fix libffi include install. [bnc#935510]
- Package new mwaitxintrin.h file.
- Update to gcc-5-branch head (r224257).
- Fix build against SLE11 SP4.
* Where mpfr 2.4.0 is not available disable the few features
requiring it to allow building with mpfr 2.3.2,
gcc48-remove-mpfr-2.4.0-requirement.patch.
* Disable building the MPX library.
* Re-instantiate IA64 support.
* Add gcc5-no-return-gcc43-workaround.patch to avoid bogus warnings
from the GCC 4.3 host compiler.
- Update to gcc-5-branch head (r223279).
* Includes fix for [bnc#930496] and [bnc#930392].
- Enable 32bit code generation for ppc64le but do not build 32bit
target libraries. Fixes ppc64le kernel compile.
- Update to gcc-5-branch head (r222900).
- Add proper dependences to -32bit/-64bit compiler variants. Add
gcc5-c++-32/64bit and gcc5-obj-c++-32/64bit (for their dependencies
only).
- Rename libstdc++5-devel to libstdc++6-devel-gcc5 following shared
library suffixing (but applying always).
- Likewise for libgcj devel and jar packages and for libffi.
- Renames libgcj and libffi spec files.
- Update to gcc-5-branch head (r222451).
* Includes GCC 5.1.0 release and first chunk of bugfixes and powerpc
backports.
- Enable building libmpx for i586 and x86_64.
- Update to gcc-5-branch head (r222226).
* Includes GCC 5.1 RC2.
- Update to gcc-5-branch head (r222139).
- Update to gcc-5-branch head (r222032).
* Matches GCC 5.1 RC1.
- Update to SVN trunk head (r221942).
- Prepare for non-icecream cross-compilers
* Define sysroot to match cross-binutils config
* Prepare for requiring cross-newlib for some targets
* Use all-host target for libc bootstrap, too
* Install target files, but suppress stripping them (breaks them)
* Suppress -icecream-backend subpackage
* Allow building on any architecture
- Update to SVN trunk head (r221888).
- Enable cross compiler builds.
- libsanitizer-tsan-res-state.patch: remove obsolete patch.
- gcc5-libsanitize-aarch64-va42.patch: support aarch64 42-bit address
- space
- Update to SVN trunk head (r221624).
- Require own ada version for suse_version > 1330, not explicitely
gcc49-ada.
- Amend _constraints to request more physical memory for gcc5 and
gcc5-testresults as well as 4 processors for gcc5.
- Update to SVN trunk head (r221515).
- Update to SVN trunk head (r221482).
* Fixes miscompile of vim.
- Update to SVN trunk head (r221322).
* Contains fixes for PR65120 and should reduce the amount of
false -Wlogical-not-parentheses warnings.
- Switch to release checking builds.
- Update to SVN trunk head (r221139).
* Includes gcc5-pr65040.patch which is now removed.
- Add libsanitizer-tsan-res-state.patch to fix build with new glibc.
- Enable asan and ubsan for ppc64le.
- Add gcc5-pr65040.patch to remove -Wformat-signedness from -Wformat=2.
- Renumber patches.
- Update to SVN trunk head (r220959).
- Update to SVN trunk head (r220833).
- Update to SVN trunk head (r220758).
- Update to SVN trunk head (r220678).
- Update to SVN trunk head (r220617).
- Update to SVN trunk head (r220580).
- Pulls bugfixing from Fedora mass-rebuild.
- Update to SVN trunk head (r220205).
- Strip GO binaries again.
- Update to SVN trunk head (r220030).
- Package go and gofmt manpages.
- Update to SVN trunk head (r219990).
- Make sure to not strip GO binaries as that makes them fail to run.
- Bump libgcj SO version.
- Update to SVN trunk head (r219892).
- Do not remove fixed includes for non-icecream like built crosses.
- Use the C++98 libstdc++ ABI by default on openSUSE 13.2 and older.
- Update to SVN trunk head (r219634).
- Bump libgo SO version.
- Update to SVN trunk head (r219531).
- Update gcc-dir-version.patch with upstream libgcj.pc file name changes.
- Update to SVN trunk head (r218749).
- Drop gcc5-pr61558.patch.
- Update to SVN trunk head (r218668).
- Enable GRAPHITE everywhere.
- Add gcc5-pr61558.patch to help identifying that issue easier.
- Update to SVN trunk head (r218580).
- Update to SVN trunk head (r218267).
* Obsoletes gcc5-libsanitizer-fix.diff and gcc5-fix-gnatvsn.patch
- Add gcc5-libsanitizer-fix.diff to fix bug in libsanitizer that
prevents build on aarch64.
- Update to SVN trunk head (r217714).
* should fix non-%x86 build.
- New package, inherits from gcc49
* gcc-dir-version.patch, drop patchlevel from install directory names
* gcc-add-defaultsspec.diff, add the ability to provide a specs file
that is read by default
* Wunprototyped-calls.diff, new warning to warn about calls to functions
without seeing a real prototype earlier
* libjava-no-multilib.diff, do not build multilibs for libjava even on
multilib systems (we use baselibs for it)
* tls-no-direct.diff, avoid direct %fs references on x86 to not slow down
Xen
* gcc43-no-unwind-tables.diff, do not produce unwind tables for CRT files
* gcc41-java-slow_pthread_self.patch, force us to assume pthread_self
is fast
* gcc41-ppc32-retaddr.patch, fix expansion of __builtin_return_addr for ppc
* gcc44-textdomain.patch, make translation files version specific and
adjust textdomain to find them
* gcc44-rename-info-files.patch, fix cross-references in info files when
renaming them to be version specific
* gcc48-libstdc++-api-reference.patch, fix link in the installed libstdc++
html documentation
- Adds the following patches
* gcc5-fix-gnatvsn.patch, fix PR63931
- Drops IA64 support.

==== libgda-5_0-4 ====
Version update (5.2.2 -> 5.2.4)
Subpackages: libgda-5_0-4-lang libgda-5_0-bdb libgda-5_0-sqlcipher
libgda-5_0-sqlite libgda-ui-5_0-4 libgda-ui-5_0-plugins

- Update to version 5.2.4:
+ Added missing file in distributed tarball (bgo#750891).
- Changes from version 5.2.3:
+ Improved Vala and introspection.
+ Misc bugs fixed.
+ Bugs fixed: bgo#722531, bgo#722773, bgo#730813, bgo# 742312,
bgo#750191.
+ Updated translations.

==== libid3tag0 ====

- Use url for source
- Add baselibs.conf as source
- Cleanup spec file with spec-cleaner

==== libindicator3-7 ====
Version update (12.10.2+14.04.20140304 -> 12.10.2+bzr20140922)

- Update to 12.10.2+bzr20140922:
+ No changes.
- Spec cleanup.
- Update to version 12.10.2+14.04.20141007.1
+ No changelog available
- Use download Url as source

==== libmtp-devel ====
Subpackages: libmtp9

- remove Requires on libusb-devel from libmtp-devel, the correct
dependency is libusb1 already included by the pkgconfig
generator.

==== libmwaw-0_3-3 ====
Version update (0.3.4 -> 0.3.5)

- Version bump to 0.3.5
* Various small fixes on 0.3 series, nothing big woth mention

==== libodfgen-0_1-1 ====
Version update (0.1.2 -> 0.1.4)

- Version bump to 0.1.4:
- drawing interface: do no forget to call startDocument/endDocument when
writing in the manifest
- metadata: added handler for 'template' metadata, unknown metadata are
written in a meta:user-defined elements,
- defineSheetNumberingStyle: can now define styles for the whole document
(and not only for the actual sheet)
- update doxygen configuration file + add a make astyle command
- Allow writing meta:creation-date metadata element for drawings and
presentations too.
- Improve handling of headings. Most importantly, write valid ODF.
- Write meta:generator metadata element.
- Add initial support for embedded fonts. It is currently limited to Flat
ODF output.

==== liboil ====
Subpackages: liboil-devel

- Use url for source
- Remove old ppc obsoletes/provides
- Cleanup spec file with spec-cleaner

==== gdk-pixbuf-loader-libopenraw ====
Subpackages: libopenraw1

- Add gpg signature
- Cleanup spec file with spec-cleaner
- Add missing dependency on curl

==== libpcap1 ====
Subpackages: libpcap1-32bit

- remove dependency on libusb-devel, only libusb-1.0 is used for
build.
- split a -devel-static subpackage that contains the static
libraries and all the extra dependencies which are not needed
for dynamic linking.

==== libraw-devel ====
Version update (0.16.1 -> 0.16.2)
Subpackages: libraw10

- Update to new upstream release 0.16.2
* Fixed several bugs detected by running American Fuzzy Lop.

==== libssh2-1 ====
Version update (1.5.0 -> 1.6.0)

- update to 1.6.0
Changes:
Added CMake build system
Added libssh2_userauth_publickey_frommemory()
Bug fixes:
wait_socket: wrong use of difftime()
userauth: Fixed prompt text no longer being copied to the prompts struct
mingw build: allow to pass custom CFLAGS
Let mansyntax.sh work regardless of where it is called from
Init HMAC_CTX before using it
direct_tcpip: Fixed channel write
WinCNG: fixed backend breakage
OpenSSL: caused by introducing libssh2_hmac_ctx_init
userauth.c: fix possible dereferences of a null pointer
wincng: Added explicit clear memory feature to WinCNG backend
openssl.c: fix possible segfault in case EVP_DigestInit fails
wincng: fix return code of libssh2_md5_init()
kex: do not ignore failure of libssh2_sha1_init()
scp: fix that scp_send may transmit not initialised memory
scp.c: improved command length calculation
nonblocking examples: fix warning about unused tvdiff on Mac OS X
configure: make clear-memory default but WARN if backend unsupported
OpenSSL: Enable use of OpenSSL that doesn't have DSA
OpenSSL: Use correct no-blowfish #define
kex: fix libgcrypt memory leaks of bignum
libssh2_channel_open: more detailed error message
wincng: fixed memleak in (block) cipher destructor

==== libusb-0_1-4 ====
Subpackages: libusb-compat-devel

- Currently disable libusb-compat-hide-libusb-1_0.patch: it causes
many more problems when linking to libusb-compat.

==== libvirt-glib-1_0-0 ====
Version update (0.2.0 -> 0.2.1)
Subpackages: typelib-1_0-LibvirtGLib-1_0

- Update to version 0.2.1:
+ Fix libtoolize detection in autogen.sh.
+ Allow storage volume format compatibility level to be set.
+ Add pre-condition checks to more public API entry points.
+ Don't try to return a value from void functions.
+ Add API for controlling storage pool autostart flag.
+ Add API for filesystem image format.
+ Add loop, nbd and ploop filesystem types.
+ Fix setting of driver type when called more than once.

==== libwebp-devel ====
Subpackages: libwebp5 libwebpdecoder1 libwebpdemux1 libwebpmux1

- remove aarch64-disable-neon.diff: compiler was fixed, neon
can be compiled now

==== libzypp ====
Version update (15.4.0 -> 15.6.0)

- Fix lost pathname when importing repo keys (bnc#936373)
- Disable code swig does not understand
- version 15.6.0 (5)
- Patch: fixup testing Category and Severity flags (FATE#318760)
- version 15.5.0 (5)
- Add details to the default signature verification problem report
- PathInfo: Avoid ExternalProgram in clean_dir
- call rpmdb2solv without executing user-supplied scripts (bnc#926853)
- version 15.4.1 (3)
- Update zypp-po.tar.bz2
- Update zypp-po.tar.bz2

==== fcitx-mozc ====
Subpackages: ibus-mozc ibus-mozc-candidate-window mozc mozc-gui-tools

- add fcitx-mozc-2.16.2037.102.2.patch
- add mozc-ninja-verbose-build.patch
- update gyp 20150628
- use-libprotobuf=0 for internal protobuf to workaround system
one's symbol undefined errors caused by gcc-5

==== libfreebl3 ====
Version update (3.19.1 -> 3.19.2)
Subpackages: libsoftokn3 mozilla-nss mozilla-nss-certs mozilla-nss-devel
mozilla-nss-tools

- as the .chk files are contained in libfreebl3 and libsoftokn
directly, provide the -hmac alias names to help :42 building.
- update to 3.19.2
* required for Firefox 39.0
* No new functionality is introduced in this release. This release
addresses a backwards compatibility issue with the NSS 3.19.1
release.
* In NSS 3.19.1, the minimum key sizes that the freebl cryptographic
implementation (part of the softoken cryptographic module used
by default by NSS) was willing to generate or use was increased
- for RSA keys, to 512 bits, and for DH keys, 1023 bits. This
was done as part of a security fix for Bug 1138554 / CVE-2015-4000.
Applications that requested or attempted to use keys smaller
then the minimum size would fail. However, this change in behaviour
unintentionally broke existing NSS applications that need to
generate or use such keys, via APIs such as
SECKEY_CreateRSAPrivateKey or SECKEY_CreateDHPrivateKey.

==== mtr ====

- add mtr-0.85-crash-with-xml-option.patch to fix crash if '--xml'
option is used [bnc#933854]

==== mysql-connector-java ====

- Fix the patches to allow jdbc3 build and reenable it:
* mysql-connector-java-jdbc-4.1.patch
* no-jdk5-requirement.patch

==== net-tools ====

- Remove hostname, domainname, dnsdomainname and require the
separate hostname package instead

==== libnetpbm-devel ====
Subpackages: libnetpbm11 netpbm

- Drop all libp?m.so symlinks

==== obs-service-tar_scm ====
Version update (0.5.3.1433158390.b0e72e1 -> 0.5.3.1434983686.0b4ce51)

- Update to version 0.5.3.1434983686.0b4ce51:
+ Add missing extension parameter to service file
+ Fix build on Debian 7.0/8.0

==== libvmtools0 ====
Subpackages: open-vm-tools open-vm-tools-desktop

- Fix compilation issues with GCC 5:
* Add toolboxcmd-fix-logic.patch
* Add asm_x86.patch

==== vmware-guest-kmp-default ====
Version update (9.10.0_k4.0.5_1 -> 9.10.0_k4.0.5_3)
Subpackages: vmware-guest-kmp-desktop

- Fix compilation issues with GCC 5:
* Add toolboxcmd-fix-logic.patch
* Add asm_x86.patch

==== libopenbabel-devel ====
Subpackages: libopenbabel4 openbabel

- Add openbabel-gcc5.patch: Fix build with gcc5.

==== openvpn ====
Version update (2.3.6 -> 2.3.7)

- Update to version 2.3.7
* down-root plugin: Replaced system() calls with execve()
* sockets: Remove the limitation of --tcp-nodelay to be server-only
* pkcs11: Load p11-kit-proxy.so module by default
* New approach to handle peer-id related changes to link-mtu
* Fix incorrect use of get_ipv6_addr() for iroute options
* Print helpful error message on --mktun/--rmtun if not available
* Explain effect of --topology subnet on --ifconfig
* Add note about file permissions and --crl-verify to manpage
* Repair --dev null breakage caused by db950be85d37
* Correct note about DNS randomization in openvpn.8
* Disallow usage of --server-poll-timeout in --secret key mode
* Slightly enhance documentation about --cipher
* On signal reception, return EAI_SYSTEM from openvpn_getaddrinfo()
* Use EAI_AGAIN instead of EAI_SYSTEM for openvpn_getaddrinfo()
* Fix --redirect-private in --dev tap mode
* Updated manpage for --rport and --lport
* Properly escape dashes on the man-page
* Improve documentation in --script-security section of the man-page
* Really fix '--cipher none' regression
* Set tls-version-max to 1.1 if cryptoapicert is used
* Account for peer-id in frame size calculation
* Disable SSL compression
* Fix frame size calculation for non-CBC modes.
* Allow for CN/username of 64 characters (fixes off-by-one)
* Re-enable TLS version negotiation by default
* Remove size limit for files inlined in config
* Improve --tls-cipher and --show-tls man page description
* Re-read auth-user-pass file on (re)connect if required
* Clarify --capath option in manpage
* Call daemon() before initializing crypto library

==== patterns-openSUSE-apparmor ====
Subpackages: patterns-openSUSE-apparmor_opt patterns-openSUSE-base
patterns-openSUSE-books patterns-openSUSE-console patterns-openSUSE-devel_C_C++
patterns-openSUSE-devel_basis patterns-openSUSE-devel_gnome
patterns-openSUSE-devel_ide patterns-openSUSE-devel_java
patterns-openSUSE-devel_kde patterns-openSUSE-devel_kde_frameworks
patterns-openSUSE-devel_kernel patterns-openSUSE-devel_perl
patterns-openSUSE-devel_python patterns-openSUSE-devel_qt4
patterns-openSUSE-devel_qt5 patterns-openSUSE-devel_rpm_build
patterns-openSUSE-devel_ruby patterns-openSUSE-devel_web
patterns-openSUSE-dhcp_dns_server patterns-openSUSE-directory_server
patterns-openSUSE-enhanced_base patterns-openSUSE-enhanced_base_opt
patterns-openSUSE-file_server patterns-openSUSE-fonts
patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns-openSUSE-gnome_games patte
rns-openSUSE-gnome_ide patterns-openSUSE-gnome_imaging
patterns-openSUSE-gnome_imaging_opt patterns-openSUSE-gnome_internet
patterns-openSUSE-gnome_laptop patterns-openSUSE-gnome_multimedia
patterns-openSUSE-gnome_multimedia_opt patterns-openSUSE-gnome_office
patterns-openSUSE-gnome_office_opt patterns-openSUSE-gnome_utilities
patterns-openSUSE-gnome_yast patterns-openSUSE-imaging
patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_laptop
patterns-openSUSE-lxde_office patterns-openSUSE-mail_serv
er patterns-openSUSE-minimal_base patterns-openSUSE-minimal_base-conflicts
patterns-openSUSE-misc_server patterns-openSUSE-multimedia
patterns-openSUSE-multimedia_opt patterns-openSUSE-network_admin
patterns-openSUSE-non_oss patterns-openSUSE-non_oss_opt
patterns-openSUSE-office patterns-openSUSE-office_opt
patterns-openSUSE-print_server patterns-openSUSE-remote_desktop
patterns-openSUSE-rest_dvd patterns-openSUSE-sw_management
patterns-openSUSE-sw_management_gnome patterns-openSUSE-sw_management_kde
patterns-openSUSE-tabletpc patterns-openSUSE-technical_writing
patterns-openSUSE-x11 patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- Recommend NTP at least until boo#936378 is fixed and YaST is not
trying to configure a service that's not there.
- remove minimal conflict with perl, perl-Bootloader-YAML draws it in via
perl-YAML-LibYAML
- since we have perl now anyways recommending vim is no problem
anymore either
- Remove kdebase4-wallpapers from the kde pattern.
- Remove gnucash and gnucash-docs from the patterns due to space
constraints on the DVD media.
- Drop gnome-do and hamster-applet from gnome_utilities pattern.
- tweak minimal pattern to make it smaller again:
* omit kernel. In theory YaST will add it for real installations.
* don't install yast anymore. Should work in theory
* remove adjtimex, hopefully not used anymore
* remove SuSEfirewall2, needs full perl which is huge
* remove eject, ntfs-3g and ntp, sysfsutils not really needed
* remove release-notes-openSUSE, pulls in perl
* remove vim, needs full perl :-(
* require zypper instead of software stack pattern to avoid additional
recommends
* blacklist perl, python-base and binutils to avoid recommended packages
pulling them in

==== perl-Class-Load ====
Version update (0.22 -> 0.23)

- updated to 0.23
see /usr/share/doc/packages/perl-Class-Load/Changes
0.23 2015-06-25
- remove use of namespace::clean

==== perl-Config-General ====
Version update (2.57 -> 2.58)

- updated to 2.58
see /usr/share/doc/packages/perl-Config-General/Changelog

==== perl-Crypt-Rijndael ====
Version update (1.12 -> 1.13)

- use cpanspec.yml to correct license automatically
- automatic update wasn't right, license should be LGPL
- updated to 1.13
see /usr/share/doc/packages/perl-Crypt-Rijndael/Changes
Revision history for Perl module Crypt::Rijndael

==== perl-DateTime-Locale ====
Version update (0.45 -> 0.46)

- updated to 0.46
see /usr/share/doc/packages/perl-DateTime-Locale/Changes
0.46 2015-05-21
- Fixed handling of C locales like "C.UTF-8". Passing these to
DateTime::Locale->load would cause a warning followed by an exception, ubt
all "C" locales should be special-cased as an alias of en-US-POSIX. Reported
by David Wheeler. RT #104574.

==== perl-DateTime-TimeZone ====
Version update (1.88 -> 1.92)

- updated to 1.92
see /usr/share/doc/packages/perl-DateTime-TimeZone/Changes
1.92 2015-06-22
- This distro now depends on DateTime::TimeZone::Local::Win32 when it is being
installed on a Windows OS. This should lead to a better experience for
Windows users. Requested by Matthew Horsfall and Karen Etheridge. RT
[#103275].
- updated to 1.91
see /usr/share/doc/packages/perl-DateTime-TimeZone/Changes
1.91 2015-06-13
- This release is based on version 2015e of the Olson database. This release
includes contemporary changes for Morocco and Cayman Islands.
1.90 2015-05-14
- Made the compilation test shipped in the last release an author-only test,
as many of the modules in this distribution try to load DateTime, but
DateTime depends on this distribution. This caused attempts to install
DateTime on a fresh perl install to fail. Reported by Noel Maddy. RT
[#104448].
1.89 2015-05-14
- Fix a syntax error in the Android local time zone module. Reported by Gregor
Hermann. RT #104105.

==== perl-Devel-Symdump ====
Version update (2.14 -> 2.15)

- updated to 2.15
see /usr/share/doc/packages/perl-Devel-Symdump/Changes
2015-06-11 k <andk@xxxxxxxx>
* release 2.15
* In the tests, always check for exists before checking for
definedness (Reini Urban)

==== perl-Encode-Locale ====
Version update (1.04 -> 1.05)

- updated to 1.05
see /usr/share/doc/packages/perl-Encode-Locale/Changes
[#]# 2015-06-09 Release 1.05
Mats Peterson (1):
Use GetACP() to get the ANSI code page like before
Thomas Sibley (1):
Conditionalize the Win32::Console recommendation

==== perl-List-MoreUtils ====
Version update (0.412 -> 0.413)

- updated to 0.413
see /usr/share/doc/packages/perl-List-MoreUtils/Changes
0.413 2015-06-10
- Fix compiling in c++ mode (depreciated, but some people seem to
require it). Solves RT#104690

==== perl-Log-Dispatch ====
Version update (2.44 -> 2.45)

- updated to 2.45
see /usr/share/doc/packages/perl-Log-Dispatch/Changes
2.45 2015-06-14
- Don't include threads and threads::shared in list of dependencies. This is
only needed for Log::Dispatch::Syslog and is loaded at runtime as needed
(which has its own issues but ...). Reported by Kent Fredric. RT #103392.

==== perl-MIME-Types ====
Version update (2.09 -> 2.11)

- updated to 2.11
see /usr/share/doc/packages/perl-MIME-Types/ChangeLog
version 2.11: Tue Jun 16 17:16:20 CEST 2015
Improvements:
- strict Perl 5.8
rt.cpan.org #105267 [Miyagawa], cpantesters
- updated to 2.10
see /usr/share/doc/packages/perl-MIME-Types/ChangeLog
version 2.10: Mon Jun 15 17:32:22 CEST 2015
Fixes:
- accept field 'q' weights [Theo van Hoesel]
Improvements:
- introduce PERL_MIME_TYPE_DB
rt.cpan.org#104945 [Philip Gwyn]

==== perl-Net-SMTP-SSL ====
Version update (1.02 -> 1.03)

- updated to 1.03
see /usr/share/doc/packages/perl-Net-SMTP-SSL/Changes
1.03 2015-06-20
- $net_smtp_ssl->isa('Net::SMTP') is now true

==== perl-Params-Validate ====
Version update (1.18 -> 1.20)

- updated to 1.20
see /usr/share/doc/packages/perl-Params-Validate/Changes
1.20 2015-06-28
- Fixed a bug with stack handling in the XS code. If a callback sub caused
Perl to reallocate the stack this could trigger weird errors of the form
"Bizarre copy of ARRAY" from Perl itself. Fixed by Noel Maddy. GH #5.
- Fixed use of inlining in the XS code to work when "gcc -std=c89" is
specified. Fixed by Vincent Pit. GH #6.
- Previously, Params::Validate would eagerly stringify all values it was
validating, even though this stringification was only needed for error
messages that are used when a parameter fails. For objects which overload
stringification and do real work, this added an unnecessary
slowdown. Stringification is now delayed until it is needed. Reported by
Klaus. RT #105326.
- updated to 1.19
see /usr/share/doc/packages/perl-Params-Validate/Changes
1.19 2015-06-12
- Fixed an uninitialized value warning from the pure Perl implementation under
5.8.8. Reported by Jim Bacon. RT #105198.

==== perl-Set-Object ====
Version update (1.34 -> 1.35)

- updated to 1.35
see /usr/share/doc/packages/perl-Set-Object/Changes.pod
=head1 1.35, 2015-06-10
=over
=item *
Change to Artistic License 2.0
=item *
Add more misc tests. Add use strict to Set::Object::Weak
=back

==== pesign ====

- Add pesign-efivar-pkgconfig.patch to get the efivar compiler
parameters from pkg-confg
- Add pesign-make-efi_guid_t-const.patch to avoid the error from
gcc

==== apache2-mod_php5 ====
Subpackages: php5 php5-bcmath php5-bz2 php5-calendar php5-ctype php5-curl
php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear php5-pgsql
php5-shmop php5-snmp php5-sockets php5-sqlite php5-suhosin php5-sysvsem
php5-sysvshm php5-tidy php5-tokenizer php5-wddx php5-xmlreader php5-xmlwriter
php5-xsl php5-zip php5-zlib

- enable apparmor support: new BR libapparmor-devel

==== libpisock-devel ====
Subpackages: libpisock9 perl-PDA-Pilot

- add missing include to fix build with gcc5
- Move udev rules to udevrulesdir, /etc/udev is reserved
for sysadmin use.

==== pk-update-icon ====
Version update (1 -> 2)
Subpackages: pk-update-icon-lang

- update to version 2
- Update German and Indonesian translations
- Update and improve Czech translation
- Avoid passing more arguments to g_strdup_printf() than specified in the
format
- Document configuration default values
- Make the update viewer command configurable
- Prevent calling g_source_remove() on an invalid source ID
- Improve README file
- Add NEWS file

==== plasma-framework ====
Version update (5.10.0 -> 5.11.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Update to 5.11.0
* Calendar components can now display week numbers (kde#338195)
* Use QtRendering for fonts in password fields
* Fix AssociatedApplicationManager lookup when a mimetype has
(kde#340326)
* Fix panel background coloring (kde#347143)
* Get rid of "Could not load applet" message
* Capability to load QML kcms in plasmoid config windows
* Don't use the DataEngineStructure for Applets
* Port libplasma away from sycoca as much as possible
* Make SectionScroller follow the ListView.section.criteria
* Scroll bars no longer automatically hide when a touch
screen is present (kde#347254)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== plasma5-desktop ====

- Use %version instead of no longer existing %{_plasma5_branding_version}
for branding provides/requires

==== plasma5-desktop-branding-openSUSE ====
Subpackages: plasma5-workspace-branding-openSUSE

- Use %plasma_version instead of no longer existing %{_plasma5_branding_version}

==== drkonqi5 ====
Subpackages: plasma5-workspace plasma5-workspace-devel plasma5-workspace-libs

- Use %version instead of no longer existing %{_plasma5_branding_version}
for branding provides/requires

==== libpulse-devel ====
Subpackages: libpulse-mainloop-glib0 libpulse0 libpulse0-32bit pulseaudio
pulseaudio-bash-completion pulseaudio-module-bluetooth pulseaudio-module-gconf
pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11
pulseaudio-module-zeroconf pulseaudio-utils

- Fix missing dock line-out jack detection (boo#934850):
0001-alsa-mixer-Make-line-out-path-unavailable-when-Front.patch
0002-alsa-mixer-Recognize-Dock-Line-Out-jack.patch

==== python-Pillow ====

- add 0001-Ico-files-are-little-endian-ref-1204.patch: fix for s390x

==== python-gobject ====
Version update (3.16.1 -> 3.16.2)
Subpackages: python-gobject-cairo python-gobject-devel

- Update to version 3.16.2:
+ overrides: Provide _overrides_module attribute (bgo#736678).

==== python-qt4 ====
Version update (4.11.3 -> 4.11.4)
Subpackages: python-qt4-devel python-qt4-utils

- Remove build-compare.diff as already in upstream
- Update to 4.11.4
- This is a minor functional and bug-fix release including support for Qt
- v4.8.7.

==== python-sip ====
Version update (4.16.5 -> 4.16.8)
Subpackages: python-sip-devel

- Update to 4.16.6:
* This is mainly a bug-fix release.
- Update to 4.16.7:
* This is a minor functional and bug-fix release.
- Update to 4.16.6:
* Added the /FileExtension/ class annotation.
* Installing into a virtual env should now work.
* Timestamps are no longer included in generated code. The -T command
line option is now ignored and deprecated.
* The @file method of passing additional command line options is now
supported. The -z command line option is now deprecated.

==== python3-gobject ====
Version update (3.16.1 -> 3.16.2)
Subpackages: python3-gobject-cairo

- Update to version 3.16.2:
+ overrides: Provide _overrides_module attribute (bgo#736678).

==== python3-qt4 ====
Version update (4.11.3 -> 4.11.4)

- Remove build-compare.diff as already in upstream
- Update to 4.11.4
- This is a minor functional and bug-fix release including support for Qt
- v4.8.7.

==== python3-setuptools ====
Version update (17.0 -> 17.1.1)

- update to version 17.1.1:
* Backed out unintended changes to pkg_resources, restoring removal
of deprecated imp module
- changes from version 17.1:
* Issue #380: Add support for range operators on environment marker
evaluation.

==== python3-sip ====
Version update (4.16.5 -> 4.16.8)

- Update to 4.16.6:
* This is mainly a bug-fix release.
- Update to 4.16.7:
* This is a minor functional and bug-fix release.
- Update to 4.16.6:
* Added the /FileExtension/ class annotation.
* Installing into a virtual env should now work.
* Timestamps are no longer included in generated code. The -T command
line option is now ignored and deprecated.
* The @file method of passing additional command line options is now
supported. The -z command line option is now deprecated.

==== libqscintilla-devel ====
Version update (2.8.4 -> 2.9)

- Update to 2.9
- Based on Scintilla v3.5.4.
- Added UserLiteral, InactiveUserLiteral, TaskMarker, InactiveTaskMarker,
EscapeSequence, InactiveEscapeSequence, setHighlightBackQuotedStrings(),
highlightBackQuotedStrings(), setHighlightEscapeSequences(),
highlightEscapeSequences(), setVerbatimStringEscapeSequencesAllowed() and
verbatimStringEscapeSequencesAllowed() to QsciLexerCPP.
- Added CommentKeyword, DeclareInputPort, DeclareOutputPort,
DeclareInputOutputPort, PortConnection and the inactive versions of all
styles to QsciLexerVerilog.
- Added CommentBlock to QsciLexerVHDL.
- Added AnnotationIndented to QsciScintilla::AnnotationDisplay.
- Added FullBoxIndicator, ThickCompositionIndicator, ThinCompositionIndicator
and TextColorIndicator to QsciScintilla::IndicatorStyle.
- Added setIndicatorHoverForegroundColor() and setIndicatorHoverStyle() to
QsciScintilla.
- Added Bookmark to QsciScintilla::MarkerSymbol.
- Added WrapWhitespace to QsciScintilla::WrapMode.
- Added SCLEX_AS, SCLEX_BIBTEX, SCLEX_DMAP, SCLEX_DMIS, SCLEX_IHEX,
SCLEX_REGISTRY, SCLEX_SREC and SCLEX_TEHEX to QsciScintillaBase.
- Added SCI_CHANGEINSERTION to QsciScintillaBase.
- Added SCI_CLEARTABSTOPS, SCI_ADDTABSTOP and SCI_GETNEXTTABSTOP to
QsciScintillaBase.
- Added SCI_GETIMEINTERACTION, SCI_SETIMEINTERACTION, SC_IME_WINDOWED and
SC_IME_INLINE to QsciScintillaBase.
- Added SC_MARK_BOOKMARK to QsciScintillaBase.
- Added INDIC_COMPOSITIONTHIN, INDIC_FULLBOX, INDIC_TEXTFORE, INDIC_IME,
INDIC_IME_MAX, SC_INDICVALUEBIT, SC_INDICVALUEMASK,
SC_INDICFLAG_VALUEBEFORE, SCI_INDICSETHOVERSTYLE, SCI_INDICGETHOVERSTYLE,
SCI_INDICSETHOVERFORE, SCI_INDICGETHOVERFORE, SCI_INDICSETFLAGS and
SCI_INDICGETFLAGS to QsciScintillaBase.
- Added SCI_SETTARGETRANGE and SCI_GETTARGETRANGE to QsciScintillaBase.
- Added SCFIND_CXX11REGEX to QsciScintillaBase.
- Added SCI_CALLTIPSETPOSSTART to QsciScintillaBase.
- Added SC_FOLDFLAG_LINESTATE to QsciScintillaBase.
- Added SC_WRAP_WHITESPACE to QsciScintillaBase.
- Added SC_PHASES_ONE, SC_PHASES_TWO, SC_PHASES_MULTIPLE, SCI_GETPHASESDRAW
and SCI_SETPHASESDRAW to QsciScintillaBase.
- Added SC_STATUS_OK, SC_STATUS_FAILURE, SC_STATUS_BADALLOC,
SC_STATUS_WARN_START and SC_STATUS_WARNREGEX to QsciScintillaBase.
- Added SC_MULTIAUTOC_ONCE, SC_MULTIAUTOC_EACH, SCI_AUTOCSETMULTI and
SCI_AUTOCGETMULTI to QsciScintillaBase.
- Added ANNOTATION_INDENTED to QsciScintillaBase.
- Added SCI_DROPSELECTIONN to QsciScintillaBase.
- Added SC_TECHNOLOGY_DIRECTWRITERETAIN and SC_TECHNOLOGY_DIRECTWRITEDC to
QsciScintillaBase.
- Added SC_LINE_END_TYPE_DEFAULT, SC_LINE_END_TYPE_UNICODE,
SCI_GETLINEENDTYPESSUPPORTED, SCI_SETLINEENDTYPESALLOWED,
SCI_GETLINEENDTYPESALLOWED and SCI_GETLINEENDTYPESACTIVE to
QsciScintillaBase.
- Added SCI_ALLOCATESUBSTYLES, SCI_GETSUBSTYLESSTART, SCI_GETSUBSTYLESLENGTH,
SCI_GETSTYLEFROMSUBSTYLE, SCI_GETPRIMARYSTYLEFROMSTYLE, SCI_FREESUBSTYLES,
SCI_SETIDENTIFIERS, SCI_DISTANCETOSECONDARYSTYLES and SCI_GETSUBSTYLEBASES
to QsciScintillaBase.
- Added SC_MOD_INSERTCHECK and SC_MOD_CHANGETABSTOPS to QsciScintillaBase.
- Qt v3 and PyQt v3 are no longer supported.

==== rsh ====

- Add systemd unit files for rshd, rlogin and rexec [bsc#934571]
Remove xinetd config files: superseeded by systemd unit files

==== rxvt-unicode ====
Version update (9.20 -> 9.21)

- install COPYING
- remove %{_terminfo}/r/rxvt-unicode
- %clean section removed, moved makeinstall to %install
- update to 9.21
- fix pixel droppings on overdraw when a secondary core font has the
same height but different ascent.
- implement cvvis in terminfo as blinking cursor, to distinguish it
from cnorm (emacs uses cvvis which is commonly a blinking cursor).
- when xft support was compiled in, colour queries erroneously returned
premultiplied values, this also affected internal queries, for example
when calculating faded colour. alpha is now divided out when possible,
which is more correct but loses colour resolution.
- add DECSCUSR xterm extension to set the cursor to a vertical bar.
- add 'extension:string' action, and associated on_action perl
hook, for keysym resources that invokes actions provided by
perl extensions. The 'perl:string' action and
on_user_command hook are deprecated but still supported.
- add 'builtin-string' action for keysym resources that restores string
mappings for keys that have predefined actions in urxvt.
- add -k option to urxvtc for killing the daemon process.
- document urxvtd's -e/--eval option that was implemented in 9.16,
but not documented.
- add -dockapp option to make the wm treat urxvt as a dockapp.
- add -mc option and multiClickTime resource to set the maximum time
between multi-click select events (patch by Joe Peterson).
- new 'eval' extension to evaluate arbitrary perl code with keysym
bindings. The extension also provides methods that implement basic
actions, such as pasting selections and scrolling.
- the macosx-clipboard and macosx-clipboard-native extensions have been
removed.
- kuake extension now uses the kuake.hotkey resource to specify the hotkey.
- new 'matcher:select' mode of matcher to iterate over the matches with the
keyboard.
- the 'matcher:list' feature of matcher now honours the launcher
associated to a matched pattern.
- speed-up matcher underlining on very long lines (reported by Edward Z.
Yang).
- fix up/down commands of searchable-scrollback so that they always move
to the previous/next logical line with a match, if any.
- searchable-scrollback resource has been deprecated (use keysym instead).
- extension parameter passing is deprecated (use resource mechanism instead).
- upgrade to GPLv3 (see COPYING).
- compile out of the box on Solaris 10, again.
- fix height and position of the stippled area in next scrollbar (patch
by Thomas Otto).
- fix off-by-one bug causing the iso14755 window not to jump out of the
way properly.
- fix crash that may happen if a lib to which urxvt is linked to calls setenv.
- fix memory leak in special_{encode,decode} perl methods.
- fix refresh bug that occurs when reverse video is set on a cell
containing a space and with the same bg and fg colour, red hat bug
[#830236].
- fix crash that may happen if an x error is received after a terminal
window/popup has been destroyed already.
- removed superfluous 0 digit from sgr terminfo sequence.
- greatly improve colour allocation on colour-starved pseudocolour
displays to avoid read-write cells instead of simply failing
(this is only relevant for antique 8bpp frame buffers).
- do not free fade colours when not doing fading (this is likely
only relevant for antique 8bpp frame buffers).
- do not specialcase 2 or 4 colour visuals, leading to
simpler and actually more correct code.
- hopefully no longer leak colours on !truecolour visuals.
- use consistent method names (scr_recolour => scr_recolor).
- use simpler (but slightly less bogus) formula for nearest
colour choice (this is likely only relevant for antique 8bpp
frame buffers).
- remove fallback behaviour when initialising colours - the
behaviour was inconsistent between startup vs. later and
was only effective when valid colours couldn't be allocated.
* add rxvt-unicode-9.21-xsubpp.patch to correct wrong harcoded patch in
makefile
* add rxvt-unicode-0001-Prefer-XDG_RUNTIME_DIR-over-the-HOME.patch
* removed unused rxvt-unicode-remove_unused_attribute.patch
- sync categories in desktop files with xterm

==== sbl ====
Version update (3.5.0 -> 3.5.0.20130317.git7a75bc29)

- Cleanup spec file with spec-clener
- Apply sbl-sppkdev.patch
- Update rcservice symlinks
- Update changelog to mention new patch (sbl-install_perms.patch)
- Use sppkdev instead of spkdev in the documentation too.
+ sbl-sppkdev.patch
- Add --nodaemon option to ExecStart of the brld.service and set Type=forking
of the sbl.service both in the service section; (bsc#931036).
- Install missing brld init script and rc sym link.
+ sbl-init-scripts.patch
- Conditionally patch LIBDIR location to satisfy bi-arch requirements.
+ sbl-libdir.patch
- Create git7a75bc29 snaptshot tar ball.
- install binaries with mode 0755 not 0744 (bnc#851625)
* sbl-install_perms.patch

==== sblim-sfcb ====

- force GNU inline semantics for GCC5.

==== libKF5Solid5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: solid-devel solid-imports solid-tools

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== libKF5SonnetCore5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: libKF5SonnetUi5 sonnet-devel

- Update to 5.11.0
* Use one central cache for the SpellerPlugins.
* Reduce temporary allocations.
* Optimize: Do not wipe dict cache when copying speller objects.
* Optimise away save() calls by calling it once at the end if needed.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== libnfsidmap-sss ====
Version update (1.12.4 -> 1.12.5)
Subpackages: libsss_idmap0 libsss_nss_idmap0 libsss_sudo sssd sssd-32bit
sssd-krb5-common sssd-ldap

- Update to new upstream release 1.12.5
* The background refresh tasks now supports refreshing users and
groups as well. See the "refresh_expired_interval" parameter in
the sssd.conf manpage.
* A new option subdomain_inherit was added.
* When an expired account attempts to log in, a configurable
error message can be displayed with sufficient pam_verbosity
setting. See the "pam_account_expired_message" option.
* OpenLDAP ppolicy can be honored even when an alternate login
method (such as SSH key) is used. See the "ldap_access_order"
option.
* A new option :krb5_map_user" was added, allowing the admin to
map UNIX usernames to Kerberos principals.
* BUG FIXES:
* Fixed AD-specific bugs that resulted in the incorrect set of
groups being displayed after the initgroups operation.
* Fixes related to the IPA ID views feature. Setups using this
should update sssd on both IPA servers and clients.
* The AD provider now handles binary GUIDs correctly.
* A bug that prevented the `ignore_group_members` parameter to be
used with the AD provider was fixed.
* The failover code now reads and honors TTL value for SRV
queries as well.
* Race condition between setting the timeout in the back ends and
reading it in the front end during initgroup operation was
fixed. This bug affected applications that perform the
initgroups(3) operation in multiple processes simultaneously.
* Setups that only want to use the domain SSSD is connected to,
but not the autodiscovered trusted domains by setting
`subdomains_provider=none` now work correctly as long as the
domain SID is set manually in the config file.
* In case only "allow" rules are used, the simple access provider
is now able to skip unresolvable groups.
* The GPO access control code now handles situations where user
and computer objects were in different domains.

==== spax ====
Subpackages: star

- move /usr/share/doc/rmt/* to /usr/share/doc/packages/rmt
[bnc#931169]

==== suse-module-tools ====

- Use absolute path to mkinitrd (bsc#935566)

==== tgt ====

- fix tgtd start by giving tgtd time to open the socket (bnc#934642)
and use bash to run multiple programs in ExecStartPost

==== libKF5ThreadWeaver5 ====
Version update (5.10.0 -> 5.11.0)
Subpackages: threadweaver-devel

- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php

==== virt-install ====
Subpackages: virt-manager virt-manager-common

- bnc#934270 - virt-convert cannot handle .ova files
virtinst-replace-unar-with-other-archivers.patch

==== wine ====
Version update (1.7.44 -> 1.7.46)
Subpackages: wine-32bit

- Updated to 1.7.46 development snapshot
- Improvements in the BITS file transfer service.
- Still more progress on DirectWrite implementation.
- Support for shared user data on 64-bit.
- Various C++ runtime improvements.
- Some more support for the 64-bit ARM platform.
- Various bug fixes.
- susepatches.patch: fix build on x86_64
- Updated to 1.7.45 development snapshot
- Better debugging support on 64-bit Mac OS X.
- Some more progress on DirectWrite implementation.
- A number of RichEdit control fixes.
- Beginning implementation of the old MSVCIRT C++ runtime.
- Various bug fixes.
- buildrequire new dependency libunwind-devel.

==== xfce4-panel-plugin-cpufreq ====
Version update (1.1.1 -> 1.1.2)
Subpackages: xfce4-panel-plugin-cpufreq-lang

- update to version 1.1.2
- fix IT_PROG_INTLTOOL warning
- translation updates

==== xfce4-panel-plugin-notes ====
Version update (1.8.0 -> 1.8.1)
Subpackages: xfce4-panel-plugin-notes-lang

- update to version 1.8.1
- provide graphics tabs/ for gtk-2.0 theme
- fit panel button inside a single panel row (for deskbar mode)

==== xfce4-panel-plugin-weather ====
Version update (0.8.5 -> 0.8.6)
Subpackages: xfce4-panel-plugin-weather-lang

- update to version 0.8.6
- add ACLOCAL_AMFLAGS to Makefile.am
- remove negative sign when temperature is rounded to 0 degree
Fahrenheit (bug #11604)
- fix IT_PROG_INTLTOOL warning
- translation updates

==== xorg-x11-server ====
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk

- U_os-support-new-implicit-local-user-access-mode.patch,
U_xwayland-default-to-local-user-if-no-xauth-file-given.patch,
U_xwayland-enable-access-control-on-open-socket.patch
* Prevent unauthorized local access. (bnc#934102, CVE-2015-3164)

==== xosd ====

- Update project url
- Use url for source
- Cleanup spec file with spec-cleaner
- Clenaup dependencies

==== yast2 ====
Version update (3.1.130 -> 3.1.132)
Subpackages: yast2-devel-doc

- fate#318804
- dropped no longer used group from YaST Control Centre
- 3.1.132
- Added new method Directory.find_data_file (needed for the
implementation of fate#318425)
- Deprecated Directory.datadir and Directory.ydatadir
- 3.1.131

==== yast2-network ====
Version update (3.1.117 -> 3.1.119)

- Fix handling of AutoYaST parameter keep_install_network
- 3.1.119
- fate#318804
- moved "Network Settings" into "System" group in YaST control
centre
- 3.1.118

==== yast2-packager ====
Version update (3.1.70 -> 3.1.71)

- proper fix for a float remaining time (bnc#882240)
- 3.1.71

==== yast2-proxy ====
Version update (3.1.4 -> 3.1.6)

- If PROXY_ENABLED is not set, interpret it as disabled,
like the rest of the system does (boo#934925).
- Internal cleanups:
- Got rid of autotools.
- Converted legacy testsuite to RSpec.
- Moved code out of clients for better testability.
- 3.1.6
- Fixed the last change not to crash with "internal error in
WriteCurlrc" when installing with a proxy (boo#929868).
- 3.1.5

==== yast2-security ====
Version update (3.1.8 -> 3.1.9)

- Updated list of mandatory and optional services (part of
fate#318425)
- 3.1.9
- When checking services, systemd aliases are now taken into
account (so, for example, rsyslog is accounted as syslog).
- Removed references to runlevels (obsolete). Only current systemd
target is analyzed.
- List of mandatory and optional services moved to a YAML file.

==== yast2-snapper ====
Version update (3.1.8 -> 3.1.9)

- removed noarch tag again (bsc#934856)
- 3.1.9

==== zypper ====
Version update (1.12.3 -> 1.12.4)
Subpackages: zypper-aptitude zypper-log

- Use 'openSUSE_$releasever' as default OBS platform (bnc#796689)
- Clarify comment in zypper.conf (bnc#820693)
- Fix format of sizes in output (bnc#897301)
- version 1.12.4
- Update zypper-po.tar.bz2
- Update zypper-po.tar.bz2
- Update zypper-po.tar.bz2




Removed packages:
libKF5BluezQt5
libcloog-isl4
esound-daemon
exim
libexiv2-13
cpp48
> gcc48
> gcc48-c++
> gcc48-fortran
> gcc48-info
> gcc48-locale
> gcc48-objc
> libasan0
> libstdc++48-devel
libstdc++6-gcc5-locale
gnucash
> gnucash-lang
guile1
> libguile-srfi-srfi-1-v-3-3
> libguile-srfi-srfi-13-14-v-3-3
> libguile-srfi-srfi-4-v-3-3
> libguile-srfi-srfi-60-v-2-2
> libguile17
> libguilereadline-v-17-17
libilbc0
java-1_9_0-openjdk
> java-1_9_0-openjdk-headless
oxygen-cursors4
libdbi3
libffi48-devel
gcc48-gij
> gcc48-java
> libgcj48
> libgcj48-devel
> libgcj48-jar
libspf2-2
perl-Finance-Quote
perl-HTML-Element-Extended
perl-HTML-TableExtract
perl-Test-Manifest
libprotobuf9
libqscintilla2-11
slib
libspeexdsp1
libsvn_auth_gnome_keyring-1-0


Added packages:
aspell-es
libKF5BluezQt6
calligra-l10n-cs
> calligra-l10n-da
> calligra-l10n-de
> calligra-l10n-de-doc
> calligra-l10n-el
> calligra-l10n-en_GB
> calligra-l10n-es
> calligra-l10n-es-doc
> calligra-l10n-fr
> calligra-l10n-fr-doc
> calligra-l10n-hu
> calligra-l10n-it
> calligra-l10n-it-doc
> calligra-l10n-ja
> calligra-l10n-pl
> calligra-l10n-pt
> calligra-l10n-pt-doc
> calligra-l10n-pt_BR
> calligra-l10n-pt_BR-doc
> calligra-l10n-ru
> calligra-l10n-ru-doc
> calligra-l10n-zh_CN
> calligra-l10n-zh_TW
cracklib-dict-small
dbus-sharp
dbus-sharp-glib
libexiv2-14
libstdc++6-gcc48-locale
cpp5
> gcc5
> gcc5-c++
> gcc5-fortran
> gcc5-info
> gcc5-locale
> gcc5-objc
> libasan2
> libcilkrts5
> liblsan0
> libmpx0
> libmpxwrappers0
> libstdc++6-devel-gcc5
> libubsan0
gconf-sharp2
glade-sharp2
> glib-sharp2
> gtk-sharp2
hostname
libffi-devel-gcc5
gcc5-gij
> gcc5-java
> libgcj-devel-gcc5
> libgcj-gcc5
> libgcj-jar-gcc5
libqt4-x11-32bit
mono-kde4
libqyoto2
> mono-qt4
> mono-qt4-devel
notify-sharp
oxygen5-cursors
pdfmod
> pdfmod-lang
pulseaudio-esound-compat
libqscintilla2-12
smuxi-frontend
> smuxi-frontend-gnome
> smuxi-frontend-gnome-irc
> smuxi-frontend-gnome-irc-lang
> smuxi-frontend-gnome-lang
> smuxi-frontend-gnome-twitter
> smuxi-frontend-gnome-twitter-lang
> smuxi-frontend-gnome-xmpp
> smuxi-frontend-lang
libsvn_auth_kwallet-1-0
tasque
> tasque-lang
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >