Mailinglist Archive: opensuse-factory (437 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20150425 released!
Changed packages:

==== MozillaFirefox ====
Version update (37.0.1 -> 37.0.2)
Subpackages: MozillaFirefox-translations-common

- update to Firefox 37.0.2 (bnc#928116)
* MFSA 2015-45/CVE-2015-2706 (bmo#1141081)
Memory corruption during failed plugin initialization

==== banshee ====
Subpackages: banshee-backend-engine-gstreamer banshee-backend-io-gio
banshee-backend-platform-gnome banshee-backend-platform-unix banshee-core
banshee-dmp banshee-dmp-apple-devices banshee-dmp-mtp banshee-extensions-default

- Backport patches to port to GStreamer 1.0:
+ Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
+ Initial-port-to-GStreamer-1.0.patch
+ Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch
- Add Database-fix-performance-for-the-new-SQLite-s-query-.patch:
improve performance with SQLite 3.8.6+).
- Replace pkgconfig(gstreamer-plugins-base-0.10) BuildRequires with
pkgconfig(gstreamer-1.0), pkgconfig(gstreamer-audio-1.0),
pkgconfig(gstreamer-base-1.0), pkgconfig(gstreamer-fft-1.0),
pkgconfig(gstreamer-controller-1.0),
pkgconfig(gstreamer-pbutils-1.0), pkgconfig(gstreamer-tag-1.0),
pkgconfig(gstreamer-video-1.0) and
pkgconfig(gstreamer-plugins-base-1.0).

==== clucene-core-devel ====
Subpackages: libclucene-contribs-lib1 libclucene-core1 libclucene-shared1

- Use url for source
- Use fdupes to reduce amount of duplicate files
- Cleanup spec-file with spec-cleaner
- Do not install empty NEWS file

==== curl ====
Version update (7.41.0 -> 7.42.0)
Subpackages: libcurl-devel libcurl4

- update to 7.42.0
* refresh libcurl-ocloexec.patch
- fixes security vulnerabilities:
* CVE-2015-3143 (bnc#927556)
- Re-using authenticated connection when unauthenticated
* CVE-2015-3144 (bnc#927608)
- host name out of boundary memory access
* CVE-2015-3145 (bnc#927607)
- cookie parser out of boundary memory access
* CVE-2015-3148 (bnc#927746)
- Negotiate not treated as connection-oriented

==== freetype2-devel ====
Subpackages: libfreetype6 libfreetype6-32bit

- Enable harfbuzz for only suse_version > 1320. Dependency is
not available on older releases.

==== gnome-contacts ====
Version update (3.16.1 -> 3.16.2)
Subpackages: gnome-shell-search-provider-contacts

- Update to version 3.16.2:
+ Bug fixed concerning Maps initialization.

==== install-initrd-openSUSE ====
Version update (14.172 -> 14.173)

- disable biostest build, it's not used any longer
- 14.173
- added ExcludeArch i586 (bnc #924024)
- add grub2 to buildrequires for s390x (bnc #893971)
- handle xen & xen-kmp separately in spec file (bnc #906248)

==== libhogweed4 ====
Subpackages: libhogweed4-32bit libnettle-devel libnettle6 libnettle6-32bit

added patch: off-by-one-test-suite.patch
- Address Sanitizer, found a off-by-one error in the test suite (bnc#928328)

==== libsecret-1-0 ====
Version update (0.18 -> 0.18.2)
Subpackages: libsecret-devel typelib-1_0-Secret-1

- Update to version 0.18.2:
+ Testing fixes.
+ Documentation typo (bgo#747654).
+ Build fixes (bgo#743444).
+ Accomodate libgcrypt 1.6+.
+ Updated translations.
- Changes from version 0.18.1:
+ Testing fix (bgo#726909).

==== libzypp ====
Version update (15.0.0 -> 15.1.0)

- Update zypp-po.tar.bz2
- ZYpp: Changed ZYpp::Ptr to be a shared_ptr;
a precondition for fixing bnc-899755
- rpmmd: support 'metalink=' in .repo (for zypper#63)
- RepoMirrorList: ignore comments and malformed urls in mirrorlist
- PathInfo: remove minor/major conflicting with GNU libc macros
DiskUsageCounter: remove ctors taking 'magic' bool flags
ZyppCallbacks: remove unused PatchDownload callbacks
- version 15.1.0 (1)

==== libzypp-plugin-appdata ====

- No need to validate appdata.xml.gz in a yast2 repo: those are
created by kiwi, which in turn spanws appstream-builder: we can
trust that it creates valid enough metadata.

==== libfreebl3 ====
Version update (3.18 -> 3.18.1)
Subpackages: libsoftokn3 mozilla-nss mozilla-nss-certs mozilla-nss-devel
mozilla-nss-tools

- update to 3.18.1
* Firefox target release 38
* No new functionality is introduced in this release.
Notable Changes:
* The following CA certificate had the Websites and Code Signing
trust bits restored to their original state to allow more time
to develop a better transition strategy for affected sites:
- OU = Equifax Secure Certificate Authority
* The following CA certificate was removed:
- CN = e-Guven Kok Elektronik Sertifika Hizmet Saglayicisi
* The following intermediate CA certificate has been added as
actively distrusted because it was mis-used to issue certificates
for domain names the holder did not own or control:
- CN=MCSHOLDING TEST, O=MCSHOLDING, C=EG
* The version number of the updated root CA list has been set
to 2.4

==== ocfs2-tools ====
Version update (1.8.2+git.1361836695.ff84eb5 -> 1.8.3+git.1418704844.65fac00)

- Update ocfs2-tools.tar.bz2 to upstream v1.8.3
- Drop patches (merged upstream):
- fix-indexed-dirs.patch
- 0001-fswreck-Create-a-loop-in-group-chains.patch
- 0002-Break-a-chain-loop-in-group-desc.patch
- restore-g_list_append.patch
- ocfs2console-libraries-include-aio.patch
- libocfs2-needs-libaio.patch
- libocfs2-Change-asserts-to-error.patch
- Drop patches for ocfs2_controld
- force-debug.patch
- extra-debug.patch
- bug-805764-ocfs2-controld.patch
- bnc804707-reduce-RR-priority.patch
- use-symlink-in-udev-rules.patch
- Recommend ocfs2-kmp
- Autosetup pcmk if no cluster stack found (bnc#862758)
+ 0006-Auto-setup-pcmk-stack-as-default-if-no-stack-is-setu.patch
- Err if cannot write to cluster_stack (cluster mismatch)
+ 0003-Auto-setup-cluster_stack-based-on-what-is-on-disk.patch
- Update summary and description for the -o2cb package (bnc#862761)

==== perl-Alien-SDL ====
Version update (1.444 -> 1.446)

- adapt to new packaging
- updated to 1.446
see /usr/share/doc/packages/perl-Alien-SDL/Changes
1.446 Sat Feb 21 2015
- fix build on OS X Mavericks (missing symbol CGDirectPaletteRef) [FROGGS]
- build fix on Windows Strawberry Perl 5.20.+ [kmx]

==== perl-Bit-Vector ====
Version update (7.3 -> 7.4)

- updated to 7.4
see /usr/share/doc/packages/perl-Bit-Vector/CHANGES.txt

==== perl-Bootloader ====
Version update (0.831 -> 0.832)
Subpackages: perl-Bootloader-YAML

- started pbl-yaml testsuite
- added test cases for various utf8/non-utf8/really broken config files
- rewrite file-io to do some utf8 processing that keeps non-utf8 files intact
as much as possible
- use only WriteFileRaw() to actually write files
- use ReadFileRaw() to read grub2 config (bnc #899921)
- rewrite ReadFile() to handle utf8 properly (bnc #899921)
- export more pbl functions via yaml interface to allow easier testing
- 0.832

==== perl-Clone ====
Version update (0.36 -> 0.38)

- updated to 0.38
see /usr/share/doc/packages/perl-Clone/Changes
0.38 2015-01-18 19:27:41 garu
- typo fixes and improvements to the README (zmughal)
- travis/coveralls integration (zmughal)
0.37 2014-05-15 16:45:33 garu
- removed Carp dependency (GARU)
- silenced some clang warnings (JACQUESG)
- added a README (GARU)

==== perl-Config-IniFiles ====
Version update (2.83 -> 2.86)

- updated to 2.86
see /usr/share/doc/packages/perl-Config-IniFiles/Changes

==== perl-Crypt-SSLeay ====
Version update (0.64 -> 0.72)

- updated to 0.72
see /usr/share/doc/packages/perl-Crypt-SSLeay/Changes
0.70 2014-04-24 14:53:43 UTC
- RT #94974: I forgot that `return` just returns from the code block for
`catch`, not the subroutine so `filter_libs` was still trying to link
against various libraries even when Devel::CheckLib was not installed.
0.68 2014-04-24 14:13:07 UTC
- Previous release did not bump version number in Net::SSL even though there
was a minor change. Correct that oversight.
0.66 2014-04-24 14:00:42 UTC
- Various minor fixes to C code
- Various fixes to the distribution such as manifest files, additional
tests, bundled module etc
- Address RT bugs #94828 and #79212
0.65_14 2014-04-16 23:55:42 UTC
- REMINDER: make test WILL FAIL if your OpenSSL is vulnerable to Heartbleed.
- Add additional functions exposing information that can be obtained via
SSLeay_version.
0.65_13 2014-04-15 22:22:43 UTC
- Work in progress
- Add ability to query OpenSSL version, add test whether OpenSSL library
being used is vulnerable to the Heartbleed bug.
- Assorted fixes to Makefile.PL, most importantly to fix build problems with
Strawberry Perl.
0.65_08 2014-04-10 13:40:08 UTC
- Work in progress
- In Makefile.PL, use assert_lib to find the libraries against which we can
actually link rather than passing a big bowl of libs to WriteMakefile.
Bail out early if we can't link against any of the candidate libraries.
0.65_07 2014-04-10 12:38:06 UTC
- Work in progres
- Make sure t/02-live.t actually uses Net::SSL.
0.65_06 2014-04-10 10:35:14 UTC
- Work in progress
- Address RT bugs #88786, #88269, #78848, and #79477
- Makefile.PL now respects live-tests and no-live-tests, and allows library
and header locations to be specified via the command line arguments
libpath and incpath, respectively.
- These options can also be specified using the environment variables
CRYPT_SSLEAY_LIVE_TEST_WANTED
OPENSSL_LIB
OPENSSL_INC
- Also fixed a number of embarrasing logic errors and typos in Makefile.PL
which were introduced in previous 0.65_xx versions.
0.65_05 2014-04-04 12:38:21 UTC
- Work in progress
- Reorganize Makefile.PL to allow incpath and libpath command line
arguments. This attempts to address RT #88786, #88269, #79477, and #78848.
This was supposed to be the next step immediately after drastically
specifying Makefile.PL. But never got done.
- Also add encoded version number to openssl-version output.
0.65_04 2014-04-02 18:03:11 UTC
- Work in progress
- Address pull requests from GitHub and bug reports on RT. These address RT
issues #83764, #86425, #86819, #62133, #82715, #90803
- disable Crypt-SSLeay-0.58.patch as it works without and it's unclear what it
wants to achieve

==== perl-DBD-SQLite ====
Version update (1.42 -> 1.46)

- updated to 1.46
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.46 2014-12-10
- Switched to a production version. (ISHIGAKI)
1.45_06 2014-11-26
- Silenced a compile-time warning (Unescaped left brace
in regex is deprecated) in PerlData virtual table
under bleadperl
1.45_05 2014-11-25
- Updated to SQLite 3.8.7.2
- Restored regexp support in PerlData virtual table
by secure reimplementation using closure (DAMI++)
1.45_04 2014-10-28
* ** CHANGES THAT MAY POSSIBLY BREAK YOUR OLD APPLICATIONS ***
- Changed to apply quotemeta() to parameters while building
a query for a virtual table using PerlData for security.
(RIBASUSHI++ and MAUKE++) (DAMI, ISHIGAKI)
1.45_03 2014-10-25
- Fixed regression of 0 as integer (ISHIGAKI)
1.45_02 2014-10-23
- Improved int overflow handling under 32bit strawberry perl
(ISHIGAKI)
1.45_01 2014-10-22
- Updated to SQLite 3.8.7 (ISHIGAKI)
- Resolved #76395 (hopefully): int values over 32 bit in length
produce an error "datatype mismatch" (ISHIGAKI)
1.44 2014-10-22
- Switched to a production version. (ISHIGAKI)
1.43_09 2014-10-20
- Resolved #99583: Legacy DOS 8.3 filename support incompatible
with SQLITE WAL journal mode (spotted by Pat Horton) (ISHIGAKI)
- 1.43_07/08 were not VC6 compatible (ISHIGAKI)
1.43_08 2014-08-21
- Updated to SQLite 3.8.6, which should fix a unique index
issue: see http://www.sqlite.org/src/info/9a6daf340df99ba93c
for details (ISHIGAKI)
1.43_07 2014-07-30
- Resolved #97598: Crash on disconnect with virtual tables (FTS4)
(patch and test code by Rob++) (ISHIGAKI)
1.43_06 2014-07-22
- Fixed compile error/warning for older perls (reported by ribasushi)
(ISHIGAKI)
1.43_05 2014-07-21
- No significant code changes; removed unnecessary dependencies.
1.43_04 2014-07-21
* ** CHANGES THAT MAY POSSIBLY BREAK YOUR OLD APPLICATIONS ***
- Resolved #96877: sql statements should be converted to utf8 (DAMI)
If you set sqlite_unicode to true, SQL statements will be upgraded
to avoid inconsistency between embedded params and bind params.
- Resolved #96494: [PATCH] add SYSTEM TABLE to table_info() type
list (MJP)
- Supported virtual tables in Perl, and added two sample tables
(DAMI++)
1.43_03 2014-06-12
- Updated to SQLite 3.8.5, which should fix query planner's
issues in SQLite (ISHIGAKI)
- Fixed busy_timeout to accept 0 to disable (reported by zdm)
(ISHIGAKI)
- Resolved #95511: primary_key_info fails to return names for
named primary keys (Kenneth Kroenlein)
- Resolved #96050: Segfault in disconnected sqlite_db_filename
(reported by Alex Vandiver) (ISHIGAKI)
1.43_02 2014-03-26
- Limited -std=gnu99 to solaris gcc only, though it may be
harmless in many cases (mattp++) (ISHIGAKI)
1.43_01 2014-03-26
- Added -std=gnu99 for solaris gcc users (reported by mattp++)
(ISHIGAKI)

==== perl-Date-Calc ====
Version update (6.3 -> 6.4)

- updated to 6.4
see /usr/share/doc/packages/perl-Date-Calc/CHANGES.txt
- remove upstream Date-Calc-6.3.diff

==== perl-Date-Manip ====
Version update (6.43 -> 6.49)

- updated to 6.49
see /usr/share/doc/packages/perl-Date-Manip/Changes

==== perl-Devel-Symdump ====
Version update (2.11 -> 2.14)

- updated to 2.14
see /usr/share/doc/packages/perl-Devel-Symdump/Changes
2014-12-16 k <andk@xxxxxxxx>
* release 2.14
* no change to 2.14-TRIAL
2014-12-08 k <andk@xxxxxxxx>
* release 2.14-TRIAL
* support for fileno() on directory handles (perl commit v5.21.6-337-g67f2cc7)
2014-07-26 k <andk@xxxxxxxx>
* release 2.13-TRIAL
* support for telldir (Brian Fraser)
2014-06-20 k <andk@xxxxxxxx>
* release 2.12
* test rewrite: v5.21.0-424-ge35475d stopped supporting
defined(@$ref) which was used in t/symdump.t (thanks to Aaron
Crane for spotting)

==== perl-Error ====
Version update (0.17022 -> 0.17023)

- updated to 0.17023
see /usr/share/doc/packages/perl-Error/ChangeLog
Feb 12 2015 <shlomif@xxxxxxxxxxxxxx> (Shlomi Fish)
Error.pm #0.17023
- Minimal version of Module-Build reduced to 0.280801
- https://rt.cpan.org/Public/Bug/Display.html?id=102062

==== perl-GD ====
Version update (2.51 -> 2.56)

- move /usr/bin/bdftogd to bdftogd.perl-gd to avoid conflict with
gd package
- updated to 2.56
see /usr/share/doc/packages/perl-GD/ChangeLog
2.56 * Fix Makefile.PL so that it works again.
2.55 * Great simplification of regression framework ought to fix make test
problems.
* Replace ExtUtils::MakeMaker script with Module::Build system
(just in time for Module::Build to be deprecated).
* Remove archaic qd.pl (for creating QuickDraw picts) from distribution.
2.54 Patch from yurly@xxxxxxxx to fix image corruption in rotate180 when
image height is odd.
2.53 Points to Gabor Szabo's GD::Simple tutorial, and fix link to repository.
2.52 Fix regression tests to run on Ubuntu 12.04 64bit.

==== perl-LWP-Protocol-https ====
Version update (6.04 -> 6.06)

- updated to 6.06
see /usr/share/doc/packages/perl-LWP-Protocol-https/Changes
2014-04-18 LWP-Protocol-https 6.06
Mike Schilli (3):
Merge pull request #12 from drieux/subjectAltName
Merge pull request #9 from chorny/master
Updated libwww requirement to 6.06 to fix failing t/proxy.t test cases.
Gisle Aas (2):
Getopt::Long isn't actually used
Merge pull request #7 from noxxi/master
Alexandr Ciornii (1):
better diagnostics in case of failures in apache.t
Karen Etheridge (1):
Merge pull request #8 from cpansprout/patch-1
Steffen Ullrich (1):
correct behavior for https_proxy, this goes together with change to
libwww-perl cb80c2ddb7, new method _upgrade_sock in LWP::Protocol::https
cpansprout (1):
Typo fix: envirionment =~ s/io/o/
drieux (1):
support for subjectAltName

_______________________________________________________________________________

==== perl-MailTools ====
Version update (2.12 -> 2.14)

- updated to 2.14
see /usr/share/doc/packages/perl-MailTools/ChangeLog
version 2.14: Fri Nov 21 17:12:42 CET 2014
Fixes:
- threads and Mail::Field initiation
rt.cpan.org#99153 [Autumn Lansing] and [Arne Becker]
Improvements:
- warn when loading of some Mail::Field::* fails [Arne Becker]
version 2.13: Sun Jan 5 18:52:25 CET 2014
Fixes:
- optional 'from' and 'on' component in in-reply-to are comments
rt.cpan.org#89371 [Ward Vandewege]
- mailcap \\ -> \
rt.cpan.org#89802 [Kevin Ryde]
Improvements:
- fix typos rt.cpan.org#87188 [D Steinbrunner]
- remove obsolete incsearch.diff

==== perl-Net-DBus ====
Version update (1.0.0 -> 1.1.0)

- updated to 1.1.0
see /usr/share/doc/packages/perl-Net-DBus/Changes

==== perl-PadWalker ====
Version update (2.0 -> 2.1)

- updated to 2.1
see /usr/share/doc/packages/perl-PadWalker/Changes
2.1 Fri 24 Apr 2015 20:29:12 BST
- Another bleadperl fix
https://rt.cpan.org/Public/Bug/Display.html?id=101037

==== perl-RPC-XML ====
Version update (0.77 -> 0.78)

- updated to 0.78
see /usr/share/doc/packages/perl-RPC-XML/ChangeLog
0.78 Thursday February 6, 2014, 08:00:00 PM -0800
* lib/RPC/XML.pm
A patch to loop detection in smart_encode from Dag-Erling
Smørgrav. Some other minor bits.
* lib/RPC/XML/Procedure.pm
RT #83108: Fixed a spelling error. Some other fixes, too.
* lib/RPC/XML.pm
RT #86187: Force key-ordering in struct as_string and
serialize. Was getting some intermittent bug reports of
failures in t/15_serialize.t that amounted to the keys in a
fault struct not being in consistent order.
* lib/RPC/XML.pm
* t/15_serialize.t
Undo the previous change and fix the test. The previous change
didn't feel right, so this rolls it back and fixes the problem
at the level of the test, instead.
* Makefile.PL
* lib/RPC/XML.pm
* lib/RPC/XML/Client.pm
* lib/RPC/XML/Server.pm
Replace direct evals for loading optional modules with
Module::Load. Required adding this to Makefile.PL because
Module::Load is not core in 5.8.8. Also did some slight doc
tweaking.
* lib/RPC/XML.pm
* lib/RPC/XML/Client.pm
Merge pull request #5 from alexrj/utf8-encode. Use
utf8::encode() instead of utf8::downgrade().
* lib/RPC/XML.pm
* lib/RPC/XML/Client.pm
* lib/RPC/XML/Server.pm
Finish the uft8 encode vs. downgrade change from the previous
commit. Changed in places that were overlooked, and adjusted
the version number in all three modules.
* lib/RPC/XML.pm
* lib/RPC/XML/Parser/XMLLibXML.pm
Merge pull request #6 from dctabuyz/master. Added 'no_blanks'
libxml option to skip blank XML::LibXML::Text nodes.
* lib/RPC/XML/Server.pm
Merge pull request #7 from kvar/master. Initialize $do_compress
in RPC::XML::Server between requests.
* lib/RPC/XML.pm
* lib/RPC/XML/Parser/XMLLibXML.pm
* lib/RPC/XML/Server.pm
Bump version numbers on modules changed in github pulls.

==== perl-Sub-Name ====
Version update (0.13 -> 0.14)

- updated to 0.14
see /usr/share/doc/packages/perl-Sub-Name/Changes
0.14 2015-04-24 03:26:54Z
- remove mandatory dependencies for optional test
- mark the test with B::C as TODO, as it seems to fail frequently and
should not block normal installations

==== perl-URI ====
Version update (1.60 -> 1.67)

- updated to 1.67
see /usr/share/doc/packages/perl-URI/Changes
Revision history for URI
2015-02-24 Karen Etheridge <ether@xxxxxxxx>
Release 1.67
Karen Etheridge:
- properly skip author test for normal user installs
2015-02-24 Karen Etheridge <ether@xxxxxxxx>
Release 1.66
Adam Herzog:
- reorganize .pm files under lib/ (github #20)
2014-11-05 Karen Etheridge <ether@xxxxxxxx>
Release 1.65
Karen Etheridge:
- add a TO_JSON method, to assist JSON serialization
2014-07-13 Karen Etheridge <ether@xxxxxxxx>
Release 1.64
Eric Brine:
- better fix for RT#96941, that also works around utf8 bugs on older perls
2014-07-13 Karen Etheridge <ether@xxxxxxxx>
Release 1.63
Karen Etheridge:
- mark utf8-related test failures on older perls caused by recent string
parsing changes as TODO (RT#97177, RT#96941)
2014-07-12 Karen Etheridge <ether@xxxxxxxx>
Release 1.62
Karen Etheridge (2):
- use strict and warnings in all modules, tests and scripts
- remove all remaining uses of "use vars"
Eric Brine:
- fixed new "\C is deprecated in regex" warning in 5.21.2 (RT#96941)
2014-07-01 Karen Etheridge <ether@xxxxxxxx>
Release 1.61
David Schmidt:
Fix test failure if local hostname is 'foo' [RT#75519]
Gisle Aas (2):
New 'has_recognized_scheme' interface [RT#71204]
Interfaces that return a single value now return undef rather than an
empty list in list context
Slaven Rezic:
Fix bad regex when parsing hostnames
Piotr Roszatycki:
Preferentially use $ENV{TMPDIR} for temporary test files over /tmp
(fixes tests on Android)

==== perl-XML-Twig ====
Version update (3.48 -> 3.49)

- updated to 3.49
see /usr/share/doc/packages/perl-XML-Twig/Changes
3.49 - 2015-03-24
- added: the DTD_base option to XML::Twig new, that forces XML::Twig to look
for the DTD in a given directory
thanks to Arun lakhana for the idea
- fixed: XML::Parser 2.43 caused a failure in the tests due to a change in
its behaviour when die-ing.
- fixed: prevent PAUSE from trying to index packages that are only used
for monkey patching (to re-use XML::XPath as the XPath engine for
XML::Twig::XPath). Will also prevent UNAUTHORIZED flag on metacpan.
patch sent by Graham Knop
- fixed: RT #96009
keep_atts_order => 0 behaviour. Spotted by Dolmen
https://rt.cpan.org/Public/Bug/Display.html?id=96009
- fixed bug RT #97461
wrong error message was returned calling parse on an invalid filehandle
Thanks to Slaven Rezic for the bug report and test case
https://rt.cpan.org/Public/Bug/Display.html?id=97461
- fixed: RT #98801
COMPATIBILITY WARNING
inconsistency between simplify and XML::Simple for empty elements (including
elements with start and end tags but no contents)
the XML::Simple behaviour is to map them to an empty hash, not an
empty/undef scalar (depending of whether the element is a PCDATA or not)
as was the case in previous versions of the module.
This has the potential to break some existing code, but simplify should be
strictly the same as XML::Simple's XMLin
Thanks to Vangelis Katsikaros for the bug report and test case
https://rt.cpan.org/Public/Bug/Display.html?id=98801

==== perl-XML-Writer ====
Version update (0.624 -> 0.625)

- updated to 0.625
see /usr/share/doc/packages/perl-XML-Writer/Changes
0.625 Thu 05 Jun 2014 23:55:42 +1000 <joe@xxxxxxxxxxx>
- Allow xml-model processing instructions (#94078).
- Don't warn when undef is passed to setOutput (#94369).

==== perl-libwww-perl ====
Version update (6.05 -> 6.13)

- disable disable-ghttp.diff
- updated to 6.13
see /usr/share/doc/packages/perl-libwww-perl/Changes
2015-02-14 Release 6.13
Karen Etheridge (1):
- fixed Makefile.PL compatibility with older ExtUtils::MakeMaker (from
release 6.12)

_______________________________________________________________________________
2015-02-13 Release 6.12
Karen Etheridge (1):
- fixed prereq declarations in release 6.11

_______________________________________________________________________________
2015-02-13 Release 6.11
Graham Knop (1):
- cleanup of the test running mechanism; allowing greater flexibility and
should also resolve RT#102083

_______________________________________________________________________________
2015-02-12 Release 6.10
Karen Etheridge (1):
- lower runtime prereqs recommendation on LWP::Protocol::https to suggests,
to work around a circular dependency in CPAN clients when the 'install
recommendations' option is enabled (RT#101732)

_______________________________________________________________________________
2015-02-09 Release 6.09
Steffen Ullrich (1):
- checks for EINTR now also check EWOULDBLOCK (they sometimes differ on
MSWin32)
Daina Pettit (1):
- fixed pod syntax
Jason A Fesler (2):
- Fixed checking the % character in address regex
- Improved regex for literal IPv6 addresses

_______________________________________________________________________________
2014-07-24 Release 6.08
Mike Schilli (1):
Requiring Net::HTTP 6.07 to fix IPv6 support
(RT#75618 and https://github.com/libwww-perl/net-http/pull/10)
Jason A Fesler (2):
When the hostname is an IPv6 literal, encapsulate it with [brackets]
before calling Net::HTTP [rt.cpan.org #29468]
Extra steps to make sure that the host address that has a ":" contains
only characters appropriate for an IPv6 address.
John Wittkoski (1):
Fix doc typo for cookie_jar

_______________________________________________________________________________
2014-07-01 Release 6.07
Mike Schilli (5):
Removed Data::Dump references in test suite and dependency in Makefile.PL
Added MANIFEST.SKIP to enable "make manifest".
release script now checks for MacOS to avoid incompatible tarballs
Bumped version number to 6.07
Fixed gnu-incompatible tarball problem ([rt.cpan.org #94844])

_______________________________________________________________________________
2014-04-16 Release 6.06
Ville Skyttä (3):
Merge pull request #44 from dsteinbrunner/master
Spelling fixes.
Merge pull request #55 from oalders/master
Karen Etheridge (2):
Merge pull request #38 from mbeijen/typo-sting
Merge pull request #43 from dsteinbrunner/master
David Steinbrunner (2):
Spelling corrections
Olaf Alders (1):
Typo fixes.
Steffen Ullrich (1):
correct behavior for https_proxy,
e.g. don't send plain https:// requests to proxy, but instead establish
CONNECT tunnel and then send requests inside tunnel.
This change does together with a change in LWP::Protocol::https.
The change supports LWP::Protocol::https with the default
IO::Socket::SSL backend, but also with Net::SSL. Also:
- proxy authorization is supported (http://user:pass@host:port as proxy
URL, Net::SSL still needs special HTTPS_PROXY_* environemt variables,
as before)
- CONNECT request does not need to be the first request inside the
tunnel (not with Net::SSL)
- conn_cache is read and written inside request(), instead of writing in
request() and reading in _new_socket(). If a https tunnel is
established the cache_key no longer depends only on proxy host,port
but also on the tunnel endpoint
- CONNECT is a proxy request and must always use Proxy-Authorization,
not Authorization header
turugina (1):
fix: auth-header of Digest auth did not conform to
RFC 2617 when WWW-Authenticate has 'qop' parameter.
Gisle Aas (1):
SSL libs might trigger ENOTTY on read
Michiel Beijen (1):
Small typo.

_______________________________________________________________________________

==== polkit-default-privs ====

- polkit-default-privs: adding gnome-control-center actions (bnc#927508)
adding realmd actions (bnc#916767)

==== powertop ====
Subpackages: powertop-lang

- Add systemd dependencies
- Add pre/post macros for service
- Add rcservice symlink
- Remove double depenency on pkg-config
- Cleanup spec file with spec-cleaner
- Add a systemd script.

==== proxymngr ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4:
* This minor maintenance release includes various build
improvements, cleanups, portability tweaks, and bug fixes,
but nothing exciting.

==== python-lxml ====
Version update (3.4.0 -> 3.4.3)

- Drop lxml-dont-depend-on-URL-formatting-in-test.patch, merged upstream
- Update to 3.4.3:
* Expression cache in ElementPath was ignored. Fix by Changaco.
* LP#1426868: Passing a default namespace and a prefixed namespace mapping
as nsmap into ``xmlfile.element()`` raised a ``TypeError``.
* LP#1421927: DOCTYPE system URLs were incorrectly quoted when containing
double quotes. Patch by Olli Pottonen.
* LP#1419354: meta-redirect URLs were incorrectly processed by
``iterlinks()`` if preceded by whitespace.
* LP#1415907: Crash when creating an XMLSchema from a non-root element
of an XML document.
* LP#1369362: HTML cleaning failed when hitting processing instructions
with pseudo-attributes.
* ``CDATA()`` wrapped content was rejected for tail text.
* CDATA sections were not serialised as tail text of the top-level element.
* New ``htmlfile`` HTML generator to accompany the incremental ``xmlfile``
serialisation API. Patch by Burak Arslan.
* ``lxml.sax.ElementTreeContentHandler`` did not initialise its superclass.

==== python-pyOpenSSL ====
Version update (0.13.1 -> 0.15.1)

- Do not hardcode version in file list
- udapte to 0.15.1
* OpenSSL/SSL.py, OpenSSL/test/test_ssl.py: Fix a regression
present in 0.15, where when an error occurs and no errno() is set,
a KeyError is raised. This happens, for example, if
Connection.shutdown() is called when the underlying transport has
gone away.
* OpenSSL/rand.py, OpenSSL/SSL.py: APIs which previously accepted
filenames only as bytes now accept them as either bytes or
unicode (and respect sys.getfilesystemencoding()).
* OpenSSL/SSL.py: Add Cory Benfield's next-protocol-negotiation
(NPN) bindings.
* OpenSSL/SSL.py: Add ``Connection.recv_into``, mirroring the
builtin ``socket.recv_into``. Based on work from Cory Benfield.
* OpenSSL/test/test_ssl.py: Add tests for ``recv_into``.
* OpenSSL/crypto.py: Expose ``X509StoreContext`` for verifying certificates.
* OpenSSL/test/test_crypto.py: Add intermediate certificates for
* OpenSSL/SSL.py: ``Connection.shutdown`` now propagates errors from the
underlying socket.
* OpenSSL/SSL.py: Fixed a regression ``Context.check_privatekey``
causing it to always succeed - even if it should fail.
* OpenSSL/crypto.py: Fixed a regression where calling ``load_pkcs7_data``
with ``FILETYPE_ASN1`` would fail with a ``NameError``.
* OpenSSL/SSL.py: Fix a regression in which the first argument of
- update to 0.14
* Support for TLSv1.1 and TLSv1.2
* First-class support for PyPy
* New flags, such as MODE_RELEASE_BUFFERS and OP_NO_COMPRESSION
* Some APIs to access to the SSL session cache
* A variety of bug fixes for error handling cases
* Documentation has been converted from LaTeX
+ python-pyOpenSSL-doc is now build from single spec file
* pyOpenSSL now depends on cryptography, so it became pure-python
module
+ changed to noarch package, add proper dependencies
* Development moved to github
+ changed Url tag respectivelly
- refreshed bug-lp-1265482.diff

==== python3-requests ====
Version update (2.6.0 -> 2.6.2)

- update to version 2.6.2:
* Fix regression where compressed data that was sent as chunked data
was not properly decompressed. (#2561)
- update to version 2.6.1:
* Remove VendorAlias import machinery introduced in v2.5.2.
* Simplify the PreparedRequest.prepare API: We no longer require the
user to pass an empty list to the hooks keyword
argument. (c.f. #2552)
* Resolve redirects now receives and forwards all of the original
arguments to the adapter. (#2503)
* Handle UnicodeDecodeErrors when trying to deal with a unicode URL
that cannot be encoded in ASCII. (#2540)
* Populate the parsed path of the URI field when performing Digest
Authentication. (#2426)
* Copy a PreparedRequest?s CookieJar more reliably when it is not an
instance of RequestsCookieJar. (#2527)

==== smproxy ====
Version update (1.0.5 -> 1.0.6)

- Update to version 1.0.6:
* This minor maintenance release provides assorted build
configuration improvements and janitorial clenaups.

==== libkpathsea6 ====
Version update (6.2.0dev -> 6.2.0)

- Port the patch set 'remove or clarify "nosell" material' from
upstream to TeXlive source tar ball of 2014 (bsc#926106)
- Add patch source-asymptote-gs9.15.dif to switch from espwrite
device to eos2write device of ghostscript (boo#912398)
- Luajittex does only compile on Intel, PPC, and ARM_LE (EABI)
- Update to TeXLive 2014 (timestamp 20140525 revision 34252)
* Support DVIPDFMx
* [fix] avoid luatex crash under math_mode 'decimal'
* luaotfload: Fix incorrect handling of font file formats luaotfload)
* Sync with Context beta as of 2014-04-05
* pdfTeX: sync with Knuth TeX 3.14159265, e-TeX 2.6
* Many more ...
- Update biblatex-biber to 1.8
- Add upstrema patch
source-xdvik-events.dif
to make Xaw3d work
- Remove the now included patches
biber-av.patch
biber-certs.dif
biber-dev.patch
source-asymptote.dif
source-bnc856363.dif
source-dvipdfmx.dif
source-poppler-0.26.patch
source-psutils-flip.dif
- Adapted the following patches
biber-decode.diff
biber-noreadonly.diff
biblatex-encoding.dif
source-64.dif
source-arraysubs.dif
source-configure.dif
source-dviutils.dif
source-lacheck.dif
source-poppler.dif
source-psutils.dif
source-texdoc.dif
source-warns.dif
source-x11r7.dif
source-xdvizilla.dif
source.dif

==== texlive-latex-doc ====
Version update (2013.92.svn27907 -> 2014.100.svn34069)

- Handle unkown scripts
- Make sure that tabs are used within <<-EOF...EOF pair
- Package pas-cours: move runfiles from doc to working directory
- Handle rpmlintrc for each meta spec file its self
- The new TeXLive package layout had suppressed the detection of many
Provides which is fixed now.
- The null.tex is now in texlive-knuth-lib, therefore require
tex(null.tex) in luatex.requires and tex.requires instead of the
gone texlive-misc.
- Add exceltex.requires which now Requires perl(Spreadsheet::ParseExcel)
(boo#891617)
- Patch kpathsea_cnf.dif moved from texlive-specs-m to texlive-specs-l
- Add patch dvips_config.dif (boo#897284)
- Remove patch pgf_plain.dif as now upstream
- Remove patch latexdiff_env.dif as the affected file is gone
- Modified patches
luaotfload_varfonts.dif
tetex_scripts.dif
tex4ht_env.dif
- Removed files pst-node.moves and pst-plot.moves as now the files
are at the correct location
- Update to TeXLive 2014 (timestamp 20140525 revision 34252)
* Support DVIPDFMx
* [fix] avoid luatex crash under math_mode 'decimal'
* luaotfload: Fix incorrect handling of font file formats luaotfload)
* Sync with Context beta as of 2014-04-05
* pdfTeX: sync with Knuth TeX 3.14159265, e-TeX 2.6
* Many more ...

==== twm ====
Version update (1.0.8 -> 1.0.9)

- Update to version 1.0.9:
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Only use results from GetWindowProperty if it returned success
* Remove custom version of system(3c) for Solaris
* config: replace deprecated use of AC_OUTPUT with AC_CONFIG_FILES
* Update manpage with the proper location of system.twmrc file

==== x11perf ====
Version update (1.5.4 -> 1.6.0)

- Update to version 1.6.0:
* This release adds one new general option:
- pause <s> pause for <s> seconds between each run
and several new test options:
- crgb10text Char in 80-char rgb core line (Charter 10)
- crgb24text Char in 30-char rgb core line (Charter 24)
- crgbftext Char in 80-char rgb core line (Courier 12)
- magpixwin10 Scale 5x5 from pixmap to 10x10 window
- magpixwin100 Scale 50x50 from pixmap to 100x100 window
- magpixwin500 Scale 250x250 from pixmap to 500x500 window
- minpixwin10 Scale 10x10 from pixmap to 5x5 window
- minpixwin100 Scale 100x100 from pixmap to 5x5 window
- minpixwin500 Scale 500x500 from pixmap to 250x250 window

==== xcmsdb ====
Version update (1.0.4 -> 1.0.5)

- Update to version 1.0.5:
* Combine usage message strings
* Print which option was in error along with usage message
* Add -version option to print program version
* Fix const char * warnings
* Remove break statements immediately after return statements
* config: Add missing AC_CONFIG_SRCDIR
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Strip trailing whitespace from source files
* Only use results from GetWindowProperty if it returned Success
* _XcmsGetProperty: don't deal with uninitialized values, fail instead

==== xcompmgr ====
Version update (1.1.6 -> 1.1.7)

- Update to version 1.1.7:
* This is a minor bugfix and janitorial cleanup release.

==== xditview ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4:
* Close file leak when fdopen() fails in OpenFile()
* Convert sprintf calls to snprintf
* config: Add missing AC_CONFIG_SRCDIR
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Const cleanup
* unifdef -UNOTDEF -UNOTUSED
* Remove #if 0 code
* Combine usage message strings
* Remove CVS/RCS $Id tags
* Use SEEK_* names instead of raw numbers for fseek whence argument

==== xfindproxy ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4:
* This minor maintenance release provides accumulated build
configuration improvements and janitorial cleanups.

==== xgamma ====
Version update (1.0.5 -> 1.0.6)

- Update to version 1.0.6:
* This minor maintenance release provides the usual recent
collection of build configuration improvements and janitorial
cleanups. It does not provide enough gamma radiation to mutate
the user into a green-skinned giant who likes to smash things. ;-)

==== xgc ====
Version update (1.0.4 -> 1.0.5)

- Update to version 1.0.5:
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Remove include of Version 7 <sys/timeb.h> header
* configure: look for gram.c in $srcdir

==== xkbevd ====
Version update (1.1.3 -> 1.1.4)

- Update to version 1.1.4:
* This minor maintenance release cleans up the code,
configuration, & docs.

==== xkbprint ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4:
* This minor maintenance release provides the recent round of
build configuration improvements and janitorial cleanups.

==== xlsatoms ====
Version update (1.1.1 -> 1.1.2)

- Update to version 1.1.2:
* Combine usage message into single string/call
* config: Add missing AC_CONFIG_SRCDIR
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Print which option was in error along with usage message
* Add -version option to print program version

==== xlsfonts ====
Version update (1.0.4 -> 1.0.5)

- Update to version 1.0.5:
* config: Add missing AC_CONFIG_SRCDIR
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Print which option was in error along with usage message
* Add -version option to print program version
* Remove old CVS id tags

==== xmag ====
Version update (1.0.5 -> 1.0.6)

- Update to version 1.0.6:
* config: Add missing AC_CONFIG_SRCDIR
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Fix typos & wording issues in source comments
* Convert sprintf to snprintf
* Delete trailing whitespace from *.[ch] files

==== xournal ====

- Improved spec file (requirements)

==== zsh ====

- Nowadays more and more terminals set $TERM to xterm-256color




Removed packages:
man-pages-cs
perl-Business-ISBN
perl-Business-ISBN-Data
perl-Data-Dump
perl-HTML-Tidy
perl-Text-Wrapper
perl-XML-XPathEngine
libtidyp-1_04-0


Added packages:
perl-CPAN-Changes
perl-DateTime
perl-DateTime-Locale
perl-DateTime-TimeZone
perl-List-AllUtils
perl-Pod-Coverage
perl-Test-Pod
perl-Test-Pod-Coverage
python-cffi
python-cryptography
python-enum34
python-pycparser
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups