Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
[opensuse-factory] Using Tumbleweed and zypper si -d -- installing package build dependencies
  • From: "Luis R. Rodriguez" <mcgrof@xxxxxxxxxxxxxxxx>
  • Date: Tue, 4 Mar 2014 11:56:29 -0800
  • Message-id: <CAB=NE6U3v9TN8EO2CUf_JqGJ2mqxrmyDZPq6c6D+0tC5WckoLA@mail.gmail.com>
Hey folks, so I've gone down the OpenSUSE Tumbleweed road and so far I
gotta say its pretty great. My only issue so far is the build
dependency doesn't seem to work. That or the instructions to install
Tumbleweed [0] are lacking a bit more context / repos.

I essentially removed all my repos and then went through the click
through which worked nicely, and now all the repos I have are:

mcgrof@ergon ~/devel/xen (git::master)$ sudo zypper repos
# | Alias | Name
| Enabled | Refresh
--+----------------------------------+----------------------------------+---------+--------
1 | openSUSE:Stable_OSS | openSUSE:Stable_OSS
| Yes | Yes
2 | openSUSE:Stable_Updates | openSUSE:Stable_Updates
| Yes | Yes
3 | openSUSE:Stable_non-OSS | openSUSE:Stable_non-OSS
| Yes | Yes
4 | openSUSE:Stable_non-OSS__Updates |
openSUSE:Stable_non-OSS__Updates | Yes | Yes
5 | openSUSE:Tumbleweed | openSUSE:Tumbleweed
| Yes | Yes

Doing the 'zypper si -d kernel-desktop' didn't what what I'd expect, I
had to manually install ncurses-devel and even make manually to get to
build my own kernel. I'm about to try the same with xen and qemu to be
able to build my own xen / qemu, but figure before I run into further
compile issues. Am I missing repos or is the above example on
kernel-desktop just not a good one? Which would have been the right
package then?

[0] http://en.opensuse.org/Portal:Tumbleweed

Luis
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages