Mailinglist Archive: opensuse-factory (1029 mails)

< Previous Next >
Re: [opensuse-factory] DisplayLink
  • From: Shawn W Dunn <sfalken@xxxxxxxxx>
  • Date: Thu, 21 Nov 2013 05:38:58 -0800
  • Message-id: <2768655.RZhWJrKP9m@linux-pzs5>
On Thursday 21 November 2013 08:32:03 Alejandro Bonilla wrote:
On Thu, Nov 21, 2013 at 12:56 AM, Oliver Neukum <oneukum@xxxxxxx> wrote:
On Wed, 2013-11-20 at 15:18 -0500, Alejandro Bonilla wrote:
Getting back to this one - now that I've received the actual
display...

When connected

[ 2308.309058] usb 2-1.5: new high-speed USB device number 4 using
ehci-pci
[ 2308.384057] usb 2-1.5: device descriptor read/64, error 64
[ 2308.574240] usb 2-1.5: New USB device found, idVendor=17e9,
idProduct=03e0
[ 2308.574247] usb 2-1.5: New USB device strings: Mfr=1, Product=2,
SerialNumber=3
[ 2308.574251] usb 2-1.5: Product: Lenovo LT1421 wide
[ 2308.574253] usb 2-1.5: Manufacturer: DisplayLink
[ 2308.574256] usb 2-1.5: SerialNumber: 6V9BZHC1
[ 2308.575818] [drm] vendor descriptor length:17 data:17 5f 01 00 15
05 00 01 03 00 04
[ 2308.668814] udl 2-1.5:1.0: fb1: udldrmfb frame buffer device
[ 2308.668819] udl 2-1.5:1.0: registered panic notifier
[ 2308.668824] [drm] Initialized udl 0.0.1 20120220 on minor 0

Good.

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x2d9 cap: 0x1, Source Output crtcs: 4 outputs: 8
associated providers: 0 name:NVIDIA-0

Not good. You should have two providers. How soon after the plugin
did you give the xrandr command?

10 seconds, 1 minute, 30 minutes and several after as a nervous tic...! :(

I could never get displaylink to work as an extended display with an NVIDIA
card. I ended up just running 2 x-sessions, and then using x2x to share
themouse and keyboard between them.

I just used a second xinitrc, and the following script, fired off manually

#!/bin/sh
xinit ~/.xinitrc2 -- /usr/bin/X :1 -config xorg.conf.dl -novtswitch -sharevts -
audit 0 vt8 &
sleep 5
x2x -west -from :0 -to :1 &

< Previous Next >