Mailinglist Archive: opensuse-factory (667 mails)

< Previous Next >
[opensuse-factory] -devel-32bit is missing deps on -devel

I notice that in openSUSE 12.3, our xxx-devel-32bit packages suddenly
lack a dependency on xxx-devel:


19:09 ares07:/FX/opensuse/distribution > rpm -qRp
12.1/repo/oss/suse/x86_64/zlib-devel-32bit-1.2.5_git201105272030-20.1.4.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
zlib-32bit = 1.2.5_git201105272030
zlib-devel = 1.2.5_git201105272030
rpmlib(PayloadIsLzma) <= 4.4.6-1

19:09 ares07:/FX/opensuse/distribution > rpm -qRp
12.2/repo/oss/suse/x86_64/zlib-devel-32bit-1.2.7-2.1.2.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
zlib-32bit = 1.2.7
zlib-devel = 1.2.7
rpmlib(PayloadIsLzma) <= 4.4.6-1

19:09 ares07:/FX/opensuse/distribution > rpm -qRp
12.3/repo/oss/suse/x86_64/zlib-devel-32bit-1.2.7-7.1.1.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1


Intentional, accidental? Should we care and fix?
(I was expecting that the baselibs magic would automatically do this,
and thus it seems someone fiddled with the baselibs generator...)
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >