Mailinglist Archive: opensuse-factory (753 mails)

< Previous Next >
Re: [opensuse-factory] Anyone able to use a UMTS data stick?
  • From: phani <listmail@xxxxxxxxxxxxxx>
  • Date: Sun, 19 Aug 2012 04:17:57 +0530
  • Message-id: <op.wi9dl7ythmi8my@localhost>
On Sun, 19 Aug 2012 04:01:27 +0530, Gerald Pfeifer <gp@xxxxxxxx> wrote:

Is anyone successfully using a UMTS data stick with 12.2 (or
Factory or 12.1 with kernel 3.4 or later for that matter)?

I always get

pppd[7116]: unrecognized option 'wwan0'

since that is what NetworkManager now passes to pppd instead of
ttyUSBX and failed to find a way to change that on the user side.


Attached is the, ahem, creative workaround I devised to
track this down and get online this weekend;
https://bugzilla.novell.com/show_bug.cgi?id=776520 has details

Is this just me, or will this hit everyone/most/many with a UMTS
data stick?

Gerald

under 12.1 i wasn't using networkmanager at all, but connected via kppp, after detecting & switching the device using sakis3g. that involed editing scripts under /etc/ppp and took me a while to get right.

since 12.2 (12.3 now) i'm using networkmanager (KDE4 plasma applet), and it works surprisingly well. i never got any errors from pppd, no unrecognized options or such.

perhaps it would help to clear out all previous configurations?

--
phani.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References