Mailinglist Archive: opensuse-factory (1134 mails)

< Previous Next >
Re: [opensuse-factory] php 5.4
Am 28.06.12 11:19, schrieb Michal Kubeček:
On Thursday 28 of June 2012 11:33EN, habernir wrote:

what do you think if we create the apache 2.4 package and add it also
to opensuse 12.2?

To 12.2? Not a good idea.

Michal Kubeček


Definitely not good for 12.2. There are some incompatibilities (page
http://www.php.net/manual/en/migration54.incompatible.php has already been
mentioned).

What I'm worried about is the dropped Magic quotes. Also those have been
deprecated for a long time, applications that rely on it will still run but
have major security bugs afterwards. So those have to be checked/rewritten. I'm
about worried about this change. If they only never had introduced those magic
quotes...

Dropping register_global also could make major rewrites necessary.

I like both of those changes, but they could cause much work...

Unfortunately PHP packaging is only a re-packaging of sources, so you do not
know at all if the packages are runnable.

Johannes

--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups