Mailinglist Archive: opensuse-factory (1134 mails)

< Previous Next >
Re: [opensuse-factory] Tumblweed and GNOME 3.4.1
On Tue, Jun 12, 2012 at 09:40:48PM +0100, Andrew Wafaa wrote:

On Jun 12, 2012 7:59 PM, "Greg KH" <gregkh@xxxxxxxxx> wrote:

I now have GNOME 3.4.1 running in Tumbleweed, but wow, it's tough to get
installed due to some odd dependancies.  Because of that, I don't feel
comfortable moving it to the "main" openSUSE:Tumbleweed repo at this
point in time (it's in openSUSE:Tumbleweed:Testing if anyone wants to
play with it.)

Which dependencies are causing issue? Is the GNOME:Apps report part of
Tumbleweed, it could hold some answers but vuntz/zaitor/DimStar would probably
be best to answer.

Yes, I had to dump a few packages from GNOME:Apps in, as they would keep
old libraries around, which caused a problem. That's not really all
that big of a deal, although it could get "big".

The biggest problem was the typelib-1_0 dependancies, that packages seem
to need, yet you had to force the update by hand in order to get zypper
to realize this, and then actually upgrade the package. That is
something that we can't ask anyone "normal" to do, as it takes a long
time and isn't automated.

Although I guess I could say this is a bug in the GNOME packages that
this happens, right? Has anyone had this problem with just using the
GNOME:3.4 repo on 12.1? I guess I can go subscribe to the opensuse
gnome list to talk about this there...

thanks,

greg k-h
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References