Mailinglist Archive: opensuse-factory (564 mails)

< Previous Next >
Re: [opensuse-factory] [RFC DRAFT] Phasing out sysvinit
On Saturday 17 December 2011, Cristian Rodríguez wrote:
On 17/12/11 21:52, Rüdiger Meier wrote:
On Saturday 17 December 2011, Cristian Rodríguez wrote:
On 17/12/11 14:33, Vahis wrote:
Where is it?

In the official update repo..

Great fun! I just noticed that my boot.msg is quite old, December
4. Is that when it disappeared?
Where can I now find what's running on the screen during boot?

all messages are logged to syslog , and can be found in
/var/log/messages, later they will also be stored in journald
binary log.

Is it also intenioned that there is no output on boot console at
all? I'm using splash=native always but there is nothing...

On my serial console only systems this is all I get when booting:
-------
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-3.1.0-1.2-desktop root=/dev/vda2 noresume
splash=native quiet
console=ttyS0,115200 console=tty0 vga=0x314
[Linux-bzImage, setup=0x4200, size=0x4baef0]
initrd /initrd-3.1.0-1.2-desktop
[Linux-initrd @ 0x374a5000, 0xb4ad6f bytes]
----------

you have to remove "quiet" from the command line, if you want the
splash to be chatty you have to use splash=verbose , it now does what
is supposed to do ;)

Hm, in past "quiet" skipped kernel messages only like these ones:
....
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009bc00 (usable)
[ 0.000000] BIOS-e820: 000000000009bc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003fffd000 (usable)
[ 0.000000] BIOS-e820: 000000003fffd000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000feffc000 - 00000000ff000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
.....

I see them on sysvinit without "quiet" too but I don't need them.
All I need is the userspace output of init scripts but anyway.


Not having a login prompt.. ? is the machine hanging ?

It's "working" but I can't login from serial console. Now without quiet it ends
this way:
-------------
[ 13.711255] device-mapper: uevent: version 1.0.3
[ 13.720722] device-mapper: ioctl: 4.21.0-ioctl (2011-07-06) initialised:
dm-devel@xxxxxxxxxx
[ 14.508873] alsactl[576]: /usr/sbin/alsactl: load_state:1586: Cannot open
/var/lib/alsa/asound.state for reading: No such file or directory
------------
(BTW I don't even have a sound card)


I would expect something like this:

------------
[...]
Starting mail service (Postfix)
done
Starting CRON daemon
done
Starting smartd
unused
Master Resource Control: Running /etc/init.d/after.local
done
Master Resource Control: runlevel 3 has been
reached
Skipped services in runlevel 3:
cpufreq microcode.ctl smartd

Welcome to openSUSE 12.1 "Asparagus" - Kernel 3.1.0-1.2-desktop (ttyS0).


factory login:
-------------------






cu,
Rudi
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups