Mailinglist Archive: opensuse-factory (379 mails)

< Previous Next >
Re: [opensuse-factory] openSUSE Tumbleweed status for the week of April 22, 2011
On Tue, Apr 26, 2011 at 12:05:25PM +1000, John Andrews (swerdna) wrote:
On 04/23/2011 09:36 AM, Greg KH wrote:
Here's a short note as to the status of some recent activity in the
openSUSE:Tumbleweed repo:

- new kernel updates tracking the upstream stable 2.6.38 releases.
- lxde (and its sub-packages) was added
- calibre was added
- other smaller packages were added
- KDE update seems stable and working. It's in the
openSUSE:Tumbleweed:KDE repo if anyone wants to test it out now. I'll
be working next few weeks to merge this into the main
openSUSE:Tumbleweed repo as my bandwidth allows.
- There is a GNOME 3.0 Tumbleweed repo at openSUSE:Tumbleweed:GNOME.
It's properly building right now, but the same caveats remain for the
main GNOME 3.0 repo (i.e. network manager issues with KDE, and other
minor stuff), so I can't merge it to the main openSUSE:Tumbleweed repo
just yet. I'll wait for these changes to settle down, but if you
want, feel free to try out the repo for your GNOME 3.0 systems running
Tumbleweed. I'll keep it up to date as the changes merge into the
main GNOME 3.0 repo.
- artwork questions were raised with one proposed logo already sent in.
More to come in this area hopefully soon.
- There were a few "version downgrades" that happened as the upstream
project release number was changed to reflect the basesystem release
number correctly. This will probably continue to happen as this
change is propagated throughout the openSUSE build system to fix up
these errors by the various developers. You can safely ignore them
when they happen.

As always, if anyone knows of any packages they wish to see added to
Tumbleweed, please let me know.


greg k-h

Hello. I've got an openSUSE 11.4 clean install of Gnome DE with the
following repos enabled: Tumbleweed and TumbleweedGnome
[TW Gnome is
I've temporarily turned off openSUSE_updates and Tumbleweed_Packman.

The install is fully updated using zypper dup --from Tumbleweed. Now
I'd like to try out updating Gnome from 2 to 3. So I run zypper dup
--from TumbleweedGnome. I had a few dependency issues that were
easily solved but these two remain:

2 Problems:
Problem: libgdata7-0.6.6-2.1.x86_64 requires libgdata-lang = 0.6.6,
but this requirement cannot be provided
Problem: orca-3.0.0-1.1.x86_64 requires pyatspi, but this
requirement cannot be provided

Problem: libgdata7-0.6.6-2.1.x86_64 requires libgdata-lang = 0.6.6,
but this requirement cannot be provided
deleted providers: bundle-lang-gnome-en-11.4-5.13.1.noarch
Solution 1: deinstallation of libgdata7-0.6.6-2.1.x86_64
Solution 2: keep obsolete bundle-lang-gnome-en-11.4-5.13.1.noarch
Solution 3: break libgdata7 by ignoring some of its dependencies

I can't find pyatspi in openSUSE or Factory or Tumbleweed software
search. I can find three or four of libgdata-lang but none of them
are 0.6.6.

Can you advise please how best to solve the 2 issues.

I don't know just yet, as the Tumbleweed GNOME 3 repo is just finally
building right now, I haven't tested it on my test systems for
installing and running it due to the reported issues that are currently
there for the existing GNOME 3 repo. Give us a few weeks to get the
kinks all worked out...

If you really want to try GNOME 3 out, you might just want to enable the
GNOME 3 repo, not the Tumbleweed one, and use it. It should work just
as well right now, and the above errors shouldn't be present.

Let me know if that works or not.


greg k-h
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >