Mailinglist Archive: opensuse-factory (487 mails)

< Previous Next >
Re: [opensuse-factory] libtool: failing dependencies
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Sat, 29 May 2010 09:50:18 +0200
  • Message-id: <20100529075018.GB31034@xxxxxxx>
On Sat, May 29, 2010 at 09:44:01AM +0200, Juergen Orschiedt wrote:
Running M7, I did a "zypper dup" against factory
(http://download.opensuse.org/factory/repo/oss) this morning.
# zypper dup
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Problem: nothing provides /usr/bin/tar needed by
libtool-2.2.6b-4.4.i586
Solution 1: keep obsolete libtool-2.2.6b-3.11.x86_64
Solution 2: break libtool by ignoring some of its dependencies

So I removed libtool:
# zypper rm libtool
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following packages are going to be REMOVED:
libtool patterns-openSUSE-devel_basis
patterns-openSUSE-devel_kernel=20

and tried to reinstall it:
# zypper in libtool patterns-openSUSE-devel_basis
patterns-openSUSE-devel_kernel
Loading repository data...
Reading installed packages...
Resolving package dependencies...
3 Problems:
Problem: nothing provides /usr/bin/tar needed by
libtool-2.2.6b-4.4.x86_64
Problem: nothing provides /usr/bin/tar needed by
libtool-2.2.6b-4.4.x86_64
Problem: nothing provides /usr/bin/tar needed by
libtool-2.2.6b-4.4.x86_64

However, there's only "/bin/tar" - from tar-1.23-1.9.x86_64.

This is fixed already, should be gone in a day or two after
the rebuild was done.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References