Mailinglist Archive: opensuse-factory (487 mails)

< Previous Next >
Re: [opensuse-factory] repositories for debug packages
  • From: Lubos Lunak <l.lunak@xxxxxxx>
  • Date: Mon, 17 May 2010 17:24:17 +0200
  • Message-id: <201005171724.18111.l.lunak@xxxxxxx>
On Saturday 15 of May 2010, Stefan Quandt wrote:
Hi,
every here and then I run into the following:
1) KDE app crashes
2) Famous crash manager pops up and offers installation
of missing debug symbols
3) Installation of missing debug symbols fails
4) crash manager offers certain links for info about
debug repositories but it turns out there is no such info.

That will get fixed in time for the release.

5) user frustrated while devs keep believing their barely tested
applications are fairly usable

A backtrace is no replacement for a proper bugreport. A bugreport with
reliable steps to reproduce often does not need a backtrace.

How do I get proper debug debug packages on a factory installation?
Why does the crash manager not find them?

You need to have the repository with the debug packages added. Additionally,
the exactly matching debuginfo packages are needed, so if you use a
repository that rebuilds often, such as Factory, such packages are available
only for a short time after updating and get soon replaced by a newer
version.

--
Lubos Lunak
openSUSE Boosters team, KDE developer
l.lunak@xxxxxxx , l.lunak@xxxxxxx
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References