Mailinglist Archive: opensuse-factory (487 mails)

< Previous Next >
Re: [opensuse-factory] 11.3 M6 live CDs - bootup time comparison
  • From: Rastislav Krupanský <rastislav.krupansky@xxxxxxxxx>
  • Date: Fri, 07 May 2010 21:53:12 +0200
  • Message-id: <4BE46FA8.3050505@xxxxxxxxx>
Dňa 5.5.2010 19:37, Lenz Grimmer wrote / napísal(a):
Hi,

granted, it's not a very sophisticated or scientificly relevant observation,
but I thought I'd share this with you, since the live CDs are likely the first
thing a new user is going to try out before he decides which Linux
distribution or desktop environment he'll choose.

I measured the times it takes the current 11.3 M6 live systems to boot up in
both VirtualBox (virtualbox-ose-3.1.4-106.2.i586) and qemu-kvm
(kvm-0.11.0-4.5.2.i586) on my Thinkpad T61 (Intel Core2 Duo T8300@xxxxxxx, 4GB
RAM, running openSUSE 11.2, 32bit). I used the ISO images directly, no CD-ROM
drive is involved here.

I used a stop watch to measure the time from the point at which GRUB loads the
kernel until the desktop is usable and fully loaded. Both virtual machines
were configured to use 1GB of RAM. Out of curiosity, I also included the
latest Ubuntu 10.04 release for comparison. Can anybody repeat my observation
that the GNOME live-CD is much slower than the KDE one? I would have actually
expected it the other way around. What also surprised me was the difference
between VirtualBox and KVM.

Product Time (qemu-kvm) Time (virtualbox)
openSUSE-GNOME 11.3M6 0:02:17 0:03:45
openSUSE-KDE 11.3M6 0:01:40 0:02:50
kubuntu 10.04 (KDE) 0:01:35 0:01:59
ubuntu 10.04 (GNOME) 0:01:17 0:01:36

Anyway, I don't know if this is useful or if anybody actually cares about this
aspect. From a "first impression" perspective, anything above 2:30 minutes
feels like a very long time, especially if there is no visual feedback about
what's going on - the GNOME bootup spends a lot of time in displaying a black
screen with a busy cursor...

Bye,
LenZ
Hi.

I did comparison in VMware on my wife´s hardware.
Intel Core2 duo E7500 - 2,93Ghz, 4GB RAM, runnig Microsoft Windows XP 32bit with Service Pack 3.
The ISO images were used directly, virtual machine had 1GB RAM.

ubuntu 10.04 - 00:00:57 (i couldn´t believe it, but it´s true)
openSUSE-GNOME 11.3M6 - 00:02:21
openSUSE-KDE 11.3M6 - 00:01:39

I can confirm in openSUSE GNOME´s case a lot of time in displaying a black screen with a busy cursor.
In openSUSE KDE´s case the time would be shorter (around 00:01:19), but still appears bnc# 582375 - An error occured during the startup of the Akonadi server, which stucks desktop for a while (around 20 seconds).

--
S pozdravom / Best regards,

Rasto

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References