Mailinglist Archive: opensuse-factory (533 mails)

< Previous Next >
Re: [opensuse-factory] M4 netiso still no X.
  • From: Oddball <monkey9@xxxxxx>
  • Date: Sun, 11 Apr 2010 15:40:47 +0200
  • Message-id: <4BC1D15F.9060803@xxxxxx>
Stefan Dirsch schreef:
On Sun, Apr 11, 2010 at 02:44:27PM +0200, Oddball wrote:

Stefan Dirsch schreef:

Updating changed 84 pkgs..
No Xserver...

Install latest X.Org packages from X11:XOrg repo:

zypper ar \
zypper mr -p 90 X11:XOrg
zypper mr -r X11:XOrg
zypper dup -r X11:XOrg

I can do this from tty1 i presume?

Yes, of course. Assuming you have already a network setup ...

Save Bootloadersettings still 'hangs' installation.
Had to reboot with ctrl+alt+del..old menu list still worked.
Boot until x, nomodeset login tty1

You need to set NO_KMS_IN_INITRD="yes" and run mkinitrd afterwards. Also add
your VGA Device ID to /etc/X11/kms-blacklist.local.

Also from tty1?


Any more details like /var/log/Xorg.0.log? Which graphics hardware are you

I will dig the log up...
Graphics card details added.

ATI Radeon X700, i.e. R300/R400 based. Should work with radeon driver (KMS +
UMS), but apparently KMS is broken. So let's try UMS.

sax2 not able to correct x. I miss sax2...

It still exists, but apparently it's no longer installed by default.

Will wait to try to install it untill the above shows no progress?


Best regards,

Public Key available
Stefan Dirsch (Res. & Dev.) SUSE LINUX Products GmbH
Tel: 0911-740 53 0 Maxfeldstraße 5
FAX: 0911-740 53 479 D-90409 Nürnberg Germany
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)

OK, i am on it..may take a while on the same box, so have to
reboot all the time to report or try....


Enjoy your time around,

Oddball, aka M9.

OS: Linux x86_64
Huidige gebruiker: oddball@AMD64x2-sfn1
Systeem: openSUSE 11.1 (x86_64)
KDE: 4.2.1 (KDE 4.2.1) "release 103"

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups