Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] RC1 Trouble with OpenOffice
  • From: Petr Mladek <pmladek@xxxxxxx>
  • Date: Mon, 16 Nov 2009 16:33:11 +0100
  • Message-id: <200911161633.11155.pmladek@xxxxxxx>
Hi,

On Thursday 05 November 2009, Karl Sinn wrote:
I'm still on RC1 and I just used OpenOffice for the first time and I was
actually unable to do what I needed to do which was a very easy task.
I'm not sure it's a problem of openSuse, but I'm going to report here
concerning the usability of 11.2

I simply wanted to put extra lines on a few pages.
The document came to me in *.docx format, and as far as I can see, it
opened and displays correctly.

After adding two empty lines I saved:
1) as docx. Here the page header was not saved.
2) as doc. Here the graphics were lost and the chapter numbers were not
formated.
3) as pdf. The graphics were lost

Cedric, are these know bugs? I would expect that it is related to the DOCX
import but similar things happened also when pasting from another document,
see below.

To be more helpful, I tried to reproduce the bugs with a new document.
I created a new document, activated the page header, tried to insert an
image. I can not see my png images in the file dialog... I have to
explicitely click on png images to see them. With the show all option it
doesn't work.

I checked for other image formats and I can't actually see any of the
images on my computer with "show all formats". JPEG can't be seen at all
even while selecting the jpeg filter.

While selecting a png file I received the error "unknown format".

I just put a few words in the page header, and a numbered list in the body,
I saved it as odt, closed it, tried to reopen it :-) OpenOffice doesn't
even see his own files, but here I can see the jpg and png files :-).

To open it I wrote down the filename myself. It openend as it should.

I expect that you used KDE4. The open/save dialog was quite broken in OOo in
KDE4 in openSUSE-11.2-rc1. It should be fixed in the final version.

I cut and pasted an image from another document, because with
insert->image-

from file, I couldn't and tried to save as:

1) odt
fine
2) docx
fine
3) doc 2000
chapter numbers dissapeared
image was not imported correctly
4) pdf
image didn't show up properly

Strange. The picture is not lost in doc2000 when I insert it from menu
by "Insert/Picture/From File..." It might be related to the cut&paste
approach. It brings many problems as well. We would need to debug it with the
particular documents that you used.

Are these known issues?
Are they resolved in the latest version?

Only the open/save dialog was fixed. I am afraid that the import/export
problems still need to be fixed.

--
Best Regards,

Petr Mladek
software developer
---------------------------------------------------------------------
SUSE LINUX, s. r. o. e-mail: pmladek@xxxxxxx
Lihovarsk√° 1060/12 tel: +420 284 028 952
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References