Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
[opensuse-factory] Didn't we say that zypper dup would not change vendor
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Fri, 13 Nov 2009 21:29:45 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0911132112220.5098@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



Hi,

I think we said recently that zypper dup would not change vendor. However, upon attempting, a few days back, to upgrade from RC2 to GM, I got these:


Tirith_chrooted_on_nimrodel:~ # time nice zypper dup --auto-agree-with-licenses
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following NEW packages are going to be installed:
gssdp gstreamer-0_10-lang gstreamer-0_10-plugins-base-lang gupnp libamrnb3
libamrwb3 libid3tag libquicktime0 libspeex1 libtheoradec1 libtheoraenc1
python-beautifulsoup

The following packages are going to be REMOVED:
RealPlayer libgssdp-1_0-1 libgupnp-1_0-2 libquicktime libspeex

The following packages are going to be upgraded:
gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-utils
gstreamer-utils libfaac0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libmp3lame0
libofx4 libsndfile libtheora0 libx264-78 libxvidcore4 mjpegtools
python-gstreamer-0_10 sox xine-ui

The following packages are going to be downgraded:
cifs-mount cpp44 gcc44-gij gnome-control-center gnome-packagekit libffi44
libgcc44 libgcj44 libgcj44-jar libgnome-window-settings1 libgomp44
libgssdp-1_0-2 libgupnp-1_0-3 libpurple libpurple-tcl libsmbclient0
libstdc++44 libstdc++44-devel libstorage libtalloc1 libtdb1 libwbclient0 pidgin
podsleuth samba samba-client splashy splashy-branding-openSUSE taglib-sharp
update-test-affects-package-manager update-test-interactive
update-test-security yast2-control-center yast2-packager
yast2-packager-webpin yast2-sound

The following packages are going to change vendor:
gstreamer-0_10 openSUSE -> http://packman.links2linux.de
gstreamer-0_10-plugins-base openSUSE -> http://packman.links2linux.de
gstreamer-0_10-utils openSUSE -> http://packman.links2linux.de
gstreamer-utils openSUSE -> http://packman.links2linux.de
libfaac0 Packman -> VideoLAN Project
(http://www.videolan.org)
libgssdp-1_0-2 openSUSE -> http://packman.links2linux.de
libgstinterfaces-0_10-0 openSUSE -> http://packman.links2linux.de
libgstreamer-0_10-0 openSUSE -> http://packman.links2linux.de
libgupnp-1_0-3 openSUSE -> http://packman.links2linux.de
libmp3lame0 http://packman.links2linux.de -> VideoLAN
Project (http://www.videolan.org)
libofx4 openSUSE -> http://packman.links2linux.de
libsndfile openSUSE -> http://packman.links2linux.de
libtheora0 openSUSE -> Packman
libx264-78 Packman -> VideoLAN Project
(http://www.videolan.org)
libxvidcore4 Packman -> VideoLAN Project
(http://www.videolan.org)
mjpegtools openSUSE -> Packman
python-gstreamer-0_10 openSUSE -> http://packman.links2linux.de
sox openSUSE -> http://packman.links2linux.de
xine-ui openSUSE -> Packman


17 packages to upgrade, 36 to downgrade, 12 new, 5 to remove, 19 to change
vendor.
Overall download size: 67.1 MiB. After the operation, 17.5 MiB will be freed.
Continue? [y/n/?] (y): n


I'm a bit surprised at this. Today I see more or less the same.

It also surprises me that it wants to remove RealPlayer. Why? I installed it manually. So, what to do? For the moment, I'm going to disable packman and videolan, and lock RealPlayer; later, I'll reinstall xine and codecs from packman, using YaST.

So, now I see:

Tirith_chrooted_on_nimrodel:~ # time nice zypper dup --auto-agree-with-licenses
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following packages are going to be REMOVED:
libxine1-arts libxine1-codecs libxine1-esd libxine1-sdl

The following packages are going to be downgraded:
cifs-mount cpp44 gcc44-gij gnome-control-center gnome-packagekit libffi44
libgcc44 libgcj44 libgcj44-jar libgnome-window-settings1 libgomp44
libpurple libpurple-tcl libsmbclient0 libstdc++44 libstdc++44-devel
libstorage libtalloc1 libtdb1 libwbclient0 libxine1 libxine1-gnome-vfs
libxine1-pulse pidgin podsleuth samba samba-client splashy
splashy-branding-openSUSE taglib-sharp update-test-affects-package-manager
update-test-interactive update-test-security yast2-control-center
yast2-packager yast2-packager-webpin yast2-sound

The following packages are going to change vendor:
libxine1 http://packman.links2linux.de -> openSUSE
libxine1-gnome-vfs http://packman.links2linux.de -> openSUSE
libxine1-pulse http://packman.links2linux.de -> openSUSE


37 packages to downgrade, 4 to remove, 3 to change vendor.
Overall download size: 63.0 MiB. After the operation, 1.6 MiB will be freed.
Continue? [y/n/?] (y):

- -- Cheers,
Carlos Robinson
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkr9wcMACgkQtTMYHG2NR9U2YQCdFb24qnZB9w0wHUOTGBQKgFSi
4CQAn2NK4htyuIxPHIQVaJOYRBXorKFv
=66/p
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups