Mailinglist Archive: opensuse-factory (594 mails)

< Previous Next >
Re: [opensuse-factory] Packman and oS 11.2
  • From: Dave Plater <dave.plater@xxxxxxxxxxx>
  • Date: Tue, 08 Sep 2009 12:52:10 +0200
  • Message-id: <4AA6375A.60402@xxxxxxxxxxx>
On 09/08/2009 09:47 AM, Karl Sinn wrote:
If you install the source package using, for instance xine-libs, zypper
si -r Packman xine-lib then all the necessary devel packages are
automatically installed as well. You can search for source packages with
zypper se -st srcpackage xine to get a listing of matching source
packages and the repository they're in. The spec file is installed in
/usr/src/packages/SPECS, simply execute as root :-
rpmbuild -bb /usr/src/packages/SPECS/xine-libs.spec to build the rpms
which will be in /usr/src/packages/RPMS under their arch directory i.e.
i386, i486, i586, i686, noarch or x86_64

Hi,

that sounded like a solution for my problem so i tried, but again I'm missing
gnutls-devel which is needed.
What can I do?


zypper si -r 5 xine-lib
Metadaten von Repository 'Packman Repository' werden abgerufen [fertig]
Zwischenspeicher für Repository 'Packman Repository' wird erzeugt [fertig]
Installierte Pakete lesen...
Daten des Repositorys laden...
Paketabhängigkeiten auflösen...

Problem: gnutls-devel, benötigt von xine-lib-1.1.16.3-2.pm.5.2.src, wird von
keinem Repository angeboten
Lösung 1: Nicht fragen, ein auflösbares Objekts zu installieren, das xine-
lib.src = 1.1.16.3-2.pm.5.2 anbietet


Thanks,
Karl

That's the only catch, when you have to specify a repository zypper
looks for the dependencies in that repo. Make sure that your factory
source repo is turned off then you can be sure that you will get the
source rpm from packman and use "zypper -v si xine-lib" the -v switch
ensures you can see which versions you are getting.
Regards
Dave P
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups