Mailinglist Archive: opensuse-factory (279 mails)

< Previous Next >
Re: [opensuse-factory] Re: [opensuse-gnome] GNOME 2.26 on openSUSE 11.1
  • From: "Terje J. Hanssen" <terje@xxxxxxxxxxxxxxxxxxx>
  • Date: Sat, 21 Mar 2009 20:01:39 +0100
  • Message-id: <49C53993.6030204@xxxxxxxxxxxxxxxxxxx>
Magnus,

First, thanks to all of you who has replied.


Magnus Boman skrev:
Terje,

On Sat, 2009-03-21 at 12:00 +0100, Terje J. Hanssen wrote:

Magnus Boman wrote:


As you might, or might not know, we are packaging GNOME 2.26 for both
Factory and openSUSE 11.1.

I'm running this myself on all my machines and I don't have any
noticeable bugs, which means that you all can install and use it :-)

For 11.1, you will need to add the following repos;

http://widehat.opensuse.org/pub/repositories/GNOME:/Factory/openSUSE_11.1/
http://widehat.opensuse.org/pub/repositories/GNOME:/Backports/openSUSE_11.1/

I got a few issues after the upgrade to Gnome 2.26 on openSUSE
11.1 x86_64:

1. Two dependency packages lack

libempathy.so.22 is required by nautilus-sendto-1.11
beagle-0.3.9-13.16.x86_64 requires mono(taglib-sharp)=2.0.3.0


nautilus-sendto have to been recompiled due to some bluetooth
incompability. Working on it. It is pretty safe to not update
nautilus-sendto for now. Have not seen the beagle one, but again,
probably just go for "don't update" with that one.


2. The Gnome terminal won't start (the Shell Console terminal works):

# /usr/bin/gnome-terminal

(gnome-terminal:25432): Gtk-WARNING **: GModule
(/usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization
check failed: Gtk+ version too old (micro mismatch)

Failed to get the session bus: Did not receive a reply. Possible causes
include: the remote application did not send a reply, the message bus
security policy blocked t
he reply, the reply timeout expired, or the network connection was broken.
Falling back to non-factory mode.
Failed to contact the GConf daemon; exiting.
on too old (micro mismatch)

(gnome-terminal:25432): Gtk-WARNING **: GModule
(/usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so) initialization
check failed: Gtk+ version too old (micro mismatch)
Failed to get the session bus: Did not receive a reply. Possible causes
include: the remote application did not send a reply, the message bus
security policy blocked t
he reply, the reply timeout expired, or the network connection was broken.
Falling back to non-factory mode.
Failed to contact the GConf daemon; exiting.


Not sure why it is, but some packages that are newer in G:F wont be
installed due to the 11.1:Updates priority, so if you have that repo,
enabled, you need to change the priority of it to 99, and then update
again.


3. Pointing withe the mouse cursor on menus, wipes out the text on high
lighted items.


I think this one is related to the one above.


Yes, changing the openSUSE-11.1-update repo's priority from 20 to 99 let
me update around 60 additional packages, included Gtk and beagle. This
solved the above isssues, but added some other dependice conflicts, se
below.

4. XKB error message:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation


Not sure what this one is about. I'm pretty sure I've seen some
bugreport about XKB but.. Try looking in bugzilla since it might, or
might not be related.



This error message disappeared after adding 'Norway' as KB layout and by
removing 'no.latin1' in Gnome Control Center | Keyboard.


During my additonal upgrade, YaST generated the following list of
package conflicts on one of my machines. Shown here is also my
preliminar manual selections [x] :

#### YaST2 conflicts list - generated 2009-03-21 16:39:57 ####

nothing provides libgnomebt.so.1()(64bit) needed by
gnome-phone-manager-0.60-5.62.x86_64
[x] do not install gnome-phone-manager-0.60-5.62.x86_64

nothing provides libempathy.so.22()(64bit) needed by
nautilus-sendto-1.1.2-16.2.x86_64
[x] do not install nautilus-sendto-1.1.2-16.2.x86_64

libpackagekit-glib10-0.3.11-1.13.1.x86_64 requires PackageKit = 0.3.11,
but this requirement cannot be provided
uninstallable providers: PackageKit-0.3.11-1.9.x86_64[openSUSE 11.1-0]

PackageKit-0.3.11-1.9.x86_64[openSUSE-NonOSS-Add-on_11.1-0]
PackageKit-0.3.11-1.9.x86_64[openSUSE_11.1-0]
PackageKit-0.3.11-1.12.i586[repo-oss]
PackageKit-0.3.11-1.9.x86_64[repo-oss]
[ ] deinstallation of libpackagekit-glib10-0.3.11-1.13.1.x86_64
[x] do not install PackageKit-0.4.5-28.14.x86_64
[ ] Ignore some dependencies of libpackagekit-glib10

libgnomebt0-0.11.0-25.105.x86_64 requires gnome-bluetooth = 0.11.0, but
this requirement cannot be provided
uninstallable providers: gnome-bluetooth-0.11.0-25.108.i586[repo-oss]
[ ] deinstallation of libgnomebt0-0.11.0-25.105.x86_64
[x] do not install gnome-bluetooth-2.27.1-7.4.x86_64
[ ] Ignore some dependencies of libgnomebt0

libffmpeg0-0.5-0.pm.1.x86_64 requires libswscale0 = 0.5-0.pm.1, but this
requirement cannot be provided
[x] Following actions will be done:
do not install libswscale0-0.5.0.18071-1.1.x86_64
do not install libavdevice52-0.5.0.18071-1.1.x86_64
do not install libpostproc51-0.5.0.18071-1.1.x86_64
do not install libavformat52-0.5.0.18071-1.1.x86_64
do not install libavcodec52-0.5.0.18071-1.1.x86_64
[ ] deinstallation of libffmpeg0-0.5-0.pm.1.x86_64
[ ] Ignore some dependencies of libffmpeg0

libschroedinger-1_0-0-1.0.5-42.pm.4.x86_64 requires liboil-0_3-0, but
this requirement cannot be provided
uninstallable providers: liboil-0_3-0-0.3.15-0.pm.3.i586[repo_1]
liboil-0_3-0-0.3.15-0.pm.3.x86_64[repo_1]
[ ] downgrade of liboil-0.3.15-8.28.x86_64 to
liboil-0_3-0-0.3.15-0.pm.3.x86_64
[x] do not install libschroedinger-1_0-0-1.0.5-42.pm.4.x86_64
[ ] Ignore some dependencies of libschroedinger-1_0-0

#### YaST2 conflicts list END ###


Rgds,
Terje



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups