Mailinglist Archive: opensuse-factory (757 mails)

< Previous Next >
Re: [opensuse-factory] Bug 177758
  • From: Graham Anderson <graham.anderson@xxxxxxxxx>
  • Date: Tue, 23 May 2006 17:56:38 +0100
  • Message-id: <200605231756.38514.graham.anderson@xxxxxxxxx>
On Tuesday 23 May 2006 13:47, Martin Schlander wrote:
> * YaST gives no information when it's downloading or refreshing repodata
> making inexperienced users think it's frozen. For inspiration on how to
> handle this I would look at the smart -gui which tells you what's
> downloaded, how much, from where, at what speed etc.

Agreed. This is a huge show stopper for the new SUSE users that visit the IRC
channels wonidering what is going on. At a rough estimate I'd say say that
95% of new users ( and there are many of them on a daily basis visit IRC and
ask about this ) assume YAST has frozen/crashed on them when they try to add
*any* online software repo, far less the main inst-sources. This is clearly
unacceptable.

What is even more annoying is that this has been a problem with yast
inst_source module for a while. I cant remember if it ever had a progress
indicator. I've seen this requested many times on IRC and the mailing lists
but im not sure if anyone has made a feature request in bugzilla.

FYI, I use rug for my software management, i add YUM sources because the
progress indicator for rug works if you add YUM sources. Of course there are
a couple of caveats, YUM sources added with rug do not synch with YaST. ZYPP
sources do synch with yast but the rug progress indicator is broken for them.

Great huh? :P

Cheers
Graham

< Previous Next >
This Thread