Mailinglist Archive: opensuse-es (1014 mails)

< Previous Next >
Re: [opensuse-es] Re: Consulta sobre repositorios RPM.
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Sat, 07 Aug 2010 01:49:40 +0200
  • Message-id: <4C5C9F94.9080409@xxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2010-08-06 16:55, Camaleón wrote:

Contesto brevemente a esto porque me ha pasado algo similar en la 11.3.

Debido a un bug que tengo abierto (por poco tiempo, parece que el
problema ya está detectado) he tenido que instalar un kernel desde el
repo KOTD (2.6.35).

Bueno, pues no había forma de hacerlo desde YaST, o al menos no una forma
"evidente" :-/

(mencionar que estaba con el gestor de paquetes de YaST de GNOME -gtk),
que lo han cambiado bastante con respecto a la versión 11.2, pero no
logro hacerme con él, no entiendo del todo bien ese gestor).

Ni yo. Por eso arranco el de qt. Ojo, no hace falta tener instalado el qt
entero para hacerlo. Se ve
un poco feo, pero funciona perfectamente.

yast2 --qt sw_single u online_update.

Hay algunos que cambian la configuración para que siempre sea el del qt el que
salga, pero también
sé un truco para que todo el yast sea el de gtk excepto el manejador de
paquetes que sea el del qt.
Pero ultimamente prefiero la linea de arriba para elegir.


Añado el repo, lo habilito, lo actualizo y le doy una prioridad de 50
(para que tenga preferencia sobre el kernel del repo /oss). Aún así, no
me muestra el kernel del repo KOTD sino el del /oss, que ya tengo
instalado :-?

Hay unos tabs arriba para ver los updates, lo que está instalado, o todo. Según
la que uses, las
opciones que puedes activar cambian.


Veo que hay una opción en los menús que dice algo así como "permitir
cambio de proveedor", así que lo activo, reinicio el gestor de paquetes
(por si acaso) pero me vuelve a presentar el kernel que ya tengo
instalado del repo /oss.

Pues vaya.

Pulsando sobre el kernel ya instalado, veo en la parte de abajo (esta
zona está muy mal diseñada en la interfaz gtk, se me voy poca información
y es -o debe ser- una de las partes más importantes) que hay una opción
para cambiar el paquete. Le digo que quiero "cambiar" al kernel superior
pero se generan un montón de conflictos (hay paquetes ya instalados que
quieren el kernel antiguo, otros paquetes que se van a instalar -sin
venir a cuento- y las resoluciones que me ofrece no me convencen).

Cancelo porque no lo veo claro.

Buf.


Y pienso... "eh, yo no quiero 'sustituir' el kernel sino 'añadir' otro
¿cómo lo hago desde YaST?" Pues no logré encontrar la opción, así que
recordé que alguna vez estuvimos comentando esto en la lista, por lo que
modifiqué el archivo de configuración de zypper para usar la opción de
"multiversion" y tiré del comando "rpm -i" (primero con su consabido --
test para ver que no había problemas) y listo. Ni una queja, se instaló
el kernel, se configuro él solito, se añadió a GRUB la línea
correspondiente en el menu.lst y arranqué con el nuevo kernel sin
problemas.

Je, has hecho lo mismo que he hecho yo. Aunque a mi se me olvidó lo del zypper,
con el comando rpm
no es necesario.


Para resumir, que no me pareció muy claro el sistema de administración de
paquetes, aunque también puede ser por falta de práctica O:-)

Les pasa a muchos, incluyéndome a mi.

Ya te digo, en esos casos usa el gestor del qt, aunque no tengas instalado el
kde (ni falta que hace).

- --
Cheers,
Carlos E. R.
(from 11.2 x86_64 "Emerald" at Elessar)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkxcn5QACgkQU92UU+smfQUmAQCfaBHqNGo0EWtqL5BowXUjT3bT
QqAAnj/cUiHFNj4VAJMXtR5x1TkOapE7
=Oa6v
-----END PGP SIGNATURE-----
--
Para dar de baja la suscripción, mande un mensaje a:
opensuse-es+unsubscribe@xxxxxxxxxxxx
Para obtener el resto de direcciones-comando, mande
un mensaje a:
opensuse-es+help@xxxxxxxxxxxx

< Previous Next >