Mailinglist Archive: opensuse-es (1608 mails)

< Previous Next >
Re: [opensuse-es] Gestión de paquetes desde Gnome
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Tue, 4 Nov 2008 14:49:50 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0811041406190.4983@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Content-ID: <alpine.LSU.2.00.0811041423080.4983@xxxxxxxxxxxxxxxx>


El 2008-11-04 a las 13:31 +0100, Camaleón escribió:

Hola,

No me aclaro con el módulo de yast de "software management" desde gnome.

¡Ni yo!

Con la versión --qt y --ncurses existe una opción para seleccionar
todos los paquetes y marcar para actualizar aquéllos que tengan alguna
versión superior disponible.

Esta opción no la veo ahora que estoy en Gnome :-?

Pues no uses la versión de gnome, usa la de kde. Yo estoy haciendo eso, arrancandolo con -qt, que se puede hacer permanente en sysconfig.

Y hay otro truco, a ver si lo localizo...

[...]

Edita /sbin/yast2. ¡Sin miedo! :-p

Busca la función select_gui_frontend()

Encontrarás esto al final de la función:

if [ "$WANTED_GUI" = "qt" ]; then
if check_qt; then
SELECTED_GUI=qt
else
echo >&2 "Qt GUI wanted but not found, falling back to ncurses."
fi
elif [ "$SELECTED_GUI" != "gtk" -a "$WANTED_GUI" != "ncurses" ]; then
echo >&2 "Unknown GUI '$WANTED_GUI', falling back to ncurses."
fi


Añade justo antes de ese párrafo:

#ElMenda, per https://bugzilla.novell.com/show_bug.cgi?id=337636
# https://bugzilla.novell.com/show_bug.cgi?id=340895
if [ "$module" = "sw_single" ] || [ "$module" = "online_update" ]; then
WANTED_GUI="qt"
fi


Lo que ese parche consigue es que el yast se ejecutase en la versión gtk si estás en gnome, excepto los dos modulos de manejo de paquetes, que lo hacen en la versión qt estés donde estés (salvo en texto).

Y a la porra ese módulo :-P


Lo siento por los chicos de Novell que lean esto, pero es que la versión del módulo de manejador de paquetes en gnome es infumable. IMO, claro. Pero sospecho no ser el único ;-)


- -- Saludos
Carlos E.R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkkQUwAACgkQtTMYHG2NR9WJlwCfX61CEWkjoZJ9D8ObpLQdk+WT
kU0An2rdXErc4cFoSiwZ3UpIcVLW6WIm
=zGdj
-----END PGP SIGNATURE-----
< Previous Next >
Follow Ups
References