Mailinglist Archive: opensuse-es (1608 mails)

< Previous Next >
Re: [opensuse-es] Instalar correctamente gnome y kde en openSUSE
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Sat, 1 Nov 2008 19:12:01 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0811011853250.5408@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



El 2008-11-01 a las 10:39 -0400, Bismark Castilla Monzon escribió:

hola, como he mencionado anteriormente hace poco que uso openSUSE y aun tengo algunas dudas. cuando instale openSUSE 11.0 que viene con kde 4.0 quice instalar kde 4.1.2 y use un .ymp que me encontre en el sitio de kde, estuve mirando en sus lineas y vi que instalaban varios paquetes es decir que no tiene un metapaquete como ubuntu por ejemplo que se instala apt-get install kubuntu-desktop, al igual que gnome(apt-get install ubuntu-desktop).

Mi duda radica en como instalar correctamente los entornos de escritorios en openSUSE, algo equivalente a ubuntu(como usuario al fin que era), por ejemplo lo equivalente a:

apt-get install kubuntu-desktop
apt-get install ubuntu-desktop
apt-get install xubuntu-desktop

existen meta paquetes para esto en openSUSE?

A ver.

En vez de apt sería "zypper", con patrones: puedes listarlos con "zypper pt", y hay unos cuantos de kde4. O bien puedes mirarlo con la herramienta "yast", que te los muestra gráficamente y los elijes con el ratón.

Por otro lado, no podrías tener kde 4.0 y 4.1 instalados al mismo tiempo, no están preparados para eso. Un kde de la 3 y otro de la 4, sí.

Además, tenemos los llamados "repositorios", que son listas de paquetes. Con zypper los puedes ver con "zypper lr", mientras que en Yast hay una herramienta gráfica para añadir o quitar repositorios;, y precisamente hay algunos que están destinados precisamente al kde4.

En <http://download.opensuse.org/repositories/> están un montón. Hay tres oficiales: el oss, non-oss, y update. El resto no lo son, son de la comunidad, aunque bastantes de ellos están mantenidos por la misma gente que lleva los paquetes oficiales.

En la página <http://en.opensuse.org/Additional_YaST_Package_Repositories>
están listados los importantes. En <http://en.opensuse.org/KDE/Repositories> están los de KDE. Verás que están divididos en

1 KDE 3.5.x
2 KDE 4.0.x 3 KDE 4.1 Factory Development
4 KDE Trunk Development (unstable)

Si no tienes web, dilo y te enviamos la página.

Finalmente, están los .ymp. Son ficheros que activan el "One Click Install" en Yast. En <http://en.opensuse.org/Standards/One_Click_Install> tienes la definición. Haciendo click en un enlace de a un fichero de esos llama a un módulo del Yast que automáticamente se encarga de añadir uno o varios repositorios, y bajarse algunos paquetes de esos repositorios.

Así, por ejemplo, si alguien dice: "no me funciona el multimedia, no puedo ver películas", pues le decimos que haga click en <http://opensuse-community.org/Restricted_Formats/11.0>, seleccionando kde o gnome, y automáticamente se instalará la parte de multimedia de dudosa legalidad que Novell no puede albergar en sus propios repositorios ;-)


¿Te vale eso? :-)


- -- Saludos
Carlos E.R.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkkMm/MACgkQtTMYHG2NR9W4TgCfQoo/bpXRPP0G5p5opDjJNoKA
X8gAn31bd0MilUEBYC+5F3aFijAnmpDx
=Bx5p
-----END PGP SIGNATURE-----
< Previous Next >