Mailinglist Archive: opensuse-doc (32 mails)

< Previous Next >
Re: [opensuse-doc] Re: Issues with building Novell documentation
  • From: Nikolay Derkach <nderkach@xxxxxxxxx>
  • Date: Wed, 15 Aug 2007 14:06:43 +0400
  • Message-id: <200708151406.43657.nderkach@xxxxxxxxx>
Hi Thomas,

В сообщении от Wednesday 15 August 2007 11:26:32 Thomas Schraitle написал(а):
> I checked out your files from svn://svn.team.org.ru/trunk/merged/ and
> build all books with XEP some with FOP and they work.
>
> I guess there are two possibilities:
>
> 1. Missing Packages or Wrong Versions
> There is a bug related to SVG in the 0.95 release of dia (published in
> 10.2). In my repository [1] you can find a patched version from
> Berthold. Please check your package versions and compare it with the
> following list:
>
> $ rpm -q susedoc inkscape transfig ImageMagick xml-commons-resolver
> docbook-xsl-stylesheets svg-dtd freefont agfa-fonts fop dia
>
>   susedoc-4.2_20070813-1
>   inkscape-0.44.1-26.2
>   transfig-3.2.5_alpha7-1
>   ImageMagick-6.3.0.0-27.6
>   xml-commons-resolver-1.1-43
>   docbook-xsl-stylesheets-1.73.0-2
>   svg-dtd-20030114-192
>   freefont-0.20060718-28
>   agfa-fonts-2003.03.19-53
>   fop-0.93-2.1
>   dia-0.96.1-5.1
>
>
> 2. Old SVG Graphics
> Did you try a "make clean"? If make finds an already processed SVG
> graphic, it will not create it from the original source. For this
> reason remove some old files and rebuild the book from scratch.
> I had this bug last time too but I am pretty sure it is fixed now.
>
>
> The last error about fop-config.xml looks really strange but I think
> is has something to do with one of the issues before.
>
>
> Hope this helps,
> Tom
>
>
> ----
> [1] http://software.opensuse.org/download/home:/thomas-schraitle/

Thanks, some of those packages were indeed not installed.

susedoc-4.2_20070813-2.1
inkscape-0.45.1-46
transfig-3.2.5-7
ImageMagick-6.3.5.3-10
xml-commons-resolver-1.1-98
docbook-xsl-stylesheets-1.73.0-3.3
package svg-dtd is not installed
freefont-0.20060718-77
agfa-fonts-2003.03.19-51
fop-0.93-11
dia-0.96.1-6.1

I couln't find svg-dtd, but seems that it's provided by svg-schema

And finally the same error :(

-- 
Regards, Nikolay Derkach
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-doc+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-doc+help@xxxxxxxxxxxx

< Previous Next >