Mailinglist Archive: opensuse-de (1852 mails)

< Previous Next >
Re: Grub installieren
  • From: Niemand <lists@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Fri, 19 May 2006 14:49:14 +0200
  • Message-id: <200605191449.14873.lists@xxxxxxxxxxxxxxxxxxxxxxx>
On Sunday 14 May 2006 20:56, Helga Fischer wrote:
> Hallo David,

hi,

sry das ich erst jetzt schreibe

> Am Sonntag 14 Mai 2006 20:28 schrieb David Haller:
> > Am Son, 14 Mai 2006, Helga Fischer schrieb:
> > >Susi 10.0 installiert, gleich noch ├╝bers Netz upgedatet und nun
> > > kommt der GRUB (und LILO) nicht mit dem Booten zurecht, sprich,
> > > GRUB haut mir den Bildschirm voller Neunen.
> >
> > Beschreib mal deine Partitionierung
>
> /dev/hda2 / xfs defaults 1 1
> /dev/hda1 /boot ext2 acl,user_xattr 1 2
> /dev/hdc1 /home xfs defaults 1 2
> /dev/hda9 /opt xfs defaults 1 2
> /dev/hdc5 /srv xfs defaults 1 2
> /dev/hda8 /tmp reiserfs acl,user_xattr 1 2
> /dev/hda6 /usr xfs defaults 1 2
> /dev/hda7 /var xfs defaults 1 2
> /dev/hda5 swap swap defaults 0 0
> [...]
>
> Das reiser ist ein Versehen :((; die etwas seltsame Reihenfolge hat
> YaST fabriziert.
>
> > und zeig deine
> > /boot/grub/menu.lst,
>
> # Modified by YaST2. Last modification on So Mai 14 17:36:48 CEST
> 2006
>
> color white/blue black/light-gray
> default 0
> timeout 8
> gfxmenu (hd0,0)/message
>
> ###Don't change this comment - YaST2 identifier: Original name:
> linux###
> title SUSE LINUX 10.0
> root (hd0,0)
> kernel /vmlinuz root=/dev/hda2 vga=0x317 selinux=0
> resume=/dev/hda5 splash=silent showopts
> initrd /initrd
>
> ###Don't change this comment - YaST2 identifier: Original name:
> floppy###
> title Diskette
> chainloader (fd0)+1
>
> ###Don't change this comment - YaST2 identifier: Original name:
> failsafe###
> title Failsafe -- SUSE LINUX 10.0
> root (hd0,0)
> kernel /vmlinuz root=/dev/hda2 vga=normal showopts ide=nodma
> apm=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off 3
> initrd /initrd
>
> ###Don't change this comment - YaST2 identifier: Original name:
> memtest86###
> title Speichertest
> kernel (hd0,0)/memtest.bin
>
> > /boot/grub/device.map
>
> (fd0) /dev/fd0
> (hd1) /dev/hdc
> (hd0) /dev/hda
>
> hda ist die erste Festplatte, hdc die zweite
>
> > und die /etc/grub.conf
>
> root (hd0,0)
> install --stage2=/boot/grub/stage2 /grub/stage1 (hd0,0) /grub/stage2
> 0x8000 (hd0,0)/grub/menu.lst
> install --stage2=/boot/grub/stage2 /grub/stage1 (hd0) /grub/stage2

grub > help install:
install [--stage2=STAGE2_FILE] [--force-lba[=off]] STAGE1 [d] DEVICE STAGE2
[ADDR] [p] [CONFIG_FILE] [REAL_CONFIG_FILE]

grub> help setup
setup: setup [--prefix=DIR] [--stage2=STAGE2_FILE] [--force-lba[=off]]
INSTALL_DEVICE [IMAGE_DEVICE]

die stage 1 muss bei install angegeben werden (wurde in dem thread ja auch
irgendwo geraetselt). allerdings nicht bei setup. der befehl macht des
selbstaendig. er macht auch noch einiges mehr deswegen mein vorschlag:

grub.conf:
setup --stage2=/boot/grub/stage2 (hd0,0) (hd0,0)
quit

> 0x8000 (hd0,0)/grub/menu.lst
> quit
>
> (Die habe ich noch nie gebraucht).

doch, als bei der installation dein bootloader installiert wurde. probier
folgendes mit der neuen konfig:
rescue system anwerfen




#alles mounten
mount /dev/hda2 /mnt
mount /dev/hda1 /mnt/boot
mount /dev/hdc1 /mnt/home
mount /dev/hda9 /mnt/opt
mount /dev/hdc5 /mnt/srv
mount /dev/hda8 /mnt/tmp
mount /dev/hda6 /mnt/usr
mount /dev/hda7 /mnt/var
#boah hast du viel *schreib schreib XD
mount --bind /dev /mnt/dev
mount -t sysfs /sys /mnt/sys
mount -t proc /proc/ /mnt/proc
chroot /mnt
#nun aendern
vi /etc/grub.conf
#grub installieren
cat /etc/grub.conf | grub
#chroot beenden
exit
#neu starten
init 6

hoffe das ist das behebt problem.

mfg michael
> Danke,
> Helga
--
Antorten bitte an die Mailingliste

PM's an Niemand_at_tbasnoopy.homelinux.net

< Previous Next >