Mailinglist Archive: opensuse-de (4938 mails)

< Previous Next >
Re: Problem mit libc
  • From: bjkro@xxxxxx (Bjoern Krombholz)
  • Date: Tue May 09 13:11:33 2000
  • Message-id: <39180E85.745F3B72@xxxxxx>



Florian Miedniak wrote:

Hallo!

Ich habe folgendes Problem:
Der Bootvorgang wird mit der Meldung abgebrochen:
sh: error in loading shared libraries
: undefined symbol: __register_frame_info

Ich habe kurz bevor dieser Fehler auftauchte versehentlich den Inhalt
von /usr/i486-linux-libc5/lib nach /lib und nach /usr/lib kopiert. Kann
es damit zusammenhaengen, dass sich jetzt libc6 und libc5 "beissen" ?
Wie
kann man das wieder beheben ?

Boote einfach mal von CD und installiere die Pakete:
libc
shlibs
neu [R] - danach sollte zumindest wieder alles funktionieren.
Bei Bedarf kannst du dann evtl. noch alte libs aus dem Verzeichnis
loeschen.

rpm -qa -l | grep /usr/lib/ |cut -c10- | grep -v / |sort > usrlib
rpm -qa -l | grep /usr/ |cut -c6- | grep -v / |sort > lib

eingeben, jetzt steht in ./usrlib alles, was laut RPM-Datenbank
in /usr/lib/ sein müßte, in ./lib alles, was nach /lib gehört.
Das kannst du vergleichen mit dem, was sich tatsächlich in den
Verzeichnissen befindet.
Das ist natürlich nur verläßlich, wenn du zusätzlich nichts in diese
Verzeichnisse installiert hast.

Viel Spaß ;)
Björn

---------------------------------------------------------------------
To unsubscribe, e-mail: suse-linux-unsubscribe@xxxxxxxx
For additional commands, e-mail: suse-linux-help@xxxxxxxx

< Previous Next >
Follow Ups
References