Mailinglist Archive: opensuse-de (4938 mails)

< Previous Next >
Re: mod_jserv.so und apache: [warn] ... EAPI ... might crash?
  • From: christian.ernst@xxxxxxxxxxxxxxxxxxxxxxxx (Christian Ernst)
  • Date: Tue May 02 06:09:29 2000
  • Message-id: <390E7119.BCC63AF6@xxxxxxxxxxxx>



Moin !

Hermann Flacke wrote:

Beim Starten des Apache erhalte ich die Fehlermeldung

"Starting service httpd [warn] Loaded DSO /usr/lib/apache/mod_jserv.so
uses plain Apache 1.3 API, this module might crash under EAPI! (please
recompile it with -DEAPI)"

Im Einsatz:
- Apache 1.3.12-7 (SuSE 6.4)
- mod_ssl 2.6.2-1.3.12 (TGZ, www.mod_ssl.org)
- ApacheJServ 1.1.2 (RPM, www.apache.org)
- SuSE 6.4 mit letzten Patches.

Nun ich habe das selbe Prob gehabt unter SuSE 6.3
Doch warum so umstaendlich Apache kompilieren !?!?!??
Kommt der Berg nicht zum Elefanten dann muss halt der Berg zum Elefanten
kommen..
-> also mod_jserv aus dem Tomcat neucompilieren,spart einiges an Arbeit.

1. fetch the 3.1 jakarta sources and change to:

../jakarta-tomcat/native/apache/jserv

2. compile with the apache tools apxs:
apxs -c mod_jserv jserv*.c

3. ich musste in der tomcat.conf noch folgenden eintrag zufuegen damit
es funzt:
ApjServLogFile /var/log/tomcat.log

mfg
christian

p.s.
An alle fleissigen SuSE's die dies eifrig mitlesen..
Wie ist es mit ner jakarta-tomcat 3.1 Integration in der SuSE 6.5 ?!?

---------------------------------------------------------------------
To unsubscribe, e-mail: suse-linux-unsubscribe@xxxxxxxx
For additional commands, e-mail: suse-linux-help@xxxxxxxx

< Previous Next >
References