Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit kpty for openSUSE:Factory
Hello community,

here is the log from the commit of package kpty for openSUSE:Factory checked in
at 2019-04-19 21:24:03
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kpty (Old)
and /work/SRC/openSUSE:Factory/.kpty.new.5536 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kpty"

Fri Apr 19 21:24:03 2019 rev:66 rq:695246 version:5.57.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/kpty/kpty.changes 2019-03-21
09:48:02.314873511 +0100
+++ /work/SRC/openSUSE:Factory/.kpty.new.5536/kpty.changes 2019-04-19
21:24:05.019851264 +0200
@@ -1,0 +2,10 @@
+Sun Apr 14 20:21:44 UTC 2019 - lbeltrame@xxxxxxx
+
+- Update to 5.57.0
+ * New feature release
+ * For more details please see:
+ * https://www.kde.org/announcements/kde-frameworks-5.57.0.php
+- Changes since 5.56.0:
+ * make it compile without foreach
+
+-------------------------------------------------------------------

Old:
----
kpty-5.56.0.tar.xz

New:
----
kpty-5.57.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kpty.spec ++++++
--- /var/tmp/diff_new_pack.n2SHYJ/_old 2019-04-19 21:24:06.215852787 +0200
+++ /var/tmp/diff_new_pack.n2SHYJ/_new 2019-04-19 21:24:06.223852797 +0200
@@ -17,14 +17,14 @@


%define lname libKF5Pty5
-%define _tar_path 5.56
+%define _tar_path 5.57
# Full KF5 version (e.g. 5.33.0)
%{!?_kf5_version: %global _kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_kf5_bugfix_version: %define _kf5_bugfix_version %(echo %{_kf5_version} |
awk -F. '{print $1"."$2}')}
%bcond_without lang
Name: kpty
-Version: 5.56.0
+Version: 5.57.0
Release: 0
Summary: Primitives to interface with pseudo terminal devices
License: LGPL-2.1-or-later

++++++ kpty-5.56.0.tar.xz -> kpty-5.57.0.tar.xz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/kpty-5.56.0/.gitignore new/kpty-5.57.0/.gitignore
--- old/kpty-5.56.0/.gitignore 1970-01-01 01:00:00.000000000 +0100
+++ new/kpty-5.57.0/.gitignore 2019-04-07 09:31:35.000000000 +0200
@@ -0,0 +1,21 @@
+# Ignore the following files
+*~
+*.[oa]
+*.diff
+*.kate-swp
+*.kdev4
+.kdev_include_paths
+*.kdevelop.pcs
+*.moc
+*.moc.cpp
+*.orig
+*.user
+.*.swp
+.swp.*
+Doxyfile
+Makefile
+avail
+random_seed
+/build*/
+CMakeLists.txt.user*
+*.unc-backup*
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/kpty-5.56.0/CMakeLists.txt
new/kpty-5.57.0/CMakeLists.txt
--- old/kpty-5.56.0/CMakeLists.txt 2019-03-02 14:46:50.000000000 +0100
+++ new/kpty-5.57.0/CMakeLists.txt 2019-04-07 09:31:35.000000000 +0200
@@ -1,11 +1,11 @@
cmake_minimum_required(VERSION 3.5)

-set(KF5_VERSION "5.56.0") # handled by release scripts
-set(KF5_DEP_VERSION "5.56.0") # handled by release scripts
+set(KF5_VERSION "5.57.0") # handled by release scripts
+set(KF5_DEP_VERSION "5.57.0") # handled by release scripts
project(KPty VERSION ${KF5_VERSION})

include(FeatureSummary)
-find_package(ECM 5.56.0 NO_MODULE)
+find_package(ECM 5.57.0 NO_MODULE)
set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake
Modules." URL
"https://projects.kde.org/projects/kdesupport/extra-cmake-modules";)
feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND
FATAL_ON_MISSING_REQUIRED_PACKAGES)

@@ -57,6 +57,7 @@
if (IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/po")
ki18n_install(po)
endif()
+add_definitions(-DQT_NO_FOREACH)
add_subdirectory( src )
if (BUILD_TESTING)
add_subdirectory( autotests )
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/kpty-5.56.0/po/id/kpty5.po
new/kpty-5.57.0/po/id/kpty5.po
--- old/kpty-5.56.0/po/id/kpty5.po 2019-03-02 14:46:50.000000000 +0100
+++ new/kpty-5.57.0/po/id/kpty5.po 2019-04-07 09:31:35.000000000 +0200
@@ -16,7 +16,7 @@
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=2; plural=n != 1;\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
"X-Generator: Lokalize 2.0\n"

#: kptydevice.cpp:324
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/kpty-5.56.0/po/te/kpty5.po
new/kpty-5.57.0/po/te/kpty5.po
--- old/kpty-5.56.0/po/te/kpty5.po 2019-03-02 14:46:50.000000000 +0100
+++ new/kpty-5.57.0/po/te/kpty5.po 2019-04-07 09:31:35.000000000 +0200
@@ -22,8 +22,7 @@
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"X-Generator: Lokalize 1.5\n"
-"Plural-Forms: nplurals=5; plural=n==1 ? 0 : n==2 ? 1 : n<7 ? 2 : n<11 ? 3 : "
-"4;\n"
+"Plural-Forms: nplurals=2; plural=(n != 1)\n"

#: kptydevice.cpp:324
#, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/kpty-5.56.0/po/zh_CN/kpty5.po
new/kpty-5.57.0/po/zh_CN/kpty5.po
--- old/kpty-5.56.0/po/zh_CN/kpty5.po 2019-03-02 14:46:50.000000000 +0100
+++ new/kpty-5.57.0/po/zh_CN/kpty5.po 2019-04-07 09:31:35.000000000 +0200
@@ -15,7 +15,7 @@
"Project-Id-Version: kdeorg\n"
"Report-Msgid-Bugs-To: http://bugs.kde.org\n";
"POT-Creation-Date: 2018-08-16 09:05+0200\n"
-"PO-Revision-Date: 2019-02-20 23:16\n"
+"PO-Revision-Date: 2019-03-07 09:22\n"
"Last-Translator: guoyunhe <i@xxxxxxxxxxx>\n"
"Language-Team: Chinese Simplified\n"
"Language: zh_CN\n"


< Previous Next >
This Thread
  • No further messages