Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit package-update-indicator for openSUSE:Factory
Hello community,

here is the log from the commit of package package-update-indicator for
openSUSE:Factory checked in at 2019-04-17 10:09:17
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/package-update-indicator (Old)
and /work/SRC/openSUSE:Factory/.package-update-indicator.new.17052 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "package-update-indicator"

Wed Apr 17 10:09:17 2019 rev:2 rq:694719 version:2

Changes:
--------
---
/work/SRC/openSUSE:Factory/package-update-indicator/package-update-indicator.changes
2018-07-12 09:21:15.382594024 +0200
+++
/work/SRC/openSUSE:Factory/.package-update-indicator.new.17052/package-update-indicator.changes
2019-04-17 10:09:29.794858097 +0200
@@ -1,0 +2,30 @@
+Tue Apr 16 07:01:16 UTC 2019 - Maurizio Galli <maurizio.galli@xxxxxxxxx>
+
+- Fix Obsoletes: pk-update-icon <= 3
+
+-------------------------------------------------------------------
+Sun Apr 14 16:07:12 UTC 2019 - Maurizio Galli <maurizio.galli@xxxxxxxxx>
+
+- Changed to more appropriate Obsoletes: pk-update-icon <= 2
+
+-------------------------------------------------------------------
+Fri Apr 12 07:50:54 UTC 2019 - Maurizio Galli <maurizio.galli@xxxxxxxxx>
+
+- Added Obsoletes: pk-update-icon
+
+-------------------------------------------------------------------
+Sun Apr 7 11:13:32 UTC 2019 - Maurizio Galli <maurizio.galli@xxxxxxxxx>
+
+- Update to version 2:
+ * Add keywords to desktop files
+ * Fix typo in notification message
+ * Do not run glib-compile-schemas if schemas are installed into staging
directory
+ * Set application indicator title
+ * Add note for vendors on how to override default settings
+
+- Added BuildRequires: clang
+- Spec file cleanup:
+ - Changed URL and Source to https://
+ - Use more appropriate macros such as %autosetup and %make_build
+
+-------------------------------------------------------------------

Old:
----
package-update-indicator-1.tar.gz

New:
----
package-update-indicator-2.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ package-update-indicator.spec ++++++
--- /var/tmp/diff_new_pack.ZMEpRk/_old 2019-04-17 10:09:31.794860406 +0200
+++ /var/tmp/diff_new_pack.ZMEpRk/_new 2019-04-17 10:09:31.822860439 +0200
@@ -1,7 +1,7 @@
#
# spec file for package package-update-indicator
#
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2018 B1 Systems GmbH, Vohburg, Germany.
#
# All modifications and additions to the file contributed by third parties
@@ -13,12 +13,12 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name: package-update-indicator
-Version: 1
+Version: 2
Release: 0
Summary: Package update status notification applet
License: MIT
@@ -26,6 +26,7 @@
URL:
https://code.guido-berhoerster.org/projects/package-update-indicator
Source:
https://code.guido-berhoerster.org/projects/package-update-indicator/downloads/%{name}-%{version}.tar.gz
Source1: 10_opensuse_update_command.gschema.override
+BuildRequires: clang
BuildRequires: docbook5-xsl-stylesheets
BuildRequires: gettext >= 0.19
BuildRequires: libxml2-tools
@@ -37,6 +38,7 @@
BuildRequires: pkgconfig(packagekit-glib2) >= 0.8.17
BuildRequires: pkgconfig(polkit-gobject-1) >= 0.105
BuildRequires: pkgconfig(upower-glib) >= 0.99.0
+Obsoletes: pk-update-icon <= 3
Recommends: gnome-packagekit

%description
@@ -45,10 +47,10 @@
%lang_package

%prep
-%setup -q
+%autosetup

%build
-make %{?_smp_mflags} prefix=%{_prefix} GLIB_COMPILE_SCHEMAS=:
CFLAGS="%{optflags}"
+%make_build prefix=%{_prefix} GLIB_COMPILE_SCHEMAS=: CFLAGS="%{optflags}"

%install
%make_install prefix=%{_prefix} GLIB_COMPILE_SCHEMAS=:

++++++ package-update-indicator-1.tar.gz -> package-update-indicator-2.tar.gz
++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/Makefile
new/package-update-indicator-2/Makefile
--- old/package-update-indicator-1/Makefile 2018-07-06 14:29:58.000000000
+0200
+++ new/package-update-indicator-2/Makefile 2018-12-08 10:03:54.000000000
+0100
@@ -24,7 +24,7 @@
PACKAGE = package-update-indicator
APPLICATION_ID = org.guido-berhoerster.code.package-update-indicator
PREFS_APPLICATION_ID =
org.guido-berhoerster.code.package-update-indicator.preferences
-VERSION = 1
+VERSION = 2
DISTNAME = $(PACKAGE)-$(VERSION)
AUTHOR = Guido Berhoerster
BUG_ADDRESS = guido+pui@xxxxxxxxxxxxxxxx
@@ -214,7 +214,7 @@
$(MSGFMT) --output $@ $<

%.desktop: %.desktop.in
- $(MSGFMT) --desktop --template $< -d po --output $@
+ $(MSGFMT) --desktop --keyword 'Keywords' --template $< -d po --output $@

$(foreach section,1 2 3 4 5 6 7 8 9,$(eval $(call
generate-manpage-rule,$(section))))

@@ -230,8 +230,9 @@
$(INSTALL.data) $${schema} \
$(DESTDIR)$(datadir)/glib-2.0/schemas/$${schema}; \
done
- [ -n "$(GSETTINGS_SCHEMAS)" ] && \
- $(GLIB_COMPILE_SCHEMAS) $(datadir)/glib-2.0/schemas
+ if [ -n "$(GSETTINGS_SCHEMAS)" ] && [ -z "$(DESTDIR)" ]; then \
+ $(GLIB_COMPILE_SCHEMAS) $(datadir)/glib-2.0/schemas; \
+ fi
$(INSTALL.data) $(AUTOSTART_FILE) \
$(DESTDIR)$(xdgautostartdir)/$(AUTOSTART_FILE)
for desktop_file in $(DESKTOP_FILES); do \
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/NEWS
new/package-update-indicator-2/NEWS
--- old/package-update-indicator-1/NEWS 2018-07-06 14:29:58.000000000 +0200
+++ new/package-update-indicator-2/NEWS 2018-12-08 10:09:51.000000000 +0100
@@ -1,6 +1,12 @@
News
====

+package-update-indicator 2 (2018-12-08T10:09:35+01:00)
+------------------------------------------------------
+
+- Add keywords to desktop files
+- Fix typo in notification message
+
package-update-indicator 1 (2018-07-06T14:21:28+02:00)
------------------------------------------------------

diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/README
new/package-update-indicator-2/README
--- old/package-update-indicator-1/README 2018-07-06 14:29:58.000000000
+0200
+++ new/package-update-indicator-2/README 2018-07-10 13:06:03.000000000
+0200
@@ -31,6 +31,15 @@
Makefile for any macros you may need to override depending on the used
toolchain and operating system.

+By default the "update-command" setting is empty which means users will not be
+offered to install updates from a notification or the indicator menu.
+Distribution vendors may override this or any other default setting by
+installing a vendor override file alongside the schema file. An example for
+is distributed with package-update-indicator, see the file
+"examples/10_vendor_update_command.gschema.override.example". For details on
+how to install a vendor override file see the manual page for
+glib-compile-schemas.
+
By default, all files will be installed under the "/usr/local" directory, a
different installation path prefix can be set via the `prefix` macro. In
addition, a second path prefix can be specified via the `DESTDIR` macro which
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore'
old/package-update-indicator-1/examples/10_vendor_update_command.gschema.override

new/package-update-indicator-2/examples/10_vendor_update_command.gschema.override
---
old/package-update-indicator-1/examples/10_vendor_update_command.gschema.override
1970-01-01 01:00:00.000000000 +0100
+++
new/package-update-indicator-2/examples/10_vendor_update_command.gschema.override
2018-07-10 09:25:23.000000000 +0200
@@ -0,0 +1,2 @@
+[org.guido-berhoerster.code.package-update-indicator]
+update-command='/usr/bin/gpk-update-viewer'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/local.mk
new/package-update-indicator-2/local.mk
--- old/package-update-indicator-1/local.mk 1970-01-01 01:00:00.000000000
+0100
+++ new/package-update-indicator-2/local.mk 2018-06-08 21:55:48.000000000
+0200
@@ -0,0 +1,3 @@
+CC = clang -std=c99
+CFLAGS = -O2 -ggdb3 -Wall -Wextra -Wno-unused-parameter
#-fsanitize=undefined,address
+LDFLAGS = #-fsanitize=undefined,address
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore'
old/package-update-indicator-1/org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in

new/package-update-indicator-2/org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in
---
old/package-update-indicator-1/org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in
2018-07-06 14:29:58.000000000 +0200
+++
new/package-update-indicator-2/org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in
2018-12-08 09:50:39.000000000 +0100
@@ -2,6 +2,7 @@
Name=Package Update Indicator Preferences
GenericName=Package Update Indicator Preferences
Comment=Edit the Preferences for Package Update Indicator
+Keywords=updates;preferences;
Icon=preferences-other
Exec=package-update-indicator-prefs
Terminal=false
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/po/de.po
new/package-update-indicator-2/po/de.po
--- old/package-update-indicator-1/po/de.po 2018-07-06 14:29:58.000000000
+0200
+++ new/package-update-indicator-2/po/de.po 2018-12-08 10:01:40.000000000
+0100
@@ -7,7 +7,7 @@
msgstr ""
"Project-Id-Version: package-update-indicator 1\n"
"Report-Msgid-Bugs-To: guido+pui@xxxxxxxxxxxxxxxx\n"
-"POT-Creation-Date: 2018-07-04 13:39+0000\n"
+"POT-Creation-Date: 2018-12-08 08:50+0000\n"
"PO-Revision-Date: 2018-07-06 12:10+0000\n"
"Last-Translator: Guido Berhoerster <guido+pui@xxxxxxxxxxxxxxxx>\n"
"Language-Team: none\n"
@@ -19,7 +19,7 @@

#: org.guido-berhoerster.code.package-update-indicator.desktop.in:3
#: org.guido-berhoerster.code.package-update-indicator.desktop.in:4
-#: package-update-indicator.c:59
+#: package-update-indicator.c:59 pui-application.c:489
msgid "Package Update Indicator"
msgstr "Paketaktualisierungsanzeige"

@@ -69,6 +69,10 @@
msgstr "Bearbeite Einstellungen der Paketaktualisierungsanzeige"

#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:6
+msgid "updates;preferences;"
+msgstr "Aktualisierungen;Updates;Einstellungen;"
+
+#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:7
msgid "preferences-other"
msgstr ""

@@ -112,12 +116,12 @@
msgstr[1] "Softwareaktualisierungen"

#: pui-application.c:239
-msgid "There is a software update avaliable."
+msgid "There is a software update available."
msgstr "Es ist eine Softwareaktualisierung verfügbar."

#: pui-application.c:242
#, c-format
-msgid "There are %u software updates avaliable."
+msgid "There are %u software updates available."
msgstr "Es sind %u Softwareaktualisierungen verfügbar."

#: pui-application.c:247
@@ -160,7 +164,8 @@

#: pui-application.c:276
msgid "The computer has to be restarted for the updates to take effect."
-msgstr "Der Computer muss neu gestarte werden damit die Updates wirksam
werden."
+msgstr ""
+"Der Computer muss neu gestarte werden damit die Updates wirksam werden."

#: pui-application.c:324
msgid "Install Updates"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/po/en.po
new/package-update-indicator-2/po/en.po
--- old/package-update-indicator-1/po/en.po 2018-07-06 14:29:58.000000000
+0200
+++ new/package-update-indicator-2/po/en.po 2018-12-08 09:59:01.000000000
+0100
@@ -7,7 +7,7 @@
msgstr ""
"Project-Id-Version: package-update-indicator 1\n"
"Report-Msgid-Bugs-To: guido+pui@xxxxxxxxxxxxxxxx\n"
-"POT-Creation-Date: 2018-07-04 13:39+0000\n"
+"POT-Creation-Date: 2018-12-08 08:50+0000\n"
"PO-Revision-Date: 2018-07-06 12:10+0000\n"
"Last-Translator: Guido Berhoerster <guido+pui@xxxxxxxxxxxxxxxx>\n"
"Language-Team: none\n"
@@ -19,7 +19,7 @@

#: org.guido-berhoerster.code.package-update-indicator.desktop.in:3
#: org.guido-berhoerster.code.package-update-indicator.desktop.in:4
-#: package-update-indicator.c:59
+#: package-update-indicator.c:59 pui-application.c:489
msgid "Package Update Indicator"
msgstr "Package Update Indicator"

@@ -67,6 +67,10 @@
msgstr "Edit the Preferences for Package Update Indicator"

#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:6
+msgid "updates;preferences;"
+msgstr "updates;preferences;"
+
+#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:7
msgid "preferences-other"
msgstr "preferences-other"

@@ -110,13 +114,13 @@
msgstr[1] "Software Updates"

#: pui-application.c:239
-msgid "There is a software update avaliable."
-msgstr "There is a software update avaliable."
+msgid "There is a software update available."
+msgstr "There is a software update available."

#: pui-application.c:242
#, c-format
-msgid "There are %u software updates avaliable."
-msgstr "There are %u software updates avaliable."
+msgid "There are %u software updates available."
+msgstr "There are %u software updates available."

#: pui-application.c:247
msgid "Important Software Update"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/po/id.po
new/package-update-indicator-2/po/id.po
--- old/package-update-indicator-1/po/id.po 2018-07-06 14:29:58.000000000
+0200
+++ new/package-update-indicator-2/po/id.po 2018-12-08 09:50:58.000000000
+0100
@@ -7,7 +7,7 @@
msgstr ""
"Project-Id-Version: package-update-indicator 1\n"
"Report-Msgid-Bugs-To: guido+pui@xxxxxxxxxxxxxxxx\n"
-"POT-Creation-Date: 2018-07-04 13:39+0000\n"
+"POT-Creation-Date: 2018-12-08 08:50+0000\n"
"PO-Revision-Date: 2018-07-06 12:10+0000\n"
"Last-Translator: Guido Berhoerster <guido+pui@xxxxxxxxxxxxxxxx>\n"
"Language-Team: none\n"
@@ -19,7 +19,7 @@

#: org.guido-berhoerster.code.package-update-indicator.desktop.in:3
#: org.guido-berhoerster.code.package-update-indicator.desktop.in:4
-#: package-update-indicator.c:59
+#: package-update-indicator.c:59 pui-application.c:489
msgid "Package Update Indicator"
msgstr ""

@@ -67,6 +67,10 @@
msgstr ""

#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:6
+msgid "updates;preferences;"
+msgstr ""
+
+#: org.guido-berhoerster.code.package-update-indicator.preferences.desktop.in:7
msgid "preferences-other"
msgstr ""

@@ -110,12 +114,12 @@
msgstr[1] "Pembaharuan-Pembaharuan Perangkat Lunak"

#: pui-application.c:239
-msgid "There is a software update avaliable."
+msgid "There is a software update available."
msgstr "Tersedia satu pembaharuan perangkat lunak."

#: pui-application.c:242
#, c-format
-msgid "There are %u software updates avaliable."
+msgid "There are %u software updates available."
msgstr "Tersedia %u pembaharuan-pembaharuan perangkat lunak."

#: pui-application.c:247
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/package-update-indicator-1/pui-application.c
new/package-update-indicator-2/pui-application.c
--- old/package-update-indicator-1/pui-application.c 2018-07-06
14:29:58.000000000 +0200
+++ new/package-update-indicator-2/pui-application.c 2018-12-08
08:01:52.000000000 +0100
@@ -237,10 +237,10 @@
"Software Updates", (gulong)normal_updates));
if (normal_updates == 1) {
body = g_strdup(_("There is a software update "
- "avaliable."));
+ "available."));
} else {
body = g_strdup_printf(_("There are %u "
- "software updates avaliable."), normal_updates);
+ "software updates available."), normal_updates);
}
break;
case PUI_STATE_IMPORTANT_UPDATES_AVAILABLE:
@@ -486,6 +486,7 @@
self->indicator = app_indicator_new(APPLICATION_ID,
"system-software-update",
APP_INDICATOR_CATEGORY_APPLICATION_STATUS);
+ app_indicator_set_title(self->indicator, _("Package Update Indicator"));

/* get menu from builder and add it to the indicator */
builder = gtk_builder_new_from_resource("/org/guido-berhoerster/code/"


< Previous Next >
This Thread