Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit kwin5 for openSUSE:Factory
Hello community,

here is the log from the commit of package kwin5 for openSUSE:Factory checked
in at 2019-04-04 15:20:13
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kwin5 (Old)
and /work/SRC/openSUSE:Factory/.kwin5.new.3908 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kwin5"

Thu Apr 4 15:20:13 2019 rev:95 rq:690741 version:5.15.4

Changes:
--------
--- /work/SRC/openSUSE:Factory/kwin5/kwin5.changes 2019-03-15
10:50:18.289001931 +0100
+++ /work/SRC/openSUSE:Factory/.kwin5.new.3908/kwin5.changes 2019-04-04
15:24:24.130829862 +0200
@@ -1,0 +2,13 @@
+Tue Apr 2 12:40:58 UTC 2019 - fabian@xxxxxxxxxxxxxx
+
+- Update to 5.15.4
+ * New bugfix release
+ * For more details please see:
+ * https://www.kde.org/announcements/plasma-5.15.4.php
+- Changes since 5.15.3:
+ * Force server-side decoration if no borders are forced by user (kde#405385)
+ * [platforms/x11] Force glXSwapBuffers to block with NVIDIA driver
+ * Properly restore current desktop from session (kde#390295)
+ * [platforms/fbdev] Use a better way to correct activating framebuffer
devices
+
+-------------------------------------------------------------------

Old:
----
kwin-5.15.3.tar.xz
kwin-5.15.3.tar.xz.sig

New:
----
kwin-5.15.4.tar.xz
kwin-5.15.4.tar.xz.sig

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kwin5.spec ++++++
--- /var/tmp/diff_new_pack.JjuEGG/_old 2019-04-04 15:24:27.154830962 +0200
+++ /var/tmp/diff_new_pack.JjuEGG/_new 2019-04-04 15:24:27.154830962 +0200
@@ -21,7 +21,7 @@
%global wayland (0%{?suse_version} >= 1330)
%bcond_without lang
Name: kwin5
-Version: 5.15.3
+Version: 5.15.4
Release: 0
# Full Plasma 5 version (e.g. 5.8.95)
%{!?_plasma5_bugfix: %define _plasma5_bugfix %{version}}
@@ -165,9 +165,6 @@
%setup -q -n kwin-%{version}
%autopatch -p1

-# Needs a newer kdoctools - upstream bug
-rm -r po/id/docs
-
%build
%if 0%{?suse_version} < 1330
# It does not build with the default compiler (GCC 4.8) on Leap 42.x

++++++ kwin-5.15.3.tar.xz -> kwin-5.15.4.tar.xz ++++++
++++ 12008 lines of diff (skipped)



< Previous Next >
This Thread