Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit gpgme for openSUSE:Factory
Hello community,

here is the log from the commit of package gpgme for openSUSE:Factory checked
in at 2019-04-04 12:00:03
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/gpgme (Old)
and /work/SRC/openSUSE:Factory/.gpgme.new.3908 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "gpgme"

Thu Apr 4 12:00:03 2019 rev:76 rq:690263 version:1.13.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/gpgme/gpgme.changes 2019-01-09
09:28:21.529353549 +0100
+++ /work/SRC/openSUSE:Factory/.gpgme.new.3908/gpgme.changes 2019-04-04
12:00:10.569259623 +0200
@@ -1,0 +2,19 @@
+Sun Mar 31 08:55:44 UTC 2019 - Andreas Stieger <andreas.stieger@xxxxxx>
+
+- gpgme 1.13.0:
+ * Support GPGME_AUDITLOG_DIAG for gpgsm
+ * New context flag "trust-model".
+ * Aligned the gpgrt-config code with our other libaries
+ * Auto-check for all installed Python versions
+ * Fixed generating card key in the C++ bindings
+ * Fixed a segv due to bad parameters in genkey
+ * Fixed crash if the plaintext is ignored in a CMS verify
+ * Fixed test suite problems related to dtags
+ * Fixed bunch of python bugs
+ * Several fixes to the Common Lisp bindings
+ * Fixed minor bugs in gpgme-json
+ * Require trace level 8 to dump all I/O data
+ * The compiler must now support variadic macros
+- drop gpgme-key-expirity.patch, included upstream
+
+-------------------------------------------------------------------

Old:
----
gpgme-1.12.0.tar.bz2
gpgme-1.12.0.tar.bz2.sig
gpgme-key-expirity.patch

New:
----
gpgme-1.13.0.tar.bz2
gpgme-1.13.0.tar.bz2.sig

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gpgme.spec ++++++
--- /var/tmp/diff_new_pack.Wy8EoZ/_old 2019-04-04 12:00:11.701260350 +0200
+++ /var/tmp/diff_new_pack.Wy8EoZ/_new 2019-04-04 12:00:11.701260350 +0200
@@ -21,19 +21,18 @@
%bcond_without python2
%bcond_without python3
Name: gpgme
-Version: 1.12.0
+Version: 1.13.0
Release: 0
Summary: Programmatic library interface to GnuPG
License: LGPL-2.1-or-later AND GPL-3.0-or-later
Group: Productivity/Security
-Url: http://www.gnupg.org/related_software/gpgme/
+URL: http://www.gnupg.org/related_software/gpgme/
Source: ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
Source1: ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2.sig
Source2: baselibs.conf
Source3: gpgme.keyring
# used to have a fixed timestamp
Source99: %{name}.changes
-Patch0: gpgme-key-expirity.patch
BuildRequires: gcc-c++
BuildRequires: gpg2 >= 2.0.10
BuildRequires: libassuan-devel >= 2.4.2
@@ -176,7 +175,6 @@

%prep
%setup -q
-%patch0 -p1

%ifarch %{ix86}
sed -i -e '/t-callbacks.py/d' lang/python/tests/Makefile.{am,in}
@@ -255,6 +253,8 @@
%{_bindir}/gpgme-config
%{_datadir}/aclocal/gpgme.m4
%{_includedir}/gpgme.h
+%{_libdir}/pkgconfig/gpgme.pc
+%{_libdir}/pkgconfig/gpgme-glib.pc

%files -n libgpgmepp6
%{_libdir}/libgpgmepp.so.*

++++++ gpgme-1.12.0.tar.bz2 -> gpgme-1.13.0.tar.bz2 ++++++
++++ 53131 lines of diff (skipped)


< Previous Next >
This Thread
  • No further messages