Mailinglist Archive: opensuse-commit (1906 mails)

< Previous Next >
commit rubygem-railties-5_1 for openSUSE:Factory
Hello community,

here is the log from the commit of package rubygem-railties-5_1 for
openSUSE:Factory checked in at 2019-04-01 12:36:26
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-railties-5_1 (Old)
and /work/SRC/openSUSE:Factory/.rubygem-railties-5_1.new.25356 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-railties-5_1"

Mon Apr 1 12:36:26 2019 rev:7 rq:689696 version:5.1.7

Changes:
--------
---
/work/SRC/openSUSE:Factory/rubygem-railties-5_1/rubygem-railties-5_1.changes
2019-03-27 16:17:41.207576235 +0100
+++
/work/SRC/openSUSE:Factory/.rubygem-railties-5_1.new.25356/rubygem-railties-5_1.changes
2019-04-01 12:36:26.313858504 +0200
@@ -1,0 +2,10 @@
+Fri Mar 29 06:13:52 UTC 2019 - Stephan Kulow <coolo@xxxxxxxx>
+
+- updated to version 5.1.7
+ see installed CHANGELOG.md
+
+ ## Rails 5.1.7 (March 27, 2019) ##
+
+ * No changes.
+
+-------------------------------------------------------------------

Old:
----
railties-5.1.6.2.gem

New:
----
railties-5.1.7.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-railties-5_1.spec ++++++
--- /var/tmp/diff_new_pack.fLU5oD/_old 2019-04-01 12:36:27.481859075 +0200
+++ /var/tmp/diff_new_pack.fLU5oD/_new 2019-04-01 12:36:27.493859081 +0200
@@ -24,7 +24,7 @@
#

Name: rubygem-railties-5_1
-Version: 5.1.6.2
+Version: 5.1.7
Release: 0
%define mod_name railties
%define mod_full_name %{mod_name}-%{version}

++++++ railties-5.1.6.2.gem -> railties-5.1.7.gem ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/CHANGELOG.md new/CHANGELOG.md
--- old/CHANGELOG.md 2019-03-13 17:46:05.000000000 +0100
+++ new/CHANGELOG.md 2019-03-28 03:46:15.000000000 +0100
@@ -1,3 +1,8 @@
+## Rails 5.1.7 (March 27, 2019) ##
+
+* No changes.
+
+
## Rails 5.1.6.2 (March 11, 2019) ##

* No changes.
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/rails/application/finisher.rb
new/lib/rails/application/finisher.rb
--- old/lib/rails/application/finisher.rb 2019-03-13 17:46:05.000000000
+0100
+++ new/lib/rails/application/finisher.rb 2019-03-28 03:46:15.000000000
+0100
@@ -125,7 +125,7 @@
initializer :set_routes_reloader_hook do |app|
reloader = routes_reloader
reloader.eager_load = app.config.eager_load
- reloader.execute_if_updated
+ reloader.execute
reloaders << reloader
app.reloader.to_run do
# We configure #execute rather than #execute_if_updated because if
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/rails/application/routes_reloader.rb
new/lib/rails/application/routes_reloader.rb
--- old/lib/rails/application/routes_reloader.rb 2019-03-13
17:46:05.000000000 +0100
+++ new/lib/rails/application/routes_reloader.rb 2019-03-28
03:46:15.000000000 +0100
@@ -5,7 +5,7 @@
class RoutesReloader
attr_reader :route_sets, :paths
attr_accessor :eager_load
- delegate :updated?, to: :updater
+ delegate :execute_if_updated, :execute, :updated?, to: :updater

def initialize
@paths = []
@@ -17,31 +17,15 @@
clear!
load_paths
finalize!
+ route_sets.each(&:eager_load!) if eager_load
ensure
revert
end

- def execute
- ret = updater.execute
- route_sets.each(&:eager_load!) if eager_load
- ret
- end
-
- def execute_if_updated
- if updated = updater.execute_if_updated
- route_sets.each(&:eager_load!) if eager_load
- end
- updated
- end
-
private

def updater
- @updater ||= begin
- updater = ActiveSupport::FileUpdateChecker.new(paths) { reload! }
- updater.execute
- updater
- end
+ @updater ||= ActiveSupport::FileUpdateChecker.new(paths) { reload! }
end

def clear!
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/rails/gem_version.rb new/lib/rails/gem_version.rb
--- old/lib/rails/gem_version.rb 2019-03-13 17:46:06.000000000 +0100
+++ new/lib/rails/gem_version.rb 2019-03-28 03:46:15.000000000 +0100
@@ -7,8 +7,8 @@
module VERSION
MAJOR = 5
MINOR = 1
- TINY = 6
- PRE = "2"
+ TINY = 7
+ PRE = nil

STRING = [MAJOR, MINOR, TINY, PRE].compact.join(".")
end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/rails/generators/rails/app/templates/Gemfile
new/lib/rails/generators/rails/app/templates/Gemfile
--- old/lib/rails/generators/rails/app/templates/Gemfile 2019-03-13
17:46:06.000000000 +0100
+++ new/lib/rails/generators/rails/app/templates/Gemfile 2019-03-28
03:46:15.000000000 +0100
@@ -34,7 +34,7 @@
gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
<%- if depends_on_system_test? -%>
# Adds support for Capybara system testing and selenium driver
- gem 'capybara', '~> 2.13'
+ gem 'capybara', '>= 2.15'
gem 'selenium-webdriver'
<%- end -%>
end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore'
old/lib/rails/generators/rails/plugin/templates/%name%.gemspec
new/lib/rails/generators/rails/plugin/templates/%name%.gemspec
--- old/lib/rails/generators/rails/plugin/templates/%name%.gemspec
2019-03-13 17:46:06.000000000 +0100
+++ new/lib/rails/generators/rails/plugin/templates/%name%.gemspec
2019-03-28 03:46:15.000000000 +0100
@@ -4,21 +4,30 @@
require "<%= namespaced_name %>/version"

# Describe your gem and declare its dependencies:
-Gem::Specification.new do |s|
- s.name = "<%= name %>"
- s.version = <%= camelized_modules %>::VERSION
- s.authors = ["<%= author %>"]
- s.email = ["<%= email %>"]
- s.homepage = "TODO"
- s.summary = "TODO: Summary of <%= camelized_modules %>."
- s.description = "TODO: Description of <%= camelized_modules %>."
- s.license = "MIT"
+Gem::Specification.new do |spec|
+ spec.name = "<%= name %>"
+ spec.version = <%= camelized_modules %>::VERSION
+ spec.authors = ["<%= author %>"]
+ spec.email = ["<%= email %>"]
+ spec.homepage = "TODO"
+ spec.summary = "TODO: Summary of <%= camelized_modules %>."
+ spec.description = "TODO: Description of <%= camelized_modules %>."
+ spec.license = "MIT"

- s.files = Dir["{app,config,db,lib}/**/*", "MIT-LICENSE", "Rakefile",
"README.md"]
+ # Prevent pushing this gem to RubyGems.org. To allow pushes either set the
'allowed_push_host'
+ # to allow pushing to a single host or delete this section to allow pushing
to any host.
+ if spec.respond_to?(:metadata)
+ spec.metadata["allowed_push_host"] = "TODO: Set to
'http://mygemserver.com'"
+ else
+ raise "RubyGems 2.0 or newer is required to protect against " \
+ "public gem pushes."
+ end

- <%= '# ' if options.dev? || options.edge? -%>s.add_dependency "rails", "<%=
Array(rails_version_specifier).join('", "') %>"
+ spec.files = Dir["{app,config,db,lib}/**/*", "MIT-LICENSE", "Rakefile",
"README.md"]
+
+ <%= '# ' if options.dev? || options.edge? -%>spec.add_dependency "rails",
"<%= Array(rails_version_specifier).join('", "') %>"
<% unless options[:skip_active_record] -%>

- s.add_development_dependency "<%= gem_for_database[0] %>"
+ spec.add_development_dependency "<%= gem_for_database[0] %>"
<% end -%>
end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/rails/rack/logger.rb new/lib/rails/rack/logger.rb
--- old/lib/rails/rack/logger.rb 2019-03-13 17:46:06.000000000 +0100
+++ new/lib/rails/rack/logger.rb 2019-03-28 03:46:15.000000000 +0100
@@ -33,9 +33,9 @@
instrumenter = ActiveSupport::Notifications.instrumenter
instrumenter.start "request.action_dispatch", request: request
logger.info { started_request_message(request) }
- resp = @app.call(env)
- resp[2] = ::Rack::BodyProxy.new(resp[2]) { finish(request) }
- resp
+ status, headers, body = @app.call(env)
+ body = ::Rack::BodyProxy.new(body) { finish(request) }
+ [status, headers, body]
rescue Exception
finish(request)
raise
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata 2019-03-13 17:46:05.000000000 +0100
+++ new/metadata 2019-03-28 03:46:15.000000000 +0100
@@ -1,14 +1,14 @@
--- !ruby/object:Gem::Specification
name: railties
version: !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
platform: ruby
authors:
- David Heinemeier Hansson
autorequire:
bindir: exe
cert_chain: []
-date: 2019-03-13 00:00:00.000000000 Z
+date: 2019-03-28 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
name: activesupport
@@ -16,28 +16,28 @@
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
type: :runtime
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
- !ruby/object:Gem::Dependency
name: actionpack
requirement: !ruby/object:Gem::Requirement
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
type: :runtime
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
- !ruby/object:Gem::Dependency
name: rake
requirement: !ruby/object:Gem::Requirement
@@ -92,14 +92,14 @@
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
type: :development
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - '='
- !ruby/object:Gem::Version
- version: 5.1.6.2
+ version: 5.1.7
description: 'Rails internals: application bootup, plugins, generators, and
rake tasks.'
email: david@xxxxxxxxxxxxxxxx
executables:
@@ -408,8 +408,8 @@
licenses:
- MIT
metadata:
- source_code_uri: https://github.com/rails/rails/tree/v5.1.6.2/railties
- changelog_uri:
https://github.com/rails/rails/blob/v5.1.6.2/railties/CHANGELOG.md
+ source_code_uri: https://github.com/rails/rails/tree/v5.1.7/railties
+ changelog_uri:
https://github.com/rails/rails/blob/v5.1.7/railties/CHANGELOG.md
post_install_message:
rdoc_options:
- "--exclude"


< Previous Next >
This Thread
  • No further messages