Mailinglist Archive: opensuse-commit (1906 mails)

< Previous Next >
commit libzypp-plugin-appdata for openSUSE:Factory
Hello community,

here is the log from the commit of package libzypp-plugin-appdata for
openSUSE:Factory checked in at 2019-04-01 12:32:06
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libzypp-plugin-appdata (Old)
and /work/SRC/openSUSE:Factory/.libzypp-plugin-appdata.new.25356 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libzypp-plugin-appdata"

Mon Apr 1 12:32:06 2019 rev:21 rq:689473 version:1.0.1+git.20180426

Changes:
--------
---
/work/SRC/openSUSE:Factory/libzypp-plugin-appdata/libzypp-plugin-appdata.changes
2018-05-07 14:50:36.139799485 +0200
+++
/work/SRC/openSUSE:Factory/.libzypp-plugin-appdata.new.25356/libzypp-plugin-appdata.changes
2019-04-01 12:32:08.425778832 +0200
@@ -1,0 +2,10 @@
+Thu Mar 28 12:54:44 UTC 2019 - Dominique Leuenberger <dimstar@xxxxxxxxxxxx>
+
+- Only Recommend instead of require AppStream: Allow distros like
+ SLE not to ship AppStream as part of the main channel, but only
+ in PK for example. SLE only ships GNOME Software, which does not
+ rely on the xapian database, so we don't need this cache being
+ refreshed. On SLE+PH or openSUSE, we also have KDE Discover,
+ where xapian becomes a topic (boo#1125898).
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libzypp-plugin-appdata.spec ++++++
--- /var/tmp/diff_new_pack.YJbPVb/_old 2019-04-01 12:32:08.993779008 +0200
+++ /var/tmp/diff_new_pack.YJbPVb/_new 2019-04-01 12:32:09.001779011 +0200
@@ -25,8 +25,8 @@
URL: https://wiki.gnome.org/Design/Apps/Software
Source0: openSUSE-appstream-%{version}.tar.xz
Source99: libzypp-plugin-appdata-rpmlintrc
-# appstreamcli is provided by the AppStream package
-Requires: AppStream
+# appstreamcli is provided by the AppStream package. Let's pull it in when
available, but ignore its absence
+Recommends: AppStream
# appstream-glib >= 0.3.6 is the first to correctly to appstream-util
uninstall in /var/cache
Requires: appstream-glib >= 0.3.6
# appdata hook was introduced in libzypp 14.29.4


< Previous Next >
This Thread
  • No further messages