Mailinglist Archive: opensuse-commit (2092 mails)

< Previous Next >
commit yast2-update
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Wed, 29 Aug 2007 22:51:38 +0200
  • Message-id: <20070829205138.87EA06781B8@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package yast2-update
checked in at Wed Aug 29 22:51:38 CEST 2007.

--------
--- yast2-update/yast2-update.changes   2007-08-27 14:20:54.000000000 +0200
+++ /mounts/work_src_done/STABLE/yast2-update/yast2-update.changes      2007-08-28 12:37:16.000000000 +0200
@@ -1,0 +2,7 @@
+Tue Aug 28 12:35:29 CEST 2007 - locilka@xxxxxxx
+
+- Update proposal doesn't use recommended Kernel if the package is
+  not available (#304646).
+- 2.15.23
+
+-------------------------------------------------------------------

Old:
----
  yast2-update-2.15.22.tar.bz2

New:
----
  yast2-update-2.15.23.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ yast2-update.spec ++++++
--- /var/tmp/diff_new_pack.UL8706/_old  2007-08-29 22:50:59.000000000 +0200
+++ /var/tmp/diff_new_pack.UL8706/_new  2007-08-29 22:50:59.000000000 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package yast2-update (Version 2.15.22)
+# spec file for package yast2-update (Version 2.15.23)
 #
 # Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # This file and all modifications and additions to the pristine
@@ -11,12 +11,12 @@
 # norootforbuild
 
 Name:           yast2-update
-Version:        2.15.22
+Version:        2.15.23
 Release:        1
 License:        GPL v2 or later
 Group:          System/YaST
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-Source0:        yast2-update-2.15.22.tar.bz2
+Source0:        yast2-update-2.15.23.tar.bz2
 prefix:                /usr
 BuildRequires:  perl-XML-Writer update-desktop-files yast2 yast2-devtools yast2-packager yast2-storage yast2-testsuite
 # package not really needed to be installed but this breaks the building cycle
@@ -35,12 +35,12 @@
 Conflicts:      yast2-storage < 2.15.4
 Summary:        YaST2 - Update
 %package FACTORY
-Version:        2.15.22
+Version:        2.15.23
 Release:        1
 License:        GPL v2 or later
 Group:          System/YaST
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-Source0:        yast2-update-2.15.22.tar.bz2
+Source0:        yast2-update-2.15.23.tar.bz2
 prefix:                /usr
 BuildRequires:  perl-XML-Writer update-desktop-files yast2-devtools
 Requires:       yast2-update yast2
@@ -73,7 +73,7 @@
     Jiri Srain <jsrain@xxxxxxx>
 
 %prep
-%setup -n yast2-update-2.15.22
+%setup -n yast2-update-2.15.23
 
 %build
 %{prefix}/bin/y2tool y2autoconf
@@ -119,6 +119,10 @@
 /usr/share/YaST2/clients/update.ycp
 
 %changelog
+* Tue Aug 28 2007 - locilka@xxxxxxx
+- Update proposal doesn't use recommended Kernel if the package is
+  not available (#304646).
+- 2.15.23
 * Mon Aug 27 2007 - locilka@xxxxxxx
 - Calling Storage::DeviceMatchFstab with not-translated device name
   instead of the translated one (Storage::GetTranslatedDevices)

++++++ yast2-update-2.15.22.tar.bz2 -> yast2-update-2.15.23.tar.bz2 ++++++
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.22/src/clients/update_proposal.ycp new/yast2-update-2.15.23/src/clients/update_proposal.ycp
--- old/yast2-update-2.15.22/src/clients/update_proposal.ycp    2007-08-23 15:30:11.000000000 +0200
+++ new/yast2-update-2.15.23/src/clients/update_proposal.ycp    2007-08-28 12:37:28.000000000 +0200
@@ -5,7 +5,7 @@
  *
  * Purpose:    Let user choose update settings.
  *
- * $Id: update_proposal.ycp 40436 2007-08-23 13:30:11Z locilka $
+ * $Id: update_proposal.ycp 40528 2007-08-28 10:37:27Z locilka $
  */
 {
     textdomain "update";
@@ -158,6 +158,11 @@
        y2milestone ("Selected kernel: %1, recommended kernel: %2",
            selected_kernel, recom_kernel);
 
+       // when the recommended Kernel is not available (installable)
+       if (recom_kernel[0]:nil != nil && ! Pkg::IsAvailable (recom_kernel[0]:nil)) {
+           recom_kernel[0] = selected_kernel;
+       }
+
        // recommended package is different to the selected one
        // select the recommended one
        if (recom_kernel[0]:nil != nil && recom_kernel[0]:nil != selected_kernel) {
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.22/VERSION new/yast2-update-2.15.23/VERSION
--- old/yast2-update-2.15.22/VERSION    2007-08-27 14:20:59.000000000 +0200
+++ new/yast2-update-2.15.23/VERSION    2007-08-28 12:37:21.000000000 +0200
@@ -1 +1 @@
-2.15.22
+2.15.23


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >