Mailinglist Archive: opensuse-commit (2092 mails)

< Previous Next >
commit yast2-update
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Sat, 25 Aug 2007 00:16:15 +0200
  • Message-id: <20070824221615.6DED86781B8@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package yast2-update
checked in at Sat Aug 25 00:16:15 CEST 2007.

--------
--- yast2-update/yast2-update.changes   2007-08-09 16:22:11.000000000 +0200
+++ /mounts/work_src_done/STABLE/yast2-update/yast2-update.changes      2007-08-23 15:23:22.000000000 +0200
@@ -1,0 +2,7 @@
+Thu Aug 23 15:22:12 CEST 2007 - locilka@xxxxxxx
+
+- Preselecting new kernel if recommended and installed kernels do
+  not match. Removing other kernels but kernel-xen (#302419).
+- 2.15.21
+
+-------------------------------------------------------------------

Old:
----
  yast2-update-2.15.20.tar.bz2

New:
----
  yast2-update-2.15.21.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ yast2-update.spec ++++++
--- /var/tmp/diff_new_pack.J15432/_old  2007-08-25 00:15:36.000000000 +0200
+++ /var/tmp/diff_new_pack.J15432/_new  2007-08-25 00:15:36.000000000 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package yast2-update (Version 2.15.20)
+# spec file for package yast2-update (Version 2.15.21)
 #
 # Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # This file and all modifications and additions to the pristine
@@ -11,12 +11,12 @@
 # norootforbuild
 
 Name:           yast2-update
-Version:        2.15.20
+Version:        2.15.21
 Release:        1
 License:        GPL v2 or later
 Group:          System/YaST
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-Source0:        yast2-update-2.15.20.tar.bz2
+Source0:        yast2-update-2.15.21.tar.bz2
 prefix:                /usr
 BuildRequires:  perl-XML-Writer update-desktop-files yast2 yast2-devtools yast2-packager yast2-storage yast2-testsuite
 # package not really needed to be installed but this breaks the building cycle
@@ -35,12 +35,12 @@
 Conflicts:      yast2-storage < 2.15.4
 Summary:        YaST2 - Update
 %package FACTORY
-Version:        2.15.20
+Version:        2.15.21
 Release:        1
 License:        GPL v2 or later
 Group:          System/YaST
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-Source0:        yast2-update-2.15.20.tar.bz2
+Source0:        yast2-update-2.15.21.tar.bz2
 prefix:                /usr
 BuildRequires:  perl-XML-Writer update-desktop-files yast2-devtools
 Requires:       yast2-update yast2
@@ -73,7 +73,7 @@
     Jiri Srain <jsrain@xxxxxxx>
 
 %prep
-%setup -n yast2-update-2.15.20
+%setup -n yast2-update-2.15.21
 
 %build
 %{prefix}/bin/y2tool y2autoconf
@@ -119,6 +119,10 @@
 /usr/share/YaST2/clients/update.ycp
 
 %changelog
+* Thu Aug 23 2007 - locilka@xxxxxxx
+- Preselecting new kernel if recommended and installed kernels do
+  not match. Removing other kernels but kernel-xen (#302419).
+- 2.15.21
 * Thu Aug 09 2007 - locilka@xxxxxxx
 - Using cryptsetup instead of losetup, patch created by Thomas Fehr
   (#258222).

++++++ yast2-update-2.15.20.tar.bz2 -> yast2-update-2.15.21.tar.bz2 ++++++
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/configure new/yast2-update-2.15.21/configure
--- old/yast2-update-2.15.20/configure  2007-07-23 14:13:10.000000000 +0200
+++ new/yast2-update-2.15.21/configure  2007-08-23 17:33:26.000000000 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.60 for yast2-update 2.15.17.
+# Generated by GNU Autoconf 2.60 for yast2-update 2.15.20.
 #
 # Report bugs to <http://bugs.opensuse.org/>.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2-update'
 PACKAGE_TARNAME='yast2-update'
-PACKAGE_VERSION='2.15.17'
-PACKAGE_STRING='yast2-update 2.15.17'
+PACKAGE_VERSION='2.15.20'
+PACKAGE_STRING='yast2-update 2.15.20'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 
 ac_unique_file="RPMNAME"
@@ -1181,7 +1181,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures yast2-update 2.15.17 to adapt to many kinds of systems.
+\`configure' configures yast2-update 2.15.20 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1252,7 +1252,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
-     short | recursive ) echo "Configuration of yast2-update 2.15.17:";;
+     short | recursive ) echo "Configuration of yast2-update 2.15.20:";;
    esac
   cat <<\_ACEOF
 
@@ -1330,7 +1330,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-yast2-update configure 2.15.17
+yast2-update configure 2.15.20
 generated by GNU Autoconf 2.60
 
 Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -1344,7 +1344,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2-update $as_me 2.15.17, which was
+It was created by yast2-update $as_me 2.15.20, which was
 generated by GNU Autoconf 2.60.  Invocation command line was
 
   $ $0 $@
@@ -2145,7 +2145,7 @@
 
 # Define the identity of the package.
  PACKAGE='yast2-update'
- VERSION='2.15.17'
+ VERSION='2.15.20'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -2372,7 +2372,7 @@
 
 
 
-VERSION="2.15.17"
+VERSION="2.15.20"
 RPMNAME="yast2-update"
 MAINTAINER="Lukas Ocilka <locilka@xxxxxxx>"
 
@@ -3260,7 +3260,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by yast2-update $as_me 2.15.17, which was
+This file was extended by yast2-update $as_me 2.15.20, which was
 generated by GNU Autoconf 2.60.  Invocation command line was
 
   CONFIG_FILES    = $CONFIG_FILES
@@ -3303,7 +3303,7 @@
 _ACEOF
 cat >>$CONFIG_STATUS <<_ACEOF
 ac_cs_version="\\
-yast2-update config.status 2.15.17
+yast2-update config.status 2.15.20
 configured by $0, generated by GNU Autoconf 2.60,
   with options \\"`echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
 
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/configure.in new/yast2-update-2.15.21/configure.in
--- old/yast2-update-2.15.20/configure.in       2007-07-23 14:13:06.000000000 +0200
+++ new/yast2-update-2.15.21/configure.in       2007-08-23 17:33:22.000000000 +0200
@@ -1,9 +1,9 @@
 dnl configure.in for yast2-update
 dnl
-dnl -- This file is generated by y2autoconf 2.15.0 - DO NOT EDIT! --
+dnl -- This file is generated by y2autoconf 2.15.7 - DO NOT EDIT! --
 dnl    (edit configure.in.in instead)
 
-AC_INIT(yast2-update, 2.15.17, http://bugs.opensuse.org/, yast2-update)
+AC_INIT(yast2-update, 2.15.20, http://bugs.opensuse.org/, yast2-update)
 dnl Check for presence of file 'RPMNAME'
 AC_CONFIG_SRCDIR([RPMNAME])
 
@@ -17,7 +17,7 @@
 AM_INIT_AUTOMAKE(tar-ustar) dnl searches for some needed programs
 
 dnl Important YaST2 variables
-VERSION="2.15.17"
+VERSION="2.15.20"
 RPMNAME="yast2-update"
 MAINTAINER="Lukas Ocilka <locilka@xxxxxxx>"
 
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/Makefile.am new/yast2-update-2.15.21/Makefile.am
--- old/yast2-update-2.15.20/Makefile.am        2007-07-23 14:13:06.000000000 +0200
+++ new/yast2-update-2.15.21/Makefile.am        2007-08-23 17:33:22.000000000 +0200
@@ -210,8 +210,7 @@
 
 # For po/ modules
 checkpo:
-       test ! -d $(srcdir)/po || $(MAKE) -C po checkpo
-#      test ! -d $(srcdir)/po \
-#        || { $(MAKE) -C po checkpo && $(MAKE) -C po make-pox; }
+       test ! -f $(srcdir)/po/Makefile || $(MAKE) -C po checkpo
+#      test ! -f $(srcdir)/po/Makefile || $(MAKE) -C po checkpo make-pox
 # No ./SUBDIRS file found - assuming default: All direct subdirs with Makefile.am
 SUBDIRS = doc src testsuite 
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/Makefile.in new/yast2-update-2.15.21/Makefile.in
--- old/yast2-update-2.15.20/Makefile.in        2007-07-23 14:13:12.000000000 +0200
+++ new/yast2-update-2.15.21/Makefile.in        2007-08-23 17:33:28.000000000 +0200
@@ -233,8 +233,7 @@
 @CREATE_PKGCONFIG_NOARCH_TRUE@@CREATE_PKGCONFIG_TRUE@pkgconfigdata_DATA = $(RPMNAME).pc
 @CREATE_PKGCONFIG_NOARCH_FALSE@@CREATE_PKGCONFIG_TRUE@pkgconfig_DATA = $(RPMNAME).pc
 TAGVERSION = $(Y2TOOL) tagversion
-#      test ! -d $(srcdir)/po \
-#        || { $(MAKE) -C po checkpo && $(MAKE) -C po make-pox; }
+#      test ! -f $(srcdir)/po/Makefile || $(MAKE) -C po checkpo make-pox
 # No ./SUBDIRS file found - assuming default: All direct subdirs with Makefile.am
 SUBDIRS = doc src testsuite 
 all: all-recursive
@@ -841,7 +840,7 @@
 
 # For po/ modules
 checkpo:
-       test ! -d $(srcdir)/po || $(MAKE) -C po checkpo
+       test ! -f $(srcdir)/po/Makefile || $(MAKE) -C po checkpo
 # Tell versions [3.59,3.63) of GNU make to not export all variables.
 # Otherwise a system limit (for SysV at least) may be exceeded.
 .NOEXPORT:
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/src/clients/update_proposal.ycp new/yast2-update-2.15.21/src/clients/update_proposal.ycp
--- old/yast2-update-2.15.20/src/clients/update_proposal.ycp    2007-07-18 09:36:29.000000000 +0200
+++ new/yast2-update-2.15.21/src/clients/update_proposal.ycp    2007-08-23 15:30:11.000000000 +0200
@@ -5,7 +5,7 @@
  *
  * Purpose:    Let user choose update settings.
  *
- * $Id: update_proposal.ycp 39486 2007-07-18 07:36:28Z locilka $
+ * $Id: update_proposal.ycp 40436 2007-08-23 13:30:11Z locilka $
  */
 {
     textdomain "update";
@@ -139,34 +139,60 @@
        return ret;
     }
 
+    // see bug 302398
     define void SelectKernelPackages () {
        list <list> provides = Pkg::PkgQueryProvides ("kernel");
+       // e.g.: [["kernel-bigsmp", `CAND, `NONE], ["kernel-default", `CAND, `CAND], ["kernel-default", `BOTH, `INST]]
        y2milestone ("provides: %1", provides);
 
+       // these kernels would be installed
        list <list> kernels = filter (list l, provides, {
            return l[1]:`NONE == `BOTH || l[1]:`NONE == l[2]:`NONE;
        });
 
        if (size (kernels) != 1)
-           y2error ("not exactly one package provides tag kernel");
+           y2warning ("not exactly one package provides tag kernel");
 
        string selected_kernel = kernels[0,0]:"none";
        list<string> recom_kernel = Kernel::ComputePackages ();
        y2milestone ("Selected kernel: %1, recommended kernel: %2",
            selected_kernel, recom_kernel);
-       list<string> kernel_packs = Kernel::ComputePackages ();
-       boolean kernel_refresh_needed = false;
-       foreach (string p, kernel_packs, {
-           if (! Pkg::IsProvided (p))
-           {
-               kernel_refresh_needed = true;
-               y2milestone ("Package %1 is not installed - forcing kernel update", p);
-           }
-       });
-       if (kernel_refresh_needed)
-       {
+
+       // recommended package is different to the selected one
+       // select the recommended one
+       if (recom_kernel[0]:nil != nil && recom_kernel[0]:nil != selected_kernel) {
+           // list of kernels to be installed
+           list <string> kernels_to_be_installed = (list <string>) maplist (list one_kernel, kernels, {
+               return one_kernel[0]:nil;
+           });
+           kernels_to_be_installed = filter (string one_kernel, kernels_to_be_installed, {
+               return (one_kernel != nil && one_kernel != "");
+           });
+
+           // remove old kernels
+           foreach (string one_kernel, kernels_to_be_installed, {
+               // exception
+               if (one_kernel == "kernel-xen") return;
+               // the recommended one
+               if (one_kernel == recom_kernel[0]:nil) return;
+
+               list <string> packages_to_remove = Kernel::ComputePackagesForBase (one_kernel, false);
+
+               if (packages_to_remove != nil && size (packages_to_remove) > 0) {
+                   y2milestone ("Removing installed packages %1", packages_to_remove);
+                   Pkg::DoRemove (packages_to_remove);
+               }
+           });
+
+           // compute recommended kernel packages
+           list<string> kernel_packs = Kernel::ComputePackages ();
+
+           // checking all recommended packages
            foreach (string p, kernel_packs, {
-               Pkg::PkgInstall (p);
+               if (! Pkg::IsProvided (p)) {
+                   y2milestone ("Package %1 is not installed - forcing kernel update", p);
+                   Pkg::PkgInstall (p);
+               }
            });
        }
     }
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore old/yast2-update-2.15.20/VERSION new/yast2-update-2.15.21/VERSION
--- old/yast2-update-2.15.20/VERSION    2007-08-09 16:20:51.000000000 +0200
+++ new/yast2-update-2.15.21/VERSION    2007-08-24 15:32:06.000000000 +0200
@@ -1 +1 @@
-2.15.20
+2.15.21


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >