Mailinglist Archive: opensuse-buildservice (88 mails)

< Previous Next >
[opensuse-buildservice] KIWI build
  • From: Roger Oberholtzer <roger.oberholtzer@xxxxxxxxx>
  • Date: Mon, 17 Feb 2020 13:17:13 +0100
  • Message-id: <CANkOqwMQ==HfGcJJBO8j++duUeqzCdJAo=MYJGNG-8+2bqYoBQ@mail.gmail.com>
I am trying to an OS image using KIWI in the build service. It had
been working as of a month or
so ago. Now it complains with:

have choice for product_flavor (openSUSE) needed by openSUSE-release:

followed by a number of packages that I guess are needed to run kiwi
and whatever. I know what this generally means with dependencies in an
RPM spec type of build. I do not know what to do about this in the
context of KIWI. Is if that it wants to know if I want Leap 15.1,
15.2, or Tumbleweed? I am happy with either 15.1 or Tumbleweed. If
this is what I need to be specifying, where do I do this? The docs
about the web interface
(https://en.opensuse.org/openSUSE:Build_Service_prjconf) didn't help
me. Or at least I'm not sure what I need to be setting. That doc's
reference to an advanced tab is odd as I do not see such a tab. I
guess using the actual tab name might be better than using the name of
what one might call what the tab contains.

My project is
https://build.opensuse.org/package/show/home:rogeroberholtzer:RSL/oem

In the project top
(https://build.opensuse.org/package/show/home:rogeroberholtzer:RSL)
Meta, I have this:

<repository name="images">
<path project="Virtualization:Appliances:Builder"
repository="openSUSE_Leap_15.1"/>
<path project="openSUSE:Leap:15.1" repository="standard"/>
<arch>x86_64</arch>
</repository>

I thought that should select openSUSE Leap 15.1

Maybe that's not enough or the correct place?

Or I'm simply confused...

--
Roger Oberholtzer
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups