Mailinglist Archive: opensuse-buildservice (95 mails)

< Previous Next >
Re: [opensuse-buildservice] Cannot create new project in self-hosted OBS 2.11 [SOLVED]
I ran the following command found in ReleaseNotes-2.11:
chroot --userspec=wwwrun:www / /bin/bash -c "cd /srv/www/obs/api/ &&
/usr/bin/bundle.ruby2.5 exec rails ts:rebuild RAILS_ENV=production"

Then I restarted the VM, and now I can create new projects. So I
consider this solved.

Thank you for help.

Ondrej M.

On Wed, 8 Jan 2020 at 14:52, Adrian Schröter <adrian@xxxxxxx> wrote:

On Mittwoch, 8. Januar 2020, 08:17:38 CET Ondrej Musil wrote:
Hello everyone,

I cannot create a new project in our OBS instance via the web UI. When
I try it, it just shows a page with 500: Internal Server Error after
sending the request. This used to work just fine before.

The only mention about it in the logs I could found is this in
2020-01-08 06:58:52: [2461] GET (

And then in the /srv/www/obs/api/log/apache_access.log: - - [08/Jan/2020:06:58:44 +0000] "GET /project/new
HTTP/1.1" 200 2877 - - [08/Jan/2020:06:58:52 +0000] "POST /project/create
HTTP/1.1" 500 4322

And some error in /srv/www/obs/api/log/production.log:

thinking sphinx has not been setup/updated and code is crashing ..

check Releasenotes file how to initialize it.

(should be documented in README.UPDATERS actually)


Adrian Schroeter <adrian@xxxxxxx>
Build Infrastructure Project Manager

SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
(HRB 247165, AG München), Geschäftsführer: Felix Imendörffer

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >