Mailinglist Archive: opensuse-buildservice (74 mails)

< Previous Next >
Re: [opensuse-buildservice] software.opensuse.org doesn't find some packages
Tobias Klausmann schrieb am 27.05.19 um 16:54:

On 27.05.19 11:54, Alexander Graul wrote:
Hi,

Werner Flamme <werner.flamme@xxxxxx> writes:
I'm not sure if I'm right here, please point me to the correct place
when I'm not :)


The best location for bug reports on software.opensuse.org is

   https://github.com/openSUSE/software-o-o/issues/new

Thanks, I will do soon.

How can these different results be explained? And can the wrong "no
packages" statements please be eliminated somehow?


This sounds like you are searching packages for a specific
distribution that you have selected in the dropdown menu. Right now,
targeting specific distributions will only return results if there is
an official release for that  distribution. The package page does not
have that limit.

Not really. It does not matter whether I use "All Distributions" or
"15.0" or "Ubuntu" or whatever. Packages like "jitsi", "proxytunnel",
"srcpd" are not found.

The searches work fine for other packages that are not component of the
distributions I search. Or do you mean, when a package belongs to one
distibution, it is found generally, not only when it's in the
distribution I'm looking for?

We had a discussion about software.opensuse.org two days ago at the
openSUSE Conference that was partly about the search function and how
it could be improved. This is something we want to change, but I don't
know how long it will take.

The behaviour has changed. I'm sure I pereviously found software
independent from it belonging to a core distro or not.

When I go to <https://build.opensuse.org> and enter "proxytunnel" as a
search term, I get results all right. It should be possible to include
those results at software.o.o

In the meantime, you can use "ALL Distributions" as a workaround, that
will also give you results for packages that have no official releases.


This point is not valid. Even when using "ALL Distributions" the search
falls back to one: openSUSE Factory.

"No packages found matching your search.
You could try to extend your search to development packages or search
for another base distribution (currently openSUSE:Factory)."


This was tested with:
https://software.opensuse.org/search?utf8=%E2%9C%93&baseproject=ALL&q=dxvk

Same observation here :(

Regards,
Werner

... just patching 2 SAP systems at the same time and thus having no
opportunity to open a bug report ...

--


< Previous Next >
Follow Ups