Mailinglist Archive: opensuse-buildservice (74 mails)

< Previous Next >
Re: [opensuse-buildservice] package requirements for _service files not enforced
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 14 May 2019 15:35:23 +0200
  • Message-id: <1678984.pGq9Q38ilJ@linux-ywca>
On Dienstag, 14. Mai 2019, 14:44:22 CEST Olaf Hering wrote:
Since a few days obs-service-set_version requires python3.
rpm -qp --requires shows '/usr/bin/python3'.
But pkgs that do use that service in their _service files do not get
python3 into the buildroot.

Are obs-service-* pkgs forced into the buildroot without taking their
dependencies into account? SLE12 and 42.3 fails because there is no
python3.

the file requires gets ignored .... but the real problem is that the
dependencies don't match and the test suite got disabled.

I tried to solve this now in openSUSE:Tools project and enabled
the test suite. Let's see where it fails ....

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References