Mailinglist Archive: opensuse-buildservice (77 mails)

< Previous Next >
Re: [opensuse-buildservice] Qt5 issue building vlc for TW on a local obs
On 4/20/19 12:24 PM, Hans-Peter Jansen wrote:
Am Samstag, 13. April 2019, 19:01:34 CEST schrieb Hans-Peter Jansen:
Hi,

struggling with a strange issue here, when building vlc for TW.
Many other packages, including vlc for other targets, and the kernel, build
fine.

Same issue breaks virtualbox builds in another repo. Just for Factory:

[ 58s] libQt5Core5-5.12.2-1.2
########################################
[ 60s] libQt5Core-devel-5.12.2-1.2
########################################

[ 104s] Checking for Qt5:
/home/abuild/rpmbuild/BUILD/VirtualBox-6.0.4/.tmp_out:
error while loading shared libraries: libQt5Core.so.5: cannot open shared
object file: No such file or directory
[ 104s]
[ 104s] ** qt5 not found!

Nobody ever seen such an issue before?

Hrmpf. It looks like ldconfig isn't doing correctly for this specific case,
is it?

Could this be some optimizations, that delay ldconfig calls, and "forget"
about it later on? But why does that work for every other lib, but Qt5?

My local builds of VirtualBox and those of OBS are mostly building OK.

They use
BuildRequires: libqt5-linguist
BuildRequires: libqt5-qtbase-devel
BuildRequires: libqt5-qtx11extras-devel

I'm not sure why package libQt5Core5 does not need to be mentioned explicitly, but it works.

I have had problems with the 586 builds at OBS, but I think those may be problems with OBS hardware.

Larry



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >