Mailinglist Archive: opensuse-buildservice (46 mails)

< Previous Next >
[opensuse-buildservice] openSUSE:Tools is failing GPG check (CentOS 7)
  • From: Neal Gompa <ngompa13@xxxxxxxxx>
  • Date: Wed, 24 Oct 2018 15:08:45 -0400
  • Message-id: <CAEg-Je-duEn=zY1xC_g459+02cQvOy9X0Zz+1yP0Bn5zLay+ww@mail.gmail.com>
Hey,

I tried to install some packages from the openSUSE:Tools project for
CentOS 7, and it failed to validate with the GPG key that is provided
in the .repo file with one of the packages.

This is the error:
Retrieving key from
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key
Importing GPG key 0x013E5B65:
Userid : "openSUSE:Tools OBS Project <openSUSE:Tools@xxxxxxxxxxxxxxxxxx>"
Fingerprint: fcad afc8 1273 b9e7 f184 f2b0 8266 59a9 013e 5b65
From :
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key
warning:
/var/cache/yum/x86_64/7/openSUSE_Tools/packages/obs-service-set_version-0.5.9-91.1.noarch.rpm:
Header V3 DSA/SHA1 Signature, key ID eefefde9: NOKEY
Retrieving key from
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key


The GPG keys listed for the "openSUSE.org tools (CentOS_7)" repository
are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.


Failing package is: obs-service-set_version-0.5.9-91.1.noarch
GPG Keys are configured as:
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key

I think the repository needs to be fully re-signed with the key, since
it was rotated...

I've attached the full log to the email.

--
真実はいつも一つ!/ Always, there's only one truth!
STEP 4: RUN cd /etc/yum.repos.d/ && wget
https://download.opensuse.org/repositories/openSUSE:Tools/CentOS_7/openSUSE:Tools.repo
&& yum -y install osc obs-service-extract_file
obs-service-download_files obs-service-set_version build && rm -rf
/var/cache/yum
--2018-10-24 19:05:30--
https://download.opensuse.org/repositories/openSUSE:Tools/CentOS_7/openSUSE:Tools.repo
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134,
2620:113:80c0:8::13
Connecting to download.opensuse.org
(download.opensuse.org)|195.135.221.134|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location:
https://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/openSUSE:Tools.repo
[following]
--2018-10-24 19:05:31--
https://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/openSUSE:Tools.repo
Reusing existing connection to download.opensuse.org:443.
HTTP request sent, awaiting response... 200 OK
Length: 259
Saving to: 'openSUSE:Tools.repo'

100%[============================>] 259 --.-K/s in 0s

2018-10-24 19:05:31 (18.2 MB/s) - 'openSUSE:Tools.repo' saved [259/259]

Loaded plugins: fastestmirror, ovl
Determining fastest mirrors
epel/x86_64/metalink | 18 kB 00:00
* base: mirrors.mit.edu
* epel: fedora-epel.mirrors.tds.net
* extras: ewr.edge.kernel.org
* updates: mirror.metrocast.net
base | 3.6 kB 00:00
centos-yum4 | 2.9 kB 00:00
epel | 3.2 kB 00:00
extras | 3.4 kB 00:00
openSUSE_Tools | 1.7 kB 00:00
updates | 3.4 kB 00:00
(1/9): epel/x86_64/group_gz | 88 kB 00:00
(2/9): base/7/x86_64/group_gz | 166 kB 00:00
(3/9): epel/x86_64/primary | 3.6 MB 00:00
(4/9): extras/7/x86_64/primary_db | 204 kB 00:00
(5/9): epel/x86_64/updateinfo | 933 kB 00:00
(6/9): base/7/x86_64/primary_db | 5.9 MB 00:00
(7/9): centos-yum4/x86_64/primary_db | 28 kB 00:00
(8/9): openSUSE_Tools/primary | 12 kB 00:00
(9/9): updates/7/x86_64/primary_db | 6.0 MB 00:00
epel 12742/12742
openSUSE_Tools 74/74
Resolving Dependencies
--> Running transaction check
---> Package build.noarch 0:20181022-301.1 will be installed
--> Processing Dependency: psmisc for package: build-20181022-301.1.noarch
--> Processing Dependency: perl(XML::Parser) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(URI) for package: build-20181022-301.1.noarch
--> Processing Dependency: perl(Time::Zone) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(LWP::UserAgent) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(IO::Uncompress::Gunzip) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(Digest::SHA) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(Digest::MD5) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(Date::Parse) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(Date::Language) for package:
build-20181022-301.1.noarch
--> Processing Dependency: perl(Data::Dumper) for package:
build-20181022-301.1.noarch
--> Processing Dependency: build-mkbaselibs for package:
build-20181022-301.1.noarch
---> Package obs-service-download_files.noarch 0:0.6.2-82.2 will be installed
---> Package obs-service-extract_file.noarch 0:0.3-19.6 will be installed
---> Package obs-service-set_version.noarch 0:0.5.9-91.1 will be installed
---> Package osc.noarch 0:0.163.0-240.1 will be installed
--> Processing Dependency: m2crypto > 0.19 for package: osc-0.163.0-240.1.noarch
--> Running transaction check
---> Package build-mkbaselibs.noarch 0:20181022-301.1 will be installed
---> Package m2crypto.x86_64 0:0.21.1-17.el7 will be installed
---> Package perl-Data-Dumper.x86_64 0:2.145-3.el7 will be installed
---> Package perl-Digest-MD5.x86_64 0:2.52-3.el7 will be installed
--> Processing Dependency: perl(Digest::base) >= 1.00 for package:
perl-Digest-MD5-2.52-3.el7.x86_64
---> Package perl-Digest-SHA.x86_64 1:5.85-4.el7 will be installed
---> Package perl-IO-Compress.noarch 0:2.061-2.el7 will be installed
--> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.061 for package:
perl-IO-Compress-2.061-2.el7.noarch
--> Processing Dependency: perl(Compress::Raw::Bzip2) >= 2.061 for package:
perl-IO-Compress-2.061-2.el7.noarch
---> Package perl-TimeDate.noarch 1:2.30-2.el7 will be installed
---> Package perl-URI.noarch 0:1.60-9.el7 will be installed
--> Processing Dependency: perl(Business::ISBN) for package:
perl-URI-1.60-9.el7.noarch
---> Package perl-XML-Parser.x86_64 0:2.41-10.el7 will be installed
---> Package perl-libwww-perl.noarch 0:6.05-2.el7 will be installed
--> Processing Dependency: perl(WWW::RobotRules) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(Net::HTTP) >= 6.04 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(LWP::MediaTypes) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Status) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Response) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Request::Common) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Request) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Negotiate) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Date) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Daemon) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTTP::Cookies) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(File::Listing) >= 6 for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTML::HeadParser) for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(HTML::Entities) for package:
perl-libwww-perl-6.05-2.el7.noarch
--> Processing Dependency: perl(Encode::Locale) for package:
perl-libwww-perl-6.05-2.el7.noarch
---> Package psmisc.x86_64 0:22.20-15.el7 will be installed
--> Running transaction check
---> Package perl-Business-ISBN.noarch 0:2.06-2.el7 will be installed
--> Processing Dependency: perl(Business::ISBN::Data) >= 20120719.001 for
package: perl-Business-ISBN-2.06-2.el7.noarch
---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.061-3.el7 will be installed
---> Package perl-Compress-Raw-Zlib.x86_64 1:2.061-4.el7 will be installed
---> Package perl-Digest.noarch 0:1.17-245.el7 will be installed
---> Package perl-Encode-Locale.noarch 0:1.03-5.el7 will be installed
---> Package perl-File-Listing.noarch 0:6.04-7.el7 will be installed
---> Package perl-HTML-Parser.x86_64 0:3.71-4.el7 will be installed
--> Processing Dependency: perl(HTML::Tagset) >= 3 for package:
perl-HTML-Parser-3.71-4.el7.x86_64
---> Package perl-HTTP-Cookies.noarch 0:6.01-5.el7 will be installed
---> Package perl-HTTP-Daemon.noarch 0:6.01-7.el7 will be installed
--> Processing Dependency: perl(IO::Socket::IP) for package:
perl-HTTP-Daemon-6.01-7.el7.noarch
---> Package perl-HTTP-Date.noarch 0:6.02-8.el7 will be installed
---> Package perl-HTTP-Message.noarch 0:6.06-6.el7 will be installed
--> Processing Dependency: perl(IO::HTML) for package:
perl-HTTP-Message-6.06-6.el7.noarch
---> Package perl-HTTP-Negotiate.noarch 0:6.01-5.el7 will be installed
---> Package perl-LWP-MediaTypes.noarch 0:6.02-2.el7 will be installed
--> Processing Dependency: mailcap for package:
perl-LWP-MediaTypes-6.02-2.el7.noarch
---> Package perl-Net-HTTP.noarch 0:6.06-2.el7 will be installed
--> Processing Dependency: perl(IO::Socket::SSL) >= 1.38 for package:
perl-Net-HTTP-6.06-2.el7.noarch
---> Package perl-WWW-RobotRules.noarch 0:6.02-5.el7 will be installed
--> Running transaction check
---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed
---> Package perl-Business-ISBN-Data.noarch 0:20120719.001-2.el7 will be
installed
---> Package perl-HTML-Tagset.noarch 0:3.20-15.el7 will be installed
---> Package perl-IO-HTML.noarch 0:1.00-2.el7 will be installed
---> Package perl-IO-Socket-IP.noarch 0:0.21-5.el7 will be installed
---> Package perl-IO-Socket-SSL.noarch 0:1.94-7.el7 will be installed
--> Processing Dependency: perl-Net-SSLeay >= 1.55-5 for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Processing Dependency: perl(Net::SSLeay) >= 1.21 for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Processing Dependency: openssl >= 0.9.8 for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Processing Dependency: perl(Net::SSLeay) for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Processing Dependency: perl(Net::LibIDN) for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Processing Dependency: perl(Mozilla::CA) for package:
perl-IO-Socket-SSL-1.94-7.el7.noarch
--> Running transaction check
---> Package openssl.x86_64 1:1.0.2k-12.el7 will be installed
--> Processing Dependency: make for package: 1:openssl-1.0.2k-12.el7.x86_64
---> Package perl-Mozilla-CA.noarch 0:20130114-5.el7 will be installed
---> Package perl-Net-LibIDN.x86_64 0:0.12-15.el7 will be installed
---> Package perl-Net-SSLeay.x86_64 0:1.55-6.el7 will be installed
--> Running transaction check
---> Package make.x86_64 1:3.82-23.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================
Package Arch Version Repository Size
======================================================================
Installing:
build noarch 20181022-301.1 openSUSE_Tools 225 k
obs-service-download_files
noarch 0.6.2-82.2 openSUSE_Tools 13 k
obs-service-extract_file noarch 0.3-19.6 openSUSE_Tools 5.9 k
obs-service-set_version noarch 0.5.9-91.1 openSUSE_Tools 14 k
osc noarch 0.163.0-240.1 openSUSE_Tools 550 k
Installing for dependencies:
build-mkbaselibs noarch 20181022-301.1 openSUSE_Tools 48 k
m2crypto x86_64 0.21.1-17.el7 base 429 k
mailcap noarch 2.1.41-2.el7 base 31 k
make x86_64 1:3.82-23.el7 base 420 k
openssl x86_64 1:1.0.2k-12.el7 base 492 k
perl-Business-ISBN noarch 2.06-2.el7 base 25 k
perl-Business-ISBN-Data noarch 20120719.001-2.el7
base 24 k
perl-Compress-Raw-Bzip2 x86_64 2.061-3.el7 base 32 k
perl-Compress-Raw-Zlib x86_64 1:2.061-4.el7 base 57 k
perl-Data-Dumper x86_64 2.145-3.el7 base 47 k
perl-Digest noarch 1.17-245.el7 base 23 k
perl-Digest-MD5 x86_64 2.52-3.el7 base 30 k
perl-Digest-SHA x86_64 1:5.85-4.el7 base 58 k
perl-Encode-Locale noarch 1.03-5.el7 base 16 k
perl-File-Listing noarch 6.04-7.el7 base 13 k
perl-HTML-Parser x86_64 3.71-4.el7 base 115 k
perl-HTML-Tagset noarch 3.20-15.el7 base 18 k
perl-HTTP-Cookies noarch 6.01-5.el7 base 26 k
perl-HTTP-Daemon noarch 6.01-7.el7 base 21 k
perl-HTTP-Date noarch 6.02-8.el7 base 14 k
perl-HTTP-Message noarch 6.06-6.el7 base 82 k
perl-HTTP-Negotiate noarch 6.01-5.el7 base 17 k
perl-IO-Compress noarch 2.061-2.el7 base 260 k
perl-IO-HTML noarch 1.00-2.el7 base 23 k
perl-IO-Socket-IP noarch 0.21-5.el7 base 36 k
perl-IO-Socket-SSL noarch 1.94-7.el7 base 115 k
perl-LWP-MediaTypes noarch 6.02-2.el7 base 24 k
perl-Mozilla-CA noarch 20130114-5.el7 base 11 k
perl-Net-HTTP noarch 6.06-2.el7 base 29 k
perl-Net-LibIDN x86_64 0.12-15.el7 base 28 k
perl-Net-SSLeay x86_64 1.55-6.el7 base 285 k
perl-TimeDate noarch 1:2.30-2.el7 base 52 k
perl-URI noarch 1.60-9.el7 base 106 k
perl-WWW-RobotRules noarch 6.02-5.el7 base 18 k
perl-XML-Parser x86_64 2.41-10.el7 base 223 k
perl-libwww-perl noarch 6.05-2.el7 base 205 k
psmisc x86_64 22.20-15.el7 base 141 k

Transaction Summary
======================================================================
Install 5 Packages (+37 Dependent packages)

Total download size: 4.3 M
Installed size: 12 M
Downloading packages:
(1/42): mailcap-2.1.41-2.el7.noarch.rpm | 31 kB 00:00
(2/42): m2crypto-0.21.1-17.el7.x86_64.rpm | 429 kB 00:00
(3/42): make-3.82-23.el7.x86_64.rpm | 420 kB 00:00
warning:
/var/cache/yum/x86_64/7/openSUSE_Tools/packages/build-mkbaselibs-20181022-301.1.noarch.rpm:
Header V3 RSA/SHA256 Signature, key ID 013e5b65: NOKEY
Public key for build-mkbaselibs-20181022-301.1.noarch.rpm is not installed
(4/42): build-mkbaselibs-20181022-301.1.noarch.r | 48 kB 00:00
(5/42): build-20181022-301.1.noarch.rpm | 225 kB 00:00
(6/42): obs-service-download_files-0.6.2-82.2.no | 13 kB 00:00
(7/42): openssl-1.0.2k-12.el7.x86_64.rpm | 492 kB 00:00
(8/42): obs-service-extract_file-0.3-19.6.noarch | 5.9 kB 00:00
(9/42): obs-service-set_version-0.5.9-91.1.noarc | 14 kB 00:00
(10/42): perl-Business-ISBN-2.06-2.el7.noarch.rp | 25 kB 00:00
(11/42): perl-Compress-Raw-Bzip2-2.061-3.el7.x86 | 32 kB 00:00
(12/42): perl-Compress-Raw-Zlib-2.061-4.el7.x86_ | 57 kB 00:00
(13/42): perl-Data-Dumper-2.145-3.el7.x86_64.rpm | 47 kB 00:00
(14/42): perl-Digest-1.17-245.el7.noarch.rpm | 23 kB 00:00
(15/42): perl-Digest-MD5-2.52-3.el7.x86_64.rpm | 30 kB 00:00
(16/42): perl-Business-ISBN-Data-20120719.001-2. | 24 kB 00:00
(17/42): perl-Digest-SHA-5.85-4.el7.x86_64.rpm | 58 kB 00:00
(18/42): perl-Encode-Locale-1.03-5.el7.noarch.rp | 16 kB 00:00
(19/42): perl-File-Listing-6.04-7.el7.noarch.rpm | 13 kB 00:00
(20/42): perl-HTML-Tagset-3.20-15.el7.noarch.rpm | 18 kB 00:00
(21/42): perl-HTML-Parser-3.71-4.el7.x86_64.rpm | 115 kB 00:00
(22/42): perl-HTTP-Cookies-6.01-5.el7.noarch.rpm | 26 kB 00:00
(23/42): perl-HTTP-Daemon-6.01-7.el7.noarch.rpm | 21 kB 00:00
(24/42): perl-HTTP-Date-6.02-8.el7.noarch.rpm | 14 kB 00:00
(25/42): perl-HTTP-Message-6.06-6.el7.noarch.rpm | 82 kB 00:00
(26/42): perl-HTTP-Negotiate-6.01-5.el7.noarch.r | 17 kB 00:00
(27/42): perl-IO-HTML-1.00-2.el7.noarch.rpm | 23 kB 00:00
(28/42): perl-IO-Compress-2.061-2.el7.noarch.rpm | 260 kB 00:00
(29/42): perl-IO-Socket-IP-0.21-5.el7.noarch.rpm | 36 kB 00:00
(30/42): perl-IO-Socket-SSL-1.94-7.el7.noarch.rp | 115 kB 00:00
(31/42): perl-LWP-MediaTypes-6.02-2.el7.noarch.r | 24 kB 00:00
(32/42): perl-Mozilla-CA-20130114-5.el7.noarch.r | 11 kB 00:00
(33/42): perl-Net-HTTP-6.06-2.el7.noarch.rpm | 29 kB 00:00
(34/42): perl-Net-LibIDN-0.12-15.el7.x86_64.rpm | 28 kB 00:00
(35/42): perl-Net-SSLeay-1.55-6.el7.x86_64.rpm | 285 kB 00:00
(36/42): perl-TimeDate-2.30-2.el7.noarch.rpm | 52 kB 00:00
(37/42): perl-URI-1.60-9.el7.noarch.rpm | 106 kB 00:00
(38/42): perl-WWW-RobotRules-6.02-5.el7.noarch.r | 18 kB 00:00
(39/42): perl-XML-Parser-2.41-10.el7.x86_64.rpm | 223 kB 00:00
(40/42): perl-libwww-perl-6.05-2.el7.noarch.rpm | 205 kB 00:00
(41/42): psmisc-22.20-15.el7.x86_64.rpm | 141 kB 00:00
(42/42): osc-0.163.0-240.1.noarch.rpm | 550 kB 00:00
----------------------------------------------------------------------
Total 2.6 MB/s | 4.3 MB 00:01
Retrieving key from
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key
Importing GPG key 0x013E5B65:
Userid : "openSUSE:Tools OBS Project <openSUSE:Tools@xxxxxxxxxxxxxxxxxx>"
Fingerprint: fcad afc8 1273 b9e7 f184 f2b0 8266 59a9 013e 5b65
From :
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key
warning:
/var/cache/yum/x86_64/7/openSUSE_Tools/packages/obs-service-set_version-0.5.9-91.1.noarch.rpm:
Header V3 DSA/SHA1 Signature, key ID eefefde9: NOKEY
Retrieving key from
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key


The GPG keys listed for the "openSUSE.org tools (CentOS_7)" repository are
already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.


Failing package is: obs-service-set_version-0.5.9-91.1.noarch
GPG Keys are configured as:
http://download.opensuse.org/repositories/openSUSE:/Tools/CentOS_7/repodata/repomd.xml.key

< Previous Next >
This Thread
  • No further messages